- Preserve timestamps on doxygen generated files

- Fix FTBFS (#565038)
This commit is contained in:
Hans de Goede 2010-02-14 09:33:10 +00:00
parent 491be9b0e1
commit cedd464de0
2 changed files with 21 additions and 1 deletions

View File

@ -3,7 +3,7 @@
Summary: iSCSI daemon and utility programs
Name: iscsi-initiator-utils
Version: 6.2.0.870
Release: 12%{?dist}
Release: 13%{?dist}
Source0: http://www.open-iscsi.org/bits/open-iscsi-2.0-870.1.tar.gz
Source1: iscsid.init
Source2: iscsidevs.init
@ -20,6 +20,7 @@ Patch8: open-iscsi-2.0-870.1-no-exit.patch
Patch9: open-iscsi-2.0-870.1-ibft-newer-kernel.patch
Patch10: open-iscsi-2.0-870.1-485217.patch
Patch11: open-iscsi-2.0-870.1-fwparam-ppc-crash.patch
Patch12: open-iscsi-2.0-870.1-compile-fix.patch
Group: System Environment/Daemons
License: GPLv2+
@ -60,6 +61,7 @@ developing applications that use %{name}.
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%build
@ -69,8 +71,10 @@ make OPTFLAGS="%{optflags}" -C utils
make OPTFLAGS="%{optflags}" -C libiscsi
pushd libiscsi
python setup.py build
touch -r libiscsi.doxy html/*
popd
%install
rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT/sbin
@ -164,6 +168,10 @@ fi
%{_includedir}/libiscsi.h
%changelog
* Sun Feb 14 2010 Hans de Goede <hdegoede@redhat.com> 6.2.0.870-13
- Preserve timestamps on doxygen generated files
- Fix FTBFS (#565038)
* Thu Jan 7 2010 Hans de Goede <hdegoede@redhat.com> 6.2.0.870-12
- Change python_sitelib macro to use %%global as the new rpm will break
using %%define here, see:

View File

@ -0,0 +1,12 @@
diff -up open-iscsi-2.0-870.1/usr/iscsi_sysfs.c~ open-iscsi-2.0-870.1/usr/iscsi_sysfs.c
--- open-iscsi-2.0-870.1/usr/iscsi_sysfs.c~ 2008-11-22 18:06:46.000000000 +0100
+++ open-iscsi-2.0-870.1/usr/iscsi_sysfs.c 2010-02-14 10:28:45.030720189 +0100
@@ -22,6 +22,8 @@
#include <string.h>
#include <errno.h>
#include <dirent.h>
+#include <sys/types.h>
+#include <sys/stat.h>
#include "log.h"
#include "initiator.h"