libiscsi build issues
also CI test failures due to unicode in iscsid.conf
This commit is contained in:
parent
22c2cdc5ed
commit
84e9317089
25
0011-remove-unicode-symbols-from-iscsid.conf.patch
Normal file
25
0011-remove-unicode-symbols-from-iscsid.conf.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From b89d270f820ea6da0639ae25864bffcbddd3ed46 Mon Sep 17 00:00:00 2001
|
||||
From: Chris Leech <cleech@redhat.com>
|
||||
Date: Tue, 4 Jul 2023 12:20:03 -0700
|
||||
Subject: [PATCH 1/1] remove unicode symbols from iscsid.conf
|
||||
|
||||
---
|
||||
etc/iscsid.conf | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/etc/iscsid.conf b/etc/iscsid.conf
|
||||
index ca29e43..607ad0f 100644
|
||||
--- a/etc/iscsid.conf
|
||||
+++ b/etc/iscsid.conf
|
||||
@@ -69,7 +69,7 @@ node.leading_login = No
|
||||
# To configure which CHAP algorithms to enable, set
|
||||
# node.session.auth.chap_algs to a comma separated list.
|
||||
# The algorithms should be listed in order of decreasing
|
||||
-# preference — in particular, with the most preferred algorithm first.
|
||||
+# preference - in particular, with the most preferred algorithm first.
|
||||
# Valid values are MD5, SHA1, SHA256, and SHA3-256.
|
||||
# The default is MD5.
|
||||
#node.session.auth.chap_algs = SHA3-256,SHA256,SHA1,MD5
|
||||
--
|
||||
2.40.1
|
||||
|
@ -1,50 +0,0 @@
|
||||
From 08eb07147f8285dd8d986ae5e1528c8a09b68dc8 Mon Sep 17 00:00:00 2001
|
||||
From: rpm-build <rpm-build>
|
||||
Date: Fri, 30 Jun 2023 22:19:23 +0000
|
||||
Subject: [PATCH 1/1] libiscsi build fixes
|
||||
|
||||
---
|
||||
Makefile | 4 ++++
|
||||
libiscsi/Makefile | 4 ++--
|
||||
2 files changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 7ae461a..e3bfab6 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -58,6 +58,10 @@ deprecation_msg:
|
||||
@echo "*** Please see the README file for more information."
|
||||
@echo "***"
|
||||
|
||||
+.PHONY: libiscsi
|
||||
+libiscsi:
|
||||
+ $(MAKE) $(MFLAGS) -C libiscsi
|
||||
+
|
||||
user: deprecation_msg iscsiuio/Makefile
|
||||
$(MAKE) $(MFLAGS) -C libopeniscsiusr
|
||||
$(MAKE) $(MFLAGS) -C sysdeps
|
||||
diff --git a/libiscsi/Makefile b/libiscsi/Makefile
|
||||
index 7f5d371..c31b25b 100644
|
||||
--- a/libiscsi/Makefile
|
||||
+++ b/libiscsi/Makefile
|
||||
@@ -19,7 +19,7 @@ CFLAGS += -DSBINDIR=\"$(SBINDIR)\"
|
||||
CFLAGS += -DISCSI_DB_ROOT=\"$(DBROOT)\"
|
||||
CFLAGS += -DISCSI_VERSION_STR=\"$(ISCSI_VERSION_STR)\"
|
||||
|
||||
-LDFLAGS = -L../libopeniscsiusr -lopeniscsiusr -lkmod -lcrypto
|
||||
+LDFLAGS = -L../redhat-linux-build -lopeniscsiusr -lkmod -lcrypto
|
||||
|
||||
LIB = libiscsi.so.0
|
||||
TESTS = tests/test_discovery_sendtargets tests/test_discovery_firmware
|
||||
@@ -59,7 +59,7 @@ fw-objs/%.o: ../usr/fwparam_ibft/%.c
|
||||
$(CC) $(CFLAGS) -c $< -o $@
|
||||
|
||||
$(LIB): $(COMMON_OBJS) $(FW_OBJS) $(USR_OBJS) libiscsi.o
|
||||
- $(CC) $(CFLAGS) -shared -Wl,-soname,$(LIB) $^ -o $@ -L$(TOPDIR)/libopeniscsiusr -lopeniscsiusr
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(LIB) $^ -o $@
|
||||
ln -s -f $(LIB) libiscsi.so
|
||||
|
||||
$(TESTS): $(FW_OBJS) $(COMMON_OBJS) $(USR_OBJS) $(LIB)
|
||||
--
|
||||
2.41.0
|
||||
|
96
0104-libiscsi-build-fixes.patch
Normal file
96
0104-libiscsi-build-fixes.patch
Normal file
@ -0,0 +1,96 @@
|
||||
From d6344267de82b7ef38e2834522a8782579b77d42 Mon Sep 17 00:00:00 2001
|
||||
From: rpm-build <rpm-build>
|
||||
Date: Fri, 30 Jun 2023 22:19:23 +0000
|
||||
Subject: [PATCH 104/104] libiscsi build fixes
|
||||
|
||||
---
|
||||
Makefile | 4 ++++
|
||||
libiscsi/Makefile | 27 +++++++++++++++------------
|
||||
2 files changed, 19 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index a537516..3fe76df 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -58,6 +58,10 @@ deprecation_msg:
|
||||
@echo "*** Please see the README file for more information."
|
||||
@echo "***"
|
||||
|
||||
+.PHONY: libiscsi
|
||||
+libiscsi:
|
||||
+ $(MAKE) $(MFLAGS) -C libiscsi
|
||||
+
|
||||
user: deprecation_msg iscsiuio/Makefile
|
||||
$(MAKE) $(MFLAGS) -C libopeniscsiusr
|
||||
$(MAKE) $(MFLAGS) -C sysdeps
|
||||
diff --git a/libiscsi/Makefile b/libiscsi/Makefile
|
||||
index 7f5d371..9f7b034 100644
|
||||
--- a/libiscsi/Makefile
|
||||
+++ b/libiscsi/Makefile
|
||||
@@ -5,21 +5,22 @@ ifeq ($(TOPDIR),)
|
||||
endif
|
||||
|
||||
OSNAME=$(shell uname -s)
|
||||
-OPTFLAGS ?= -O2 -g
|
||||
-WARNFLAGS ?= -Wall -Wstrict-prototypes
|
||||
-CFLAGS = $(OPTFLAGS) $(WARNFLAGS) -I../include -I../usr \
|
||||
- -D$(OSNAME) -fPIC -D_GNU_SOURCE -fvisibility=hidden \
|
||||
+# OPTFLAGS ?= -O2 -g
|
||||
+# WARNFLAGS ?= -Wall -Wstrict-prototypes
|
||||
+CFLAGS ?= -O2 -g -Wall
|
||||
+CFLAGS += $(OPTFLAGS) $(WARNFLAGS) -I../include -I../usr \
|
||||
+ -D$(OSNAME) -D_GNU_SOURCE -fvisibility=hidden \
|
||||
-I../libopeniscsiusr
|
||||
|
||||
-#CFLAGS ?= -O2 -g
|
||||
#CFLAGS += -Wall -Werror -Wextra -fvisibility=hidden -fPIC
|
||||
-CFLAGS += -I../libopeniscsiusr -I../include -I../usr
|
||||
+#CFLAGS += -I../libopeniscsiusr -I../include -I../usr
|
||||
#CFLAGS += $(shell $(PKG_CONFIG) --cflags libkmod)
|
||||
CFLAGS += -DSBINDIR=\"$(SBINDIR)\"
|
||||
CFLAGS += -DISCSI_DB_ROOT=\"$(DBROOT)\"
|
||||
CFLAGS += -DISCSI_VERSION_STR=\"$(ISCSI_VERSION_STR)\"
|
||||
|
||||
-LDFLAGS = -L../libopeniscsiusr -lopeniscsiusr -lkmod -lcrypto
|
||||
+CFLAGS += -L../redhat-linux-build
|
||||
+LDLIBS += -lopeniscsiusr -lkmod -lcrypto
|
||||
|
||||
LIB = libiscsi.so.0
|
||||
TESTS = tests/test_discovery_sendtargets tests/test_discovery_firmware
|
||||
@@ -39,7 +40,7 @@ USR_OBJS = $(patsubst %.o, usr-objs/%.o, $(ISCSI_LIB_SRCS) local_strings.o)
|
||||
FW_OBJS = $(patsubst %.o, fw-objs/%.o, $(FW_PARAM_SRCS))
|
||||
|
||||
# Flags for the tests
|
||||
-tests/% : CFLAGS = $(OPTFLAGS) $(WARNFLAGS) -I.
|
||||
+tests/% : CFLAGS += -I.
|
||||
|
||||
all: lib tests html
|
||||
|
||||
@@ -48,18 +49,20 @@ tests: $(TESTS)
|
||||
|
||||
common-objs/%.o: ../sysdeps/%.c
|
||||
mkdir -p common-objs
|
||||
- $(CC) $(CFLAGS) -c $< -o $@
|
||||
+ $(CC) $(CFLAGS) -c $< -o $@ $(LDFLAGS) $(LDLIBS)
|
||||
|
||||
usr-objs/%.o: ../usr/%.c
|
||||
mkdir -p usr-objs
|
||||
- $(CC) $(CFLAGS) -c $< -o $@
|
||||
+ $(CC) $(CFLAGS) -c $< -o $@ $(LDFLAGS) $(LDLIBS)
|
||||
|
||||
fw-objs/%.o: ../usr/fwparam_ibft/%.c
|
||||
mkdir -p fw-objs
|
||||
- $(CC) $(CFLAGS) -c $< -o $@
|
||||
+ $(CC) $(CFLAGS) -c $< -o $@ $(LDFLAGS) $(LDLIBS)
|
||||
+
|
||||
+$(LIB): CFLAGS += -fPIC
|
||||
|
||||
$(LIB): $(COMMON_OBJS) $(FW_OBJS) $(USR_OBJS) libiscsi.o
|
||||
- $(CC) $(CFLAGS) -shared -Wl,-soname,$(LIB) $^ -o $@ -L$(TOPDIR)/libopeniscsiusr -lopeniscsiusr
|
||||
+ $(CC) $(CFLAGS) -shared -Wl,-soname,$(LIB) $^ -o $@ $(LDFLAGS) $(LDLIBS)
|
||||
ln -s -f $(LIB) libiscsi.so
|
||||
|
||||
$(TESTS): $(FW_OBJS) $(COMMON_OBJS) $(USR_OBJS) $(LIB)
|
||||
--
|
||||
2.40.1
|
||||
|
@ -10,7 +10,7 @@
|
||||
Summary: iSCSI daemon and utility programs
|
||||
Name: iscsi-initiator-utils
|
||||
Version: 6.%{open_iscsi_version}.%{open_iscsi_build}
|
||||
Release: 14.git%{shortcommit0}%{?dist}
|
||||
Release: 15.git%{shortcommit0}%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://github.com/open-iscsi/open-iscsi
|
||||
Source0: https://github.com/open-iscsi/open-iscsi/archive/%{commit0}.tar.gz#/open-iscsi-%{shortcommit0}.tar.gz
|
||||
@ -31,12 +31,13 @@ Patch07: 0007-Disable-Data-Digests.patch
|
||||
Patch08: 0008-Revert-iscsiadm-return-error-when-login-fails.patch
|
||||
Patch09: 0009-Coverity-scan-fixes.patch
|
||||
Patch10: 0010-use-Red-Hat-version-string-to-match-RPM-package-vers.patch
|
||||
Patch11: 0011-remove-unicode-symbols-from-iscsid.conf.patch
|
||||
|
||||
# libiscsi, deprecated but still needed until UDisks2 is converted to libopeniscsiusr
|
||||
Patch11: 0011-libiscsi.patch
|
||||
Patch12: 0012-libiscsi-introduce-sessions-API.patch
|
||||
Patch13: 0013-fix-libiscsi-firmware-discovery-issue-with-NULL-drec.patch
|
||||
Patch14: 0014-libiscsi-build-fixes.patch
|
||||
Patch101: 0101-libiscsi.patch
|
||||
Patch102: 0102-libiscsi-introduce-sessions-API.patch
|
||||
Patch103: 0103-fix-libiscsi-firmware-discovery-issue-with-NULL-drec.patch
|
||||
Patch104: 0104-libiscsi-build-fixes.patch
|
||||
|
||||
BuildRequires: meson git
|
||||
BuildRequires: flex bison doxygen kmod-devel systemd-units
|
||||
@ -117,7 +118,7 @@ libiscsi interface for interacting with %{name}
|
||||
%meson -Diqn_prefix=iqn.1994-05.com.redhat
|
||||
%meson_build
|
||||
|
||||
%make_build iqn_prefix=iqn.1994-05.com.redhat DBROOT=/var/lib/iscsi libiscsi
|
||||
%make_build LDFLAGS="%{build_ldflags}" iqn_prefix=iqn.1994-05.com.redhat DBROOT=/var/lib/iscsi libiscsi
|
||||
pushd libiscsi
|
||||
%if %{with python2}
|
||||
%py2_build
|
||||
@ -272,6 +273,12 @@ systemctl --no-reload preset iscsi.service iscsi-starter.service &>/dev/null ||
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jul 04 2023 Chris Leech <cleech@redhat.com> - 6.2.1.9-15.gitc26218d
|
||||
- libiscsi build issues with new makefiles
|
||||
|
||||
* Tue Jul 04 2023 Chris Leech <cleech@redhat.com> - 6.2.1.9-14.gitc26218d
|
||||
- Rebased to Open-iSCSI 2.1.9
|
||||
|
||||
* Fri Jun 16 2023 Python Maint <python-maint@redhat.com> - 6.2.1.4-14.git2a8f9d8
|
||||
- Rebuilt for Python 3.12
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user