rebase to new upstream v2.1.1

enhanced CHAP options are now a configuration to deal with broken targets (#1774746)

Stop using Werror for now, need to clean up warning that are only
showing up on s390x.  Werror is a nightmare for packaging
This commit is contained in:
Chris Leech 2020-03-02 11:52:47 -08:00
parent 252a956dea
commit 2c41582e3d
10 changed files with 170 additions and 185 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@
/open-iscsi-4ef9261.tar.gz /open-iscsi-4ef9261.tar.gz
/open-iscsi-f3c8e90.tar.gz /open-iscsi-f3c8e90.tar.gz
/open-iscsi-4440e57.tar.gz /open-iscsi-4440e57.tar.gz
/open-iscsi-ac87641.tar.gz

View File

@ -0,0 +1,56 @@
From d4758b0d347e4adccf4d39e6bd29ba68c53a92b8 Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build>
Date: Tue, 3 Mar 2020 10:35:40 -0800
Subject: [PATCH 1/1] stop using Werror for now
need to work through these warning that only appear on s390x
Werror seems bad for release, makes packaging a nightmare when new
compilers come around
---
Makefile | 2 +-
usr/Makefile | 2 +-
usr/initiator.c | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
index 7e6b734..0069e75 100644
--- a/Makefile
+++ b/Makefile
@@ -7,7 +7,7 @@
DESTDIR ?=
prefix = /usr
-exec_prefix = /
+exec_prefix = /usr
sbindir = $(exec_prefix)/sbin
bindir = $(exec_prefix)/bin
mandir = $(prefix)/share/man
diff --git a/usr/Makefile b/usr/Makefile
index 885243a..1a743d1 100644
--- a/usr/Makefile
+++ b/usr/Makefile
@@ -35,7 +35,7 @@ endif
PKG_CONFIG = /usr/bin/pkg-config
CFLAGS ?= -O2 -g
-WARNFLAGS ?= -Wall -Wextra -Werror -Wstrict-prototypes -fno-common
+WARNFLAGS ?= -Wall -Wextra -Wstrict-prototypes -fno-common
CFLAGS += $(WARNFLAGS) -I../include -I. -D_GNU_SOURCE \
-I$(TOPDIR)/libopeniscsiusr -DISNS_ENABLE
CFLAGS += $(shell $(PKG_CONFIG) --cflags libkmod)
diff --git a/usr/initiator.c b/usr/initiator.c
index a07f9aa..a06760c 100644
--- a/usr/initiator.c
+++ b/usr/initiator.c
@@ -580,7 +580,7 @@ __session_conn_reopen(iscsi_conn_t *conn, queue_task_t *qtask, int do_stop,
int redirected)
{
iscsi_session_t *session = conn->session;
- uint32_t delay;
+ uint32_t delay = 0;
log_debug(1, "re-opening session %d (reopen_cnt %d)", session->id,
session->reopen_cnt);
--
2.21.1

View File

@ -1,7 +1,7 @@
From 6051b9ef3cdf206630969940aba980f4088e2e14 Mon Sep 17 00:00:00 2001 From 351ee477f713730d1c53cf26b6fb87706d268a5f Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Tue, 13 Aug 2013 12:39:07 -0700 Date: Tue, 13 Aug 2013 12:39:07 -0700
Subject: [PATCH] idbw_rec_write, pick tpgt from existing record Subject: [PATCH 1/1] idbw_rec_write, pick tpgt from existing record
On a static add (-m node -o new) without a user specified tpgt, looks On a static add (-m node -o new) without a user specified tpgt, looks
for existing new style records with tpgt before creating an old style for existing new style records with tpgt before creating an old style
@ -12,7 +12,7 @@ updated new style record instead.
1 file changed, 40 insertions(+) 1 file changed, 40 insertions(+)
diff --git a/usr/idbm.c b/usr/idbm.c diff --git a/usr/idbm.c b/usr/idbm.c
index 2f5e309..a2332cc 100644 index b6193e7..2208c4a 100644
--- a/usr/idbm.c --- a/usr/idbm.c
+++ b/usr/idbm.c +++ b/usr/idbm.c
@@ -28,6 +28,7 @@ @@ -28,6 +28,7 @@
@ -23,21 +23,21 @@ index 2f5e309..a2332cc 100644
#include <sys/stat.h> #include <sys/stat.h>
#include <sys/file.h> #include <sys/file.h>
#include <inttypes.h> #include <inttypes.h>
@@ -164,6 +165,8 @@ static struct idbm *db; @@ -202,6 +203,8 @@ static struct int_list_tbl {
_n++; \ { "SHA3-256", AUTH_CHAP_ALG_SHA3_256 },
} while(0) };
+static int idbm_remove_disc_to_node_link(node_rec_t *rec, char *portal); +static int idbm_remove_disc_to_node_link(node_rec_t *rec, char *portal);
+ +
static void static void
idbm_recinfo_discovery(discovery_rec_t *r, recinfo_t *ri) idbm_recinfo_discovery(discovery_rec_t *r, recinfo_t *ri)
{ {
@@ -2107,12 +2110,49 @@ static int idbm_rec_write_old(node_rec_t *rec) @@ -2206,12 +2209,49 @@ static int idbm_rec_write_old(node_rec_t *rec)
FILE *f; FILE *f;
char *portal; char *portal;
int rc = 0; int rc = 0;
+ glob_t globbuf; + glob_t globbuf;
+ int i; + size_t i;
+ int tpgt = PORTAL_GROUP_TAG_UNKNOWN; + int tpgt = PORTAL_GROUP_TAG_UNKNOWN;
portal = malloc(PATH_MAX); portal = malloc(PATH_MAX);
@ -83,5 +83,5 @@ index 2f5e309..a2332cc 100644
rec->name, rec->conn[0].address, rec->conn[0].port); rec->name, rec->conn[0].address, rec->conn[0].port);
-- --
2.21.0 2.21.1

View File

@ -1,7 +1,7 @@
From af721a438031fa9f79db5de3b018c4b532ac2e0c Mon Sep 17 00:00:00 2001 From 029ded4ed0de80a15836caed8747fab17958179a Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build> From: rpm-build <rpm-build>
Date: Mon, 26 Jan 2015 12:57:11 -0800 Date: Mon, 26 Jan 2015 12:57:11 -0800
Subject: [PATCH] libiscsi Subject: [PATCH 1/1] libiscsi
--- ---
Makefile | 2 + Makefile | 2 +
@ -3914,12 +3914,12 @@ index 0000000..a21f888
+ return rc; + return rc;
+} +}
diff --git a/usr/Makefile b/usr/Makefile diff --git a/usr/Makefile b/usr/Makefile
index 3bb0cb4..8ae6e07 100644 index 21bb154..885243a 100644
--- a/usr/Makefile --- a/usr/Makefile
+++ b/usr/Makefile +++ b/usr/Makefile
@@ -37,7 +37,7 @@ PKG_CONFIG = /usr/bin/pkg-config @@ -37,7 +37,7 @@ PKG_CONFIG = /usr/bin/pkg-config
CFLAGS ?= -O2 -g CFLAGS ?= -O2 -g
WARNFLAGS ?= -Wall -Wstrict-prototypes WARNFLAGS ?= -Wall -Wextra -Werror -Wstrict-prototypes -fno-common
CFLAGS += $(WARNFLAGS) -I../include -I. -D_GNU_SOURCE \ CFLAGS += $(WARNFLAGS) -I../include -I. -D_GNU_SOURCE \
- -I$(TOPDIR)/libopeniscsiusr - -I$(TOPDIR)/libopeniscsiusr
+ -I$(TOPDIR)/libopeniscsiusr -DISNS_ENABLE + -I$(TOPDIR)/libopeniscsiusr -DISNS_ENABLE
@ -3927,7 +3927,7 @@ index 3bb0cb4..8ae6e07 100644
ISCSI_LIB = -L$(TOPDIR)/libopeniscsiusr -lopeniscsiusr ISCSI_LIB = -L$(TOPDIR)/libopeniscsiusr -lopeniscsiusr
LDFLAGS += $(shell $(PKG_CONFIG) --libs libkmod) LDFLAGS += $(shell $(PKG_CONFIG) --libs libkmod)
diff --git a/usr/discovery.c b/usr/discovery.c diff --git a/usr/discovery.c b/usr/discovery.c
index 199c160..d17a250 100644 index 9ce122e..4ef5448 100644
--- a/usr/discovery.c --- a/usr/discovery.c
+++ b/usr/discovery.c +++ b/usr/discovery.c
@@ -36,6 +36,7 @@ @@ -36,6 +36,7 @@
@ -3965,13 +3965,13 @@ index 199c160..d17a250 100644
} }
+#endif +#endif
int discovery_fw(void *data, struct iface_rec *iface, int discovery_fw(void *data,
struct list_head *rec_list) __attribute__((unused))struct iface_rec *iface,
diff --git a/usr/idbm.c b/usr/idbm.c diff --git a/usr/idbm.c b/usr/idbm.c
index 15802c3..3184c77 100644 index a5c653c..d5e16cb 100644
--- a/usr/idbm.c --- a/usr/idbm.c
+++ b/usr/idbm.c +++ b/usr/idbm.c
@@ -1725,9 +1725,9 @@ int idbm_print_all_discovery(int info_level) @@ -1824,9 +1824,9 @@ int idbm_print_all_discovery(int info_level)
* fn should return -1 if it skipped the rec, an ISCSI_ERR error code if * fn should return -1 if it skipped the rec, an ISCSI_ERR error code if
* the operation failed or 0 if fn was run successfully. * the operation failed or 0 if fn was run successfully.
*/ */
@ -3985,10 +3985,10 @@ index 15802c3..3184c77 100644
DIR *iface_dirfd; DIR *iface_dirfd;
struct dirent *iface_dent; struct dirent *iface_dent;
diff --git a/usr/idbm.h b/usr/idbm.h diff --git a/usr/idbm.h b/usr/idbm.h
index 6bdfd60..c6982e4 100644 index ce098b7..d1a7f63 100644
--- a/usr/idbm.h --- a/usr/idbm.h
+++ b/usr/idbm.h +++ b/usr/idbm.h
@@ -103,6 +103,9 @@ struct rec_op_data { @@ -105,6 +105,9 @@ struct rec_op_data {
node_rec_t *match_rec; node_rec_t *match_rec;
idbm_iface_op_fn *fn; idbm_iface_op_fn *fn;
}; };
@ -4006,9 +4006,9 @@ index 47857dd..fb8e965 100644
char *host_stats); char *host_stats);
}; };
+struct iscsi_ipc *ipc; +extern struct iscsi_ipc *ipc;
+ +
#endif /* ISCSI_IPC_H */ #endif /* ISCSI_IPC_H */
-- --
2.21.0 2.21.1

View File

@ -1,15 +1,15 @@
From 44bb05de04c0f8819c1fdae8f567dd802a8444e8 Mon Sep 17 00:00:00 2001 From ad8c3353b8e482575ff2208182290cf35b624dde Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Wed, 5 Jun 2019 09:08:39 -0700 Date: Wed, 5 Jun 2019 09:08:39 -0700
Subject: [PATCH] Coverity scan fixes Subject: [PATCH 1/1] Coverity scan fixes
--- ---
iscsiuio/src/unix/libs/qedi.c | 2 +- iscsiuio/src/unix/libs/qedi.c | 2 +-
iscsiuio/src/unix/main.c | 12 ++++++++++-- iscsiuio/src/unix/main.c | 3 +++
libopeniscsiusr/idbm.c | 11 +++++------ libopeniscsiusr/idbm.c | 11 +++++------
usr/idbm.c | 10 ++++------ usr/idbm.c | 10 ++++------
usr/iscsid.c | 2 +- usr/iscsid.c | 2 +-
5 files changed, 21 insertions(+), 16 deletions(-) 5 files changed, 14 insertions(+), 14 deletions(-)
diff --git a/iscsiuio/src/unix/libs/qedi.c b/iscsiuio/src/unix/libs/qedi.c diff --git a/iscsiuio/src/unix/libs/qedi.c b/iscsiuio/src/unix/libs/qedi.c
index 3414cb5..a359700 100644 index 3414cb5..a359700 100644
@ -25,22 +25,10 @@ index 3414cb5..a359700 100644
if (bd_cons != bd_prod) { if (bd_cons != bd_prod) {
diff --git a/iscsiuio/src/unix/main.c b/iscsiuio/src/unix/main.c diff --git a/iscsiuio/src/unix/main.c b/iscsiuio/src/unix/main.c
index 5e3f66c..4c50890 100644 index 0c9ad49..f83f305 100644
--- a/iscsiuio/src/unix/main.c --- a/iscsiuio/src/unix/main.c
+++ b/iscsiuio/src/unix/main.c +++ b/iscsiuio/src/unix/main.c
@@ -341,7 +341,10 @@ int main(int argc, char *argv[]) @@ -391,6 +391,9 @@ int main(int argc, char *argv[])
/* parent: wait for child msg then exit */
close(pipefds[1]);
- read(pipefds[0], msgbuf, sizeof(msgbuf));
+ if (read(pipefds[0], msgbuf, sizeof(msgbuf)) < 0) {
+ fprintf(stderr, "ERR: Waiting for child process failed\n");
+ exit(1);
+ }
exit(0);
}
@@ -387,6 +390,9 @@ int main(int argc, char *argv[])
sigaddset(&set, SIGTERM); sigaddset(&set, SIGTERM);
sigaddset(&set, SIGUSR1); sigaddset(&set, SIGUSR1);
rc = pthread_sigmask(SIG_SETMASK, &set, NULL); rc = pthread_sigmask(SIG_SETMASK, &set, NULL);
@ -50,22 +38,11 @@ index 5e3f66c..4c50890 100644
/* Spin off the signal handling thread */ /* Spin off the signal handling thread */
pthread_attr_init(&attr); pthread_attr_init(&attr);
@@ -416,7 +422,9 @@ int main(int argc, char *argv[])
if (!foreground) {
/* signal parent they can go away now */
close(pipefds[0]);
- write(pipefds[1], "ok\n", 3);
+ if (write(pipefds[1], "ok\n", 3) < 0) {
+ LOG_ERR("Failed to signal parent process of completed initialization");
+ }
close(pipefds[1]);
}
diff --git a/libopeniscsiusr/idbm.c b/libopeniscsiusr/idbm.c diff --git a/libopeniscsiusr/idbm.c b/libopeniscsiusr/idbm.c
index d020e6c..342aab5 100644 index 7bc2381..7d4c338 100644
--- a/libopeniscsiusr/idbm.c --- a/libopeniscsiusr/idbm.c
+++ b/libopeniscsiusr/idbm.c +++ b/libopeniscsiusr/idbm.c
@@ -287,12 +287,11 @@ int _idbm_lock(struct iscsi_context *ctx) @@ -321,12 +321,11 @@ int _idbm_lock(struct iscsi_context *ctx)
return 0; return 0;
} }
@ -84,10 +61,10 @@ index d020e6c..342aab5 100644
fd = open(LOCK_FILE, O_RDWR | O_CREAT, 0666); fd = open(LOCK_FILE, O_RDWR | O_CREAT, 0666);
diff --git a/usr/idbm.c b/usr/idbm.c diff --git a/usr/idbm.c b/usr/idbm.c
index 3184c77..0c6870c 100644 index d5e16cb..a210c88 100644
--- a/usr/idbm.c --- a/usr/idbm.c
+++ b/usr/idbm.c +++ b/usr/idbm.c
@@ -1339,12 +1339,10 @@ int idbm_lock(void) @@ -1438,12 +1438,10 @@ int idbm_lock(void)
return 0; return 0;
} }
@ -105,10 +82,10 @@ index 3184c77..0c6870c 100644
fd = open(LOCK_FILE, O_RDWR | O_CREAT, 0666); fd = open(LOCK_FILE, O_RDWR | O_CREAT, 0666);
diff --git a/usr/iscsid.c b/usr/iscsid.c diff --git a/usr/iscsid.c b/usr/iscsid.c
index 8f1c597..96a6452 100644 index 99d27ab..dbb0900 100644
--- a/usr/iscsid.c --- a/usr/iscsid.c
+++ b/usr/iscsid.c +++ b/usr/iscsid.c
@@ -489,8 +489,8 @@ int main(int argc, char *argv[]) @@ -490,8 +490,8 @@ int main(int argc, char *argv[])
log_close(log_pid); log_close(log_pid);
exit(ISCSI_ERR); exit(ISCSI_ERR);
} }
@ -119,5 +96,5 @@ index 8f1c597..96a6452 100644
if ((control_fd = ipc->ctldev_open()) < 0) { if ((control_fd = ipc->ctldev_open()) < 0) {
log_close(log_pid); log_close(log_pid);
-- --
2.21.0 2.21.1

View File

@ -1,25 +1,25 @@
From c589d94293f3bee77c34ca61371ddfbeef71f2af Mon Sep 17 00:00:00 2001 From 58d24c239b9b6f762231ff3eedbc685971ce0a98 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Mon, 21 Jan 2013 15:43:36 -0800 Date: Mon, 21 Jan 2013 15:43:36 -0800
Subject: [PATCH] use Red Hat version string to match RPM package version Subject: [PATCH 1/1] use Red Hat version string to match RPM package version
--- ---
usr/version.h | 2 +- usr/version.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-) 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/usr/version.h b/usr/version.h diff --git a/usr/version.h b/usr/version.h
index 615f533..a1f6cc2 100644 index 4fa9179..c5c9e76 100644
--- a/usr/version.h --- a/usr/version.h
+++ b/usr/version.h +++ b/usr/version.h
@@ -6,7 +6,7 @@ @@ -6,7 +6,7 @@
* This may not be the same value as the kernel versions because * This may not be the same value as the kernel versions because
* some other maintainer could merge a patch without going through us * some other maintainer could merge a patch without going through us
*/ */
-#define ISCSI_VERSION_STR "2.1.0" -#define ISCSI_VERSION_STR "2.1.1"
+#define ISCSI_VERSION_STR "6.2.1.0-0" +#define ISCSI_VERSION_STR "6.2.1.1-0"
#define ISCSI_VERSION_FILE "/sys/module/scsi_transport_iscsi/version" #define ISCSI_VERSION_FILE "/sys/module/scsi_transport_iscsi/version"
#endif #endif
-- --
2.21.0 2.21.1

View File

@ -0,0 +1,62 @@
From d4ed4972df1ffe9381e33f2800f8e574f632948c Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build>
Date: Mon, 2 Mar 2020 15:21:30 -0800
Subject: [PATCH 1/1] iscsi_if.h replace zero-length array with flexible-array
member
---
include/iscsi_if.h | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/include/iscsi_if.h b/include/iscsi_if.h
index 2d46214..e8cee0d 100644
--- a/include/iscsi_if.h
+++ b/include/iscsi_if.h
@@ -337,7 +337,7 @@ enum iscsi_param_type {
struct iscsi_param_info {
uint32_t len; /* Actual length of the param value */
uint16_t param; /* iscsi param */
- uint8_t value[0]; /* length sized value follows */
+ uint8_t value[]; /* length sized value follows */
} __attribute__((__packed__));
struct iscsi_iface_param_info {
@@ -346,7 +346,7 @@ struct iscsi_iface_param_info {
uint16_t param; /* iscsi param value */
uint8_t iface_type; /* IPv4 or IPv6 */
uint8_t param_type; /* iscsi_param_type */
- uint8_t value[0]; /* length sized value follows */
+ uint8_t value[]; /* length sized value follows */
} __attribute__((__packed__));
/*
@@ -723,7 +723,7 @@ enum iscsi_flashnode_param {
struct iscsi_flashnode_param_info {
uint32_t len; /* Actual length of the param */
uint16_t param; /* iscsi param value */
- uint8_t value[0]; /* length sized value follows */
+ uint8_t value[]; /* length sized value follows */
} __attribute__((__packed__));
enum iscsi_discovery_parent_type {
@@ -841,7 +841,7 @@ struct iscsi_stats {
* up to ISCSI_STATS_CUSTOM_MAX
*/
uint32_t custom_length;
- struct iscsi_stats_custom custom[0]
+ struct iscsi_stats_custom custom[]
__attribute__ ((aligned (sizeof(uint64_t))));
};
@@ -972,7 +972,7 @@ struct iscsi_offload_host_stats {
* up to ISCSI_HOST_STATS_CUSTOM_MAX
*/
uint32_t custom_length;
- struct iscsi_host_stats_custom custom[0]
+ struct iscsi_host_stats_custom custom[]
__attribute__ ((aligned (sizeof(uint64_t))));
};
--
2.21.1

View File

@ -1,111 +0,0 @@
commit 499a006a7d6bb154f9e1ab430e4c9e231ba6096a
Author: Lee Duncan <lduncan@suse.com>
Date: Tue Jan 28 16:36:56 2020 -0800
Updates to support gcc -fno-common option.
This meant cleaning up the definition of some
global variables, so that they were only defined
in one place and refered to as external elsewhere.
diff --git a/include/iscsi_err.h b/include/iscsi_err.h
index ed000dd..04a8723 100644
--- a/include/iscsi_err.h
+++ b/include/iscsi_err.h
@@ -4,7 +4,7 @@
#ifndef _ISCSI_ERR_
#define _ISCSI_ERR_
-enum {
+enum iscsi_error_list {
ISCSI_SUCCESS = 0,
/* Generic error */
ISCSI_ERR = 1,
@@ -73,7 +73,9 @@ enum {
/* Always last. Indicates end of error code space */
ISCSI_MAX_ERR_VAL,
-} iscsi_err;
+};
+
+extern enum iscsi_error_list iscsi_err;
extern void iscsi_err_print_msg(int err);
extern char *iscsi_err_to_str(int err);
diff --git a/iscsiuio/configure.ac b/iscsiuio/configure.ac
index b41df0e..8099f09 100644
--- a/iscsiuio/configure.ac
+++ b/iscsiuio/configure.ac
@@ -78,7 +78,7 @@ AC_CONFIG_COMMANDS([default],[[
else
echo 'char *build_date = "'`date`'";' > src/unix/build_date.c
fi
- echo 'char *build_date;'> src/unix/build_date.h
+ echo 'extern char *build_date;'> src/unix/build_date.h
]],[[]])
AC_PREFIX_DEFAULT()
diff --git a/iscsiuio/src/uip/uip.h b/iscsiuio/src/uip/uip.h
index 1180ab5..9d9428a 100644
--- a/iscsiuio/src/uip/uip.h
+++ b/iscsiuio/src/uip/uip.h
@@ -70,8 +70,8 @@ struct uip_stack;
typedef u16_t uip_ip4addr_t[2];
typedef u16_t uip_ip6addr_t[8];
-const uip_ip6addr_t all_zeroes_addr6;
-const uip_ip4addr_t all_zeroes_addr4;
+extern const uip_ip6addr_t all_zeroes_addr6;
+extern const uip_ip4addr_t all_zeroes_addr4;
#define ETH_BUF(buf) ((struct uip_eth_hdr *)buf)
#define VLAN_ETH_BUF(buf) ((struct uip_vlan_eth_hdr *)buf)
diff --git a/usr/iscsi_err.c b/usr/iscsi_err.c
index 23c61fc..4a057d5 100644
--- a/usr/iscsi_err.c
+++ b/usr/iscsi_err.c
@@ -21,6 +21,8 @@
#include "iscsi_err.h"
#include "log.h"
+enum iscsi_error_list iscsi_err;
+
static char *iscsi_err_msgs[] = {
/* 0 */ "",
/* 1 */ "unknown error",
diff --git a/usr/log.c b/usr/log.c
index f29b54b..6e16e7c 100644
--- a/usr/log.c
+++ b/usr/log.c
@@ -33,6 +33,7 @@
char *log_name;
int log_level = 0;
+struct logarea *la = NULL;
static int log_stop_daemon = 0;
static void (*log_func)(int prio, void *priv, const char *fmt, va_list ap);
diff --git a/usr/log.h b/usr/log.h
index 486a08e..c548791 100644
--- a/usr/log.h
+++ b/usr/log.h
@@ -64,7 +64,7 @@ struct logarea {
union semun semarg;
};
-struct logarea *la;
+extern struct logarea *la;
extern int log_init(char *program_name, int size,
void (*func)(int prio, void *priv, const char *fmt, va_list ap),
diff -up open-iscsi-4440e57a59c7f1c23bbfdcb10844017f478918b6/usr/iscsi_ipc.h.me open-iscsi-4440e57a59c7f1c23bbfdcb10844017f478918b6/usr/iscsi_ipc.h
--- open-iscsi-4440e57a59c7f1c23bbfdcb10844017f478918b6/usr/iscsi_ipc.h.me 2020-02-24 16:26:12.571078646 +0100
+++ open-iscsi-4440e57a59c7f1c23bbfdcb10844017f478918b6/usr/iscsi_ipc.h 2020-02-24 16:29:18.619824160 +0100
@@ -162,6 +162,6 @@ struct iscsi_ipc {
char *host_stats);
};
-struct iscsi_ipc *ipc;
+extern struct iscsi_ipc *ipc;
#endif /* ISCSI_IPC_H */

View File

@ -1,6 +1,6 @@
%global open_iscsi_version 2.1 %global open_iscsi_version 2.1
%global open_iscsi_build 0 %global open_iscsi_build 1
%global commit0 4440e57a59c7f1c23bbfdcb10844017f478918b6 %global commit0 ac87641cd3d87b38480e212e7bdff7a44810036d
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7}) %global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
# Disable python2 build by default # Disable python2 build by default
@ -9,7 +9,7 @@
Summary: iSCSI daemon and utility programs Summary: iSCSI daemon and utility programs
Name: iscsi-initiator-utils Name: iscsi-initiator-utils
Version: 6.%{open_iscsi_version}.%{open_iscsi_build} Version: 6.%{open_iscsi_version}.%{open_iscsi_build}
Release: 2.git%{shortcommit0}%{?dist} Release: 0.git%{shortcommit0}%{?dist}
License: GPLv2+ License: GPLv2+
URL: http://www.open-iscsi.org URL: http://www.open-iscsi.org
Source0: https://github.com/open-iscsi/open-iscsi/archive/%{commit0}.tar.gz#/open-iscsi-%{shortcommit0}.tar.gz Source0: https://github.com/open-iscsi/open-iscsi/archive/%{commit0}.tar.gz#/open-iscsi-%{shortcommit0}.tar.gz
@ -38,12 +38,8 @@ Patch0019: 0019-Coverity-scan-fixes.patch
Patch0020: 0020-fix-upstream-build-breakage-of-iscsiuio-LDFLAGS.patch Patch0020: 0020-fix-upstream-build-breakage-of-iscsiuio-LDFLAGS.patch
Patch0021: 0021-improve-systemd-service-files-for-boot-session-handl.patch Patch0021: 0021-improve-systemd-service-files-for-boot-session-handl.patch
Patch0022: 0022-use-Red-Hat-version-string-to-match-RPM-package-vers.patch Patch0022: 0022-use-Red-Hat-version-string-to-match-RPM-package-vers.patch
Patch0023: 0023-support-gcc-fno-common-option.patch Patch0023: 0023-iscsi_if.h-replace-zero-length-array-with-flexible-a.patch
Patch0024: 0001-stop-using-Werror-for-now.patch
# Rebased backport of https://github.com/open-iscsi/open-iscsi/commit/d3daa7a2
# Intended to fix error using iSCSI during install:
# https://bugzilla.redhat.com/show_bug.cgi?id=1774746
Patch1000: 0001-configuration-support-for-CHAP-algorithms-rebased.patch
BuildRequires: flex bison doxygen kmod-devel systemd-units BuildRequires: flex bison doxygen kmod-devel systemd-units
BuildRequires: autoconf automake libtool libmount-devel openssl-devel BuildRequires: autoconf automake libtool libmount-devel openssl-devel
@ -342,6 +338,10 @@ fi
%{python3_sitearch}/* %{python3_sitearch}/*
%changelog %changelog
* Mon Mar 02 2020 Chris Leech <cleech@redhat.com> - 6.2.1.1-0.gitac87641.
- rebase to new upstream v2.1.1
- enhanced CHAP options are now a configuration to deal with broken targets (#1774746)
* Sun Mar 01 2020 Adam Williamson <awilliam@redhat.com> - 6.2.1.0-2.git4440e57 * Sun Mar 01 2020 Adam Williamson <awilliam@redhat.com> - 6.2.1.0-2.git4440e57
- Backport upstream d3daa7a2 to fix bz #1774746 - Backport upstream d3daa7a2 to fix bz #1774746

View File

@ -1 +1 @@
SHA512 (open-iscsi-4440e57.tar.gz) = 5f2264168977f85da4654a1a1d6777c5bb4aa3655eb350a92ee29d9cc0126e16a8c82c0e1935e682fe0c4e17b4aaa0e76a9e3fdf8496b71f2747b88fd4b57fe9 SHA512 (open-iscsi-ac87641.tar.gz) = ed255bb78e622b7946f343f8323eaea42a66ba68ef06daa21ec815e6a77f4177adb0921b53f8c9bc377da4882c27feff6d45fa451a78a5a80ae8ce68c8c8e125