upstream sync, use external isns-utils package

build with external isns-utils
rebase with upstream, change Source0 url to github
This commit is contained in:
Chris Leech 2015-10-05 17:26:08 -07:00
parent ff3d34ef28
commit 2abe1f9093
27 changed files with 129 additions and 40963 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/open-iscsi-2.0-873.tar.gz /open-iscsi-2.0-873.tar.gz
/iscsiuio-0.7.2.1.tar.gz /iscsiuio-0.7.2.1.tar.gz
/open-iscsi-4c9d6f9.tar.gz

File diff suppressed because it is too large Load Diff

View File

@ -1,71 +0,0 @@
From 1f7fd558c4da3c92bdae67646504eaec16e6081f Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com>
Date: Thu, 12 Feb 2015 16:01:48 -0800
Subject: [PATCH] honor all requested delays in iscsi_sched_ev_context
The session_conn_uio_poll function reschedules itself in the same was as
session_conn_poll, by calling iscsi_sched_ev_context with a delay. That
delay needs to not be ignored.
Actually, most all of the cases in iscsi_sched_ev_context can use
actor_timer to ensure any passed delay argument is honored (even if most
of them are passed as 0).
Signed-off-by: Chris Leech <cleech@redhat.com>
---
usr/initiator.c | 20 ++++++++------------
1 file changed, 8 insertions(+), 12 deletions(-)
diff --git a/usr/initiator.c b/usr/initiator.c
index 3b39c5d..93a3c27 100644
--- a/usr/initiator.c
+++ b/usr/initiator.c
@@ -1800,9 +1800,8 @@ static int iscsi_sched_ev_context(struct iscsi_ev_context *ev_context,
ev_context->conn = conn;
switch (event) {
case EV_CONN_RECV_PDU:
- actor_init(&ev_context->actor, session_conn_recv_pdu,
- ev_context);
- actor_schedule(&ev_context->actor);
+ actor_timer(&ev_context->actor, tmo,
+ session_conn_recv_pdu, ev_context);
break;
case EV_CONN_ERROR:
error = *(enum iscsi_err *)ev_context->data;
@@ -1820,27 +1819,24 @@ static int iscsi_sched_ev_context(struct iscsi_ev_context *ev_context,
actor_schedule(&ev_context->actor);
break;
case EV_CONN_LOGIN:
- actor_init(&ev_context->actor, session_conn_process_login,
- ev_context);
- actor_schedule(&ev_context->actor);
+ actor_timer(&ev_context->actor, tmo,
+ session_conn_process_login, ev_context);
break;
case EV_CONN_POLL:
actor_timer(&ev_context->actor, tmo,
session_conn_poll, ev_context);
break;
case EV_UIO_POLL:
- actor_init(&ev_context->actor, session_conn_uio_poll,
- ev_context);
- actor_schedule(&ev_context->actor);
+ actor_timer(&ev_context->actor, tmo,
+ session_conn_uio_poll, ev_context);
break;
case EV_CONN_LOGOUT_TIMER:
actor_timer(&ev_context->actor, tmo,
iscsi_logout_timedout, ev_context);
break;
case EV_CONN_STOP:
- actor_init(&ev_context->actor, iscsi_stop,
- ev_context);
- actor_schedule(&ev_context->actor);
+ actor_timer(&ev_context->actor, tmo,
+ iscsi_stop, ev_context);
break;
default:
log_error("Invalid event type %d.", event);
--
2.1.0

View File

@ -1,48 +1,45 @@
%global open_iscsi_version 2.0 %global open_iscsi_version 2.0
%global open_iscsi_build 873 %global open_iscsi_build 873
%global checkout 6aa2c9b %global commit0 4c9d6f9908bc55e4514b00c178ae72bb0d8fc96b
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
Summary: iSCSI daemon and utility programs Summary: iSCSI daemon and utility programs
Name: iscsi-initiator-utils Name: iscsi-initiator-utils
Version: 6.%{open_iscsi_version}.%{open_iscsi_build} Version: 6.%{open_iscsi_version}.%{open_iscsi_build}
Release: 28.git%{checkout}%{?dist} Release: 29.git%{shortcommit0}%{?dist}
Group: System Environment/Daemons Group: System Environment/Daemons
License: GPLv2+ License: GPLv2+
URL: http://www.open-iscsi.org URL: http://www.open-iscsi.org
Source0: https://github.com/mikechristie/open-iscsi/archive/%{commit0}.tar.gz#/open-iscsi-%{shortcommit0}.tar.gz
Source0: http://www.open-iscsi.org/bits/open-iscsi-%{open_iscsi_version}-%{open_iscsi_build}.tar.gz
Source4: 04-iscsi Source4: 04-iscsi
Source5: iscsi-tmpfiles.conf Source5: iscsi-tmpfiles.conf
# upstream patches, post last tagged version Patch1: open-iscsi-v2.0.873-4c9d6f9-1-idmb_rec_write-check-for-tpgt-first.patch
Patch1: 0001-sync-to-2.0.873-134-g6aa2c9b.patch Patch2: open-iscsi-v2.0.873-4c9d6f9-2-idbm_rec_write-seperate-old-and-new-style-writes.patch
Patch2: 0002-idmb_rec_write-check-for-tpgt-first.patch Patch3:open-iscsi-v2.0.873-4c9d6f9-3-idbw_rec_write-pick-tpgt-from-existing-record.patch
Patch3: 0003-idbm_rec_write-seperate-old-and-new-style-writes.patch Patch4:open-iscsi-v2.0.873-4c9d6f9-4-update-systemd-service-files-add-iscsi.service-for-s.patch
Patch4: 0004-idbw_rec_write-pick-tpgt-from-existing-record.patch Patch5:open-iscsi-v2.0.873-4c9d6f9-5-iscsi-boot-related-service-file-updates.patch
Patch5: 0005-update-systemd-service-files-add-iscsi.service-for-s.patch Patch6:open-iscsi-v2.0.873-4c9d6f9-6-update-initscripts-and-docs.patch
Patch6: 0006-iscsi-boot-related-service-file-updates.patch Patch7:open-iscsi-v2.0.873-4c9d6f9-7-use-var-for-config.patch
Patch7: 0007-update-initscripts-and-docs.patch Patch8:open-iscsi-v2.0.873-4c9d6f9-8-use-red-hat-for-name.patch
Patch8: 0008-use-var-for-config.patch Patch9:open-iscsi-v2.0.873-4c9d6f9-9-libiscsi.patch
Patch9: 0009-use-red-hat-for-name.patch Patch10:open-iscsi-v2.0.873-4c9d6f9-10-remove-the-offload-boot-supported-ifdef.patch
Patch10: 0010-libiscsi.patch Patch11:open-iscsi-v2.0.873-4c9d6f9-11-iscsiuio-systemd-unit-files.patch
Patch11: 0011-remove-the-offload-boot-supported-ifdef.patch Patch12:open-iscsi-v2.0.873-4c9d6f9-12-disable-iscsid.startup-from-iscsiadm-prefer-systemd-.patch
Patch12: 0012-iscsiuio-systemd-unit-files.patch Patch13:open-iscsi-v2.0.873-4c9d6f9-13-Don-t-check-for-autostart-sessions-if-iscsi-is-not-u.patch
Patch13: 0013-disable-iscsid.startup-from-iscsiadm-prefer-systemd-.patch Patch14:open-iscsi-v2.0.873-4c9d6f9-14-start-socket-listeners-on-iscsiadm-command.patch
Patch14: 0014-Don-t-check-for-autostart-sessions-if-iscsi-is-not-u.patch Patch15:open-iscsi-v2.0.873-4c9d6f9-15-Revert-iscsiadm-return-error-when-login-fails.patch
Patch15: 0015-start-socket-listeners-on-iscsiadm-command.patch Patch16:open-iscsi-v2.0.873-4c9d6f9-16-update-handling-of-boot-sessions.patch
Patch16: 0016-Revert-iscsiadm-return-error-when-login-fails.patch Patch17:open-iscsi-v2.0.873-4c9d6f9-17-update-iscsi.service-for-boot-session-recovery.patch
Patch17: 0017-update-handling-of-boot-sessions.patch Patch18:open-iscsi-v2.0.873-4c9d6f9-18-updates-to-iscsi.service.patch
Patch18: 0018-update-iscsi.service-for-boot-session-recovery.patch Patch19:open-iscsi-v2.0.873-4c9d6f9-19-make-session-shutdown-a-seperate-service.patch.patch
Patch19: 0019-updates-to-iscsi.service.patch Patch20:open-iscsi-v2.0.873-4c9d6f9-20-Add-macros-to-release-GIL-lock.patch
Patch20: 0020-make-session-shutdown-a-seperate-service.patch.patch Patch21:open-iscsi-v2.0.873-4c9d6f9-21-libiscsi-introduce-sessions-API.patch
Patch22: 0022-honor-all-requested-delays-in-iscsi_sched_ev_context.patch
Patch23: 0023-Add-macros-to-release-GIL-lock.patch
Patch24: 0024-libiscsi-introduce-sessions-api.patch
# ugly version string patch, should change with every rebuild # ugly version string patch, should change with every rebuild
Patch9999: 9999-use-Red-Hat-version-string-to-match-RPM-package-vers.patch Patch22:open-iscsi-v2.0.873-4c9d6f9-22-use-Red-Hat-version-string-to-match-RPM-package-vers.patch
BuildRequires: flex bison python2-devel python3-devel python-setuptools doxygen kmod-devel systemd-units BuildRequires: flex bison python2-devel python3-devel python-setuptools doxygen kmod-devel systemd-units
BuildRequires: autoconf automake libtool libmount-devel BuildRequires: autoconf automake libtool libmount-devel isns-utils-devel openssl-devel
# For dir ownership # For dir ownership
Requires: %{name}-iscsiuio >= %{version}-%{release} Requires: %{name}-iscsiuio >= %{version}-%{release}
Requires(post): systemd Requires(post): systemd
@ -94,7 +91,7 @@ The %{name}-python3 package contains Python %{python3_version} bindings to the
libiscsi interface for interacting with %{name} libiscsi interface for interacting with %{name}
%prep %prep
%autosetup -p1 -n open-iscsi-%{open_iscsi_version}-%{open_iscsi_build} %autosetup -p1 -n open-iscsi-%{commit0}
# change exec_prefix, there's no easy way to override # change exec_prefix, there's no easy way to override
%{__sed} -i -e 's|^exec_prefix = /$|exec_prefix = %{_exec_prefix}|' Makefile %{__sed} -i -e 's|^exec_prefix = /$|exec_prefix = %{_exec_prefix}|' Makefile
@ -107,9 +104,6 @@ cd iscsiuio
autoreconf --install autoreconf --install
%{configure} %{configure}
cd .. cd ..
cd utils/open-isns
%{configure} --with-security=no --with-slp=no
cd ../..
%{__make} OPTFLAGS="%{optflags} %{?__global_ldflags} -DUSE_KMOD -lkmod" %{__make} OPTFLAGS="%{optflags} %{?__global_ldflags} -DUSE_KMOD -lkmod"
pushd libiscsi pushd libiscsi
@ -283,6 +277,10 @@ fi
%{python3_sitearch}/* %{python3_sitearch}/*
%changelog %changelog
* Tue Oct 06 2015 Chris Leech <cleech@redhat.com> - 6.2.0.873-29.git4c9d6f9
- rebase with upstream, change Source0 url to github
- build with external isns-utils
* Mon Oct 05 2015 Chris Leech <cleech@redhat.com> - 6.2.0.873-28.git6aa2c9b * Mon Oct 05 2015 Chris Leech <cleech@redhat.com> - 6.2.0.873-28.git6aa2c9b
- fixed broken multiple trigger scripts, removed old pre-systemd migration triggers - fixed broken multiple trigger scripts, removed old pre-systemd migration triggers
- added libiscsi session API patch (bz #1262279) - added libiscsi session API patch (bz #1262279)

View File

@ -1,4 +1,4 @@
From a6b6a38a783a29951a3c91f95416ebec69ea2375 Mon Sep 17 00:00:00 2001 From 974339c4e2f8321057bb5a28611433bbd5e28463 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Tue, 13 Aug 2013 10:59:44 -0700 Date: Tue, 13 Aug 2013 10:59:44 -0700
Subject: [PATCH] idmb_rec_write, check for tpgt first Subject: [PATCH] idmb_rec_write, check for tpgt first

View File

@ -1,4 +1,4 @@
From 8c5e8c8afba875944daa61fadc3add41475fab61 Mon Sep 17 00:00:00 2001 From 350deee0c814c5a3e2659436b69fdf999dd2d6a5 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Mon, 19 Nov 2012 17:09:24 -0800 Date: Mon, 19 Nov 2012 17:09:24 -0800
Subject: [PATCH] remove the offload boot supported ifdef Subject: [PATCH] remove the offload boot supported ifdef

View File

@ -1,4 +1,4 @@
From c9994e01142feb7010d695747062367c5dfd5c4d Mon Sep 17 00:00:00 2001 From d66273ad26fac7c6bbea6f6f0a34ea28ffd3a416 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Tue, 22 Jan 2013 14:27:12 -0800 Date: Tue, 22 Jan 2013 14:27:12 -0800
Subject: [PATCH] iscsiuio systemd unit files Subject: [PATCH] iscsiuio systemd unit files

View File

@ -1,4 +1,4 @@
From 5e8feef0fd14fc6247df2aaf2e514f2301c74ae0 Mon Sep 17 00:00:00 2001 From ae7a99ffb02936d6ab9da51ed1e98a08439a6acb Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Thu, 21 Feb 2013 21:05:39 -0800 Date: Thu, 21 Feb 2013 21:05:39 -0800
Subject: [PATCH] disable iscsid.startup from iscsiadm, prefer systemd socket Subject: [PATCH] disable iscsid.startup from iscsiadm, prefer systemd socket

View File

@ -1,4 +1,4 @@
From 63852a2853d190f9305c9c4056843fd79ab8219c Mon Sep 17 00:00:00 2001 From 89aefb2bb117d9766cc3ff4e05f4e0735d108a41 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Tue, 28 May 2013 13:12:27 -0700 Date: Tue, 28 May 2013 13:12:27 -0700
Subject: [PATCH] Don't check for autostart sessions if iscsi is not used (bug Subject: [PATCH] Don't check for autostart sessions if iscsi is not used (bug

View File

@ -1,4 +1,4 @@
From c285ea2f418f0dcba8526966c68610dc1f34edbb Mon Sep 17 00:00:00 2001 From a139c403e63a47b53b29df9588bed66db3d0d8d1 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Mon, 25 Nov 2013 22:28:12 -0800 Date: Mon, 25 Nov 2013 22:28:12 -0800
Subject: [PATCH] start socket listeners on iscsiadm command Subject: [PATCH] start socket listeners on iscsiadm command

View File

@ -1,4 +1,4 @@
From 55764ecafcc1df70111cbcb9643a77182b53a8e7 Mon Sep 17 00:00:00 2001 From d7e58a63422351cdf0e7a3917a7f1a4303036878 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Mon, 24 Feb 2014 09:33:33 -0800 Date: Mon, 24 Feb 2014 09:33:33 -0800
Subject: [PATCH] Revert "iscsiadm: return error when login fails" Subject: [PATCH] Revert "iscsiadm: return error when login fails"
@ -11,7 +11,7 @@ Done to address RHBZ #1015563
1 file changed, 2 insertions(+), 2 deletions(-) 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/usr/session_mgmt.c b/usr/session_mgmt.c diff --git a/usr/session_mgmt.c b/usr/session_mgmt.c
index 87b8e00..3815b1d 100644 index 596085b..07f587d 100644
--- a/usr/session_mgmt.c --- a/usr/session_mgmt.c
+++ b/usr/session_mgmt.c +++ b/usr/session_mgmt.c
@@ -178,12 +178,12 @@ int iscsi_login_portal(void *data, struct list_head *list, struct node_rec *rec) @@ -178,12 +178,12 @@ int iscsi_login_portal(void *data, struct list_head *list, struct node_rec *rec)

View File

@ -1,4 +1,4 @@
From 6ee8a34d108d8d3663da057cad210372e80cb65c Mon Sep 17 00:00:00 2001 From c769948e31e7d6239e792ed4e8f60b293811421b Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Wed, 26 Feb 2014 16:33:48 -0800 Date: Wed, 26 Feb 2014 16:33:48 -0800
Subject: [PATCH] update handling of boot sessions Subject: [PATCH] update handling of boot sessions

View File

@ -1,4 +1,4 @@
From 3e2bcef50b2b0a68f4ae9fb32a1cb67189b7a203 Mon Sep 17 00:00:00 2001 From 83e75cc234306e699067303bf573c41b4454ae87 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Fri, 14 Mar 2014 09:22:21 -0700 Date: Fri, 14 Mar 2014 09:22:21 -0700
Subject: [PATCH] update iscsi.service for boot session recovery Subject: [PATCH] update iscsi.service for boot session recovery

View File

@ -1,4 +1,4 @@
From 275312e70e0b076532af25fe93c05bbbd15a2295 Mon Sep 17 00:00:00 2001 From fb58e20b5d988a4dc863ed0087f701efa1454d78 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Wed, 17 Sep 2014 09:58:39 -0700 Date: Wed, 17 Sep 2014 09:58:39 -0700
Subject: [PATCH] updates to iscsi.service Subject: [PATCH] updates to iscsi.service

View File

@ -1,4 +1,4 @@
From ed34e9b47b883f4cf9d5ea03b5e6cc12cc010f07 Mon Sep 17 00:00:00 2001 From c4a695ec82c71e01ac2ab66a67b9b463a7ffb44f Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build> From: rpm-build <rpm-build>
Date: Tue, 13 Jan 2015 16:30:01 -0800 Date: Tue, 13 Jan 2015 16:30:01 -0800
Subject: [PATCH] make-session-shutdown-a-seperate-service.patch Subject: [PATCH] make-session-shutdown-a-seperate-service.patch

View File

@ -1,4 +1,4 @@
From c9247e2ad8b8e2b6cebdb5e5de4e0949f0d3db8c Mon Sep 17 00:00:00 2001 From 42412c08a8b0f38650f36aeaf311d558f96a749f Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Tue, 13 Aug 2013 11:34:31 -0700 Date: Tue, 13 Aug 2013 11:34:31 -0700
Subject: [PATCH] idbm_rec_write, seperate old and new style writes Subject: [PATCH] idbm_rec_write, seperate old and new style writes

View File

@ -1,4 +1,4 @@
From 8b7dc01508ee5a47566d2270d2e164c0435bdfe3 Mon Sep 17 00:00:00 2001 From c152b424c406bcc0b6495be91fecc60eacabe9cb Mon Sep 17 00:00:00 2001
From: Jiri Konecny <jkonecny@redhat.com> From: Jiri Konecny <jkonecny@redhat.com>
Date: Mon, 11 May 2015 13:16:26 +0200 Date: Mon, 11 May 2015 13:16:26 +0200
Subject: [PATCH] Add macros to release GIL lock Subject: [PATCH] Add macros to release GIL lock

View File

@ -1,3 +1,15 @@
From 3029917e4ed624245cb6d3ab6fd6a4058530f988 Mon Sep 17 00:00:00 2001
From: Peter Hatina <phatina@redhat.com>
Date: Mon, 5 Oct 2015 16:50:36 -0700
Subject: [PATCH] libiscsi introduce sessions API
---
libiscsi/libiscsi.c | 125 ++++++++++++++++++++++++++++++++++++++++++++++++++++
libiscsi/libiscsi.h | 56 +++++++++++++++++++++++
usr/iscsi_sysfs.c | 6 +++
usr/iscsi_sysfs.h | 2 +
4 files changed, 189 insertions(+)
diff --git a/libiscsi/libiscsi.c b/libiscsi/libiscsi.c diff --git a/libiscsi/libiscsi.c b/libiscsi/libiscsi.c
index 064e4b5..755c18c 100644 index 064e4b5..755c18c 100644
--- a/libiscsi/libiscsi.c --- a/libiscsi/libiscsi.c
@ -230,7 +242,7 @@ index 756590e..a9891f4 100644
* *
* Set the given nodes iSCSI parameter named by \e parameter to value \e value. * Set the given nodes iSCSI parameter named by \e parameter to value \e value.
diff --git a/usr/iscsi_sysfs.c b/usr/iscsi_sysfs.c diff --git a/usr/iscsi_sysfs.c b/usr/iscsi_sysfs.c
index c916ed8..5856f02 100644 index 3a37a48..1420421 100644
--- a/usr/iscsi_sysfs.c --- a/usr/iscsi_sysfs.c
+++ b/usr/iscsi_sysfs.c +++ b/usr/iscsi_sysfs.c
@@ -3,6 +3,7 @@ @@ -3,6 +3,7 @@
@ -273,3 +285,6 @@ index 9a56105..e4eaf20 100644
extern int iscsi_sysfs_for_each_iface_on_host(void *data, uint32_t host_no, extern int iscsi_sysfs_for_each_iface_on_host(void *data, uint32_t host_no,
int *nr_found, int *nr_found,
iscsi_sysfs_iface_op_fn *fn); iscsi_sysfs_iface_op_fn *fn);
--
2.1.0

View File

@ -0,0 +1,25 @@
From 72c4065472070e543c2d1e1aa0375fb87a2c3e6c Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com>
Date: Mon, 21 Jan 2013 15:43:36 -0800
Subject: [PATCH] use Red Hat version string to match RPM package version
---
usr/version.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/usr/version.h b/usr/version.h
index a090522..6894655 100644
--- a/usr/version.h
+++ b/usr/version.h
@@ -6,7 +6,7 @@
* This may not be the same value as the kernel versions because
* some other maintainer could merge a patch without going through us
*/
-#define ISCSI_VERSION_STR "2.0-873"
+#define ISCSI_VERSION_STR "6.2.0.873-29"
#define ISCSI_VERSION_FILE "/sys/module/scsi_transport_iscsi/version"
#endif
--
2.1.0

View File

@ -1,4 +1,4 @@
From 6143b83d2a0a313b1588ec0949fdf61e38f3b980 Mon Sep 17 00:00:00 2001 From 4fab0a9cc43f057296d7fc0e6f9b3f9897a3e5bc Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Tue, 13 Aug 2013 12:39:07 -0700 Date: Tue, 13 Aug 2013 12:39:07 -0700
Subject: [PATCH] idbw_rec_write, pick tpgt from existing record Subject: [PATCH] idbw_rec_write, pick tpgt from existing record

View File

@ -1,4 +1,4 @@
From d8eb7f9f08f3371aa153779ee6dafb6b04afb914 Mon Sep 17 00:00:00 2001 From d9f3f79341167e5cd956683bf2d223b8e9114745 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Wed, 19 Dec 2012 15:07:36 -0800 Date: Wed, 19 Dec 2012 15:07:36 -0800
Subject: [PATCH] update systemd service files, add iscsi.service for starting Subject: [PATCH] update systemd service files, add iscsi.service for starting

View File

@ -1,4 +1,4 @@
From 33c39eb2242c01ead31aaaa964bc17a60dbf1582 Mon Sep 17 00:00:00 2001 From 41c832215e1d76907c28eccd6b5a29d7356ae34e Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Mon, 19 Aug 2013 07:18:25 -0700 Date: Mon, 19 Aug 2013 07:18:25 -0700
Subject: [PATCH] iscsi boot related service file updates Subject: [PATCH] iscsi boot related service file updates

View File

@ -1,4 +1,4 @@
From 067a87077e35e4df3564b42c675394797afa59c8 Mon Sep 17 00:00:00 2001 From 42b331859a5fbbf4ed63c558828480c9070eccdc Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Mon, 19 Nov 2012 16:37:13 -0800 Date: Mon, 19 Nov 2012 16:37:13 -0800
Subject: [PATCH] update initscripts and docs Subject: [PATCH] update initscripts and docs
@ -10,7 +10,7 @@ Subject: [PATCH] update initscripts and docs
3 files changed, 18 insertions(+), 18 deletions(-) 3 files changed, 18 insertions(+), 18 deletions(-)
diff --git a/README b/README diff --git a/README b/README
index 06d1b6f..0ac4529 100644 index cbe8763..8db3013 100644
--- a/README --- a/README
+++ b/README +++ b/README
@@ -74,11 +74,6 @@ the cache sync command will fail. @@ -74,11 +74,6 @@ the cache sync command will fail.
@ -22,10 +22,10 @@ index 06d1b6f..0ac4529 100644
-you do not use header or data digests. They are the kernel options, -you do not use header or data digests. They are the kernel options,
-CONFIG_CRYPTO and CONFIG_CRYPTO_CRC32C, respectively. -CONFIG_CRYPTO and CONFIG_CRYPTO_CRC32C, respectively.
- -
By default the kernel's iSCSI modules will be used. Running: The userspace components: iscsid, iscsiadm and iscsistart require the
open-isns library which can be found here:
make @@ -1132,7 +1127,7 @@ Red Hat or Fedora:
@@ -1118,7 +1113,7 @@ Red Hat or Fedora:
----------------- -----------------
To start open-iscsi in Red Hat/Fedora you can do: To start open-iscsi in Red Hat/Fedora you can do:
@ -34,7 +34,7 @@ index 06d1b6f..0ac4529 100644
To get open-iscsi to automatically start at run time you may have to To get open-iscsi to automatically start at run time you may have to
run: run:
@@ -1326,6 +1321,8 @@ iscsid will only perform rediscovery when it gets a SCN from the server. @@ -1340,6 +1335,8 @@ iscsid will only perform rediscovery when it gets a SCN from the server.
# linux-isns (SLES's iSNS server) where it sometimes does not send SCN # linux-isns (SLES's iSNS server) where it sometimes does not send SCN
# events in the proper format, so they may not get handled. # events in the proper format, so they may not get handled.

View File

@ -1,4 +1,4 @@
From f60148c57a269a5dc79a8138e3b9775611ff20d0 Mon Sep 17 00:00:00 2001 From 45031a3cf05a2b1c2b558e361299fc0e5964a4e1 Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Mon, 19 Nov 2012 16:38:45 -0800 Date: Mon, 19 Nov 2012 16:38:45 -0800
Subject: [PATCH] use var for config Subject: [PATCH] use var for config
@ -12,10 +12,10 @@ Subject: [PATCH] use var for config
5 files changed, 33 insertions(+), 31 deletions(-) 5 files changed, 33 insertions(+), 31 deletions(-)
diff --git a/README b/README diff --git a/README b/README
index 0ac4529..e7c7bf5 100644 index 8db3013..cfc7f2f 100644
--- a/README --- a/README
+++ b/README +++ b/README
@@ -156,8 +156,7 @@ Usage: iscsid [OPTION] @@ -170,8 +170,7 @@ Usage: iscsid [OPTION]
Open-iSCSI persistent configuration is stored in a number of Open-iSCSI persistent configuration is stored in a number of
directories under a configuration root directory, using a flat-file directories under a configuration root directory, using a flat-file
@ -25,7 +25,7 @@ index 0ac4529..e7c7bf5 100644
Configuration is contained in directories for: Configuration is contained in directories for:
@@ -475,7 +474,7 @@ a scsi_host per HBA port). @@ -489,7 +488,7 @@ a scsi_host per HBA port).
To manage both types of initiator stacks, iscsiadm uses the interface (iface) To manage both types of initiator stacks, iscsiadm uses the interface (iface)
structure. For each HBA port or for software iscsi for each network structure. For each HBA port or for software iscsi for each network
device (ethX) or NIC, that you wish to bind sessions to you must create device (ethX) or NIC, that you wish to bind sessions to you must create
@ -34,7 +34,7 @@ index 0ac4529..e7c7bf5 100644
Prep: Prep:
@@ -509,29 +508,29 @@ Running: @@ -523,29 +522,29 @@ Running:
iface0 qla4xxx,00:c0:dd:08:63:e8,20.15.0.7,default,iqn.2005-06.com.redhat:madmax iface0 qla4xxx,00:c0:dd:08:63:e8,20.15.0.7,default,iqn.2005-06.com.redhat:madmax
iface1 qla4xxx,00:c0:dd:08:63:ea,20.15.0.9,default,iqn.2005-06.com.redhat:madmax iface1 qla4xxx,00:c0:dd:08:63:ea,20.15.0.9,default,iqn.2005-06.com.redhat:madmax
@ -69,7 +69,7 @@ index 0ac4529..e7c7bf5 100644
iface.transport_name = tcp iface.transport_name = tcp
iface.hwaddress = 00:C0:DD:08:63:E7 iface.hwaddress = 00:C0:DD:08:63:E7
@@ -581,7 +580,7 @@ cxgb3i.00:07:43:05:97:07 cxgb3i,00:07:43:05:97:07,<empty>,<empty>,<empty> @@ -595,7 +594,7 @@ cxgb3i.00:07:43:05:97:07 cxgb3i,00:07:43:05:97:07,<empty>,<empty>,<empty>
qla4xxx.00:0e:1e:04:8b:2e qla4xxx,00:0e:1e:04:8b:2e,<empty>,<empty>,<empty> qla4xxx.00:0e:1e:04:8b:2e qla4xxx,00:0e:1e:04:8b:2e,<empty>,<empty>,<empty>
@ -78,7 +78,7 @@ index 0ac4529..e7c7bf5 100644
The format is: The format is:
iface_name transport_name,hwaddress,ipaddress,net_ifacename,initiatorname iface_name transport_name,hwaddress,ipaddress,net_ifacename,initiatorname
@@ -667,7 +666,7 @@ need a seperate network connection to the target for discovery purposes. @@ -681,7 +680,7 @@ need a seperate network connection to the target for discovery purposes.
*This will be fixed in the next version of open-iscsi* *This will be fixed in the next version of open-iscsi*
For compatibility reasons, when you run iscsiadm to do discovery, it For compatibility reasons, when you run iscsiadm to do discovery, it
@ -87,7 +87,7 @@ index 0ac4529..e7c7bf5 100644
tcp for the iface.transport and it will bind the portals that are discovered tcp for the iface.transport and it will bind the portals that are discovered
so that they will be logged in through those ifaces. This behavior can also so that they will be logged in through those ifaces. This behavior can also
be overriden by passing in the interfaces you want to use. For the case be overriden by passing in the interfaces you want to use. For the case
@@ -685,7 +684,7 @@ we do not bind a session to a iface, then you can use the special iface @@ -699,7 +698,7 @@ we do not bind a session to a iface, then you can use the special iface
iscsiadm -m discoverydb -t st -p ip:port -I default --discover -P 1 iscsiadm -m discoverydb -t st -p ip:port -I default --discover -P 1
@ -96,7 +96,7 @@ index 0ac4529..e7c7bf5 100644
not pass anything into iscsiadm, running iscsiadm will do the default not pass anything into iscsiadm, running iscsiadm will do the default
behavior, where we allow the network subsystem to decide which behavior, where we allow the network subsystem to decide which
device to use. device to use.
@@ -727,7 +726,7 @@ To now log into targets it is the same as with sofware iscsi. See section @@ -741,7 +740,7 @@ To now log into targets it is the same as with sofware iscsi. See section
./iscsiadm -m discoverydb -t st -p 192.168.1.1:3260 --discover ./iscsiadm -m discoverydb -t st -p 192.168.1.1:3260 --discover
@ -105,7 +105,7 @@ index 0ac4529..e7c7bf5 100644
ID [portal = 192.168.1.1:3260 and type = sendtargets. If found it ID [portal = 192.168.1.1:3260 and type = sendtargets. If found it
will perform discovery using the settings stored in the record. will perform discovery using the settings stored in the record.
If a record does not exist, it will be created using the iscsid.conf If a record does not exist, it will be created using the iscsid.conf
@@ -736,7 +735,7 @@ To now log into targets it is the same as with sofware iscsi. See section @@ -750,7 +749,7 @@ To now log into targets it is the same as with sofware iscsi. See section
The argument to -p may also be a hostname instead of an address. The argument to -p may also be a hostname instead of an address.
./iscsiadm -m discoverydb -t st -p smoehost --discover ./iscsiadm -m discoverydb -t st -p smoehost --discover
@ -114,7 +114,7 @@ index 0ac4529..e7c7bf5 100644
interfaces using software iscsi. If any are found then nodes found interfaces using software iscsi. If any are found then nodes found
during discovery will be setup so that they can logged in through during discovery will be setup so that they can logged in through
those interfaces. To specify a specific iface, pass the those interfaces. To specify a specific iface, pass the
@@ -792,7 +791,7 @@ To now log into targets it is the same as with sofware iscsi. See section @@ -806,7 +805,7 @@ To now log into targets it is the same as with sofware iscsi. See section
This command will perform discovery, but not manipulate the node DB. This command will perform discovery, but not manipulate the node DB.
- SendTargets iSCSI Discovery with a specific interface. If you - SendTargets iSCSI Discovery with a specific interface. If you
@ -123,7 +123,7 @@ index 0ac4529..e7c7bf5 100644
then you can pass them in during discovery: then you can pass them in during discovery:
./iscsiadm -m discoverydb -t sendtargets -p 192.168.1.1:3260 \ ./iscsiadm -m discoverydb -t sendtargets -p 192.168.1.1:3260 \
@@ -1193,8 +1192,8 @@ where targetname is the name of the target and ip_address:port is the address @@ -1207,8 +1206,8 @@ where targetname is the name of the target and ip_address:port is the address
and port of the portal. tpgt, is the portal group tag of and port of the portal. tpgt, is the portal group tag of
the portal, and is not used in iscsiadm commands except for static the portal, and is not used in iscsiadm commands except for static
record creation. And iface name is the name of the iscsi interface record creation. And iface name is the name of the iscsi interface
@ -134,7 +134,7 @@ index 0ac4529..e7c7bf5 100644
Default here is iscsi_tcp/tcp to be used over which ever NIC the Default here is iscsi_tcp/tcp to be used over which ever NIC the
network layer decides is best. network layer decides is best.
@@ -1309,7 +1308,7 @@ If set, iscsid will perform discovery to the address every @@ -1323,7 +1322,7 @@ If set, iscsid will perform discovery to the address every
discovery.isns.discoveryd_poll_inval or discovery.isns.discoveryd_poll_inval or
discovery.sendtargets.discoveryd_poll_inval seconds, discovery.sendtargets.discoveryd_poll_inval seconds,
and it will log into any portals found from the discovery source using and it will log into any portals found from the discovery source using
@ -144,7 +144,7 @@ index 0ac4529..e7c7bf5 100644
Note that for iSNS the poll_interval does not have to be set. If not set, Note that for iSNS the poll_interval does not have to be set. If not set,
iscsid will only perform rediscovery when it gets a SCN from the server. iscsid will only perform rediscovery when it gets a SCN from the server.
diff --git a/doc/iscsiadm.8 b/doc/iscsiadm.8 diff --git a/doc/iscsiadm.8 b/doc/iscsiadm.8
index f046236..3a581e3 100644 index c7d8c92..3f33f6c 100644
--- a/doc/iscsiadm.8 --- a/doc/iscsiadm.8
+++ b/doc/iscsiadm.8 +++ b/doc/iscsiadm.8
@@ -241,7 +241,7 @@ This option is only valid for ping submode. @@ -241,7 +241,7 @@ This option is only valid for ping submode.

View File

@ -1,4 +1,4 @@
From b346b33b7a0031cb9e727be994fa4a05d18b5f66 Mon Sep 17 00:00:00 2001 From ccdc848d3e9a10f4615fbb55aa928dd28b29df7b Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com> From: Chris Leech <cleech@redhat.com>
Date: Mon, 19 Nov 2012 16:40:04 -0800 Date: Mon, 19 Nov 2012 16:40:04 -0800
Subject: [PATCH] use red hat for name Subject: [PATCH] use red hat for name

View File

@ -1,4 +1,4 @@
From c76c0965e20aa2a0df13b02cf080594d1a1f7c04 Mon Sep 17 00:00:00 2001 From 31d85c66cce07fedd0c8eba7dfba27ed573a26e9 Mon Sep 17 00:00:00 2001
From: rpm-build <rpm-build> From: rpm-build <rpm-build>
Date: Mon, 26 Jan 2015 12:57:11 -0800 Date: Mon, 26 Jan 2015 12:57:11 -0800
Subject: [PATCH] libiscsi Subject: [PATCH] libiscsi
@ -45,10 +45,10 @@ Subject: [PATCH] libiscsi
create mode 100644 libiscsi/tests/test_set_auth.c create mode 100644 libiscsi/tests/test_set_auth.c
diff --git a/Makefile b/Makefile diff --git a/Makefile b/Makefile
index 1ef9273..859f13f 100644 index c8cd00e..cf028cf 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -44,6 +44,7 @@ user: utils/open-isns/Makefile iscsiuio/Makefile @@ -43,6 +43,7 @@ user: iscsiuio/Makefile
$(MAKE) -C usr $(MAKE) -C usr
$(MAKE) -C utils $(MAKE) -C utils
$(MAKE) -C iscsiuio $(MAKE) -C iscsiuio
@ -56,7 +56,7 @@ index 1ef9273..859f13f 100644
@echo @echo
@echo "Compilation complete Output file" @echo "Compilation complete Output file"
@echo "----------------------------------- ----------------" @echo "----------------------------------- ----------------"
@@ -75,6 +76,7 @@ kernel: force @@ -71,6 +72,7 @@ kernel: force
force: ; force: ;
clean: clean:
@ -3910,20 +3910,20 @@ index 0000000..a21f888
+ return rc; + return rc;
+} +}
diff --git a/usr/Makefile b/usr/Makefile diff --git a/usr/Makefile b/usr/Makefile
index e23fee1..12780e4 100644 index 5ac0726..ae1e51f 100644
--- a/usr/Makefile --- a/usr/Makefile
+++ b/usr/Makefile +++ b/usr/Makefile
@@ -31,7 +31,7 @@ endif @@ -30,7 +30,7 @@ endif
CFLAGS ?= -O2 -g CFLAGS ?= -O2 -g
WARNFLAGS ?= -Wall -Wstrict-prototypes WARNFLAGS ?= -Wall -Wstrict-prototypes
CFLAGS += $(WARNFLAGS) -I../include -I. -I../utils/open-isns \ -CFLAGS += $(WARNFLAGS) -I../include -I. -D$(OSNAME) $(IPC_CFLAGS)
- -D$(OSNAME) $(IPC_CFLAGS) +CFLAGS += $(WARNFLAGS) -I../include -I. -D$(OSNAME) $(IPC_CFLAGS) -DISNS_ENABLE
+ -D$(OSNAME) $(IPC_CFLAGS) -DISNS_ENABLE
PROGRAMS = iscsid iscsiadm iscsistart PROGRAMS = iscsid iscsiadm iscsistart
# libc compat files # libc compat files
diff --git a/usr/discovery.c b/usr/discovery.c diff --git a/usr/discovery.c b/usr/discovery.c
index 38968ca..ab89c69 100644 index 43c2359..3cc2379 100644
--- a/usr/discovery.c --- a/usr/discovery.c
+++ b/usr/discovery.c +++ b/usr/discovery.c
@@ -36,6 +36,7 @@ @@ -36,6 +36,7 @@
@ -3934,14 +3934,15 @@ index 38968ca..ab89c69 100644
#include "log.h" #include "log.h"
#include "idbm.h" #include "idbm.h"
#include "iscsi_settings.h" #include "iscsi_settings.h"
@@ -50,9 +51,11 @@ @@ -49,10 +50,12 @@
#include "iface.h"
#include "iscsi_timer.h" #include "iscsi_timer.h"
#include "iscsi_err.h" #include "iscsi_err.h"
/* libisns includes */
+#ifdef ISNS_ENABLE +#ifdef ISNS_ENABLE
#include "isns.h" /* libisns includes */
#include "paths.h" #include <libisns/isns.h>
#include "message.h" #include <libisns/paths.h>
#include <libisns/message.h>
+#endif +#endif
#ifdef SLP_ENABLE #ifdef SLP_ENABLE

View File

@ -1 +1 @@
8b8316d7c9469149a6cc6234478347f7 open-iscsi-2.0-873.tar.gz e67e4f2bce31fadb9795b2780ead91e6 open-iscsi-4c9d6f9.tar.gz