parent
eaa26054bb
commit
1065f5c1cb
@ -1,20 +1,12 @@
|
||||
diff -aurp open-iscsi-2.0-872-rc4-bnx2i/include/fw_context.h open-iscsi-2.0-872-rc4-bnx2i.work/include/fw_context.h
|
||||
--- open-iscsi-2.0-872-rc4-bnx2i/include/fw_context.h 2011-10-10 13:57:38.000000000 -0500
|
||||
+++ open-iscsi-2.0-872-rc4-bnx2i.work/include/fw_context.h 2011-10-12 01:03:30.000000000 -0500
|
||||
@@ -21,6 +21,7 @@
|
||||
#ifndef FWPARAM_CONTEXT_H_
|
||||
#define FWPARAM_CONTEXT_H_
|
||||
|
||||
+#include <netdb.h>
|
||||
#include <net/if.h>
|
||||
|
||||
#include "iscsi_proto.h"
|
||||
@@ -33,7 +34,7 @@ struct boot_context {
|
||||
/* target settings */
|
||||
int target_port;
|
||||
char targetname[TARGET_NAME_MAXLEN + 1];
|
||||
- char target_ipaddr[32];
|
||||
+ char target_ipaddr[NI_MAXHOST];
|
||||
+ char target_ipaddr[256];
|
||||
char chap_name[AUTH_STR_MAX_LEN];
|
||||
char chap_password[AUTH_STR_MAX_LEN];
|
||||
char chap_name_in[AUTH_STR_MAX_LEN];
|
||||
@ -23,7 +15,7 @@ diff -aurp open-iscsi-2.0-872-rc4-bnx2i/include/fw_context.h open-iscsi-2.0-872-
|
||||
|
||||
/* network settings */
|
||||
- char dhcp[18];
|
||||
+ char dhcp[NI_MAXHOST];
|
||||
+ char dhcp[256];
|
||||
char iface[IF_NAMESIZE];
|
||||
char mac[18];
|
||||
- char ipaddr[18];
|
||||
@ -31,35 +23,11 @@ diff -aurp open-iscsi-2.0-872-rc4-bnx2i/include/fw_context.h open-iscsi-2.0-872-
|
||||
- char primary_dns[18];
|
||||
- char secondary_dns[18];
|
||||
- char mask[18];
|
||||
+ char ipaddr[NI_MAXHOST];
|
||||
+ char gateway[NI_MAXHOST];
|
||||
+ char primary_dns[NI_MAXHOST];
|
||||
+ char secondary_dns[NI_MAXHOST];
|
||||
+ char mask[NI_MAXHOST];
|
||||
+ char ipaddr[256];
|
||||
+ char gateway[256];
|
||||
+ char primary_dns[256];
|
||||
+ char secondary_dns[256];
|
||||
+ char mask[256];
|
||||
char lun[17];
|
||||
char vlan[15];
|
||||
|
||||
diff -aurp open-iscsi-2.0-872-rc4-bnx2i/README open-iscsi-2.0-872-rc4-bnx2i.work/README
|
||||
--- open-iscsi-2.0-872-rc4-bnx2i/README 2011-10-10 13:57:38.000000000 -0500
|
||||
+++ open-iscsi-2.0-872-rc4-bnx2i.work/README 2011-10-11 00:39:46.000000000 -0500
|
||||
@@ -161,7 +161,7 @@ term node to refer to a portal on a targ
|
||||
require that --targetname and --portal argument be used when in node mode.
|
||||
|
||||
For session mode, a session id (sid) is used. The sid of a session can be
|
||||
-found by running iscsiadm -m session -i. The session id is not currently
|
||||
+found by running iscsiadm -m session -P 1. The session id is not currently
|
||||
persistent and is partially determined by when the session is setup.
|
||||
|
||||
Note that some of the iSCSI Node and iSCSI Discovery operations
|
||||
diff -aurp open-iscsi-2.0-872-rc4-bnx2i/utils/fwparam_ibft/Makefile open-iscsi-2.0-872-rc4-bnx2i.work/utils/fwparam_ibft/Makefile
|
||||
--- open-iscsi-2.0-872-rc4-bnx2i/utils/fwparam_ibft/Makefile 2011-10-10 13:57:38.000000000 -0500
|
||||
+++ open-iscsi-2.0-872-rc4-bnx2i.work/utils/fwparam_ibft/Makefile 2011-10-12 01:03:30.000000000 -0500
|
||||
@@ -28,7 +28,7 @@ CLEANFILES = $(OBJS) *.output *~
|
||||
|
||||
OPTFLAGS ?= -O2 -g -fPIC
|
||||
WARNFLAGS ?= -Wall -Wstrict-prototypes
|
||||
-CFLAGS += $(OPTFLAGS) $(WARNFLAGS) -I../../include -I../../usr
|
||||
+CFLAGS += $(OPTFLAGS) $(WARNFLAGS) -I../../include -I../../usr -D_GNU_SOURCE
|
||||
|
||||
all: $(OBJS)
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
Summary: iSCSI daemon and utility programs
|
||||
Name: iscsi-initiator-utils
|
||||
Version: 6.2.0.872
|
||||
Release: 28%{?dist}
|
||||
Release: 29%{?dist}
|
||||
Source0: http://people.redhat.com/mchristi/iscsi/rhel6.0/source/open-iscsi-2.0-872-rc4-bnx2i.tar.gz
|
||||
Source1: iscsid.init
|
||||
Source2: iscsidevs.init
|
||||
|
Loading…
Reference in New Issue
Block a user