67 lines
1.8 KiB
Diff
67 lines
1.8 KiB
Diff
From af8fba0402dda8e459399542d19d5a9afebe71b2 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Pavel=20=C5=A0imerda?= <psimerda@redhat.com>
|
|
Date: Fri, 13 Mar 2015 13:17:02 +0100
|
|
Subject: [PATCH 2/7] turn Makefile more distribution friendly
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Changes:
|
|
|
|
* Accept directory settings from environment.
|
|
* Remove redundant ROOTDIR variable.
|
|
* Set KERNEL_INCLUDE default to '/usr/include'.
|
|
* Use CFLAGS from environemnt.
|
|
|
|
Note: In the long term it might be better to improve the configure
|
|
script to generate those parts of the Makefile in a manner similar
|
|
to autoconf. It might be even practical to autotoolize the package.
|
|
|
|
Signed-Off-By: Pavel Šimerda <psimerda@redhat.com>
|
|
---
|
|
Makefile | 22 +++++++++++-----------
|
|
1 file changed, 11 insertions(+), 11 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 9dbb29f..18faee4 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1,15 +1,15 @@
|
|
-ROOTDIR=$(DESTDIR)
|
|
-PREFIX=/usr
|
|
-LIBDIR=$(PREFIX)/lib
|
|
-SBINDIR=/sbin
|
|
-CONFDIR=/etc/iproute2
|
|
-DATADIR=$(PREFIX)/share
|
|
-DOCDIR=$(DATADIR)/doc/iproute2
|
|
-MANDIR=$(DATADIR)/man
|
|
-ARPDDIR=/var/lib/arpd
|
|
+PREFIX?=/usr
|
|
+LIBDIR?=$(PREFIX)/lib
|
|
+SBINDIR?=/sbin
|
|
+CONFDIR?=/etc/iproute2
|
|
+DATADIR?=$(PREFIX)/share
|
|
+DOCDIR?=$(DATADIR)/doc/iproute2
|
|
+MANDIR?=$(DATADIR)/man
|
|
+ARPDDIR?=/var/lib/arpd
|
|
+KERNEL_INCLUDE?=/usr/include
|
|
|
|
# Path to db_185.h include
|
|
-DBM_INCLUDE:=$(ROOTDIR)/usr/include
|
|
+DBM_INCLUDE:=$(DESTDIR)/usr/include
|
|
|
|
SHARED_LIBS = y
|
|
|
|
@@ -33,7 +33,7 @@ CCOPTS = -O2
|
|
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
|
|
WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
|
|
|
|
-CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
|
|
+CFLAGS := $(WFLAGS) $(CCOPTS) -I../include $(DEFINES) $(CFLAGS)
|
|
YACCFLAGS = -d -t -v
|
|
|
|
SUBDIRS=lib ip tc bridge misc netem genl man
|
|
--
|
|
2.0.5
|
|
|