iproute-6.7.0-1.f40
* Fri Feb 09 2024 Andrea Claudi <aclaudi@redhat.com> - 6.7.0-1.f40 - New version 6.7.0 (Andrea Claudi) [2247875] - Fix FTBFS on ppc64le (Andrea Claudi) [2261250] - Remove libdb-devel dependency from iproute [1788538] - Enable color output by default [2239120] Resolves: rhbz#2247875, rhbz#2261250, rhbz#1788538, #rhbz2239120 Signed-off-by: Andrea Claudi <aclaudi@redhat.com>
This commit is contained in:
parent
ff66d681df
commit
f8ce705323
1
.gitignore
vendored
1
.gitignore
vendored
@ -23,3 +23,4 @@
|
||||
/iproute2-6.3.0.tar.xz
|
||||
/iproute2-6.4.0.tar.xz
|
||||
/iproute2-6.5.0.tar.xz
|
||||
/iproute2-6.7.0.tar.xz
|
||||
|
@ -1,48 +0,0 @@
|
||||
From 358ce5cf068fb9f630a699e94e5aa1498856296a Mon Sep 17 00:00:00 2001
|
||||
Message-ID: <358ce5cf068fb9f630a699e94e5aa1498856296a.1695218419.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Wed, 20 Sep 2023 15:52:51 +0200
|
||||
Subject: [PATCH] Makefile: ensure CONF_USR_DIR honours the libdir config
|
||||
|
||||
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=2237746
|
||||
Upstream Status: iproute2.git commit 946753a4
|
||||
|
||||
commit 946753a4459bd035132a27bb2eb87529c1979b90
|
||||
Author: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Fri Sep 15 21:59:06 2023 +0200
|
||||
|
||||
Makefile: ensure CONF_USR_DIR honours the libdir config
|
||||
|
||||
Following commit cee0cf84bd32 ("configure: add the --libdir option"),
|
||||
iproute2 lib directory is configurable using the --libdir option on the
|
||||
configure script. However, CONF_USR_DIR does not honour the configured
|
||||
lib path in its default value.
|
||||
|
||||
This fixes the issue simply using $(LIBDIR) instead of $(PREFIX)/lib.
|
||||
Please note that the default value for $(LIBDIR) is exactly
|
||||
$(PREFIX)/lib, so this does not change the default value for
|
||||
CONF_USR_DIR.
|
||||
|
||||
Fixes: 0a0a8f12fa1b ("Read configuration files from /etc and /usr")
|
||||
Signed-off-by: Andrea Claudi <aclaudi@redhat.com>
|
||||
Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 7d1819ce..54539ce4 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -17,7 +17,7 @@ endif
|
||||
PREFIX?=/usr
|
||||
SBINDIR?=/sbin
|
||||
CONF_ETC_DIR?=/etc/iproute2
|
||||
-CONF_USR_DIR?=$(PREFIX)/lib/iproute2
|
||||
+CONF_USR_DIR?=$(LIBDIR)/iproute2
|
||||
NETNS_RUN_DIR?=/var/run/netns
|
||||
NETNS_ETC_DIR?=/etc/netns
|
||||
DATADIR?=$(PREFIX)/share
|
||||
--
|
||||
2.41.0
|
||||
|
66
0001-iproute2-fix-build-failure-on-ppc64le.patch
Normal file
66
0001-iproute2-fix-build-failure-on-ppc64le.patch
Normal file
@ -0,0 +1,66 @@
|
||||
From ac4e9bd66d9c8461024dfd3698e120c678eb6cfc Mon Sep 17 00:00:00 2001
|
||||
Message-ID: <ac4e9bd66d9c8461024dfd3698e120c678eb6cfc.1707519557.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Fri, 9 Feb 2024 23:56:20 +0100
|
||||
Subject: [PATCH] iproute2: fix build failure on ppc64le
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=2261250
|
||||
Upstream Status: posted upstream
|
||||
|
||||
commit d13ef7c00b60a50a5e8ddbb7ff138399689d3483
|
||||
Author: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Fri Feb 9 10:44:55 2024 +0100
|
||||
|
||||
iproute2: fix build failure on ppc64le
|
||||
|
||||
ppc64le build fails with error on ifstat.c when
|
||||
-Wincompatible-pointer-types is enabled:
|
||||
|
||||
ifstat.c: In function ‘dump_raw_db’:
|
||||
ifstat.c:323:44: error: initialization of ‘long long unsigned int *’ from incompatible pointer type ‘__u64 *’ {aka ‘long unsigned int *’} [-Wincompatible-pointer-types]
|
||||
323 | unsigned long long *vals = n->val;
|
||||
|
||||
Several other warnings are produced when -Wformat= is set, for example:
|
||||
|
||||
ss.c:3244:34: warning: format ‘%llu’ expects argument of type ‘long long unsigned int’, but argument 2 has type ‘__u64’ {aka ‘long unsigned int’} [-Wformat=]
|
||||
3244 | out(" rcv_nxt:%llu", s->mptcpi_rcv_nxt);
|
||||
| ~~~^ ~~~~~~~~~~~~~~~~~
|
||||
| | |
|
||||
| | __u64 {aka long unsigned int}
|
||||
| long long unsigned int
|
||||
| %lu
|
||||
|
||||
This happens because __u64 is defined as long unsigned on ppc64le. As
|
||||
pointed out by Florian Weimar, we should use -D__SANE_USERSPACE_TYPES__
|
||||
if we really want to use long long unsigned in iproute2.
|
||||
|
||||
This fix the build failure and all the warnings without any change on
|
||||
the code itself.
|
||||
|
||||
Suggested-by: Florian Weimer <fweimer@redhat.com>
|
||||
Signed-off-by: Andrea Claudi <aclaudi@redhat.com>
|
||||
|
||||
Signed-off-by: Andrea Claudi <aclaudi@redhat.com>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 8024d45e..3b9daede 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -60,7 +60,7 @@ CC := gcc
|
||||
HOSTCC ?= $(CC)
|
||||
DEFINES += -D_GNU_SOURCE
|
||||
# Turn on transparent support for LFS
|
||||
-DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
|
||||
+DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D__SANE_USERSPACE_TYPES__
|
||||
CCOPTS = -O2 -pipe
|
||||
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
|
||||
WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
|
||||
--
|
||||
2.43.0
|
||||
|
27
iproute.spec
27
iproute.spec
@ -1,13 +1,10 @@
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 6.5.0
|
||||
Version: 6.7.0
|
||||
Release: %autorelease
|
||||
%if 0%{?rhel}
|
||||
Group: Applications/System
|
||||
%endif
|
||||
URL: https://kernel.org/pub/linux/utils/net/%{name}2/
|
||||
Source0: https://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.xz
|
||||
Patch0: 0001-Makefile-ensure-CONF_USR_DIR-honours-the-libdir-conf.patch
|
||||
Patch0: 0001-iproute2-fix-build-failure-on-ppc64le.patch
|
||||
|
||||
License: GPL-2.0-or-later AND NIST-PD
|
||||
BuildRequires: bison
|
||||
@ -17,7 +14,6 @@ BuildRequires: gcc
|
||||
BuildRequires: iptables-devel >= 1.4.5
|
||||
BuildRequires: libbpf-devel
|
||||
BuildRequires: libcap-devel
|
||||
BuildRequires: libdb-devel
|
||||
BuildRequires: libmnl-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: make
|
||||
@ -38,9 +34,6 @@ kernel.
|
||||
|
||||
%package tc
|
||||
Summary: Linux Traffic Control utility
|
||||
%if 0%{?rhel}
|
||||
Group: Applications/System
|
||||
%endif
|
||||
License: GPL-2.0-or-later
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Provides: /sbin/tc
|
||||
@ -53,9 +46,6 @@ Linux.
|
||||
%if ! 0%{?_module_build}
|
||||
%package doc
|
||||
Summary: Documentation for iproute2 utilities with examples
|
||||
%if 0%{?rhel}
|
||||
Group: Applications/System
|
||||
%endif
|
||||
License: GPL-2.0-or-later
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
@ -65,9 +55,6 @@ The iproute documentation contains howtos and examples of settings.
|
||||
|
||||
%package devel
|
||||
Summary: iproute development files
|
||||
%if 0%{?rhel}
|
||||
Group: Development/Libraries
|
||||
%endif
|
||||
License: GPL-2.0-or-later
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Provides: iproute-static = %{version}-%{release}
|
||||
@ -79,8 +66,8 @@ The libnetlink static library.
|
||||
%autosetup -p1 -n %{name}2-%{version}
|
||||
|
||||
%build
|
||||
%configure
|
||||
echo -e "\nCONFDIR:=%{_libdir}/iproute2\nSBINDIR=%{_sbindir}" >> config.mk
|
||||
%configure --color auto
|
||||
echo -e "\nSBINDIR=%{_sbindir}" >> config.mk
|
||||
%make_build
|
||||
|
||||
%install
|
||||
@ -97,11 +84,11 @@ rm -rf '%{buildroot}%{_docdir}'
|
||||
|
||||
# append deprecated values to rt_dsfield for compatibility reasons
|
||||
%if 0%{?rhel} && ! 0%{?eln}
|
||||
cat %{SOURCE1} >>%{buildroot}%{_libdir}/iproute2/rt_dsfield
|
||||
cat %{SOURCE1} >>%{buildroot}%{_datadir}/iproute2/rt_dsfield
|
||||
%endif
|
||||
|
||||
%files
|
||||
%dir %{_libdir}/iproute2
|
||||
%dir %{_datadir}/iproute2
|
||||
%license COPYING
|
||||
%doc README README.devel
|
||||
%{_mandir}/man7/*
|
||||
@ -109,7 +96,7 @@ cat %{SOURCE1} >>%{buildroot}%{_libdir}/iproute2/rt_dsfield
|
||||
%{_mandir}/man8/*
|
||||
%exclude %{_mandir}/man8/tc*
|
||||
%exclude %{_mandir}/man8/cbq*
|
||||
%attr(644,root,root) %config(noreplace) %{_libdir}/iproute2/*
|
||||
%attr(644,root,root) %config(noreplace) %{_datadir}/iproute2/*
|
||||
%{_sbindir}/*
|
||||
%exclude %{_sbindir}/tc
|
||||
%exclude %{_sbindir}/routel
|
||||
|
15
sources
15
sources
@ -1,14 +1 @@
|
||||
SHA512 (iproute2-5.10.0.tar.xz) = a468eefa797898b6de452212aa432c0a931434defacae5fb4335754c1292c5d86a8c8dbf3017f90cec266d71a2a17ae469aac17e1a85a5cbddc70814313e4c13
|
||||
SHA512 (iproute2-5.11.0.tar.xz) = 8d0e7efc20db70af2d344962610b7fb7f464da567f63e094a2e2a9915f6e9087a2282163d2c73eb2065aaec4f0b0cf19614253798153b31e34b06f57e704f3ed
|
||||
SHA512 (iproute2-5.12.0.tar.xz) = 9249beb67b30ceef178b60b2b61a5e6c45277e747ae4c865e739b7ab84192549e8e94ebaee43c0a87c0291037746ffb6936346245220786e369201ee13d60fac
|
||||
SHA512 (iproute2-5.13.0.tar.xz) = a3286639fb303a7c3c553cb5df0a7336c4c67e53eb05e872d2776b771dbfa36ffdf2df140f570275db6785c882992f469f8eb34a5b506aac876216df7dde245d
|
||||
SHA512 (iproute2-5.14.0.tar.xz) = e2b9b0a2c3e6fc4c67cb50b0a9bf710e749648b83369a49bf905edd7e519d76c50c2cc818bb63cc605c409c66075d4d371f2371796e5f7a8f9d04101b80ef75c
|
||||
SHA512 (iproute2-5.15.0.tar.xz) = e94918fa10e523224b965c7cb5303a101745e89c90d149d2d9876a002b2a894b1c689c519dc22168f3d334c3ee0810c59ec43223baab3d5f4c56f017d6281f22
|
||||
SHA512 (iproute2-5.17.0.tar.xz) = fcffe96fb4819305ddf5c3764b100bd1d204069cf53a6bd776c2716144f574b4fc17963fc231a83ad253cce6a563814556eeb60b211ba9b0b87330186259b34d
|
||||
SHA512 (iproute2-5.18.0.tar.xz) = 7b43c89741a8ffe8fd529ac4ee19c8eab7dce2f064de494c160c75456ffb960fb5f1e78c868ab98360dafde28d5e2c4d58177135b6d380e80e06eba9e3eaf068
|
||||
SHA512 (iproute2-6.0.0.tar.xz) = be30362b0df6906aa786f935d5f555b8b86c747fe05314066f4180ab2f7c952ae227b7cf04c15e75d8f99ca17bafb7c8dc0fb1c18f3a9e3222d98716bb449f7a
|
||||
SHA512 (iproute2-6.1.0.tar.xz) = 4e4d3b5e1e1a5444f42671c1e6caee072e80063e34e37386695f76f85a1ab662f4513050814006e5154426cbaadfba1d86b0be14e65978d5e670a16446047b28
|
||||
SHA512 (iproute2-6.2.0.tar.xz) = b24e0fdd0f51b8b78bc3bb681e3829af47d3011e93f3892289eb070b336709a6883728ecc7627ca37f6449720f8ed1349af321c0d04454894a7175b82f7de151
|
||||
SHA512 (iproute2-6.3.0.tar.xz) = aec1d8ceb54c8849a075ec1ce079678638e05ccaec093e8b3cbc7243b5fafea2a8c11f10930fced3df82f52d6750aa325178e44f9058e37a556ab108d4a968bf
|
||||
SHA512 (iproute2-6.4.0.tar.xz) = 42330be6e061302694ea301765ff8d3cbfaeca4b1d06e39778861e4390ed211c03cb2d41498190202b659f7f5647b1ca4857410ef8c16fd601a35e7162788d21
|
||||
SHA512 (iproute2-6.5.0.tar.xz) = 615ba6924becdf08af3f491d347d84897ff0198426d65b194c87146c4527b0856fc51688b59834abe1cb6f9a70b93c66ff7ade6b7c305c1ece0fd6a29df6bc54
|
||||
SHA512 (iproute2-6.7.0.tar.xz) = 5d8dca139b1b980dac6c841f477b951dd199074cb078b5ea8df23b3532eeb235cca1df9f6628b0f81b7edd62aaf4e95bad15a851843bd61e5715215da97cc546
|
||||
|
Loading…
Reference in New Issue
Block a user