3.14 bump
- Drop out iplink_have_newlink() fix in favor of upstream's approach
This commit is contained in:
parent
268d42225a
commit
f4499e279c
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@ iproute2-2.6.35.tar.bz2
|
||||
/iproute2-3.10.0.tar.gz
|
||||
/iproute2-3.11.0.tar.gz
|
||||
/iproute2-3.12.0.tar.gz
|
||||
/iproute2-3.14.0.tar.gz
|
||||
|
28
iproute.spec
28
iproute.spec
@ -1,8 +1,8 @@
|
||||
%global cbq_version v0.7.3
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 3.12.0
|
||||
Release: 2%{?dist}
|
||||
Version: 3.14.0
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/System
|
||||
URL: http://kernel.org/pub/linux/utils/net/%{name}2/
|
||||
Source0: http://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.gz
|
||||
@ -14,13 +14,11 @@ Patch2: iproute2-3.11.0-optflags.patch
|
||||
Patch3: iproute2-3.9.0-IPPROTO_IP_for_SA.patch
|
||||
Patch4: iproute2-example-cbq-service.patch
|
||||
Patch5: iproute2-2.6.35-print-route.patch
|
||||
Patch6: iproute2-2.6.39-create-peer-veth-without-a-name.patch
|
||||
Patch7: iproute2-3.12.0-lnstat-dump-to-stdout.patch
|
||||
Patch8: iproute2-3.10.0-rtnl_send.patch
|
||||
Patch6: iproute2-3.12.0-lnstat-dump-to-stdout.patch
|
||||
# Rejected by upstream <http://thread.gmane.org/gmane.linux.network/284101>
|
||||
Patch9: iproute2-3.11.0-tc-ok.patch
|
||||
Patch10: iproute2-3.11.0-rtt.patch
|
||||
Patch11: iproute2-3.12.0-lnstat-interval.patch
|
||||
Patch7: iproute2-3.11.0-tc-ok.patch
|
||||
Patch8: iproute2-3.11.0-rtt.patch
|
||||
Patch9: iproute2-3.12.0-lnstat-interval.patch
|
||||
License: GPLv2+ and Public Domain
|
||||
BuildRequires: bison
|
||||
BuildRequires: flex
|
||||
@ -70,12 +68,10 @@ The libnetlink static library.
|
||||
%patch3 -p1 -b .ipproto
|
||||
%patch4 -p1 -b .fix_cbq
|
||||
%patch5 -p1 -b .print-route
|
||||
%patch6 -p1 -b .peer-veth-without-name
|
||||
%patch7 -p1 -b .lnstat-dump-to-stdout
|
||||
%patch8 -p1 -b .rtnl_send
|
||||
%patch9 -p1 -b .tc_ok
|
||||
%patch10 -p1 -b .rtt
|
||||
%patch11 -p1 -b .lnstat-interval
|
||||
%patch6 -p1 -b .lnstat-dump-to-stdout
|
||||
%patch7 -p1 -b .tc_ok
|
||||
%patch8 -p1 -b .rtt
|
||||
%patch9 -p1 -b .lnstat-interval
|
||||
sed -i 's/^LIBDIR=/LIBDIR?=/' Makefile
|
||||
|
||||
%build
|
||||
@ -175,6 +171,10 @@ done
|
||||
%{_includedir}/libnetlink.h
|
||||
|
||||
%changelog
|
||||
* Tue Apr 15 2014 Petr Šabata <contyk@redhat.com> - 3.14.0-1
|
||||
- 3.14 bump
|
||||
- Drop out iplink_have_newlink() fix in favor of upstream's approach
|
||||
|
||||
* Tue Nov 26 2013 Petr Šabata <contyk@redhat.com> - 3.12.0-2
|
||||
- Drop libnl from dependencies (#1034454)
|
||||
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/ip/link_veth.c b/ip/link_veth.c
|
||||
index 3d19b01..eb0f41e 100644
|
||||
--- a/ip/link_veth.c
|
||||
+++ b/ip/link_veth.c
|
||||
@@ -27,7 +27,7 @@ static void usage(void)
|
||||
static int veth_parse_opt(struct link_util *lu, int argc, char **argv,
|
||||
struct nlmsghdr *hdr)
|
||||
{
|
||||
- char *name, *type, *link, *dev;
|
||||
+ char *name = NULL, *type = NULL, *link = NULL, *dev = NULL;
|
||||
int err, len;
|
||||
struct rtattr * data;
|
||||
int group;
|
@ -1,15 +0,0 @@
|
||||
diff --git a/ip/iplink.c b/ip/iplink.c
|
||||
index dc98019..56768bd 100644
|
||||
--- a/ip/iplink.c
|
||||
+++ b/ip/iplink.c
|
||||
@@ -176,8 +176,8 @@ static int iplink_have_newlink(void)
|
||||
req.n.nlmsg_type = RTM_NEWLINK;
|
||||
req.i.ifi_family = AF_UNSPEC;
|
||||
|
||||
- rtnl_send(&rth, &req.n, req.n.nlmsg_len);
|
||||
- rtnl_listen(&rth, accept_msg, NULL);
|
||||
+ if (rtnl_send(&rth, &req.n, req.n.nlmsg_len) == 0)
|
||||
+ rtnl_listen(&rth, accept_msg, NULL);
|
||||
}
|
||||
return have_rtnl_newlink;
|
||||
}
|
Loading…
Reference in New Issue
Block a user