Rebase package on top of iproute2-4.10.0
This commit is contained in:
parent
5362d1ec60
commit
e068a451ec
@ -1,58 +0,0 @@
|
||||
From 25ee240c3e80b772dc596fc28013a3f0e2291ab3 Mon Sep 17 00:00:00 2001
|
||||
From: Jiri Benc <jbenc@redhat.com>
|
||||
Date: Wed, 18 Jan 2017 13:37:25 +0100
|
||||
Subject: [PATCH] Revert "man pages: add man page for skbmod action"
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
This reverts commit a40995d1c79e5a1b8711f6cd26eca9807fc4dd50.
|
||||
|
||||
The patch is missing the actual tc-skbmod.8 file which causes 'make
|
||||
install' to fail:
|
||||
|
||||
install -m 0755 -d /tmp/ip/usr/share/man/man8
|
||||
install -m 0644 ip-address.8 ip-link.8 ip-route.8 ip.8 arpd.8 lnstat.8
|
||||
routel.8 rtacct.8 rtmon.8 rtpr.8 ss.8 tc.8 tc-bfifo.8 tc-bpf.8 tc-cbq.8
|
||||
tc-cbq-details.8 tc-choke.8 tc-codel.8 tc-fq.8 tc-drr.8 tc-ematch.8
|
||||
tc-fq_codel.8 tc-hfsc.8 tc-htb.8 tc-pie.8 tc-mqprio.8 tc-netem.8 tc-pfifo.8
|
||||
tc-pfifo_fast.8 tc-prio.8 tc-red.8 tc-sfb.8 tc-sfq.8 tc-stab.8 tc-tbf.8
|
||||
bridge.8 rtstat.8 ctstat.8 nstat.8 routef.8 ip-addrlabel.8 ip-fou.8 ip-gue.8
|
||||
ip-l2tp.8 ip-macsec.8 ip-maddress.8 ip-monitor.8 ip-mroute.8 ip-neighbour.8
|
||||
ip-netns.8 ip-ntable.8 ip-rule.8 ip-tunnel.8 ip-xfrm.8 ip-tcp_metrics.8
|
||||
ip-netconf.8 ip-token.8 tipc.8 tipc-bearer.8 tipc-link.8 tipc-media.8
|
||||
tipc-nametable.8 tipc-node.8 tipc-socket.8 tc-basic.8 tc-cgroup.8 tc-flow.8
|
||||
tc-flower.8 tc-fw.8 tc-route.8 tc-tcindex.8 tc-u32.8 tc-matchall.8
|
||||
tc-connmark.8 tc-csum.8 tc-mirred.8 tc-nat.8 tc-pedit.8 tc-police.8
|
||||
tc-simple.8 tc-skbedit.8 tc-vlan.8 tc-xt.8 tc-ife.8 tc-skbmod.8
|
||||
tc-tunnel_key.8 devlink.8 devlink-dev.8 devlink-monitor.8 devlink-port.8
|
||||
devlink-sb.8 /tmp/ip/usr/share/man/man8
|
||||
install: cannot stat ‘tc-skbmod.8’: No such file or directory
|
||||
make[2]: *** [install] Error 1
|
||||
make[1]: *** [install] Error 2
|
||||
|
||||
Signed-off-by: Jiri Benc <jbenc@redhat.com>
|
||||
|
||||
Conflicts:
|
||||
man/man8/Makefile
|
||||
-> Context changes due to missing other new man pages.
|
||||
---
|
||||
man/man8/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/man/man8/Makefile b/man/man8/Makefile
|
||||
index de6f249b..4ad96ce4 100644
|
||||
--- a/man/man8/Makefile
|
||||
+++ b/man/man8/Makefile
|
||||
@@ -16,7 +16,7 @@ MAN8PAGES = $(TARGETS) ip.8 arpd.8 lnstat.8 routel.8 rtacct.8 rtmon.8 rtpr.8 ss.
|
||||
tc-basic.8 tc-cgroup.8 tc-flow.8 tc-flower.8 tc-fw.8 tc-route.8 \
|
||||
tc-tcindex.8 tc-u32.8 tc-matchall.8 \
|
||||
tc-connmark.8 tc-csum.8 tc-mirred.8 tc-nat.8 tc-pedit.8 tc-police.8 \
|
||||
- tc-simple.8 tc-skbedit.8 tc-vlan.8 tc-xt.8 tc-ife.8 tc-skbmod.8 \
|
||||
+ tc-simple.8 tc-skbedit.8 tc-vlan.8 tc-xt.8 tc-ife.8 \
|
||||
devlink.8 devlink-dev.8 devlink-monitor.8 devlink-port.8 devlink-sb.8
|
||||
|
||||
all: $(TARGETS)
|
||||
--
|
||||
2.11.0
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 34ea60b5b7645e96c600b8073dd82ac65144d711 Mon Sep 17 00:00:00 2001
|
||||
From: Phil Sutter <phil@nwl.cc>
|
||||
Date: Thu, 12 Jan 2017 15:12:26 +0100
|
||||
Subject: [iproute PATCH] tc: m_xt: Fix segfault with iptables-1.6.0
|
||||
|
||||
Said iptables version introduced struct xtables_globals field
|
||||
'compat_rev', a function pointer. Initializing it is mandatory as
|
||||
libxtables calls it without existence check.
|
||||
|
||||
Without this, tc segfaults when using the xt action like so:
|
||||
|
||||
| tc filter add dev d0 parent ffff: u32 match u32 0 0 \
|
||||
| action xt -j MARK --set-mark 20
|
||||
|
||||
Signed-off-by: Phil Sutter <phil@nwl.cc>
|
||||
---
|
||||
tc/m_xt.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/tc/m_xt.c b/tc/m_xt.c
|
||||
index dbb54981462ee..57ed40d7aa3a8 100644
|
||||
--- a/tc/m_xt.c
|
||||
+++ b/tc/m_xt.c
|
||||
@@ -77,6 +77,9 @@ static struct xtables_globals tcipt_globals = {
|
||||
.orig_opts = original_opts,
|
||||
.opts = original_opts,
|
||||
.exit_err = NULL,
|
||||
+#if (XTABLES_VERSION_CODE >= 11)
|
||||
+ .compat_rev = xtables_compatible_revision,
|
||||
+#endif
|
||||
};
|
||||
|
||||
/*
|
||||
--
|
||||
2.11.0
|
||||
|
32
iproute.spec
32
iproute.spec
@ -1,30 +1,21 @@
|
||||
%global cbq_version v0.7.3
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 4.9.0
|
||||
Release: 4%{?dist}
|
||||
Version: 4.10.0
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/System
|
||||
URL: http://kernel.org/pub/linux/utils/net/%{name}2/
|
||||
Source0: http://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.xz
|
||||
Source1: cbq-0000.example
|
||||
Source2: avpkt
|
||||
|
||||
# manpage/help improvements
|
||||
#
|
||||
# * Piece by piece absorbed upstream.
|
||||
#
|
||||
# https://github.com/pavlix/iproute2/commits/fedora
|
||||
# Fedora local docs changes:
|
||||
# - We ship cbq.init-v0.7.3 as cbq binary, so have a cbq.8 man page which links
|
||||
# to tc-cbq.8.
|
||||
# - Drop reference to Debian from ss.8 man page.
|
||||
# - We ship ss.ps instead of ss.html.
|
||||
Patch1: 0001-Documentation-fixes.patch
|
||||
|
||||
# Fix for bz#1411127
|
||||
#
|
||||
# Accepted upstream:
|
||||
# https://patchwork.ozlabs.org/patch/714480/
|
||||
Patch2: 0001-tc-m_xt-Fix-segfault-with-iptables-1.6.0.patch
|
||||
|
||||
# Fix 'make install'
|
||||
Patch3: 0001-Revert-man-pages-add-man-page-for-skbmod-action.patch
|
||||
|
||||
License: GPLv2+ and Public Domain
|
||||
BuildRequires: bison
|
||||
BuildRequires: elfutils-libelf-devel
|
||||
@ -87,8 +78,6 @@ The libnetlink static library.
|
||||
%prep
|
||||
%setup -q -n %{name}2-%{version}
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
export CFLAGS="%{optflags}"
|
||||
@ -170,8 +159,15 @@ rm -rf '%{buildroot}%{_docdir}'
|
||||
%{_mandir}/man3/*
|
||||
%{_libdir}/libnetlink.a
|
||||
%{_includedir}/libnetlink.h
|
||||
%{_includedir}/iproute2/bpf_elf.h
|
||||
|
||||
%changelog
|
||||
* Tue Mar 14 2017 Phil Sutter <psutter@redhat.com> - 4.10.0-1
|
||||
- Ship new header iproute2/bpf_elf.h
|
||||
- Document content of remaining docs fixup patch in spec file
|
||||
- Drop patches already applied upstream
|
||||
- New version 4.10.0
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.9.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user