iproute-5.15.0-1
* Thu Nov 04 2021 Andrea Claudi <aclaudi@redhat.com> - 5.15.0-1 - New version 5.15.0 [2019267] Resolves: rhbz#2019267 Signed-off-by: Andrea Claudi <aclaudi@redhat.com>
This commit is contained in:
parent
665ce7375f
commit
dfbb7f212c
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
||||
/iproute2-5.12.0.tar.xz
|
||||
/iproute2-5.13.0.tar.xz
|
||||
/iproute2-5.14.0.tar.xz
|
||||
/iproute2-5.15.0.tar.xz
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 290ce87f0a59ec4ddc83918c073364540057ae64 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <290ce87f0a59ec4ddc83918c073364540057ae64.1634733799.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
Message-Id: <290ce87f0a59ec4ddc83918c073364540057ae64.1636047125.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Wed, 20 Oct 2021 12:32:38 +0200
|
||||
Subject: [PATCH] configure: fix parsing issue on include_dir option
|
@ -1,50 +0,0 @@
|
||||
From 5e6e93a55d2335b90aacb0107e962610cce64007 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Wed, 20 Oct 2021 12:32:38 +0200
|
||||
Subject: [PATCH] configure: restore backward compatibility
|
||||
|
||||
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1999860
|
||||
Upstream Status: iproute2.git commit a3272b93
|
||||
|
||||
commit a3272b93725a406bc98b67373da67a4bdf6fcdb0
|
||||
Author: Luca Boccassi <bluca@debian.org>
|
||||
Date: Thu Sep 2 12:38:54 2021 +0100
|
||||
|
||||
configure: restore backward compatibility
|
||||
|
||||
Commit a9c3d70d902a0473ee5c13336317006a52ce8242 broke backward compatibility
|
||||
by making 'configure' error out if parameters are passed, instead of
|
||||
ignoring them.
|
||||
Sometimes packaging systems detect 'configure' and assume it's from
|
||||
autotools, and pass a bunch of options. Eg:
|
||||
|
||||
dh_auto_configure
|
||||
./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-option-checking --disable-silent-rules --libdir=${prefix}/lib/x86_64-linux-gnu --runstatedir=/run --disable-maintainer-mode --disable-dependency-tracking
|
||||
|
||||
Ignore unknown options again instead of erroring out.
|
||||
|
||||
Fixes: a9c3d70d902a ("configure: add options ability")
|
||||
|
||||
Signed-off-by: Luca Boccassi <bluca@debian.org>
|
||||
Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
|
||||
---
|
||||
configure | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 0a4a0fc9..7f4f3bd9 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -518,7 +518,7 @@ else
|
||||
"")
|
||||
break ;;
|
||||
*)
|
||||
- usage 1 ;;
|
||||
+ shift 1 ;;
|
||||
esac
|
||||
done
|
||||
fi
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 5f717b9a1bb8c49e101670682d73bc5ae9ee701a Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <5f717b9a1bb8c49e101670682d73bc5ae9ee701a.1634733799.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
Message-Id: <5f717b9a1bb8c49e101670682d73bc5ae9ee701a.1636047125.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Wed, 20 Oct 2021 12:32:38 +0200
|
||||
Subject: [PATCH] configure: fix parsing issue on libbpf_dir option
|
@ -1,7 +1,7 @@
|
||||
From 4f9ade07eafe74db184eb09603e8187f3ca14423 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <4f9ade07eafe74db184eb09603e8187f3ca14423.1634733799.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
Message-Id: <4f9ade07eafe74db184eb09603e8187f3ca14423.1636047125.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Wed, 20 Oct 2021 12:32:38 +0200
|
||||
Subject: [PATCH] configure: fix parsing issue with more than one value per
|
@ -1,7 +1,7 @@
|
||||
From e563a97894c173dcfe2ccdb061c9bfe16526678b Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <e563a97894c173dcfe2ccdb061c9bfe16526678b.1634733799.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
Message-Id: <e563a97894c173dcfe2ccdb061c9bfe16526678b.1636047125.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Wed, 20 Oct 2021 12:32:38 +0200
|
||||
Subject: [PATCH] configure: simplify options parsing
|
@ -1,7 +1,7 @@
|
||||
From 6de1c71cf82d67784a185ba912bdbfa24fa6bce5 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <6de1c71cf82d67784a185ba912bdbfa24fa6bce5.1634733799.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
Message-Id: <6de1c71cf82d67784a185ba912bdbfa24fa6bce5.1636047125.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Wed, 20 Oct 2021 12:32:38 +0200
|
||||
Subject: [PATCH] configure: support --param=value style
|
@ -1,7 +1,7 @@
|
||||
From aad7307a1ca9f2c8df26e1ed5e8a8b9816f87792 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <aad7307a1ca9f2c8df26e1ed5e8a8b9816f87792.1634733799.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
Message-Id: <aad7307a1ca9f2c8df26e1ed5e8a8b9816f87792.1636047125.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Wed, 20 Oct 2021 12:32:38 +0200
|
||||
Subject: [PATCH] configure: add the --prefix option
|
@ -1,7 +1,7 @@
|
||||
From d2e278fcff8a699a2dbac8d74758b4e5f86fd5f0 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <d2e278fcff8a699a2dbac8d74758b4e5f86fd5f0.1634733799.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1634733799.git.aclaudi@redhat.com>
|
||||
Message-Id: <d2e278fcff8a699a2dbac8d74758b4e5f86fd5f0.1636047125.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
References: <5e6e93a55d2335b90aacb0107e962610cce64007.1636047125.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Wed, 20 Oct 2021 12:32:38 +0200
|
||||
Subject: [PATCH] configure: add the --libdir option
|
33
iproute.spec
33
iproute.spec
@ -1,6 +1,6 @@
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 5.14.0
|
||||
Version: 5.15.0
|
||||
Release: 1%{?dist}%{?buildid}
|
||||
%if 0%{?rhel}
|
||||
Group: Applications/System
|
||||
@ -8,17 +8,15 @@ Group: Applications/System
|
||||
URL: https://kernel.org/pub/linux/utils/net/%{name}2/
|
||||
Source0: https://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.xz
|
||||
%if ! 0%{?fedora}
|
||||
Source1: iproute2.sh
|
||||
Source2: rt_dsfield.deprecated
|
||||
Source1: rt_dsfield.deprecated
|
||||
%endif
|
||||
Patch0: 0001-configure-restore-backward-compatibility.patch
|
||||
Patch1: 0002-configure-fix-parsing-issue-on-include_dir-option.patch
|
||||
Patch2: 0003-configure-fix-parsing-issue-on-libbpf_dir-option.patch
|
||||
Patch3: 0004-configure-fix-parsing-issue-with-more-than-one-value.patch
|
||||
Patch4: 0005-configure-simplify-options-parsing.patch
|
||||
Patch5: 0006-configure-support-param-value-style.patch
|
||||
Patch6: 0007-configure-add-the-prefix-option.patch
|
||||
Patch7: 0008-configure-add-the-libdir-option.patch
|
||||
Patch0: 0001-configure-fix-parsing-issue-on-include_dir-option.patch
|
||||
Patch1: 0002-configure-fix-parsing-issue-on-libbpf_dir-option.patch
|
||||
Patch2: 0003-configure-fix-parsing-issue-with-more-than-one-value.patch
|
||||
Patch3: 0004-configure-simplify-options-parsing.patch
|
||||
Patch4: 0005-configure-support-param-value-style.patch
|
||||
Patch5: 0006-configure-add-the-prefix-option.patch
|
||||
Patch6: 0007-configure-add-the-libdir-option.patch
|
||||
|
||||
License: GPLv2+ and Public Domain
|
||||
BuildRequires: bison
|
||||
@ -107,12 +105,9 @@ install -D -m644 lib/libnetlink.a %{buildroot}%{_libdir}/libnetlink.a
|
||||
# drop these files, iproute-doc package extracts files directly from _builddir
|
||||
rm -rf '%{buildroot}%{_docdir}'
|
||||
|
||||
# RHEL-specific stuff
|
||||
%if ! 0%{?fedora}
|
||||
# use TC_LIB_DIR environment variable
|
||||
install -D -m644 %{SOURCE1} %{buildroot}%{_sysconfdir}/profile.d/iproute2.sh
|
||||
# append deprecated values to rt_dsfield for compatibility reasons
|
||||
cat %{SOURCE2} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
%if ! 0%{?fedora}
|
||||
cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
%endif
|
||||
|
||||
%files
|
||||
@ -131,9 +126,6 @@ cat %{SOURCE2} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
|
||||
%files tc
|
||||
%license COPYING
|
||||
%if ! 0%{?fedora}
|
||||
%{_sysconfdir}/profile.d/iproute2.sh
|
||||
%endif
|
||||
%{_mandir}/man7/tc-*
|
||||
%{_mandir}/man8/tc*
|
||||
%{_mandir}/man8/cbq*
|
||||
@ -156,6 +148,9 @@ cat %{SOURCE2} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
%{_includedir}/iproute2/bpf_elf.h
|
||||
|
||||
%changelog
|
||||
* Thu Nov 04 2021 Andrea Claudi <aclaudi@redhat.com> - 5.15.0-1
|
||||
- New version 5.15.0 [2019267]
|
||||
|
||||
* Wed Oct 20 2021 Andrea Claudi <aclaudi@redhat.com> - 5.14.0-1
|
||||
- New version 5.14.0 [1999860]
|
||||
|
||||
|
1
sources
1
sources
@ -3,3 +3,4 @@ SHA512 (iproute2-5.11.0.tar.xz) = 8d0e7efc20db70af2d344962610b7fb7f464da567f63e0
|
||||
SHA512 (iproute2-5.12.0.tar.xz) = 9249beb67b30ceef178b60b2b61a5e6c45277e747ae4c865e739b7ab84192549e8e94ebaee43c0a87c0291037746ffb6936346245220786e369201ee13d60fac
|
||||
SHA512 (iproute2-5.13.0.tar.xz) = a3286639fb303a7c3c553cb5df0a7336c4c67e53eb05e872d2776b771dbfa36ffdf2df140f570275db6785c882992f469f8eb34a5b506aac876216df7dde245d
|
||||
SHA512 (iproute2-5.14.0.tar.xz) = e2b9b0a2c3e6fc4c67cb50b0a9bf710e749648b83369a49bf905edd7e519d76c50c2cc818bb63cc605c409c66075d4d371f2371796e5f7a8f9d04101b80ef75c
|
||||
SHA512 (iproute2-5.15.0.tar.xz) = e94918fa10e523224b965c7cb5303a101745e89c90d149d2d9876a002b2a894b1c689c519dc22168f3d334c3ee0810c59ec43223baab3d5f4c56f017d6281f22
|
||||
|
Loading…
Reference in New Issue
Block a user