iproute-6.2.0-3.el8
* Wed Jun 07 2023 Andrea Claudi <aclaudi@redhat.com> - 6.2.0-3.el8 - tc: add missing separator (Andrea Claudi) [RHEL-487] Resolves: RHEL-487 Signed-off-by: Andrea Claudi <aclaudi@redhat.com>
This commit is contained in:
parent
2f81f7a2d5
commit
de46600ae3
43
0003-tc-add-missing-separator.patch
Normal file
43
0003-tc-add-missing-separator.patch
Normal file
@ -0,0 +1,43 @@
|
||||
From 4c2e1768c0d446345796dc058d1e114147a1029a Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <4c2e1768c0d446345796dc058d1e114147a1029a.1686090191.git.aclaudi@redhat.com>
|
||||
In-Reply-To: <6a3ecf4fd80f7dcecb72b6c83781f5aed463a75b.1686090191.git.aclaudi@redhat.com>
|
||||
References: <6a3ecf4fd80f7dcecb72b6c83781f5aed463a75b.1686090191.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Wed, 7 Jun 2023 00:15:59 +0200
|
||||
Subject: [PATCH] tc: add missing separator
|
||||
|
||||
Jira: https://issues.redhat.com/browse/RHEL-487
|
||||
Upstream Status: iproute2-next.git commit 4e0e56e0
|
||||
|
||||
commit 4e0e56e0ef05387f7f5d8ab41fe6ec6a1897b26d
|
||||
Author: Christian Hesse <mail@eworm.de>
|
||||
Date: Thu Feb 23 11:15:03 2023 +0100
|
||||
|
||||
tc: add missing separator
|
||||
|
||||
This is missing a separator, that was accidently removed
|
||||
when JSON was added.
|
||||
|
||||
Fixes: 010a8388aea1 ("tc: Add JSON output to tc-class")
|
||||
Signed-off-by: Christian Hesse <mail@eworm.de>
|
||||
Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
|
||||
---
|
||||
tc/tc_class.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tc/tc_class.c b/tc/tc_class.c
|
||||
index c1feb009..096fa2ec 100644
|
||||
--- a/tc/tc_class.c
|
||||
+++ b/tc/tc_class.c
|
||||
@@ -356,7 +356,7 @@ int print_class(struct nlmsghdr *n, void *arg)
|
||||
print_string(PRINT_ANY, "parent", "parent %s ", abuf);
|
||||
}
|
||||
if (t->tcm_info)
|
||||
- print_0xhex(PRINT_ANY, "leaf", "leaf %x", t->tcm_info>>16);
|
||||
+ print_0xhex(PRINT_ANY, "leaf", "leaf %x: ", t->tcm_info>>16);
|
||||
|
||||
q = get_qdisc_kind(RTA_DATA(tb[TCA_KIND]));
|
||||
if (tb[TCA_OPTIONS]) {
|
||||
--
|
||||
2.40.1
|
||||
|
28
iproute.spec
28
iproute.spec
@ -1,7 +1,7 @@
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 6.2.0
|
||||
Release: 2%{?dist}%{?buildid}
|
||||
Release: 3%{?dist}%{?buildid}
|
||||
%if 0%{?rhel}
|
||||
Group: Applications/System
|
||||
%endif
|
||||
@ -10,6 +10,7 @@ Source0: https://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{v
|
||||
Source1: rt_dsfield.deprecated
|
||||
Patch0: 0001-Update-kernel-headers.patch
|
||||
Patch1: 0002-macvlan-Add-bclim-parameter.patch
|
||||
Patch2: 0003-tc-add-missing-separator.patch
|
||||
|
||||
License: GPL-2.0-or-later AND NIST-PD
|
||||
BuildRequires: bison
|
||||
@ -141,6 +142,9 @@ cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
%{_includedir}/iproute2/bpf_elf.h
|
||||
|
||||
%changelog
|
||||
* Wed Jun 07 2023 Andrea Claudi <aclaudi@redhat.com> - 6.2.0-3.el8
|
||||
- tc: add missing separator (Andrea Claudi)
|
||||
|
||||
* Wed May 03 2023 Andrea Claudi <aclaudi@redhat.com> - 6.2.0-2.el8
|
||||
- macvlan: Add bclim parameter (Andrea Claudi) [2188134]
|
||||
- Update kernel headers (Andrea Claudi) [2188134]
|
||||
@ -775,14 +779,14 @@ cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Thu Apr 23 2009 Marcela Mašláňová <mmaslano@redhat.com> - 2.6.29-3
|
||||
- new iptables (xtables) bring problems to tc, when ipt is used.
|
||||
- new iptables (xtables) bring problems to tc, when ipt is used.
|
||||
rhbz#497344 still broken. tc_modules.patch brings correct paths to
|
||||
xtables, but that doesn't fix whole issue.
|
||||
- 497355 ip should allow creation of an IPsec SA with 'proto any'
|
||||
- 497355 ip should allow creation of an IPsec SA with 'proto any'
|
||||
and specified sport and dport as selectors
|
||||
|
||||
* Tue Apr 14 2009 Marcela Mašláňová <mmaslano@redhat.com> - 2.6.29-2
|
||||
- c3651bf4763d7247e3edd4e20526a85de459041b ip6tunnel: Fix no default
|
||||
- c3651bf4763d7247e3edd4e20526a85de459041b ip6tunnel: Fix no default
|
||||
display of ip4ip6 tunnels
|
||||
- e48f73d6a5e90d2f883e15ccedf4f53d26bb6e74 missing arpd directory
|
||||
|
||||
@ -841,7 +845,7 @@ cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
|
||||
* Wed Feb 6 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-3
|
||||
- rebuild without tetex files. It isn't working in rawhide yet. Added
|
||||
new source for ps files.
|
||||
new source for ps files.
|
||||
- #431179 backward compatibility for previous iproute versions
|
||||
|
||||
* Mon Jan 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-2
|
||||
@ -893,7 +897,7 @@ cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
- bug fix for xfrm monitor
|
||||
- alignment fixes for cris
|
||||
- documentation corrections
|
||||
|
||||
|
||||
* Mon Oct 2 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-7
|
||||
- fix ip.8 man page, add initcwnd option
|
||||
|
||||
@ -943,7 +947,7 @@ cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
- use tc manpages and cbq.init from source tarball (#172851)
|
||||
|
||||
* Thu Nov 10 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-8
|
||||
- new upstream source
|
||||
- new upstream source
|
||||
|
||||
* Mon Oct 31 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-7
|
||||
- add warning to ip tunnel add command (#128107)
|
||||
@ -959,7 +963,7 @@ cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
- add RPM_OPT_FLAGS
|
||||
|
||||
* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-3
|
||||
- forget to apply the patch :(
|
||||
- forget to apply the patch :(
|
||||
|
||||
* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-2
|
||||
- make ip help work again (#168449)
|
||||
@ -978,7 +982,7 @@ cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
|
||||
* Tue May 24 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-2
|
||||
- removed useless initvar patch (#150798)
|
||||
- new upstream source
|
||||
- new upstream source
|
||||
|
||||
* Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
|
||||
- update to iproute-2.6.11
|
||||
@ -997,7 +1001,7 @@ cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
|
||||
* Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
|
||||
- source file updated from snapshot version
|
||||
- endian patch adding <endian.h>
|
||||
- endian patch adding <endian.h>
|
||||
|
||||
* Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
|
||||
- added installation of netem module for tc
|
||||
@ -1023,7 +1027,7 @@ cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
* Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
|
||||
- Fixed -f option for ss (#118355).
|
||||
- Small description fix (#110997).
|
||||
- Added initialization of some vars (#74961).
|
||||
- Added initialization of some vars (#74961).
|
||||
- Added patch to initialize "default" rule as well (#60693).
|
||||
|
||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||
@ -1076,7 +1080,7 @@ cat %{SOURCE1} >>%{buildroot}%{_sysconfdir}/iproute2/rt_dsfield
|
||||
- fix build problem in beehive if kernel-sources is not installed
|
||||
|
||||
* Fri May 25 2001 Helge Deller <hdeller@redhat.de>
|
||||
- updated to iproute2-2.2.4-now-ss001007.tar.gz
|
||||
- updated to iproute2-2.2.4-now-ss001007.tar.gz
|
||||
- bzip2 source tar file
|
||||
- "License" replaces "Copyright"
|
||||
- added "BuildPrereq: tetex-latex tetex-dvips psutils"
|
||||
|
Loading…
Reference in New Issue
Block a user