move files from /usr/lib/tc to /usr/share/tc for merge review

This commit is contained in:
Marcela Mašláňová 2007-10-24 08:55:47 +00:00
parent fd21a4cda4
commit c8c245d80b
2 changed files with 38 additions and 5 deletions

View File

@ -4,7 +4,7 @@
Summary: Advanced IP routing and network device configuration tools
Name: iproute
Version: 2.6.22
Release: 3%{?dist}
Release: 4%{?dist}
Group: Applications/System
Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-%{date_version}.tar.gz
URL: http://linux-net.osdl.org/index.php/Iproute2
@ -12,6 +12,7 @@ Patch1: iproute2-2.6.9-kernel.patch
Patch2: iproute2-ss050901-opt_flags.patch
Patch3: iproute2-2.6.16-ip_resolve_crash.patch
Patch4: iproute-ip-man.patch
Patch5: iproute2-movelib.patch
License: GPLv2+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -29,6 +30,7 @@ capabilities of the Linux 2.4.x and 2.6.x kernel.
%patch2 -p1 -b .opt_flags
%patch3 -p1 -b .ip_resolve
%patch4 -p1
%patch5 -p1 -b .movelib
%build
export LIBDIR=%{_libdir}
@ -43,12 +45,12 @@ mkdir -p $RPM_BUILD_ROOT/sbin \
$RPM_BUILD_ROOT%{_sbindir} \
$RPM_BUILD_ROOT%{_mandir}/man8 \
$RPM_BUILD_ROOT/%{_sysconfdir}/iproute2 \
$RPM_BUILD_ROOT%{_libdir}/tc
$RPM_BUILD_ROOT%{_datadir}/tc
install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
#install -m 755 tc/q_netem.so $RPM_BUILD_ROOT%{_libdir}/tc
install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_libdir}/tc
install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
@ -83,13 +85,16 @@ EOF
%{_mandir}/man8/*
%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/*
%{_sbindir}/*
%dir %{_libdir}/tc
%{_libdir}/tc/*
%dir %{_datadir}/tc
%{_datadir}/tc/*
/sbin/cbq
%dir %{_sysconfdir}/sysconfig/cbq
%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
%changelog
* Tue Oct 23 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-4
- move files from /usr/lib/tc to /usr/share/tc
* Fri Aug 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-3
- package review #225903

28
iproute2-movelib.patch Normal file
View File

@ -0,0 +1,28 @@
diff -up iproute-2.6.22/netem/Makefile.old iproute-2.6.22/netem/Makefile
--- iproute-2.6.22/netem/Makefile.old 2007-07-11 03:34:14.000000000 +0200
+++ iproute-2.6.22/netem/Makefile 2007-10-23 09:11:25.000000000 +0200
@@ -19,9 +19,9 @@ stats: stats.c
$(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
install: all
- mkdir -p $(DESTDIR)/usr/lib/tc
+ mkdir -p $(DESTDIR)/usr/share/tc
for i in $(DISTDATA); \
- do install -m 755 $$i $(DESTDIR)/usr/lib/tc; \
+ do install -m 755 $$i $(DESTDIR)/usr/share/tc; \
done
clean:
diff -up iproute-2.6.22/tc/q_netem.c.old iproute-2.6.22/tc/q_netem.c
diff -up iproute-2.6.22/tc/tc_util.c.old iproute-2.6.22/tc/tc_util.c
--- iproute-2.6.22/tc/tc_util.c.old 2007-07-11 03:34:14.000000000 +0200
+++ iproute-2.6.22/tc/tc_util.c 2007-10-23 10:47:29.000000000 +0200
@@ -30,7 +30,7 @@ const char *get_tc_lib(void)
lib_dir = getenv("TC_LIB_DIR");
if (!lib_dir)
- lib_dir = "/usr/lib/tc";
+ lib_dir = "/usr/share/tc";
return lib_dir;
}