- 483484 install distribution files into /usr/share and also fixed install

paths in spec
- add the latest change from git which add DRR support
    c86f34942a0ce9f8203c0c38f9fe9604f96be706
This commit is contained in:
Marcela Mašláňová 2009-02-04 08:33:47 +00:00
parent 85548bc1f1
commit c0257c2309
3 changed files with 222 additions and 1 deletions

View File

@ -4,7 +4,7 @@
Summary: Advanced IP routing and network device configuration tools
Name: iproute
Version: 2.6.28
Release: 1%{?dist}
Release: 2%{?dist}
Group: Applications/System
Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}.tar.bz2
#Source1: iproute-doc-2.6.22.tar.gz
@ -13,6 +13,8 @@ Patch1: iproute2-2.6.9-kernel.patch
Patch2: iproute2-ss050901-opt_flags.patch
Patch3: iproute-ip-man.patch
Patch4: iproute2-2.6.25-segfault.patch
Patch5: iproute2-sharepath.patch
Patch6: iproute2-ddr_support.patch
License: GPLv2+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -30,6 +32,8 @@ capabilities of the Linux 2.4.x and 2.6.x kernel.
%patch2 -p1 -b .opt_flags
%patch3 -p1
%patch4 -p1 -b .seg
%patch5 -p1 -b .share
%patch6 -p1 -b .ddr
%build
export LIBDIR=%{_libdir}
@ -105,6 +109,12 @@ EOF
%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
%changelog
* Wed Feb 4 2009 Marcela Mašláňová <mmaslano@redhat.com> - 2.6.28-2
- 483484 install distribution files into /usr/share and also fixed
install paths in spec
- add the latest change from git which add DRR support
c86f34942a0ce9f8203c0c38f9fe9604f96be706
* Mon Jan 19 2009 Marcela Mašláňová <mmaslano@redhat.com> - 2.6.28-1
- previous two patches were included into 2.6.28 release.
- update

188
iproute2-ddr_support.patch Normal file
View File

@ -0,0 +1,188 @@
From c86f34942a0ce9f8203c0c38f9fe9604f96be706 Mon Sep 17 00:00:00 2001
From: Patrick McHardy <kaber@trash.net>
Date: Wed, 19 Nov 2008 16:08:05 +0100
Subject: [PATCH] iproute: add DRR support
add DRR support
This patch adds support for the DRR scheduler I just sent
to iproute.
Signed-off-by: Patrick McHardy <kaber@trash.net>
---
include/linux/pkt_sched.h | 16 ++++++
tc/Makefile | 1 +
tc/q_drr.c | 124 +++++++++++++++++++++++++++++++++++++++++++++
3 files changed, 141 insertions(+), 0 deletions(-)
create mode 100644 tc/q_drr.c
diff --git a/include/linux/pkt_sched.h b/include/linux/pkt_sched.h
index 5d921fa..8495053 100644
--- iproute-2.6.28/iproute2-2.6.28/include/linux/pkt_sched.h.old
+++ iproute-2.6.28/iproute2-2.6.28/include/linux/pkt_sched.h
@@ -500,4 +500,20 @@ struct tc_netem_corrupt
#define NETEM_DIST_SCALE 8192
+/* DRR */
+
+enum
+{
+ TCA_DRR_UNSPEC,
+ TCA_DRR_QUANTUM,
+ __TCA_DRR_MAX
+};
+
+#define TCA_DRR_MAX (__TCA_DRR_MAX - 1)
+
+struct tc_drr_stats
+{
+ __u32 deficit;
+};
+
#endif
diff --git a/tc/Makefile b/tc/Makefile
index bd9b833..eb67ede 100644
--- iproute-2.6.28/iproute2-2.6.28/tc/Makefile.old
+++ iproute-2.6.28/iproute2-2.6.28/tc/Makefile
@@ -26,6 +26,7 @@ TCMODULES += f_tcindex.o
TCMODULES += q_ingress.o
TCMODULES += q_hfsc.o
TCMODULES += q_htb.o
+TCMODULES += q_drr.o
TCMODULES += m_gact.o
TCMODULES += m_mirred.o
TCMODULES += m_ipt.o
diff --git a/tc/q_drr.c b/tc/q_drr.c
new file mode 100644
index 0000000..7d2d874
--- /dev/null
+++ iproute-2.6.28/iproute2-2.6.28/tc/q_drr.c
@@ -0,0 +1,124 @@
+/*
+ * q_drr.c DRR.
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version
+ * 2 of the License, or (at your option) any later version.
+ *
+ * Authors: Patrick McHardy <kaber@trash.net>
+ *
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <unistd.h>
+#include <syslog.h>
+#include <fcntl.h>
+#include <sys/socket.h>
+#include <netinet/in.h>
+#include <arpa/inet.h>
+#include <string.h>
+
+#include "utils.h"
+#include "tc_util.h"
+
+static void explain(void)
+{
+ fprintf(stderr, "Usage: ... drr\n");
+}
+
+static void explain2(void)
+{
+ fprintf(stderr, "Usage: ... drr quantum SIZE\n");
+}
+
+#define usage() return(-1)
+
+static int drr_parse_opt(struct qdisc_util *qu, int argc, char **argv, struct nlmsghdr *n)
+{
+ while (argc > 0) {
+ if (strcmp(*argv, "help") == 0) {
+ explain();
+ return -1;
+ } else {
+ fprintf(stderr, "What is \"%s\"?\n", *argv);
+ explain();
+ return -1;
+ }
+ argc--; argv++;
+ }
+ return 0;
+}
+
+static int drr_parse_class_opt(struct qdisc_util *qu, int argc, char **argv,
+ struct nlmsghdr *n)
+{
+ struct rtattr *tail;
+ __u32 tmp;
+
+ tail = NLMSG_TAIL(n);
+ addattr_l(n, 1024, TCA_OPTIONS, NULL, 0);
+
+ while (argc > 0) {
+ if (strcmp(*argv, "quantum") == 0) {
+ NEXT_ARG();
+ if (get_size(&tmp, *argv)) {
+ fprintf(stderr, "Illegal \"quantum\"\n");
+ return -1;
+ }
+ addattr_l(n, 1024, TCA_DRR_QUANTUM, &tmp, sizeof(tmp));
+ } else if (strcmp(*argv, "help") == 0) {
+ explain2();
+ return -1;
+ } else {
+ fprintf(stderr, "What is \"%s\"?\n", *argv);
+ explain2();
+ return -1;
+ }
+ argc--; argv++;
+ }
+
+ tail->rta_len = (void *) NLMSG_TAIL(n) - (void *)tail;
+ return 0;
+}
+
+static int drr_print_opt(struct qdisc_util *qu, FILE *f, struct rtattr *opt)
+{
+ struct rtattr *tb[TCA_DRR_MAX + 1];
+ SPRINT_BUF(b1);
+
+ if (opt == NULL)
+ return 0;
+
+ parse_rtattr_nested(tb, TCA_DRR_MAX, opt);
+
+ if (tb[TCA_DRR_QUANTUM])
+ fprintf(f, "quantum %s ",
+ sprint_size(*(__u32 *)RTA_DATA(tb[TCA_DRR_QUANTUM]), b1));
+ return 0;
+}
+
+static int drr_print_xstats(struct qdisc_util *qu, FILE *f, struct rtattr *xstats)
+{
+ struct tc_drr_stats *x;
+ SPRINT_BUF(b1);
+
+ if (xstats == NULL)
+ return 0;
+ if (RTA_PAYLOAD(xstats) < sizeof(*x))
+ return -1;
+ x = RTA_DATA(xstats);
+
+ fprintf(f, " deficit %s ", sprint_size(x->deficit, b1));
+ return 0;
+}
+
+struct qdisc_util drr_qdisc_util = {
+ .id = "drr",
+ .parse_qopt = drr_parse_opt,
+ .print_qopt = drr_print_opt,
+ .print_xstats = drr_print_xstats,
+ .parse_copt = drr_parse_class_opt,
+ .print_copt = drr_print_opt,
+};
--
1.6.0.6

23
iproute2-sharepath.patch Normal file
View File

@ -0,0 +1,23 @@
diff -up iproute-2.6.28/iproute2-2.6.28/tc/tc_util.c.movelib iproute-2.6.28/iproute2-2.6.28/tc/tc_util.c
--- iproute-2.6.28/iproute2-2.6.28/tc/tc_util.c.movelib 2009-01-15 21:25:04.000000000 +0100
+++ iproute-2.6.28/iproute2-2.6.28/tc/tc_util.c 2009-02-04 08:58:36.000000000 +0100
@@ -24,8 +24,8 @@
#include "utils.h"
#include "tc_util.h"
-#ifndef LIBDIR
-#define LIBDIR "/usr/lib/"
+#ifndef SHAREDIR
+#define SHAREDIR "/usr/share/"
#endif
const char *get_tc_lib(void)
@@ -34,7 +34,7 @@ const char *get_tc_lib(void)
lib_dir = getenv("TC_LIB_DIR");
if (!lib_dir)
- lib_dir = LIBDIR "/tc/";
+ lib_dir = SHAREDIR "/tc/";
return lib_dir;
}