upgrade to 2.6.22
This commit is contained in:
parent
c4519d5dbb
commit
87c51d64d6
@ -1 +1 @@
|
||||
iproute2-2.6.20-070313.tar.gz
|
||||
iproute2-2.6.22-070710.tar.gz
|
||||
|
16
iproute.spec
16
iproute.spec
@ -1,17 +1,15 @@
|
||||
%define date_version 070313
|
||||
%define date_version 070710
|
||||
%define cbq_version v0.7.3
|
||||
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 2.6.20
|
||||
Release: 2%{?dist}
|
||||
Version: 2.6.22
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/System
|
||||
Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-%{date_version}.tar.gz
|
||||
URL: http://linux-net.osdl.org/index.php/Iproute2
|
||||
Patch2: iproute2-2.6.9-kernel.patch
|
||||
Patch5: iproute2-ss050901-opt_flags.patch
|
||||
Patch8: iproute2-2.6.16-libdir.patch
|
||||
Patch10: iproute2-2.6.16-flags.patch
|
||||
Patch11: iproute2-2.6.16-ip_resolve_crash.patch
|
||||
Patch12: iproute-ip-man.patch
|
||||
|
||||
@ -27,12 +25,9 @@ example) which are designed to use the advanced networking
|
||||
capabilities of the Linux 2.4.x and 2.6.x kernel.
|
||||
|
||||
%prep
|
||||
%setup -q -n iproute-%{version}-%{date_version}
|
||||
#%patch1 -p1
|
||||
%setup -q -c iproute-%{version}-%{date_version}
|
||||
%patch2 -p1 -b .kernel
|
||||
%patch5 -p1 -b .opt_flags
|
||||
%patch8 -p1 -b .libdir
|
||||
%patch10 -p1 -b .flags
|
||||
%patch11 -p1 -b .ip_resolve
|
||||
%patch12 -p1
|
||||
|
||||
@ -95,6 +90,9 @@ EOF
|
||||
%config(noreplace) /etc/sysconfig/cbq/*
|
||||
|
||||
%changelog
|
||||
* Wed Jul 11 2007 Radek Vokál <rvokal@redhat.com> - 2.6.22-1
|
||||
- upgrade to 2.6.22
|
||||
|
||||
* Mon Mar 19 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-2
|
||||
- fix broken tc-pfifo man page (#232891)
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- iproute2-2.6.17-000000/ip/ipaddress.c.old 2006-08-21 13:31:30.000000000 +0200
|
||||
+++ iproute2-2.6.17-000000/ip/ipaddress.c 2006-08-21 13:41:33.000000000 +0200
|
||||
@@ -97,6 +97,8 @@
|
||||
_PF(PORTSEL);
|
||||
_PF(NOTRAILERS);
|
||||
_PF(UP);
|
||||
+ _PF(LOWER_UP);
|
||||
+ _PF(DORMANT);
|
||||
#undef _PF
|
||||
if (flags)
|
||||
fprintf(fp, "%x", flags);
|
@ -1,53 +0,0 @@
|
||||
--- iproute2-2.6.16-060323/tc/Makefile.libdir 2005-07-06 00:11:37.000000000 +0200
|
||||
+++ iproute2-2.6.16-060323/tc/Makefile 2006-03-27 07:09:28.000000000 +0200
|
||||
@@ -42,7 +42,7 @@
|
||||
TCLIB += tc_cbq.o
|
||||
TCLIB += tc_estimator.o
|
||||
|
||||
-CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PROB
|
||||
+CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PROB -DLIBDIR=\"$(LIBDIR)\"
|
||||
|
||||
TCSO :=
|
||||
TCSO += q_netem.so
|
||||
--- iproute2-2.6.16-060323/tc/q_netem.c.libdir 2005-12-10 01:01:02.000000000 +0100
|
||||
+++ iproute2-2.6.16-060323/tc/q_netem.c 2006-03-27 07:09:28.000000000 +0200
|
||||
@@ -60,7 +60,11 @@
|
||||
char *line = NULL;
|
||||
char name[128];
|
||||
|
||||
+ #ifdef LIBDIR
|
||||
+ snprintf(name, sizeof(name), "%s/tc/%s.dist", LIBDIR, type);
|
||||
+ #else
|
||||
snprintf(name, sizeof(name), "/usr/lib/tc/%s.dist", type);
|
||||
+ #endif
|
||||
if ((f = fopen(name, "r")) == NULL) {
|
||||
fprintf(stderr, "No distribution data for %s (%s: %s)\n",
|
||||
type, name, strerror(errno));
|
||||
--- iproute2-2.6.16-060323/tc/tc.c.libdir 2005-10-07 18:33:21.000000000 +0200
|
||||
+++ iproute2-2.6.16-060323/tc/tc.c 2006-03-27 07:11:53.000000000 +0200
|
||||
@@ -98,8 +98,11 @@
|
||||
for (q = qdisc_list; q; q = q->next)
|
||||
if (strcmp(q->id, str) == 0)
|
||||
return q;
|
||||
-
|
||||
+ #ifdef LIBDIR
|
||||
+ snprintf(buf, sizeof(buf), "%s/tc/q_%s.so", LIBDIR, str);
|
||||
+ #else
|
||||
snprintf(buf, sizeof(buf), "/usr/lib/tc/q_%s.so", str);
|
||||
+ #endif
|
||||
dlh = dlopen(buf, RTLD_LAZY);
|
||||
if (!dlh) {
|
||||
/* look in current binary, only open once */
|
||||
@@ -144,8 +147,11 @@
|
||||
for (q = filter_list; q; q = q->next)
|
||||
if (strcmp(q->id, str) == 0)
|
||||
return q;
|
||||
-
|
||||
+ #ifdef LIBDIR
|
||||
+ snprintf(buf, sizeof(buf), "%s/tc/f_%s.so", LIBDIR, str);
|
||||
+ #else
|
||||
snprintf(buf, sizeof(buf), "/usr/lib/tc/f_%s.so", str);
|
||||
+ #endif
|
||||
dlh = dlopen(buf, RTLD_LAZY);
|
||||
if (dlh == NULL) {
|
||||
dlh = BODY;
|
Loading…
Reference in New Issue
Block a user