new version 4.1.1

This commit is contained in:
Pavel Šimerda 2015-07-07 20:13:13 +02:00
parent 791dd176b8
commit 7b5b0d9243
9 changed files with 7 additions and 1919 deletions

1
.gitignore vendored
View File

@ -22,3 +22,4 @@ iproute2-2.6.35.tar.bz2
/iproute2-3.16.0.tar.gz
/iproute2-3.19.0.tar.xz
/iproute2-4.0.0.tar.xz
/iproute2-4.1.1.tar.xz

View File

@ -1,8 +1,8 @@
%global cbq_version v0.7.3
Summary: Advanced IP routing and network device configuration tools
Name: iproute
Version: 4.0.0
Release: 4%{?dist}
Version: 4.1.1
Release: 1%{?dist}
Group: Applications/System
URL: http://kernel.org/pub/linux/utils/net/%{name}2/
Source0: http://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.xz
@ -23,41 +23,6 @@ Source2: avpkt
# http://www.spinics.net/lists/netdev/msg325114.html
Patch1: iproute2-3.19.0-docs.patch
# build system improvements
#
# (no bugzilla tickets)
# http://www.spinics.net/lists/netdev/msg325109.html
# https://git.kernel.org/cgit/linux/kernel/git/shemminger/iproute2.git/commit/?id=06ec9039c3aa07924f9c23b0daa8885204704a62
Patch2: iproute2-3.19.0-build.patch
# ip-xfrm: support 'proto any' with 'sport' and 'dport'
#
# https://bugzilla.redhat.com/show_bug.cgi?id=497355
# http://www.spinics.net/lists/netdev/msg325111.html
# https://git.kernel.org/cgit/linux/kernel/git/shemminger/iproute2.git/commit/?id=11a3e5c4b31530840d6ea4339ce4078d5922b5d6
Patch3: iproute2-3.19.0-proto-any.patch
# cbq: fix find syntax in example
#
# https://bugzilla.redhat.com/show_bug.cgi?id=539232
# http://www.spinics.net/lists/netdev/msg325112.html
# https://git.kernel.org/cgit/linux/kernel/git/shemminger/iproute2.git/commit/?id=a51842dcd77200159e091da8b2e38e428652532d
Patch4: iproute2-3.19.0-cbq-example.patch
# lnstat: dump to stdout, not stderr
#
# (no bugzilla ticket)
# http://www.spinics.net/lists/netdev/msg325113.html
# https://git.kernel.org/cgit/linux/kernel/git/shemminger/iproute2.git/commit/?id=b1410e0ab1b4f2f9f0b21392efc213692adf2bd5
Patch6: iproute2-3.19.0-lnstat-stdout.patch
# lnstat: run indefinitely by default
#
# https://bugzilla.redhat.com/show_bug.cgi?id=977845
# http://www.spinics.net/lists/netdev/msg325110.html
# https://git.kernel.org/cgit/linux/kernel/git/shemminger/iproute2.git/commit/?id=e7e2913fe44780edf6a7c45123577a522f7adbb4
Patch7: iproute2-3.19.0-lnstat-interval.patch
License: GPLv2+ and Public Domain
BuildRequires: bison
BuildRequires: flex
@ -102,11 +67,6 @@ The libnetlink static library.
%prep
%setup -q -n %{name}2-%{version}
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch6 -p1
%patch7 -p1
%build
export CFLAGS="%{optflags}"
@ -211,6 +171,9 @@ done
%{_includedir}/libnetlink.h
%changelog
* Tue Jul 07 2015 Pavel Šimerda <psimerda@redhat.com> - 4.1.1-1
- new version 4.1.1
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

View File

@ -1,66 +0,0 @@
From af8fba0402dda8e459399542d19d5a9afebe71b2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Pavel=20=C5=A0imerda?= <psimerda@redhat.com>
Date: Fri, 13 Mar 2015 13:17:02 +0100
Subject: [PATCH 2/7] turn Makefile more distribution friendly
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Changes:
* Accept directory settings from environment.
* Remove redundant ROOTDIR variable.
* Set KERNEL_INCLUDE default to '/usr/include'.
* Use CFLAGS from environemnt.
Note: In the long term it might be better to improve the configure
script to generate those parts of the Makefile in a manner similar
to autoconf. It might be even practical to autotoolize the package.
Signed-Off-By: Pavel Šimerda <psimerda@redhat.com>
---
Makefile | 22 +++++++++++-----------
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/Makefile b/Makefile
index 9dbb29f..18faee4 100644
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,15 @@
-ROOTDIR=$(DESTDIR)
-PREFIX=/usr
-LIBDIR=$(PREFIX)/lib
-SBINDIR=/sbin
-CONFDIR=/etc/iproute2
-DATADIR=$(PREFIX)/share
-DOCDIR=$(DATADIR)/doc/iproute2
-MANDIR=$(DATADIR)/man
-ARPDDIR=/var/lib/arpd
+PREFIX?=/usr
+LIBDIR?=$(PREFIX)/lib
+SBINDIR?=/sbin
+CONFDIR?=/etc/iproute2
+DATADIR?=$(PREFIX)/share
+DOCDIR?=$(DATADIR)/doc/iproute2
+MANDIR?=$(DATADIR)/man
+ARPDDIR?=/var/lib/arpd
+KERNEL_INCLUDE?=/usr/include
# Path to db_185.h include
-DBM_INCLUDE:=$(ROOTDIR)/usr/include
+DBM_INCLUDE:=$(DESTDIR)/usr/include
SHARED_LIBS = y
@@ -33,7 +33,7 @@ CCOPTS = -O2
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
-CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
+CFLAGS := $(WFLAGS) $(CCOPTS) -I../include $(DEFINES) $(CFLAGS)
YACCFLAGS = -d -t -v
SUBDIRS=lib ip tc bridge misc netem genl man
--
2.0.5

View File

@ -1,59 +0,0 @@
From ee92ed5c996f95e1f14da3945cb8f92becbfdf2c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Pavel=20=C5=A0imerda?= <psimerda@redhat.com>
Date: Fri, 13 Mar 2015 13:17:03 +0100
Subject: [PATCH 4/7] cbq: fix find syntax in example
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Without modification, using the example resulted in the following error:
[root@localhost sbin]# cbq restart
find: warning: you have specified the -maxdepth option after a
non-option argument (, but options are not positional (-maxdepth affects
tests specified before it as well as those specified after it). Please
specify options before other arguments.
find: warning: you have specified the -maxdepth option after a
non-option argument (, but options are not positional (-maxdepth affects
tests specified before it as well as those specified after it). Please
specify options before other arguments.
**CBQ: failed to compile CBQ configuration!
See also:
* https://bugzilla.redhat.com/show_bug.cgi?id=539232
Reported-By: Mads Kiilerich <mads@kiilerich.com>
Signed-Off-By: Pavel Šimerda <psimerda@redhat.com>
---
examples/cbq.init-v0.7.3 | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/examples/cbq.init-v0.7.3 b/examples/cbq.init-v0.7.3
index 35a0a05..1bc0d44 100644
--- a/examples/cbq.init-v0.7.3
+++ b/examples/cbq.init-v0.7.3
@@ -578,14 +578,14 @@ cbq_show () {
### Check configuration and load DEVICES, DEVFIELDS and CLASSLIST from $1
cbq_init () {
### Get a list of configured classes
- CLASSLIST=`find $1 \( -type f -or -type l \) -name 'cbq-*' \
- -not -name '*~' -maxdepth 1 -printf "%f\n"| sort`
+ CLASSLIST=`find $1 -maxdepth 1 \( -type f -or -type l \) -name 'cbq-*' \
+ -not -name '*~' -printf "%f\n"| sort`
[ -z "$CLASSLIST" ] &&
cbq_failure "no configuration files found in $1!"
### Gather all DEVICE fields from $1/cbq-*
- DEVFIELDS=`find $1 \( -type f -or -type l \) -name 'cbq-*' \
- -not -name '*~' -maxdepth 1| xargs sed -n 's/#.*//; \
+ DEVFIELDS=`find $1 -maxdepth 1 \( -type f -or -type l \) -name 'cbq-*' \
+ -not -name '*~' | xargs sed -n 's/#.*//; \
s/[[:space:]]//g; /^DEVICE=[^,]*,[^,]*\(,[^,]*\)\?/ \
{ s/.*=//; p; }'| sort -u`
[ -z "$DEVFIELDS" ] &&
--
2.0.5

File diff suppressed because it is too large Load Diff

View File

@ -1,54 +0,0 @@
From f016b9a352182df5856412c4e046d2a23424297f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Pavel=20=C5=A0imerda?= <psimerda@redhat.com>
Date: Fri, 13 Mar 2015 13:17:02 +0100
Subject: [PATCH 7/7] lnstat: run indefinitely by default
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
See also:
* https://bugzilla.redhat.com/show_bug.cgi?id=977845
Signed-Off-By: Pavel Šimerda <psimerda@redhat.com>
---
misc/lnstat.c | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)
diff --git a/misc/lnstat.c b/misc/lnstat.c
index e105b70..0385cbb 100644
--- a/misc/lnstat.c
+++ b/misc/lnstat.c
@@ -249,7 +249,7 @@ int main(int argc, char **argv)
MODE_JSON,
MODE_NORMAL,
} mode = MODE_NORMAL;
- unsigned long count = 1;
+ unsigned long count = 0;
struct table_hdr *header;
static struct field_params fp;
int num_req_files = 0;
@@ -362,7 +362,7 @@ int main(int argc, char **argv)
if (interval < 1 )
interval = 1;
- for (i = 0; i < count; i++) {
+ for (i = 0; i < count || !count; ) {
lnstat_update(lnstat_files);
if (mode == MODE_JSON)
print_json(stdout, lnstat_files, &fp);
@@ -373,8 +373,10 @@ int main(int argc, char **argv)
print_line(stdout, lnstat_files, &fp);
}
fflush(stdout);
- if (i < count - 1)
+ if (i < count - 1 || !count)
sleep(interval);
+ if (count)
+ ++i;
}
break;
}
--
2.0.5

View File

@ -1,33 +0,0 @@
From 740b484db02f2398499e7953e08a50c4b708613b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Pavel=20=C5=A0imerda?= <psimerda@redhat.com>
Date: Fri, 13 Mar 2015 13:17:02 +0100
Subject: [PATCH 6/7] lnstat: dump to stdout, not stderr
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
See also:
* https://bugzilla.redhat.com/show_bug.cgi?id=736332
Signed-Off-By: Pavel Šimerda <psimerda@redhat.com>
---
misc/lnstat.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/misc/lnstat.c b/misc/lnstat.c
index 32b5cbe..e105b70 100644
--- a/misc/lnstat.c
+++ b/misc/lnstat.c
@@ -347,7 +347,7 @@ int main(int argc, char **argv)
switch (mode) {
case MODE_DUMP:
- lnstat_dump(stderr, lnstat_files);
+ lnstat_dump(stdout, lnstat_files);
break;
case MODE_NORMAL:
--
2.0.5

View File

@ -1,43 +0,0 @@
From ee80f98063d8265e754efcf11f43a7c0b25a1899 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Pavel=20=C5=A0imerda?= <psimerda@redhat.com>
Date: Fri, 13 Mar 2015 13:17:02 +0100
Subject: [PATCH 3/7] ip-xfrm: support 'proto any' with 'sport' and 'dport'
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
When creating an IPsec SA that sets 'proto any' (IPPROTO_IP) and
specifies 'sport' and 'dport' at the same time in selector, the
following error is issued:
"sport" and "dport" are invalid with proto=ip
However using IPPROTO_IP with ports is completely legal and necessary
when one wants to share the SA on both TCP and UDP. One of the
applications requiring sharing SAs is 3GPP IMS AKA authentication.
See also:
* https://bugzilla.redhat.com/show_bug.cgi?id=497355
Reported-By: Jiří Klimeš <jklimes@redhat.com>
Signed-Off-By: Pavel Šimerda <psimerda@redhat.com>
---
ip/ipxfrm.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/ip/ipxfrm.c b/ip/ipxfrm.c
index 95f91a5..e685571 100644
--- a/ip/ipxfrm.c
+++ b/ip/ipxfrm.c
@@ -1339,6 +1339,7 @@ static int xfrm_selector_upspec_parse(struct xfrm_selector *sel,
case IPPROTO_UDP:
case IPPROTO_SCTP:
case IPPROTO_DCCP:
+ case IPPROTO_IP: /* to allow shared SA for different protocols */
break;
default:
fprintf(stderr, "\"sport\" and \"dport\" are invalid with PROTO value \"%s\"\n", strxf_proto(sel->proto));
--
2.0.5

View File

@ -1 +1 @@
3adc263ade4ee76c35032e8f50b54108 iproute2-4.0.0.tar.xz
39290cb3a55d38dd8d10e19a3094109f iproute2-4.1.1.tar.xz