iproute-6.11.0-1.el10
* Wed Dec 18 2024 Andrea Claudi <aclaudi@redhat.com> - 6.11.0-1.el10 - New version 6.11.0 (Andrea Claudi) [RHEL-71726] - Add support for --bpf-maps and --bpf-map-id= in ss [RHEL-27533] Signed-off-by: Andrea Claudi <aclaudi@redhat.com>
This commit is contained in:
parent
6cbb5125d2
commit
6b46d4e5c6
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@
|
||||
/iproute2-6.4.0.tar.xz
|
||||
/iproute2-6.5.0.tar.xz
|
||||
/iproute2-6.7.0.tar.xz
|
||||
/iproute2-6.11.0.tar.xz
|
||||
|
@ -1,66 +0,0 @@
|
||||
From ac4e9bd66d9c8461024dfd3698e120c678eb6cfc Mon Sep 17 00:00:00 2001
|
||||
Message-ID: <ac4e9bd66d9c8461024dfd3698e120c678eb6cfc.1707519557.git.aclaudi@redhat.com>
|
||||
From: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Fri, 9 Feb 2024 23:56:20 +0100
|
||||
Subject: [PATCH] iproute2: fix build failure on ppc64le
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=2261250
|
||||
Upstream Status: posted upstream
|
||||
|
||||
commit d13ef7c00b60a50a5e8ddbb7ff138399689d3483
|
||||
Author: Andrea Claudi <aclaudi@redhat.com>
|
||||
Date: Fri Feb 9 10:44:55 2024 +0100
|
||||
|
||||
iproute2: fix build failure on ppc64le
|
||||
|
||||
ppc64le build fails with error on ifstat.c when
|
||||
-Wincompatible-pointer-types is enabled:
|
||||
|
||||
ifstat.c: In function ‘dump_raw_db’:
|
||||
ifstat.c:323:44: error: initialization of ‘long long unsigned int *’ from incompatible pointer type ‘__u64 *’ {aka ‘long unsigned int *’} [-Wincompatible-pointer-types]
|
||||
323 | unsigned long long *vals = n->val;
|
||||
|
||||
Several other warnings are produced when -Wformat= is set, for example:
|
||||
|
||||
ss.c:3244:34: warning: format ‘%llu’ expects argument of type ‘long long unsigned int’, but argument 2 has type ‘__u64’ {aka ‘long unsigned int’} [-Wformat=]
|
||||
3244 | out(" rcv_nxt:%llu", s->mptcpi_rcv_nxt);
|
||||
| ~~~^ ~~~~~~~~~~~~~~~~~
|
||||
| | |
|
||||
| | __u64 {aka long unsigned int}
|
||||
| long long unsigned int
|
||||
| %lu
|
||||
|
||||
This happens because __u64 is defined as long unsigned on ppc64le. As
|
||||
pointed out by Florian Weimar, we should use -D__SANE_USERSPACE_TYPES__
|
||||
if we really want to use long long unsigned in iproute2.
|
||||
|
||||
This fix the build failure and all the warnings without any change on
|
||||
the code itself.
|
||||
|
||||
Suggested-by: Florian Weimer <fweimer@redhat.com>
|
||||
Signed-off-by: Andrea Claudi <aclaudi@redhat.com>
|
||||
|
||||
Signed-off-by: Andrea Claudi <aclaudi@redhat.com>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 8024d45e..3b9daede 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -60,7 +60,7 @@ CC := gcc
|
||||
HOSTCC ?= $(CC)
|
||||
DEFINES += -D_GNU_SOURCE
|
||||
# Turn on transparent support for LFS
|
||||
-DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
|
||||
+DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D__SANE_USERSPACE_TYPES__
|
||||
CCOPTS = -O2 -pipe
|
||||
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
|
||||
WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
|
||||
--
|
||||
2.43.0
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-10
|
||||
- rhel-9
|
||||
decision_context: osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
|
||||
- !PassingTestCaseRule {test_case_name: baseos-ci.brew-build.tier1-gating.functional}
|
||||
- !PassingTestCaseRule {test_case_name: baseos-ci.brew-build.tier2-gating.functional}
|
||||
|
15
iproute.spec
15
iproute.spec
@ -1,11 +1,10 @@
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 6.7.0
|
||||
Version: 6.11.0
|
||||
Release: %autorelease
|
||||
URL: https://kernel.org/pub/linux/utils/net/%{name}2/
|
||||
Source0: https://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.xz
|
||||
Source1: rt_dsfield.deprecated
|
||||
Patch0: 0001-iproute2-fix-build-failure-on-ppc64le.patch
|
||||
|
||||
License: GPL-2.0-or-later AND NIST-PD
|
||||
BuildRequires: bison
|
||||
@ -26,7 +25,15 @@ BuildRequires: linux-atm-libs-devel
|
||||
%endif
|
||||
Requires: libbpf
|
||||
Requires: psmisc
|
||||
|
||||
# Compat symlinks for Requires in other packages.
|
||||
Provides: /sbin/ip
|
||||
%if "%{_sbindir}" == "%{_bindir}"
|
||||
# We rely on filesystem to create the symlink for us.
|
||||
Requires: filesystem(unmerged-sbin-symlinks)
|
||||
Provides: /usr/sbin/ip
|
||||
Provides: /usr/sbin/ss
|
||||
%endif
|
||||
|
||||
%description
|
||||
The iproute package contains networking utilities (ip and rtmon, for example)
|
||||
@ -68,7 +75,7 @@ The libnetlink static library.
|
||||
|
||||
%build
|
||||
%configure --color auto
|
||||
echo -e "\nSBINDIR=%{_sbindir}" >> config.mk
|
||||
echo -e "\nPREFIX=%{_prefix}\nSBINDIR=%{_sbindir}" >> config.mk
|
||||
%make_build
|
||||
|
||||
%install
|
||||
@ -84,7 +91,7 @@ install -D -m644 lib/libnetlink.a %{buildroot}%{_libdir}/libnetlink.a
|
||||
rm -rf '%{buildroot}%{_docdir}'
|
||||
|
||||
# append deprecated values to rt_dsfield for compatibility reasons
|
||||
%if 0%{?rhel} && ! 0%{?eln}
|
||||
%if 0%{?rhel}
|
||||
cat %{SOURCE1} >>%{buildroot}%{_datadir}/iproute2/rt_dsfield
|
||||
%endif
|
||||
|
||||
|
1
sources
1
sources
@ -1 +1,2 @@
|
||||
SHA512 (iproute2-6.7.0.tar.xz) = 5d8dca139b1b980dac6c841f477b951dd199074cb078b5ea8df23b3532eeb235cca1df9f6628b0f81b7edd62aaf4e95bad15a851843bd61e5715215da97cc546
|
||||
SHA512 (iproute2-6.11.0.tar.xz) = 06bedd7ae573fe5cf9c72af698987ba03e53dc6fce5f41813bf5bb155b683490e5c75cc835ce5ba4509e491eb6138e96da162204c28ea1b3d80887107997a3b3
|
||||
|
Loading…
Reference in New Issue
Block a user