Rebase package on top of iproute2-5.0.0
This commit is contained in:
parent
ae59d604a2
commit
5a8ceeb824
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/iproute2-4.18.0.tar.xz
|
||||
/iproute2-4.20.0.tar.xz
|
||||
/iproute2-5.0.0.tar.xz
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 00e0e82a31cede883b2784f08377008c3e996857 Mon Sep 17 00:00:00 2001
|
||||
From: "Dmitry V. Levin" <ldv@altlinux.org>
|
||||
Date: Tue, 8 Jan 2019 01:37:15 +0300
|
||||
Subject: [PATCH] configure: fix typo in check_xt_old_internal_h
|
||||
|
||||
Fixes: 377a09902a57 ("configure: Minor code cleanup")
|
||||
Signed-off-by: Dmitry V. Levin <ldv@altlinux.org>
|
||||
Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
|
||||
(cherry picked from commit db4ad742e196a3d76cd72ae1257bf444584fa5c5)
|
||||
Signed-off-by: Phil Sutter <psutter@redhat.com>
|
||||
---
|
||||
configure | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index b85eb58b2ba9e..45fcffb69bb53 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -115,7 +115,7 @@ EOF
|
||||
check_xt_old_internal_h()
|
||||
{
|
||||
# bail if previous XT checks has already succeeded.
|
||||
- grep -q if grep -q TC_CONFIG_XT $CONFIG && return
|
||||
+ grep -q TC_CONFIG_XT $CONFIG && return
|
||||
|
||||
#check if we need our own internal.h
|
||||
cat >$TMPDIR/ipttest.c <<EOF
|
||||
--
|
||||
2.20.1
|
||||
|
@ -1,47 +0,0 @@
|
||||
From 806106d6e17f7910c63bed52a046ba4d2d158f7a Mon Sep 17 00:00:00 2001
|
||||
From: Luca Boccassi <bluca@debian.org>
|
||||
Date: Sat, 12 Jan 2019 12:28:54 +0000
|
||||
Subject: [PATCH] man: ss.8: more line breaks
|
||||
|
||||
groff stiff complains about unbreakable lines:
|
||||
96: warning [p 2, 3.0i]: can't break line
|
||||
|
||||
Indent it some more.
|
||||
|
||||
Fixes: 7f5047524c99 ("man: ss.8: break and indent long line")
|
||||
|
||||
Signed-off-by: Luca Boccassi <bluca@debian.org>
|
||||
Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
|
||||
(cherry picked from commit cffeeb39466bdfcead182138e1f4c6881384ab16)
|
||||
Signed-off-by: Phil Sutter <psutter@redhat.com>
|
||||
---
|
||||
man/man8/ss.8 | 10 ++++++++--
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/man/man8/ss.8 b/man/man8/ss.8
|
||||
index f138c91a1fcc4..553a6cf46f0e2 100644
|
||||
--- a/man/man8/ss.8
|
||||
+++ b/man/man8/ss.8
|
||||
@@ -89,11 +89,17 @@ an uuid of the socket
|
||||
Show socket memory usage. The output format is:
|
||||
.RS
|
||||
.P
|
||||
-skmem:(r<rmem_alloc>,rb<rcv_buf>,t<wmem_alloc>,tb<snd_buf>,f<fwd_alloc>,
|
||||
+skmem:(r<rmem_alloc>,rb<rcv_buf>,t<wmem_alloc>,tb<snd_buf>,
|
||||
.br
|
||||
.RS
|
||||
.RS
|
||||
-w<wmem_queued>,o<opt_mem>,bl<back_log>)
|
||||
+f<fwd_alloc>,w<wmem_queued>,
|
||||
+.RE
|
||||
+.RE
|
||||
+.br
|
||||
+.RS
|
||||
+.RS
|
||||
+o<opt_mem>,bl<back_log>)
|
||||
.RE
|
||||
.RE
|
||||
.P
|
||||
--
|
||||
2.20.1
|
||||
|
@ -1,34 +0,0 @@
|
||||
From 06dfededed954e6d98450ae8f57d561359f2430e Mon Sep 17 00:00:00 2001
|
||||
From: Luca Boccassi <bluca@debian.org>
|
||||
Date: Sat, 12 Jan 2019 12:28:55 +0000
|
||||
Subject: [PATCH] man: tc-taprio.8: fix syntax error
|
||||
|
||||
.Q does not exist so groff complains and the "queues" word is actually
|
||||
not displayed.
|
||||
|
||||
Fixes: 579acb4bc52f ("taprio: Add manpage for tc-taprio(8)")
|
||||
|
||||
Signed-off-by: Luca Boccassi <bluca@debian.org>
|
||||
Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
|
||||
(cherry picked from commit 8242808ced032d56d690ae66a93fa52e8d0ada9a)
|
||||
Signed-off-by: Phil Sutter <psutter@redhat.com>
|
||||
---
|
||||
man/man8/tc-taprio.8 | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/man/man8/tc-taprio.8 b/man/man8/tc-taprio.8
|
||||
index 92055b434b942..850be9b036491 100644
|
||||
--- a/man/man8/tc-taprio.8
|
||||
+++ b/man/man8/tc-taprio.8
|
||||
@@ -45,7 +45,7 @@ How traffic is mapped to different hardware queues is similar to
|
||||
and so the
|
||||
.B map
|
||||
and
|
||||
-.Q queues
|
||||
+.B queues
|
||||
parameters have the same meaning.
|
||||
|
||||
The other parameters specify the schedule, and at what point in time
|
||||
--
|
||||
2.20.1
|
||||
|
15
iproute.spec
15
iproute.spec
@ -1,15 +1,11 @@
|
||||
%global cbq_version v0.7.3
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 4.20.0
|
||||
Version: 5.0.0
|
||||
Release: 1%{?dist}
|
||||
URL: http://kernel.org/pub/linux/utils/net/%{name}2/
|
||||
Source0: http://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.xz
|
||||
|
||||
Patch0: 0001-configure-fix-typo-in-check_xt_old_internal_h.patch
|
||||
Patch1: 0002-man-ss.8-more-line-breaks.patch
|
||||
Patch2: 0003-man-tc-taprio.8-fix-syntax-error.patch
|
||||
|
||||
License: GPLv2+ and Public Domain
|
||||
BuildRequires: gcc
|
||||
BuildRequires: bison
|
||||
@ -26,10 +22,6 @@ BuildRequires: pkgconfig
|
||||
BuildRequires: linux-atm-libs-devel
|
||||
%endif
|
||||
%endif
|
||||
# For the UsrMove transition period
|
||||
Conflicts: filesystem < 3
|
||||
Provides: /sbin/ip
|
||||
Obsoletes: %{name} < 4.5.0-3
|
||||
Recommends: %{name}-tc
|
||||
|
||||
%description
|
||||
@ -40,7 +32,6 @@ kernel.
|
||||
%package tc
|
||||
Summary: Linux Traffic Control utility
|
||||
License: GPLv2+
|
||||
Obsoletes: %{name} < 4.5.0-3
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Provides: tc
|
||||
|
||||
@ -130,6 +121,10 @@ install -D -m644 lib/libnetlink.a %{buildroot}%{_libdir}/libnetlink.a
|
||||
%{_includedir}/iproute2/bpf_elf.h
|
||||
|
||||
%changelog
|
||||
* Wed Mar 20 2019 Phil Sutter <psutter@redhat.com> - 5.0.0-1
|
||||
- New version 5.0.0
|
||||
- Get rid of old upgrade path hints
|
||||
|
||||
* Fri Feb 01 2019 Phil Sutter <psutter@redhat.com> - 4.20.0-1
|
||||
- New version 4.20.0
|
||||
- Add upstream-suggested backports
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (iproute2-4.20.0.tar.xz) = ed29638c864062e199152c7b3b24b6495987ca6f79cc9ab1b529dab37a8a840fa2b5858d5db2b94eeefa1c0d72ff666a790107e27d11a597b189bfb7a01a4b8b
|
||||
SHA512 (iproute2-5.0.0.tar.xz) = 4b1649ccdfefbb5eace9d444843492db9d1357b9b3ee1567d6241283cde00ad3c9dbee6b8e507c4e9a5ca0a6378b71ca0c5fbf1e2ed2a9c7d479daf5d49eaed0
|
||||
|
Loading…
Reference in New Issue
Block a user