new version 3.19.0
This commit is contained in:
parent
0bc5d2c911
commit
4c8bebf141
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@ iproute2-2.6.35.tar.bz2
|
||||
/iproute2-3.14.0.tar.gz
|
||||
/iproute2-3.15.0.tar.gz
|
||||
/iproute2-3.16.0.tar.gz
|
||||
/iproute2-3.19.0.tar.xz
|
||||
|
11
iproute.spec
11
iproute.spec
@ -1,11 +1,11 @@
|
||||
%global cbq_version v0.7.3
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 3.16.0
|
||||
Release: 3%{?dist}
|
||||
Version: 3.19.0
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/System
|
||||
URL: http://kernel.org/pub/linux/utils/net/%{name}2/
|
||||
Source0: http://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.gz
|
||||
Source0: http://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.xz
|
||||
Source1: cbq-0000.example
|
||||
Source2: avpkt
|
||||
Patch0: man-pages.patch
|
||||
@ -19,7 +19,6 @@ Patch6: iproute2-3.12.0-lnstat-dump-to-stdout.patch
|
||||
Patch7: iproute2-3.11.0-tc-ok.patch
|
||||
Patch8: iproute2-3.11.0-rtt.patch
|
||||
Patch9: iproute2-3.12.0-lnstat-interval.patch
|
||||
Patch10: iproute2-3.16.0-ip-link-add-name.patch
|
||||
License: GPLv2+ and Public Domain
|
||||
BuildRequires: bison
|
||||
BuildRequires: flex
|
||||
@ -73,7 +72,6 @@ The libnetlink static library.
|
||||
%patch7 -p1 -b .tc_ok
|
||||
%patch8 -p1 -b .rtt
|
||||
%patch9 -p1 -b .lnstat-interval
|
||||
%patch10 -p1 -b .ip-link-add-name
|
||||
sed -i 's/^LIBDIR=/LIBDIR?=/' Makefile
|
||||
|
||||
%build
|
||||
@ -176,6 +174,9 @@ done
|
||||
%{_includedir}/libnetlink.h
|
||||
|
||||
%changelog
|
||||
* Fri Mar 13 2015 Pavel Šimerda <psimerda@redhat.com> - 3.19.0-1
|
||||
- new version 3.19.0
|
||||
|
||||
* Sat Oct 04 2014 Lubomir Rintel <lkundrak@v3.sk> - 3.16.0-3
|
||||
- Backport fix for ip link add name regression that broke libvirt
|
||||
|
||||
|
@ -2,24 +2,6 @@ diff --git a/lib/utils.c b/lib/utils.c
|
||||
index dae1b51..8a1a65d 100644
|
||||
--- a/lib/utils.c
|
||||
+++ b/lib/utils.c
|
||||
@@ -145,7 +145,7 @@ int get_time_rtt(unsigned *val, const char *arg, int *raw)
|
||||
return -1;
|
||||
|
||||
/* extra non-digits */
|
||||
- if (!p || p == arg || *p)
|
||||
+ if (!p || p == arg)
|
||||
return -1;
|
||||
|
||||
/* over/underflow */
|
||||
@@ -155,7 +155,7 @@ int get_time_rtt(unsigned *val, const char *arg, int *raw)
|
||||
res = strtoul(arg, &p, 0);
|
||||
|
||||
/* empty string or trailing non-digits */
|
||||
- if (!p || p == arg || *p)
|
||||
+ if (!p || p == arg)
|
||||
return -1;
|
||||
|
||||
/* overflow */
|
||||
@@ -165,8 +165,6 @@ int get_time_rtt(unsigned *val, const char *arg, int *raw)
|
||||
t = (double)res;
|
||||
}
|
||||
|
@ -25,17 +25,17 @@ index e0acfeb..583eae2 100644
|
||||
--- a/man/man8/tc.8
|
||||
+++ b/man/man8/tc.8
|
||||
@@ -49,7 +49,7 @@ DEV
|
||||
DEV
|
||||
|
||||
.P
|
||||
-.B tc [ -force ] -b\fR[\fIatch\fR] \fB[ filename ]
|
||||
+.B tc [ -force ] [ -OK ] -b\fR[\fIatch\fR] \fB[ filename ]
|
||||
.ti 8
|
||||
.IR OPTIONS " := {"
|
||||
-\fB[ -force ] -b\fR[\fIatch\fR] \fB[ filename ] \fR|
|
||||
+\fB[ -force ] [ -OK ] -b\fR[\fIatch\fR] \fB[ filename ] \fR|
|
||||
\fB[ \fB-n\fR[\fIetns\fR] name \fB] \fR}
|
||||
|
||||
.ti 8
|
||||
.IR FORMAT " := {"
|
||||
@@ -440,6 +440,12 @@ First failure will cause termination of tc.
|
||||
don't terminate tc on errors in batch mode.
|
||||
If there were any errors during execution of the commands, the application return code will be non zero.
|
||||
.RS 4
|
||||
Shows classes as ASCII graph with stats info under each class.
|
||||
|
||||
+.TP
|
||||
+.BR "\-OK"
|
||||
@ -65,8 +65,8 @@ index 9b50e74..b43bb47 100644
|
||||
- " tc [-force] -batch filename\n"
|
||||
+ " tc [-force] [-OK] -batch filename\n"
|
||||
"where OBJECT := { qdisc | class | filter | action | monitor }\n"
|
||||
" OPTIONS := { -s[tatistics] | -d[etails] | -r[aw] | -p[retty] | -b[atch] [filename] }\n");
|
||||
}
|
||||
" OPTIONS := { -s[tatistics] | -d[etails] | -r[aw] | -p[retty] | -b[atch] [filename] | "
|
||||
"-n[etns] name }\n");
|
||||
@@ -251,6 +252,9 @@ static int batch(const char *name)
|
||||
ret = 1;
|
||||
if (!force)
|
||||
|
@ -72,18 +72,18 @@ index 2a4bbc5..f4b9282 100644
|
||||
@@ -128,7 +128,7 @@ Read filter information from FILE.
|
||||
Each line of FILE is interpreted like single command line option. If FILE is - stdin is used.
|
||||
.TP
|
||||
.B FILTER := [ state TCP-STATE ] [ EXPRESSION ]
|
||||
.B FILTER := [ state STATE-FILTER ] [ EXPRESSION ]
|
||||
-Please take a look at the official documentation (Debian package iproute-doc) for details regarding filters.
|
||||
+Please take a look at the official documentation (Debian package iproute\-doc) for details regarding filters.
|
||||
.SH USAGE EXAMPLES
|
||||
.TP
|
||||
.B ss -t -a
|
||||
+Please take a look at the official documentation (package iproute\-doc) for details regarding filters.
|
||||
|
||||
.SH STATE-FILTER
|
||||
|
||||
@@ -150,7 +150,7 @@ Find all local processes connected to X server.
|
||||
List all the tcp sockets in state FIN-WAIT-1 for our apache to network 193.233.7/24 and look at their timers.
|
||||
.SH SEE ALSO
|
||||
.BR ip (8),
|
||||
-.BR /usr/share/doc/iproute-doc/ss.html " (package iproutedoc)"
|
||||
+.BR /usr/share/doc/iproute-doc/ss.ps " (package iproute\-doc)"
|
||||
.SH AUTHOR
|
||||
.I ss
|
||||
was written by Alexey Kuznetosv, <kuznet@ms2.inr.ac.ru>.
|
||||
-.BR /usr/share/doc/iproute-doc/ss.html " (package iproutedoc)",
|
||||
+.BR /usr/share/doc/iproute-doc/ss.ps " (package iproute\-doc)",
|
||||
.br
|
||||
.BR RFC " 793 "
|
||||
- https://tools.ietf.org/rfc/rfc793.txt (TCP states)
|
||||
|
Loading…
Reference in New Issue
Block a user