3.12.0 bump

This commit is contained in:
Petr Šabata 2013-11-25 19:39:35 +09:00
parent 1a254c6d5e
commit 1a082968b8
8 changed files with 55 additions and 294 deletions

View File

@ -1,7 +1,7 @@
%global cbq_version v0.7.3 %global cbq_version v0.7.3
Summary: Advanced IP routing and network device configuration tools Summary: Advanced IP routing and network device configuration tools
Name: iproute Name: iproute
Version: 3.11.0 Version: 3.12.0
Release: 1%{?dist} Release: 1%{?dist}
Group: Applications/System Group: Applications/System
URL: http://kernel.org/pub/linux/utils/net/%{name}2/ URL: http://kernel.org/pub/linux/utils/net/%{name}2/
@ -15,15 +15,12 @@ Patch3: iproute2-3.9.0-IPPROTO_IP_for_SA.patch
Patch4: iproute2-example-cbq-service.patch Patch4: iproute2-example-cbq-service.patch
Patch5: iproute2-2.6.35-print-route.patch Patch5: iproute2-2.6.35-print-route.patch
Patch6: iproute2-2.6.39-create-peer-veth-without-a-name.patch Patch6: iproute2-2.6.39-create-peer-veth-without-a-name.patch
Patch7: iproute2-2.6.39-lnstat-dump-to-stdout.patch Patch7: iproute2-3.12.0-lnstat-dump-to-stdout.patch
Patch8: iproute2-3.10.0-xfrm-state-overflow.patch Patch8: iproute2-3.10.0-rtnl_send.patch
Patch9: iproute2-3.10.0-lnstat-interval.patch
Patch10: iproute2-3.10.0-rtnl_send.patch
# Rejected by upstream <http://thread.gmane.org/gmane.linux.network/284101> # Rejected by upstream <http://thread.gmane.org/gmane.linux.network/284101>
Patch11: iproute2-3.11.0-tc-ok.patch Patch9: iproute2-3.11.0-tc-ok.patch
Patch12: iproute2-3.11.0-iproute2-bridge-document-mdb.patch Patch10: iproute2-3.11.0-rtt.patch
# Bug #1011822, in upstream after 3.11.0 Patch11: iproute2-3.12.0-lnstat-interval.patch
Patch13: iproute2-3.11.0-iproute2-bridge-Close-file-with-bridge-monitor-file.patch
License: GPLv2+ and Public Domain License: GPLv2+ and Public Domain
BuildRequires: bison BuildRequires: bison
BuildRequires: flex BuildRequires: flex
@ -76,12 +73,10 @@ The libnetlink static library.
%patch5 -p1 -b .print-route %patch5 -p1 -b .print-route
%patch6 -p1 -b .peer-veth-without-name %patch6 -p1 -b .peer-veth-without-name
%patch7 -p1 -b .lnstat-dump-to-stdout %patch7 -p1 -b .lnstat-dump-to-stdout
%patch8 -p1 -b .xfrm-state %patch8 -p1 -b .rtnl_send
%patch9 -p1 -b .lnstat-interval %patch9 -p1 -b .tc_ok
%patch10 -p1 -b .rtnl_send %patch10 -p1 -b .rtt
%patch11 -p1 -b .tc_ok %patch11 -p1 -b .lnstat-interval
%patch12 -p1 -b .bridge_mdb_doc
%patch13 -p1 -b .bridge_monitor_close
sed -i 's/^LIBDIR=/LIBDIR?=/' Makefile sed -i 's/^LIBDIR=/LIBDIR?=/' Makefile
%build %build
@ -181,6 +176,12 @@ done
%{_includedir}/libnetlink.h %{_includedir}/libnetlink.h
%changelog %changelog
* Mon Nov 25 2013 Petr Šabata <contyk@redhat.com> - 3.12.0-1
- 3.12.0 bump
* Thu Nov 21 2013 Petr Šabata <contyk@redhat.com> - 3.11.0-2
- Fix the rtt time parsing again
* Tue Oct 22 2013 Petr Šabata <contyk@redhat.com> - 3.11.0-1 * Tue Oct 22 2013 Petr Šabata <contyk@redhat.com> - 3.11.0-1
- 3.11 bump - 3.11 bump

View File

@ -1,29 +0,0 @@
diff --git a/misc/lnstat.c b/misc/lnstat.c
index dca10ad..2889e5e 100644
--- a/misc/lnstat.c
+++ b/misc/lnstat.c
@@ -226,7 +226,7 @@ int main(int argc, char **argv)
MODE_NORMAL,
} mode = MODE_NORMAL;
- unsigned long count = 1;
+ unsigned long count = 0;
static struct field_params fp;
int num_req_files = 0;
char *req_files[LNSTAT_MAX_FILES];
@@ -336,13 +336,14 @@ int main(int argc, char **argv)
if (interval < 1 )
interval=1;
- for (i = 0; i < count; i++) {
+ for (i = 0; !count || i < count; ) {
if ((hdr > 1 && (! (i % 20))) || (hdr == 1 && i == 0))
print_hdr(stdout, header);
lnstat_update(lnstat_files);
print_line(stdout, lnstat_files, &fp);
fflush(stdout);
sleep(interval);
+ if (count) ++i;
}
}

View File

@ -1,38 +0,0 @@
From 7887635f629c5a73be5e2db0a1a8a221e8b16077 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20=C5=A0abata?= <contyk@redhat.com>
Date: Wed, 17 Jul 2013 15:29:54 +0200
Subject: [PATCH] Avoid overflow segfault with FORTIFY_SOURCE
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Šabata <contyk@redhat.com>
---
ip/xfrm_state.c | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/ip/xfrm_state.c b/ip/xfrm_state.c
index 389942c..160ab32 100644
--- a/ip/xfrm_state.c
+++ b/ip/xfrm_state.c
@@ -157,12 +157,16 @@ static int xfrm_algo_parse(struct xfrm_algo *alg, enum xfrm_attr_type_t type,
buf[j] = val;
}
} else {
+ int i;
len = slen;
if (len > 0) {
if (len > max)
invarg("ALGO-KEYMAT value makes buffer overflow\n", key);
- strncpy(buf, key, len);
+ for (i = 0 ; i < len && key[i] != '\0'; i++)
+ buf[i] = key[i];
+ for ( ; i < len; i++)
+ buf[i] = '\0';
}
}
--
1.8.3.1

View File

@ -1,41 +0,0 @@
From 101847446e6a5e3ca370e65ebc462584934fce0e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Wed, 25 Sep 2013 09:45:45 +0200
Subject: [PATCH] iproute2: bridge: Close file with bridge monitor file
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The `bridge monitor file FILENAME' reads dumped netlink messages from
a file. But it forgot to close the file after using it. This patch
fixes it.
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
bridge/monitor.c | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/bridge/monitor.c b/bridge/monitor.c
index e96fcaf..76e7d47 100644
--- a/bridge/monitor.c
+++ b/bridge/monitor.c
@@ -132,12 +132,15 @@ int do_monitor(int argc, char **argv)
if (file) {
FILE *fp;
+ int err;
fp = fopen(file, "r");
if (fp == NULL) {
perror("Cannot fopen");
exit(-1);
}
- return rtnl_from_file(fp, accept_msg, stdout);
+ err = rtnl_from_file(fp, accept_msg, stdout);
+ fclose(fp);
+ return err;
}
if (rtnl_open(&rth, groups) < 0)
--
1.8.3.1

View File

@ -1,153 +0,0 @@
From 54e9c3a34d4ba8a0890f3bf21d708342329461b5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Thu, 19 Sep 2013 10:41:26 +0200
Subject: [PATCH] iproute2: bridge: document mdb
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
This augments bridge(8) manual page with `bridge mdb' and `bridge
monitor mdb' commands which have been added recently.
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
man/man8/bridge.8 | 88 +++++++++++++++++++++++++++++++++++++++++++++++++++++--
1 file changed, 85 insertions(+), 3 deletions(-)
diff --git a/man/man8/bridge.8 b/man/man8/bridge.8
index 66678b5..9a34804 100644
--- a/man/man8/bridge.8
+++ b/man/man8/bridge.8
@@ -13,7 +13,7 @@ bridge \- show / manipulate bridge addresses and devices
.ti -8
.IR OBJECT " := { "
-.BR link " | " fdb " | " vlan " | " monitor " }"
+.BR link " | " fdb " | " mdb " | " vlan " | " monitor " }"
.sp
.ti -8
@@ -65,6 +65,21 @@ bridge \- show / manipulate bridge addresses and devices
.IR DEV " ]"
.ti -8
+.BR "bridge mdb" " { " add " | " del " } "
+.B dev
+.IR DEV
+.B port
+.IR PORT
+.B grp
+.IR GROUP " [ "
+.BR permanent " | " temp " ]"
+
+.ti -8
+.BR "bridge mdb show " [ "
+.B dev
+.IR DEV " ]"
+
+.ti -8
.BR "bridge vlan" " { " add " | " del " } "
.B dev
.IR DEV
@@ -79,7 +94,7 @@ bridge \- show / manipulate bridge addresses and devices
.IR DEV " ]"
.ti -8
-.BR "bridge monitor" " [ " all " | " neigh " | " link " ]"
+.BR "bridge monitor" " [ " all " | " neigh " | " link " | " mdb " ]"
.SH OPTIONS
@@ -110,6 +125,10 @@ As a rule, the information is statistics or some time values.
- Forwarding Database entry.
.TP
+.B mdb
+- Multicast group database entry.
+
+.TP
.B vlan
- VLAN filter list.
@@ -326,6 +345,69 @@ With the
option, the command becomes verbose. It prints out the last updated
and last used time for each entry.
+.SH bridge mdb - multicast group database management
+
+.B mdb
+objects contain known IP multicast group addresses on a link.
+
+.P
+The corresponding commands display mdb entries, add new entries,
+and delete old ones.
+
+.SS bridge mdb add - add a new multicast group database entry
+
+This command creates a new mdb entry.
+
+.TP
+.BI dev " DEV"
+the interface where this group address is associated.
+
+.TP
+.BI port " PORT"
+the port whose link is known to have members of this multicast group.
+
+.TP
+.BI grp " GROUP"
+the IP multicast group address whose members reside on the link connected to
+the port.
+
+.B permanent
+- the mdb entry is permanent
+.sp
+
+.B temp
+- the mdb entry is temporary (default)
+.sp
+
+.in -8
+.SS bridge mdb delete - delete a multicast group database entry
+This command removes an existing mdb entry.
+
+.PP
+The arguments are the same as with
+.BR "bridge mdb add" .
+
+.SS bridge mdb show - list multicast group database entries
+
+This command displays the current multicast group membership table. The table
+is populated by IGMP and MLD snooping in the bridge driver automatically. It
+can be altered by
+.B bridge mdb add
+and
+.B bridge mdb del
+commands manually too.
+
+.TP
+.BI dev " DEV"
+the interface only whose entries should be listed. Default is to list all
+bridge interfaces.
+
+.PP
+With the
+.B -details
+option, the command becomes verbose. It prints out the ports known to have
+a connected router.
+
.SH bridge vlan - VLAN filter list
.B vlan
@@ -395,7 +477,7 @@ command is the first in the command line and then the object list follows:
.I OBJECT-LIST
is the list of object types that we want to monitor.
It may contain
-.BR link ", and " fdb "."
+.BR link ", " fdb ", and " mdb "."
If no
.B file
argument is given,
--
1.8.3.1

View File

@ -1,13 +1,13 @@
diff --git a/misc/lnstat.c b/misc/lnstat.c diff --git a/misc/lnstat.c b/misc/lnstat.c
index 32ab6a4..431bfc7 100644 index d6415ef..8608cfa 100644
--- a/misc/lnstat.c --- a/misc/lnstat.c
+++ b/misc/lnstat.c +++ b/misc/lnstat.c
@@ -322,7 +322,7 @@ int main(int argc, char **argv) @@ -351,7 +351,7 @@ int main(int argc, char **argv)
int i;
struct table_hdr *header; switch (mode) {
case MODE_DUMP: case MODE_DUMP:
- lnstat_dump(stderr, lnstat_files); - lnstat_dump(stderr, lnstat_files);
+ lnstat_dump(stdout, lnstat_files); + lnstat_dump(stdout, lnstat_files);
break; break;
case MODE_NORMAL:
case MODE_NORMAL:

View File

@ -0,0 +1,34 @@
diff --git a/misc/lnstat.c b/misc/lnstat.c
index 8608cfa..8e8b1ba 100644
--- a/misc/lnstat.c
+++ b/misc/lnstat.c
@@ -253,7 +253,7 @@ int main(int argc, char **argv)
MODE_JSON,
MODE_NORMAL,
} mode = MODE_NORMAL;
- unsigned long count = 1;
+ unsigned long count = 0;
struct table_hdr *header;
static struct field_params fp;
int num_req_files = 0;
@@ -366,7 +366,7 @@ int main(int argc, char **argv)
if (interval < 1 )
interval = 1;
- for (i = 0; i < count; i++) {
+ for (i = 0; i < count || !count; ) {
lnstat_update(lnstat_files);
if (mode == MODE_JSON)
print_json(stdout, lnstat_files, &fp);
@@ -377,8 +377,10 @@ int main(int argc, char **argv)
print_line(stdout, lnstat_files, &fp);
}
fflush(stdout);
- if (i < count - 1)
+ if (i < count - 1 || !count)
sleep(interval);
+ if (count)
+ ++i;
}
break;
}

View File

@ -1,13 +0,0 @@
diff --git a/Makefile b/Makefile
index 5edffc0..898b572 100644
--- a/Makefile
+++ b/Makefile
@@ -34,7 +34,7 @@ CCOPTS = -O2
WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
WFLAGS += -Wmissing-declarations -Wold-style-definition
-CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
+CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES) $(RPM_OPT_FLAGS)
YACCFLAGS = -d -t -v
SUBDIRS=lib ip tc bridge misc netem genl man