Remove unused patches.

This commit is contained in:
Marcela Mašláňová 2007-09-12 11:07:36 +00:00
parent 89f9700070
commit 127dbb9e38
5 changed files with 0 additions and 106 deletions

View File

@ -1,12 +0,0 @@
--- iproute2/ip/iproute.c.initvar 2004-04-21 16:57:59.307562694 +0200
+++ iproute2/ip/iproute.c 2004-04-21 16:58:35.353103364 +0200
@@ -620,6 +620,9 @@
}
memset(rtnh, 0, sizeof(*rtnh));
rtnh->rtnh_len = sizeof(*rtnh);
+ rtnh->rtnh_ifindex = 0;
+ rtnh->rtnh_flags = 0;
+ rtnh->rtnh_hops = 0;
rta->rta_len += rtnh->rtnh_len;
parse_one_nh(rta, rtnh, &argc, &argv);
rtnh = RTNH_NEXT(rtnh);

View File

@ -1,54 +0,0 @@
--- iproute2-2.6.9/misc/nstat.c.bound 2004-08-31 14:32:14.000000000 -0400
+++ iproute2-2.6.9/misc/nstat.c 2004-09-05 10:32:26.000000000 -0400
@@ -121,14 +121,16 @@
int nr;
unsigned long long val;
double rate;
- char idbuf[256];
+ char idbuf[sizeof(buf)];
if (buf[0] == '#') {
buf[strlen(buf)-1] = 0;
if (info_source[0] && strcmp(info_source, buf+1))
source_mismatch = 1;
- strncpy(info_source, buf+1, sizeof(info_source)-1);
+ info_source[0] = 0;
+ strncat(info_source, buf+1, sizeof(info_source)-1);
continue;
}
+ /* idbuf is as big as buf, so this is safe */
nr = sscanf(buf, "%s%llu%lg", idbuf, &val, &rate);
if (nr < 2)
abort();
@@ -162,7 +164,7 @@
struct nstat_ent *n;
while (fgets(buf, sizeof(buf), fp) != NULL) {
- char idbuf[256];
+ char idbuf[sizeof(buf)];
int off;
char *p;
@@ -170,8 +172,9 @@
if (!p)
abort();
*p = 0;
- strcpy(idbuf, buf);
- off = strlen(idbuf);
+ idbuf[0] = 0;
+ strncat(idbuf, buf, sizeof(idbuf) -1);
+ off = p - buf;
p += 2;
while (*p) {
@@ -180,7 +183,10 @@
*next++ = 0;
else if ((next = strchr(p, '\n')) != NULL)
*next++ = 0;
- strcpy(idbuf+off, p);
+ if (off < sizeof(idbuf)) {
+ idbuf[off] = 0;
+ strncat(idbuf, p, sizeof(idbuf) - off - 1);
+ }
n = malloc(sizeof(*n));
if (!n)
abort();

View File

@ -1,11 +0,0 @@
--- iproute2-2.6.9/misc/ss.c.ss 2004-08-31 20:32:14.000000000 +0200
+++ iproute2-2.6.9/misc/ss.c 2004-09-01 13:02:54.574367176 +0200
@@ -34,7 +34,7 @@
#include "SNAPSHOT.h"
#include <asm/byteorder.h>
-#include <linux/tcp.h>
+#include <netinet/tcp.h>
#include <linux/tcp_diag.h>
int resolve_hosts = 0;

View File

@ -1,18 +0,0 @@
--- iproute2-ss050901/ip/iproute.c~ 2005-09-01 14:21:50.000000000 -0500
+++ iproute2-ss050901/ip/iproute.c 2005-10-06 21:30:36.000000000 -0500
@@ -216,13 +216,13 @@ int print_route(const struct sockaddr_nl
memset(&via, 0, sizeof(via));
via.family = r->rtm_family;
if (tb[RTA_GATEWAY])
- memcpy(&via.data, RTA_DATA(tb[RTA_GATEWAY]), host_len);
+ memcpy(&via.data, RTA_DATA(tb[RTA_GATEWAY]), host_len/8);
}
if (filter.rprefsrc.bitlen>0) {
memset(&prefsrc, 0, sizeof(prefsrc));
prefsrc.family = r->rtm_family;
if (tb[RTA_PREFSRC])
- memcpy(&prefsrc.data, RTA_DATA(tb[RTA_PREFSRC]), host_len);
+ memcpy(&prefsrc.data, RTA_DATA(tb[RTA_PREFSRC]), host_len/8);
}
if (filter.rdst.family && inet_addr_match(&dst, &filter.rdst, filter.rdst.bitlen))

View File

@ -1,11 +0,0 @@
--- iproute2-ss050901/Makefile.opt_flags 2005-09-23 11:49:01.000000000 +0200
+++ iproute2-ss050901/Makefile 2005-09-23 11:49:31.000000000 +0200
@@ -22,7 +22,7 @@
CC = gcc
HOSTCC = gcc
-CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall
+CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall $(RPM_OPT_FLAGS)
CFLAGS = $(CCOPTS) -I../include $(DEFINES)
YACCFLAGS = -d -t -v