- update from upstream
- fixed host_len size for memcpy (#168903) <Matt_Domsch@dell.com>
This commit is contained in:
parent
bcaaae0cd2
commit
06f99a4685
@ -1 +1 @@
|
||||
iproute2-ss050901.tar.bz2
|
||||
iproute2-050929.tar.gz
|
||||
|
14
iproute.spec
14
iproute.spec
@ -1,12 +1,12 @@
|
||||
%define date_version ss050901
|
||||
%define date_version 050929
|
||||
%define cbq_version v0.7.3
|
||||
|
||||
Summary: Advanced IP routing and network device configuration tools.
|
||||
Name: iproute
|
||||
Version: 2.6.14
|
||||
Release: 4
|
||||
Release: 5
|
||||
Group: Applications/System
|
||||
Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{date_version}.tar.bz2
|
||||
Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{date_version}.tar.gz
|
||||
URL: http://developer.osdl.org/dev/iproute2/
|
||||
Source1: ip.8
|
||||
Source2: tc.8
|
||||
@ -25,8 +25,8 @@ Source13: README.cbq
|
||||
Patch1: iproute2-2.4.7-rt_config.patch
|
||||
Patch2: iproute2-2.6.9-kernel.patch
|
||||
Patch3: cbq-0.7.1-avpkt-enhancement.patch
|
||||
Patch4: iproute2-ss050901-help.patch
|
||||
Patch5: iproute2-ss050901-opt_flags.patch
|
||||
Patch6: iproute2-ss050901-host_len.patch
|
||||
|
||||
License: GNU GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -43,8 +43,8 @@ cp %{SOURCE12} $RPM_BUILD_DIR/iproute2-%{date_version}
|
||||
%patch1 -p1 -b .rt_config
|
||||
%patch2 -p1 -b .kernel
|
||||
%patch3 -p0 -b .avpkt-enhancment
|
||||
%patch4 -p1 -b .help
|
||||
%patch5 -p1 -b .opt_flags
|
||||
%patch6 -p1 -b .host_len
|
||||
|
||||
%build
|
||||
make
|
||||
@ -114,6 +114,10 @@ EOF
|
||||
%config(noreplace) /etc/sysconfig/cbq/*
|
||||
|
||||
%changelog
|
||||
* Fri Oct 07 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-5
|
||||
- update from upstream
|
||||
- fixed host_len size for memcpy (#168903) <Matt_Domsch@dell.com>
|
||||
|
||||
* Fri Sep 23 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-4
|
||||
- add RPM_OPT_FLAGS
|
||||
|
||||
|
18
iproute2-ss050901-host_len.patch
Normal file
18
iproute2-ss050901-host_len.patch
Normal file
@ -0,0 +1,18 @@
|
||||
--- iproute2-ss050901/ip/iproute.c~ 2005-09-01 14:21:50.000000000 -0500
|
||||
+++ iproute2-ss050901/ip/iproute.c 2005-10-06 21:30:36.000000000 -0500
|
||||
@@ -216,13 +216,13 @@ int print_route(const struct sockaddr_nl
|
||||
memset(&via, 0, sizeof(via));
|
||||
via.family = r->rtm_family;
|
||||
if (tb[RTA_GATEWAY])
|
||||
- memcpy(&via.data, RTA_DATA(tb[RTA_GATEWAY]), host_len);
|
||||
+ memcpy(&via.data, RTA_DATA(tb[RTA_GATEWAY]), host_len/8);
|
||||
}
|
||||
if (filter.rprefsrc.bitlen>0) {
|
||||
memset(&prefsrc, 0, sizeof(prefsrc));
|
||||
prefsrc.family = r->rtm_family;
|
||||
if (tb[RTA_PREFSRC])
|
||||
- memcpy(&prefsrc.data, RTA_DATA(tb[RTA_PREFSRC]), host_len);
|
||||
+ memcpy(&prefsrc.data, RTA_DATA(tb[RTA_PREFSRC]), host_len/8);
|
||||
}
|
||||
|
||||
if (filter.rdst.family && inet_addr_match(&dst, &filter.rdst, filter.rdst.bitlen))
|
Loading…
Reference in New Issue
Block a user