- 49933 fix segfault after non-existent combination of commands
This commit is contained in:
parent
20e2934642
commit
000b2439f1
12
iproute.spec
12
iproute.spec
@ -4,7 +4,7 @@
|
||||
Summary: Advanced IP routing and network device configuration tools
|
||||
Name: iproute
|
||||
Version: 2.6.25
|
||||
Release: 1%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Group: Applications/System
|
||||
Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}.tar.bz2
|
||||
#Source1: iproute-doc-2.6.22.tar.gz
|
||||
@ -16,6 +16,7 @@ Patch4: iproute-ip-man.patch
|
||||
Patch5: iproute2-movelib.patch
|
||||
Patch6: iproute2-tex.patch
|
||||
Patch7: iproute2-2.6.25-aead.patch
|
||||
Patch8: iproute2-2.6.25-xfrmsegfault.patch
|
||||
|
||||
License: GPLv2+
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -31,12 +32,13 @@ capabilities of the Linux 2.4.x and 2.6.x kernel.
|
||||
%setup -q -c iproute-%{version}
|
||||
%patch1 -p1 -b .kernel
|
||||
%patch2 -p1 -b .opt_flags
|
||||
%patch3 -p1 -b .ip_resolve
|
||||
#%patch3 -p1 -b .ip_resolve
|
||||
%patch4 -p1
|
||||
%patch5 -p1 -b .movelib
|
||||
#remove tex for the while
|
||||
#%patch6 -p1 -b .wotex
|
||||
%patch7 -p1 -b .aead
|
||||
%patch8 -p1 -b .seg
|
||||
|
||||
%build
|
||||
export LIBDIR=%{_libdir}
|
||||
@ -112,6 +114,12 @@ EOF
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
|
||||
|
||||
%changelog
|
||||
* Thu Jul 3 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-3
|
||||
- 49933 fix segfault after non-existent combination of commands
|
||||
|
||||
* Wed May 14 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-2
|
||||
- allow replay setting, solve also 444724
|
||||
|
||||
* Mon Apr 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-1
|
||||
- update
|
||||
- remove patch for backward compatibility
|
||||
|
@ -1,15 +1,6 @@
|
||||
diff -up iproute-2.6.25/iproute2-2.6.25/include/linux/xfrm.h.aead iproute-2.6.25/iproute2-2.6.25/include/linux/xfrm.h
|
||||
--- iproute-2.6.25/iproute2-2.6.25/include/linux/xfrm.h.aead 2008-04-17 19:12:54.000000000 +0200
|
||||
+++ iproute-2.6.25/iproute2-2.6.25/include/linux/xfrm.h 2008-04-22 08:38:15.000000000 +0200
|
||||
@@ -277,7 +277,7 @@ enum xfrm_attr_type_t {
|
||||
XFRMA_LASTUSED,
|
||||
XFRMA_POLICY_TYPE, /* struct xfrm_userpolicy_type */
|
||||
XFRMA_MIGRATE,
|
||||
- XFRMA_ALG_AEAD, /* struct xfrm_algo_aead */
|
||||
+ XFRMA_ALG_AEAD, /* struct xfrm_algo_aead */
|
||||
__XFRMA_MAX
|
||||
|
||||
#define XFRMA_MAX (__XFRMA_MAX - 1)
|
||||
@@ -426,12 +426,14 @@ struct xfrm_user_migrate {
|
||||
__u16 new_family;
|
||||
};
|
||||
|
13
iproute2-2.6.25-xfrmsegfault.patch
Normal file
13
iproute2-2.6.25-xfrmsegfault.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -up iproute-2.6.25/iproute2-2.6.25/ip/xfrm_state.c.oprava iproute-2.6.25/iproute2-2.6.25/ip/xfrm_state.c
|
||||
--- iproute-2.6.25/iproute2-2.6.25/ip/xfrm_state.c.oprava 2008-07-03 16:00:13.000000000 +0200
|
||||
+++ iproute-2.6.25/iproute2-2.6.25/ip/xfrm_state.c 2008-07-03 16:08:43.000000000 +0200
|
||||
@@ -162,7 +162,8 @@ static int xfrm_algo_parse(struct xfrm_a
|
||||
if (len > 0) {
|
||||
if (len > max)
|
||||
invarg("\"ALGOKEY\" makes buffer overflow\n", key);
|
||||
-
|
||||
+ else
|
||||
+ invarg("\"ALGOKEY\" is invalid", key);
|
||||
strncpy(buf, key, len);
|
||||
}
|
||||
}
|
Loading…
Reference in New Issue
Block a user