Resolves: rhbz#681941 don't link unneccessary -lm, etc
This commit is contained in:
parent
208fe99d89
commit
07a40ef8eb
@ -1,19 +0,0 @@
|
|||||||
--- icu/source/configure.in 2011-03-07 09:39:32.223725803 +0000
|
|
||||||
+++ icu/source/configure.in 2011-03-07 09:42:46.482876656 +0000
|
|
||||||
@@ -214,15 +214,7 @@
|
|
||||||
# Determine the Makefile fragment
|
|
||||||
ICU_CHECK_MH_FRAG
|
|
||||||
|
|
||||||
-# Checks for libraries and other host specific stuff
|
|
||||||
-# On HP/UX, don't link to -lm from a shared lib because it isn't
|
|
||||||
-# PIC (at least on 10.2)
|
|
||||||
-case "${host}" in
|
|
||||||
- *-*-hpux*) AC_CHECK_LIB(m, floor, LIB_M="-lm") ;;
|
|
||||||
-
|
|
||||||
- *) AC_CHECK_LIB(m, floor)
|
|
||||||
- LIB_M="" ;;
|
|
||||||
-esac
|
|
||||||
+AC_CHECK_LIB(m, floor, LIB_M="-lm")
|
|
||||||
AC_SUBST(LIB_M)
|
|
||||||
|
|
||||||
# Check whether to build shared libraries
|
|
19
icu.spec
19
icu.spec
@ -1,6 +1,6 @@
|
|||||||
Name: icu
|
Name: icu
|
||||||
Version: 4.6
|
Version: 4.6
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: International Components for Unicode
|
Summary: International Components for Unicode
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: MIT and UCD and Public Domain
|
License: MIT and UCD and Public Domain
|
||||||
@ -12,7 +12,6 @@ Requires: lib%{name} = %{version}-%{release}
|
|||||||
|
|
||||||
Patch1: icu.8198.revert.icu5431.patch
|
Patch1: icu.8198.revert.icu5431.patch
|
||||||
Patch2: icu.8320.freeserif.crash.patch
|
Patch2: icu.8320.freeserif.crash.patch
|
||||||
Patch3: icu.rhbz681941.extralinklm.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Tools and utilities for developing with icu.
|
Tools and utilities for developing with icu.
|
||||||
@ -54,7 +53,6 @@ BuildArch: noarch
|
|||||||
%setup -q -n %{name}
|
%setup -q -n %{name}
|
||||||
%patch1 -p2 -R -b .icu8198.revert.icu5431.patch
|
%patch1 -p2 -R -b .icu8198.revert.icu5431.patch
|
||||||
%patch2 -p1 -b .icu8320.freeserif.crash.patch
|
%patch2 -p1 -b .icu8320.freeserif.crash.patch
|
||||||
%patch3 -p1 -b .rhbz681941.extralinklm.patch
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd source
|
cd source
|
||||||
@ -63,7 +61,16 @@ CFLAGS='%optflags -fno-strict-aliasing'
|
|||||||
CXXFLAGS='%optflags -fno-strict-aliasing'
|
CXXFLAGS='%optflags -fno-strict-aliasing'
|
||||||
%configure --with-data-packaging=library --disable-samples
|
%configure --with-data-packaging=library --disable-samples
|
||||||
#rhbz#225896
|
#rhbz#225896
|
||||||
sed -i -- "s/-nodefaultlibs -nostdlib//" config/mh-linux
|
sed -i 's|-nodefaultlibs -nostdlib||' config/mh-linux
|
||||||
|
#rhbz#681491
|
||||||
|
sed -i 's|^LIBS =.*|LIBS = -L../lib -licuuc -lpthread -lm|' i18n/Makefile
|
||||||
|
sed -i 's|^LIBS =.*|LIBS = -nostdlib -L../lib -licuuc -licui18n -lc|' io/Makefile
|
||||||
|
sed -i 's|^LIBS =.*|LIBS = -nostdlib -L../lib -licuuc -lc|' layout/Makefile
|
||||||
|
sed -i 's|^LIBS =.*|LIBS = -nostdlib -L../lib -licuuc -licule -lc|' layoutex/Makefile
|
||||||
|
sed -i 's|^LIBS =.*|LIBS = -nostdlib -L../../lib -licutu -licuuc -lc|' tools/ctestfw/Makefile
|
||||||
|
sed -i 's|^LIBS =.*|LIBS = -nostdlib -L../../lib -licui18n -licuuc -lpthread -lc|' tools/toolutil/Makefile
|
||||||
|
|
||||||
|
|
||||||
make # %{?_smp_mflags} # -j(X>1) may "break" man pages as of 3.2, b.f.u #2357
|
make # %{?_smp_mflags} # -j(X>1) may "break" man pages as of 3.2, b.f.u #2357
|
||||||
make doc
|
make doc
|
||||||
|
|
||||||
@ -133,6 +140,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc source/__docs/%{name}/html/*
|
%doc source/__docs/%{name}/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 08 2011 Caolán McNamara <caolanm@redhat.com> - 4.6-2
|
||||||
|
- Resolves: rhbz#681941 don't link unneccessary -lm, etc.
|
||||||
|
|
||||||
* Mon Mar 07 2011 Caolán McNamara <caolanm@redhat.com> - 4.6-1
|
* Mon Mar 07 2011 Caolán McNamara <caolanm@redhat.com> - 4.6-1
|
||||||
- latest version
|
- latest version
|
||||||
- upgrade includes a .pc now of its own, drop ours
|
- upgrade includes a .pc now of its own, drop ours
|
||||||
@ -141,7 +151,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
- drop integrated icu.7972.buildfix.patch
|
- drop integrated icu.7972.buildfix.patch
|
||||||
- drop integrated icu.7932.doublecompare.patch
|
- drop integrated icu.7932.doublecompare.patch
|
||||||
- drop integrated icu.8011.buildfix.patch
|
- drop integrated icu.8011.buildfix.patch
|
||||||
- Resolves: rhbz#681941 don't link unneccessary -lm
|
|
||||||
|
|
||||||
* Fri Feb 11 2011 Caolán McNamara <caolanm@redhat.com> - 4.4.2-8
|
* Fri Feb 11 2011 Caolán McNamara <caolanm@redhat.com> - 4.4.2-8
|
||||||
- Resolves: rhbz#674328 yet more ways that freeserif crashes libicu
|
- Resolves: rhbz#674328 yet more ways that freeserif crashes libicu
|
||||||
|
Loading…
Reference in New Issue
Block a user