bump to 4.6
This commit is contained in:
parent
fc397b218c
commit
208fe99d89
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,2 +1 @@
|
||||
icu4c-4_4_2-src.tgz
|
||||
/icu-config
|
||||
/icu4c-4_6-src.tgz
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- icu.orig/source/layout/IndicClassTables.cpp 2009-06-11 11:10:08.000000000 +0100
|
||||
+++ icu/source/layout/IndicClassTables.cpp 2009-06-11 11:11:30.000000000 +0100
|
||||
@@ -179,7 +179,7 @@
|
||||
// http://brahmi.sourceforge.net/docs/KannadaComputing.html
|
||||
static const IndicClassTable::CharClass kndaCharClasses[] =
|
||||
{
|
||||
- _xx, _xx, _mp, _mp, _xx, _iv, _iv, _iv, _iv, _iv, _iv, _iv, _iv, _iv, _xx, _iv, // 0C80 - 0C8F
|
||||
+ _xx, _xx, _mp, _mp, _xx, _iv, _iv, _iv, _iv, _iv, _iv, _iv, _iv, _xx, _iv, _iv, // 0C80 - 0C8F
|
||||
_iv, _xx, _iv, _iv, _iv, _bb, _bb, _bb, _bb, _bb, _bb, _bb, _bb, _bb, _bb, _bb, // 0C90 - 0C9F
|
||||
_bb, _bb, _bb, _bb, _bb, _bb, _bb, _bb, _bb, _xx, _bb, _bb, _bb, _bb, _bb, _bb, // 0CA0 - 0CAF
|
||||
_rb, _ct, _bb, _bb, _xx, _bb, _bb, _bb, _bb, _bb, _xx, _xx, _xx, _xx, _dr, _da, // 0CB0 - 0CBF
|
@ -1,14 +0,0 @@
|
||||
diff -ru icu.orig/source/test/cintltst/cnumtst.c icu/source/test/cintltst/cnumtst.c
|
||||
--- icu.orig/source/test/cintltst/cnumtst.c 2010-09-09 08:52:26.043634583 +0100
|
||||
+++ icu/source/test/cintltst/cnumtst.c 2010-09-09 09:03:28.602635460 +0100
|
||||
@@ -358,7 +358,9 @@
|
||||
log_err("parse failed. The error is : %s\n", myErrorName(status));
|
||||
}
|
||||
|
||||
- if(d1!=462.12345)
|
||||
+ a1 = 462.12345;
|
||||
+
|
||||
+ if(d1!=a1)
|
||||
log_err("Fail: Error in parsing\n");
|
||||
else
|
||||
log_verbose("Pass: parsing successful\n");
|
@ -1,11 +0,0 @@
|
||||
--- icu/source/Makefile.in 2010-04-28 17:28:54.000000000 +0200
|
||||
+++ icu/source/Makefile.in 2010-07-28 22:50:45.056353070 +0200
|
||||
@@ -18,7 +18,7 @@
|
||||
docsubdir = $(PACKAGE)$(ICULIBDASHSUFFIX)/html
|
||||
docsubsrchdir = $(docsubdir)/search
|
||||
docfilesdir = doc/html
|
||||
-docfiles = $(docfilesdir)/*.gif $(docfilesdir)/*.png $(docfilesdir)/*.html $(docfilesdir)/*.css $(docfilesdir)/*.tag $(docfilesdir)/installdox
|
||||
+docfiles = $(docfilesdir)/*.png $(docfilesdir)/*.html $(docfilesdir)/*.css $(docfilesdir)/*.tag $(docfilesdir)/installdox
|
||||
docsrchdir = $(docfilesdir)/search
|
||||
docsrchfiles = $(docsrchdir)/*
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- icu/source/configure.in 2009-07-01 19:51:26.000000000 +0100
|
||||
+++ icu/source/configure.in 2009-11-19 09:12:23.000000000 +0000
|
||||
@@ -57,6 +57,11 @@
|
||||
|
||||
AC_SUBST(cross_compiling)
|
||||
|
||||
+dnl use the pld hack to get ac_fn_cxx_try_link defined globally and not local
|
||||
+AC_LANG_PUSH([C++])
|
||||
+AC_LINK_IFELSE([AC_LANG_PROGRAM()])
|
||||
+AC_LANG_POP([C++])
|
||||
+
|
||||
# make sure install is relative to srcdir - if a script
|
||||
if test "$srcdir" = "."; then
|
||||
# If srcdir isn't just ., then (srcdir) is already prepended.
|
@ -1,11 +0,0 @@
|
||||
--- icu/source/test/intltest/numfmtst.cpp 2010-10-04 15:16:58.000000000 +0100
|
||||
+++ icu/source/test/intltest/numfmtst.cpp 2010-10-04 15:22:37.000000000 +0100
|
||||
@@ -6144,7 +6144,7 @@
|
||||
)
|
||||
{
|
||||
errln("ERROR: parse failed - expected 123.0, 3 - returned %d, %i",
|
||||
- result.getDouble(), parsePos);
|
||||
+ result.getDouble(), parsePos.getErrorIndex());
|
||||
}
|
||||
}
|
||||
|
19
icu.rhbz681941.extralinklm.patch
Normal file
19
icu.rhbz681941.extralinklm.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- icu/source/configure.in 2011-03-07 09:39:32.223725803 +0000
|
||||
+++ icu/source/configure.in 2011-03-07 09:42:46.482876656 +0000
|
||||
@@ -214,15 +214,7 @@
|
||||
# Determine the Makefile fragment
|
||||
ICU_CHECK_MH_FRAG
|
||||
|
||||
-# Checks for libraries and other host specific stuff
|
||||
-# On HP/UX, don't link to -lm from a shared lib because it isn't
|
||||
-# PIC (at least on 10.2)
|
||||
-case "${host}" in
|
||||
- *-*-hpux*) AC_CHECK_LIB(m, floor, LIB_M="-lm") ;;
|
||||
-
|
||||
- *) AC_CHECK_LIB(m, floor)
|
||||
- LIB_M="" ;;
|
||||
-esac
|
||||
+AC_CHECK_LIB(m, floor, LIB_M="-lm")
|
||||
AC_SUBST(LIB_M)
|
||||
|
||||
# Check whether to build shared libraries
|
45
icu.spec
45
icu.spec
@ -1,24 +1,18 @@
|
||||
Name: icu
|
||||
Version: 4.4.2
|
||||
Release: 8%{?dist}
|
||||
Version: 4.6
|
||||
Release: 1%{?dist}
|
||||
Summary: International Components for Unicode
|
||||
Group: Development/Tools
|
||||
License: MIT and UCD and Public Domain
|
||||
URL: http://www.icu-project.org/
|
||||
Source0: http://download.icu-project.org/files/icu4c/4.4.2/icu4c-4_4_2-src.tgz
|
||||
Source1: icu-config
|
||||
Source: http://download.icu-project.org/files/icu4c/4.6/icu4c-4_6-src.tgz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: doxygen, autoconf
|
||||
Requires: lib%{name} = %{version}-%{release}
|
||||
|
||||
Patch1: icu-3.4-multiarchdevel.patch
|
||||
Patch2: icu.6995.kannada.patch
|
||||
Patch3: icu.7971.buildfix.patch
|
||||
Patch4: icu.7972.buildfix.patch
|
||||
Patch5: icu.7932.doublecompare.patch
|
||||
Patch6: icu.8011.buildfix.patch
|
||||
Patch7: icu.8198.revert.icu5431.patch
|
||||
Patch8: icu.8320.freeserif.crash.patch
|
||||
Patch1: icu.8198.revert.icu5431.patch
|
||||
Patch2: icu.8320.freeserif.crash.patch
|
||||
Patch3: icu.rhbz681941.extralinklm.patch
|
||||
|
||||
%description
|
||||
Tools and utilities for developing with icu.
|
||||
@ -58,14 +52,9 @@ BuildArch: noarch
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%patch1 -p1 -b .multiarchdevel
|
||||
%patch2 -p1 -b .icu6995.kannada.patch
|
||||
%patch3 -p1 -b .icu7971.buildfix.patch
|
||||
%patch4 -p1 -b .icu7972.buildfix.patch
|
||||
%patch5 -p1 -b .icu7932.doublecompare.patch
|
||||
%patch6 -p1 -b .icu8011.buildfix.patch
|
||||
%patch7 -p2 -R -b .icu8198.revert.icu5431.patch
|
||||
%patch8 -p1 -b .icu8320.freeserif.crash.patch
|
||||
%patch1 -p2 -R -b .icu8198.revert.icu5431.patch
|
||||
%patch2 -p1 -b .icu8320.freeserif.crash.patch
|
||||
%patch3 -p1 -b .rhbz681941.extralinklm.patch
|
||||
|
||||
%build
|
||||
cd source
|
||||
@ -82,11 +71,7 @@ make doc
|
||||
rm -rf $RPM_BUILD_ROOT source/__docs
|
||||
make -C source install DESTDIR=$RPM_BUILD_ROOT
|
||||
make -C source install-doc docdir=__docs
|
||||
cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}-config
|
||||
chmod 0755 $RPM_BUILD_ROOT%{_bindir}/%{name}-config
|
||||
chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
|
||||
sed -i s/\\\$\(THREADSCXXFLAGS\)// $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/icu.pc
|
||||
sed -i s/\\\$\(THREADSCPPFLAGS\)/-D_REENTRANT/ $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/icu.pc
|
||||
|
||||
%check
|
||||
make -C source check
|
||||
@ -133,7 +118,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/layout
|
||||
%{_includedir}/unicode
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/icu.pc
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%{_libdir}/%{name}
|
||||
%dir %{_datadir}/%{name}
|
||||
%dir %{_datadir}/%{name}/%{version}
|
||||
@ -148,6 +133,16 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc source/__docs/%{name}/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Mar 07 2011 Caolán McNamara <caolanm@redhat.com> - 4.6-1
|
||||
- latest version
|
||||
- upgrade includes a .pc now of its own, drop ours
|
||||
- drop integrated icu.6995.kannada.patch
|
||||
- drop integrated icu.7971.buildfix.patch
|
||||
- drop integrated icu.7972.buildfix.patch
|
||||
- drop integrated icu.7932.doublecompare.patch
|
||||
- drop integrated icu.8011.buildfix.patch
|
||||
- Resolves: rhbz#681941 don't link unneccessary -lm
|
||||
|
||||
* Fri Feb 11 2011 Caolán McNamara <caolanm@redhat.com> - 4.4.2-8
|
||||
- Resolves: rhbz#674328 yet more ways that freeserif crashes libicu
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user