Bumped to 1.5.3

This commit is contained in:
Takao Fujiwara 2013-07-27 00:08:07 +09:00
parent 99df57f02e
commit ecd5942fe9
10 changed files with 60 additions and 1653 deletions

4
.gitignore vendored
View File

@ -6,6 +6,7 @@ ibus-1.3.6.tar.gz
/ibus-1.4.1.tar.gz
/ibus-1.5.1.tar.gz
/ibus-1.5.2.tar.gz
/ibus-1.5.3.tar.gz
/ibus-gjs-3.0.2.20110823.tar.gz
/ibus-gjs-3.1.4.20110823.tar.gz
/ibus-gjs-3.0.2.20110908.tar.gz
@ -32,6 +33,3 @@ ibus-1.3.6.tar.gz
/ibus-gjs-3.4.1.20120518.tar.gz
/ibus-gjs-3.4.1.20120815.tar.gz
/ibus-gjs-3.4.1.20130115.tar.gz
/ibus.1
/ibus-setup.1
/ibus-daemon.1

View File

@ -1,6 +1,6 @@
From 95fd937e14ec2d2f1de0f5fa0e186cfdf996c921 Mon Sep 17 00:00:00 2001
From 38a22f910f28d0babadd79d8430b2854281f705e Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Wed, 1 May 2013 13:35:01 +0900
Date: Fri, 26 Jul 2013 11:28:51 +0900
Subject: [PATCH] Reload preload engines until users customize the list.
The idea is, if users don't customize the preload_engines with ibus-setup,
@ -60,10 +60,10 @@ index d0b3db8..52ece27 100644
<applyto>/desktop/ibus/general/preload_engines</applyto>
<owner>ibus</owner>
diff --git a/setup/main.py b/setup/main.py
index 0281ac7..ba78eeb 100644
index 9703d5e..b39a044 100644
--- a/setup/main.py
+++ b/setup/main.py
@@ -190,16 +190,27 @@ class Setup(object):
@@ -189,16 +189,27 @@ class Setup(object):
self.__checkbutton_use_global_engine.connect("toggled",
self.__checkbutton_use_global_engine_toggled_cb)
@ -95,7 +95,7 @@ index 0281ac7..ba78eeb 100644
self.__treeview = self.__builder.get_object("treeview_engines")
self.__treeview.set_engines(engines)
@@ -243,6 +254,7 @@ class Setup(object):
@@ -242,6 +253,7 @@ class Setup(object):
self.__checkbutton_auto_start_toggled_cb)
self.__config = self.__bus.get_config()
@ -103,7 +103,7 @@ index 0281ac7..ba78eeb 100644
self.__init_hotkey()
self.__init_panel()
@@ -251,8 +263,8 @@ class Setup(object):
@@ -250,8 +262,8 @@ class Setup(object):
def __combobox_notify_active_engine_cb(self, combobox, property):
engine = self.__combobox.get_active_engine()
button = self.__builder.get_object("button_engine_add")
@ -114,7 +114,7 @@ index 0281ac7..ba78eeb 100644
def __get_engine_setup_exec_args(self, engine):
args = []
@@ -272,6 +284,13 @@ class Setup(object):
@@ -271,6 +283,13 @@ class Setup(object):
args.append(path.basename(setup_path))
return args
@ -128,7 +128,7 @@ index 0281ac7..ba78eeb 100644
def __treeview_notify_cb(self, treeview, prop):
if prop.name not in ("active-engine", "engines"):
return
@@ -324,6 +343,34 @@ class Setup(object):
@@ -323,6 +342,34 @@ class Setup(object):
del self.__engine_setup_exec_list[name]
self.__engine_setup_exec_list[name] = os.spawnl(os.P_NOWAIT, *args)
@ -163,7 +163,7 @@ index 0281ac7..ba78eeb 100644
def __init_bus(self):
self.__bus = IBus.Bus()
if self.__bus.is_connected():
@@ -538,8 +585,18 @@ class Setup(object):
@@ -541,8 +588,18 @@ class Setup(object):
value = GLib.Variant.new_boolean(value)
self.__config.set_value("general", "use_global_engine", value)
@ -185,7 +185,7 @@ index 0281ac7..ba78eeb 100644
def __config_reloaded_cb(self, bus):
pass
diff --git a/setup/setup.ui b/setup/setup.ui
index e56e917..b3165aa 100644
index 2042263..33827f1 100644
--- a/setup/setup.ui
+++ b/setup/setup.ui
@@ -669,7 +669,23 @@

View File

@ -1,6 +1,6 @@
From 69171c9c9446a60da1979c88478055c9df35136f Mon Sep 17 00:00:00 2001
From 53928ed24b12912fdec8e279f5e739b251a5084a Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Wed, 5 Jun 2013 11:48:54 +0900
Date: Fri, 26 Jul 2013 11:27:37 +0900
Subject: [PATCH] Add libgnomekbd and load preload engines.
---
@ -105,10 +105,10 @@ index 0000000..172632c
+glib-2.0
+gmodule-2.0
diff --git a/configure.ac b/configure.ac
index 781bbf5..f576f46 100644
index 45c195a..79cae77 100644
--- a/configure.ac
+++ b/configure.ac
@@ -237,6 +237,45 @@ else
@@ -242,6 +242,45 @@ else
enable_xim="no (disabled, use --enable-xim to enable)"
fi
@ -154,7 +154,7 @@ index 781bbf5..f576f46 100644
# GObject introspection
GOBJECT_INTROSPECTION_CHECK([0.6.8])
@@ -590,6 +629,7 @@ Build options:
@@ -595,6 +634,7 @@ Build options:
Panel icon "$IBUS_ICON_KEYBOARD"
Enable surrounding-text $enable_surrounding_text
Enable libnotify $enable_libnotify
@ -252,7 +252,7 @@ index 9f593ab..c93a0ed 100644
Name: IBus
Description: IBus Library
diff --git a/ibus.spec.in b/ibus.spec.in
index 7989949..5391538 100644
index 334f37e..2017af9 100644
--- a/ibus.spec.in
+++ b/ibus.spec.in
@@ -5,6 +5,7 @@
@ -274,7 +274,7 @@ index 7989949..5391538 100644
Requires: %{name}-libs = %{version}-%{release}
Requires: %{name}-gtk2 = %{version}-%{release}
@@ -53,6 +58,9 @@ Requires: dbus-python >= %{dbus_python_version}
@@ -52,6 +57,9 @@ Requires: dbus-python >= %{dbus_python_version}
Requires: im-chooser >= %{im_chooser_version}
Requires: notify-python
Requires: librsvg2
@ -284,7 +284,7 @@ index 7989949..5391538 100644
Requires(post): desktop-file-utils
Requires(postun): desktop-file-utils
@@ -153,6 +161,10 @@ OPTIONS="$OPTIONS --enable-python-library"
@@ -152,6 +160,10 @@ OPTIONS="$OPTIONS --enable-python-library"
OPTIONS="$OPTIONS --disable-python-library"
%endif
@ -296,10 +296,10 @@ index 7989949..5391538 100644
# make -C po update-gmo
diff --git a/src/Makefile.am b/src/Makefile.am
index 7ee5df8..8fa954e 100644
index 74b6838..2645314 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -197,6 +197,9 @@ typelibs_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
@@ -201,6 +201,9 @@ typelibs_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
CLEANFILES += $(dist_gir_DATA) $(typelibs_DATA)
endif
@ -310,7 +310,7 @@ index 7ee5df8..8fa954e 100644
ibusenumtypes.h: $(ibus_headers) ibusenumtypes.h.template
$(AM_V_GEN) ( top_builddir=`cd $(top_builddir) && pwd`; \
diff --git a/src/ibus.h b/src/ibus.h
index ef811a4..f82a162 100644
index e27f845..4b3919c 100644
--- a/src/ibus.h
+++ b/src/ibus.h
@@ -47,6 +47,7 @@
@ -987,19 +987,19 @@ index 0000000..5aa486d
+G_END_DECLS
+#endif
diff --git a/ui/gtk3/Makefile.am b/ui/gtk3/Makefile.am
index 2038814..aa79eee 100644
index 97c915c..5d53836 100644
--- a/ui/gtk3/Makefile.am
+++ b/ui/gtk3/Makefile.am
@@ -45,6 +45,8 @@ USE_SYMBOL_ICON = FALSE
# force include config.h before gi18n.h.
AM_CPPFLAGS = -include $(CONFIG_HEADER)
@@ -44,6 +44,8 @@ AM_CPPFLAGS = \
USE_SYMBOL_ICON = FALSE
+HAVE_IBUS_GKBD_C = $(strip $(subst false, FALSE, $(subst true, TRUE, $(HAVE_IBUS_GKBD))))
+
AM_CFLAGS = \
@GLIB2_CFLAGS@ \
@GIO2_CFLAGS@ \
@@ -56,6 +58,8 @@ AM_CFLAGS = \
@@ -54,6 +56,8 @@ AM_CFLAGS = \
-DBINDIR=\"$(bindir)\" \
-DIBUS_DISABLE_DEPRECATED \
-DSWITCHER_USE_SYMBOL_ICON=$(USE_SYMBOL_ICON) \
@ -1008,7 +1008,7 @@ index 2038814..aa79eee 100644
-Wno-unused-variable \
-Wno-unused-but-set-variable \
-Wno-unused-function \
@@ -98,12 +102,40 @@ AM_VALAFLAGS += \
@@ -97,12 +101,40 @@ AM_VALAFLAGS += \
$(NULL)
endif
@ -1049,7 +1049,7 @@ index 2038814..aa79eee 100644
handle.vala \
iconwidget.vala \
keybindingmanager.vala \
@@ -112,6 +144,7 @@ ibus_ui_gtk3_SOURCES = \
@@ -111,6 +143,7 @@ ibus_ui_gtk3_SOURCES = \
property.vala \
separator.vala \
switcher.vala \
@ -1057,7 +1057,7 @@ index 2038814..aa79eee 100644
$(NULL)
ibus_ui_gtk3_LDADD = \
@@ -120,9 +153,12 @@ ibus_ui_gtk3_LDADD = \
@@ -119,9 +152,12 @@ ibus_ui_gtk3_LDADD = \
CLEANFILES = \
gtkpanel.xml \

File diff suppressed because it is too large Load Diff

View File

@ -1,13 +0,0 @@
diff --git a/ui/gtk3/panel.vala b/ui/gtk3/panel.vala
index 54251e7..69d0723 100644
--- a/ui/gtk3/panel.vala
+++ b/ui/gtk3/panel.vala
@@ -386,7 +386,7 @@ class Panel : IBus.PanelService {
prev_version = var_prev_version.dup_string();
}
- if (compare_versions(prev_version, "1.5.3") < 0) {
+ if (compare_versions(prev_version, "1.5.2") < 0) {
update_version_1_5_3();
}

View File

@ -1,11 +0,0 @@
--- ibus-1.5.1/setup/keyboardshortcut.py.orig 2013-01-15 17:00:05.093191054 +0900
+++ ibus-1.5.1/setup/keyboardshortcut.py 2013-01-15 17:00:18.034160760 +0900
@@ -207,7 +207,7 @@ class KeyboardShortcutSelection(Gtk.VBox
def __set_selected_shortcut(self, shortcut):
model = self.__shortcut_view.get_model()
path, column = self.__shortcut_view.get_cursor()
- model[path[0]][0] = shortcut
+ model[path][0] = shortcut
self.__update_add_and_apply_buttons()
def __del_selected_shortcut(self):

View File

@ -1,33 +0,0 @@
From 027e4a40a37601c6733a8911fd3949a9310b0258 Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Wed, 9 May 2012 19:15:00 +0900
Subject: [PATCH] Added a workaround to disable preedit in gnome-shell
https://bugzilla.gnome.org/show_bug.cgi?id=658420
---
client/gtk2/ibusimcontext.c | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/client/gtk2/ibusimcontext.c b/client/gtk2/ibusimcontext.c
index 584b92d..c4c61d3 100644
--- a/client/gtk2/ibusimcontext.c
+++ b/client/gtk2/ibusimcontext.c
@@ -645,6 +645,15 @@ ibus_im_context_init (GObject *obj)
ibusimcontext->events_queue = g_queue_new ();
+ if (!g_getenv ("IBUS_GNOME_SHELL_ENABLE_PREEDIT_TEXT")) {
+ const gchar * prgname = g_get_prgname ();
+ if (g_strcmp0 (prgname, "gnome-shell") == 0) {
+ if (ibusimcontext->caps & IBUS_CAP_PREEDIT_TEXT) {
+ ibusimcontext->caps ^= IBUS_CAP_PREEDIT_TEXT;
+ }
+ }
+ }
+
// Create slave im context
ibusimcontext->slave = gtk_im_context_simple_new ();
gtk_im_context_simple_add_table (GTK_IM_CONTEXT_SIMPLE (ibusimcontext->slave),
--
1.7.10.4

View File

@ -1,4 +1,4 @@
From 056dfbe663a0dd8158f05baae764e2debd73c1e5 Mon Sep 17 00:00:00 2001
From c9d8db44583262f49adf7588fe0adbf0842a995a Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Thu, 31 Jan 2013 17:31:55 +0900
Subject: [PATCH] Enable ibus-setup to show the frequently used languages
@ -411,10 +411,10 @@ index 0f8a6ae..9828ee6 100644
return self.get_property("active-engine")
diff --git a/setup/main.py b/setup/main.py
index ba78eeb..b219771 100644
index b39a044..5b077a8 100644
--- a/setup/main.py
+++ b/setup/main.py
@@ -207,6 +207,7 @@ class Setup(object):
@@ -206,6 +206,7 @@ class Setup(object):
# init engine page
self.__engines = self.__bus.list_engines()
self.__combobox = self.__builder.get_object("combobox_engines")

172
ibus.spec
View File

@ -4,27 +4,12 @@
%global with_pkg_config %(pkg-config --version >/dev/null 2>&1 && echo -n "1" || echo -n "0")
%if (0%{?fedora} > 17 || 0%{?rhel} > 6)
#ifarch ppc ppc64 s390 s390x
%global with_gjs 0
%else
%global with_gjs 1
%endif
%if (0%{?fedora} > 17 || 0%{?rhel} > 6)
%global with_gkbd 0
%else
%global with_gkbd 1
%endif
%if (0%{?fedora} > 18 || 0%{?rhel} > 6)
%global with_python_pkg 1
%else
%global with_python_pkg 0
%endif
%global ibus_gjs_version 3.4.1.20130115
%global ibus_api_version 1.0
%if %with_pkg_config
@ -40,20 +25,16 @@
%global dbus_python_version 0.83.0
Name: ibus
Version: 1.5.2
Release: 8%{?dist}
Version: 1.5.3
Release: 1%{?dist}
Summary: Intelligent Input Bus for Linux OS
License: LGPLv2+
Group: System Environment/Libraries
URL: http://code.google.com/p/ibus/
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
Source1: %{name}-xinput
%if %with_gjs
# ibus-gjs
Source2: http://fujiwara.fedorapeople.org/ibus/gnome-shell/%{name}-gjs-%{ibus_gjs_version}.tar.gz
%endif
# Upstreamed patches.
Patch0: %{name}-HEAD.patch
# Patch0: %{name}-HEAD.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=810211
Patch1: %{name}-810211-no-switch-by-no-trigger.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=541492
@ -63,24 +44,11 @@ Patch3: %{name}-530711-preload-sys.patch
# Hide minor input method engines on ibus-setup by locale
Patch4: %{name}-xx-setup-frequent-lang.patch
%if (0%{?fedora} <= 17 && 0%{?rhel} < 7)
# Workaround to disable preedit on gnome-shell until bug 658420 is fixed.
# https://bugzilla.gnome.org/show_bug.cgi?id=658420
Patch92: %{name}-xx-g-s-disable-preedit.patch
%endif
%if (0%{?fedora} < 18 && 0%{?rhel} < 7)
# The patch enables to build on fedora 17.
Patch93: %{name}-xx-f17.patch
%endif
# The patch is applied until ibus 1.5.3 is released.
Patch94: %{name}-xx-1.5.2.patch
%if (0%{?fedora} < 19 && 0%{?rhel} < 7)
# Keep the default triggers for the back compatiblity.
Patch95: %{name}-xx-ctrl-space.patch
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gettext-devel
BuildRequires: libtool
@ -101,14 +69,6 @@ BuildRequires: GConf2-devel
BuildRequires: intltool
BuildRequires: iso-codes-devel
BuildRequires: libnotify-devel
%if %with_gkbd
BuildRequires: libgnomekbd-devel
%endif
%if %with_gjs
# for ibus-gjs-xx.tar.gz
BuildRequires: gjs
BuildRequires: gnome-shell
%endif
Requires: %{name}-libs = %{version}-%{release}
Requires: %{name}-gtk2 = %{version}-%{release}
@ -120,27 +80,13 @@ Requires: %{name}-setup = %{version}-%{release}
Requires: iso-codes
Requires: dbus-python >= %{dbus_python_version}
Requires: dbus-x11
%if (0%{?fedora} <= 17 && 0%{?rhel} < 7)
Requires: im-chooser
%endif
Requires: dconf
Requires: notify-python
%if %with_gkbd
Requires: libgnomekbd
%endif
Requires: librsvg2
# for setxkbmap
Requires: xorg-x11-xkb-utils
%if (0%{?fedora} <= 17 && 0%{?rhel} < 7)
Requires: gnome-icon-theme-symbolic
%endif
%if (0%{?fedora} > 17 || 0%{?rhel} > 6)
# The feature in ibus-gnome3 is provided by gnome-shell.
Obsoletes: ibus-gnome3 < %{version}-%{release}
%endif
%if %with_python_pkg
Obsoletes: ibus-panel < %{version}-%{release}
%endif
%if ! %with_python_pkg
%if %with_pygobject3
Requires: pygobject3
@ -178,9 +124,12 @@ This package contains the libraries for IBus
%package gtk2
Summary: IBus im module for gtk2
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{name}-libs = %{version}-%{release}
Requires(post): glib2 >= %{glib_ver}
# Added for upgrade el6 to el7
Provides: ibus-gtk = %{version}-%{release}
Obsoletes: ibus-gtk < %{version}-%{release}
%description gtk2
This package contains ibus im module for gtk2
@ -188,11 +137,8 @@ This package contains ibus im module for gtk2
%package gtk3
Summary: IBus im module for gtk3
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{name}-libs = %{version}-%{release}
%if (0%{?fedora} <= 17 && 0%{?rhel} < 7)
Requires: imsettings-gnome
%endif
Requires(post): glib2 >= %{glib_ver}
%description gtk3
@ -227,24 +173,10 @@ and this package will be deprecated.
%endif
%endif
%if %with_gjs
%package gnome3
Summary: IBus gnome-shell-extension for GNOME3
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Requires: %{name}-libs = %{version}-%{release}
Requires: gnome-shell
%description gnome3
This is a transitional package which allows users to try out new IBus
GUI for GNOME3 in development. Note that this package will be marked
as obsolete once the integration has completed in the GNOME3 upstream.
%endif
%package devel
Summary: Development tools for ibus
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{name}-libs = %{version}-%{release}
Requires: glib2-devel
Requires: dbus-devel
@ -256,9 +188,11 @@ docs for ibus.
%package devel-docs
Summary: Developer documents for ibus
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%if (0%{?fedora} >= 19 || 0%{?rhel} >= 7)
Requires: %{name} = %{version}-%{release}
BuildArch: noarch
%else
Requires: %{name}%{?_isa} = %{version}-%{release}
%endif
%description devel-docs
@ -267,15 +201,8 @@ The ibus-devel-docs package contains developer documentation for ibus
%prep
%setup -q
%if %with_gjs
gzip -dc %SOURCE2 | tar xf -
%endif
# %%patch0 -p1
%patch0 -p1
%if (0%{?fedora} <= 17 && 0%{?rhel} < 7)
%patch92 -p1 -b .g-s-preedit
%endif
cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c ||
%patch1 -p1 -b .noswitch
%if %with_preload_xkb_engine
@ -286,10 +213,6 @@ rm -f data/dconf/00-upstream-settings
%patch3 -p1 -b .preload-sys
%patch4 -p1 -b .setup-frequent-lang
%if (0%{?fedora} < 18 && 0%{?rhel} < 7)
%patch93 -p1 -b .f17
%endif
%patch94 -p1 -b .152
%if (0%{?fedora} < 19 && 0%{?rhel} < 7)
%patch95 -p1 -b .ctrl
%endif
@ -306,12 +229,6 @@ autoreconf -f -i -v
--enable-gtk-doc \
--with-no-snooper-apps='gnome-do,Do.*,firefox.*,.*chrome.*,.*chromium.*' \
--enable-surrounding-text \
%if (0%{?fedora} <= 17 && 0%{?rhel} < 7)
--with-panel-icon-keyboard=yes \
%endif
%if %with_gkbd
--enable-libgnomekbd \
%endif
%if %with_pygobject2
--enable-python-library \
%endif
@ -323,17 +240,6 @@ make -C ui/gtk3 maintainer-clean-generic
# make -C po update-gmo
make %{?_smp_mflags}
%if %with_gjs
d=`basename %SOURCE2 .tar.gz`
cd $d
export PKG_CONFIG_PATH=..:/usr/lib64/pkgconfig:/usr/lib/pkgconfig
%configure \
--with-gnome-shell-version="3.5.3,3.4,3.3.92,3.3.90,3.3.5,3.3.4,3.3.3,3.2" \
--with-gjs-version="1.33.3,1.32,1.31.22,1.31.20,1.31.10,1.31.6,1.31.11,1.30"
make %{?_smp_mflags}
cd ..
%endif
%install
make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
rm -f $RPM_BUILD_ROOT%{_libdir}/libibus-%{ibus_api_version}.la
@ -344,45 +250,13 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{gtk3_binary_version}/immodules/im-ibus
install -pm 644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_xinputconf}
# install .desktop files
# correct location in upstream.
if test ! -f $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/ibus.desktop -a \
-f $RPM_BUILD_ROOT%{_datadir}/applications/ibus.desktop ; then
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart
mv $RPM_BUILD_ROOT%{_datadir}/applications/ibus.desktop \
$RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/ibus.desktop
fi
echo "NoDisplay=true" >> $RPM_BUILD_ROOT%{_datadir}/applications/ibus-setup.desktop
echo "X-GNOME-Autostart-enabled=false" >> $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/ibus.desktop
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/ibus.desktop
rm -rf $RPM_BUILD_ROOT%{_datadir}/applications/ibus.desktop
#echo "X-GNOME-Autostart-enabled=false" >> $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/ibus.desktop
# workaround for desktop-file-install
sed -i -e 's|Comment\[ja\]=IBus |& |' \
$RPM_BUILD_ROOT%{_datadir}/applications/ibus-setup.desktop
desktop-file-install --delete-original \
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
$RPM_BUILD_ROOT%{_datadir}/applications/*
# home [dot] corp [dot] redhat [dot] com/wiki/rpmdiff-multilib
if test -f ibus/_config.py.in -a \
-f $RPM_BUILD_ROOT%{python2_sitelib}/ibus/_config.py ; then
touch -r ibus/_config.py.in \
$RPM_BUILD_ROOT%{python2_sitelib}/ibus/_config.py
if test -f ./py-compile ; then
sh ./py-compile --destdir $RPM_BUILD_ROOT \
--basedir %{python2_sitelib}/ibus _config.py
fi
fi
%if %with_gjs
# https://bugzilla.redhat.com/show_bug.cgi?id=657165
d=`basename %SOURCE2 .tar.gz`
cd $d
make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/ibus-gjs.mo
cd ..
%endif
# FIXME: no version number
%find_lang %{name}10
@ -408,12 +282,19 @@ if [ "$1" -eq 0 ]; then
if [ -f %{_sysconfdir}/dconf/db/ibus ] ; then
rm -f %{_sysconfdir}/dconf/db/ibus
fi
# 'ibus write-cache --system' updates the system cache.
if [ -f /var/cache/ibus/bus/registry ] ; then
rm -f /var/cache/ibus/bus/registry
fi
fi
%posttrans
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
dconf update
if [ %{_bindir}/ibus ] ; then
%{_bindir}/ibus write-cache --system &>/dev/null || :
fi
%post libs -p /sbin/ldconfig
@ -458,7 +339,6 @@ fi
%{_libexecdir}/ibus-dconf
%{_libexecdir}/ibus-ui-gtk3
%{_libexecdir}/ibus-x11
# {_sysconfdir}/xdg/autostart/ibus.desktop
%{_sysconfdir}/dconf/db/ibus.d
%{_sysconfdir}/dconf/profile/ibus
%python2_sitearch/gi/overrides/IBus.py*
@ -500,12 +380,6 @@ fi
%endif
%endif
%if %with_gjs
%files gnome3
%{_datadir}/gnome-shell/js/ui/status/ibus
%{_datadir}/gnome-shell/extensions/ibus-indicator@example.com
%endif
%files devel
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*
@ -518,6 +392,12 @@ fi
%{_datadir}/gtk-doc/html/*
%changelog
* Thu Jul 11 2013 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.3-1
- Bumped to 1.5.3
- Deleted ibus-xx-g-s-disable-preedit.patch as EOL.
- Deleted ibus-gjs as EOL.
- Removed imsettings-gnome, im-chooser, libgnomekbd dependencies.
* Thu Jul 11 2013 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.2-8
- Updated ibus-HEAD.patch to delete pyxdg dependencies.

View File

@ -1,3 +1 @@
1b6b9c91089767762e00f8b5858d1b59 ibus-1.5.2.tar.gz
2d2ad58e3e41429dbd883ba7e501c9b2 ibus-gjs-3.2.1.20111230.tar.gz
da9a22c82ab33423d7afeb3da4146fa8 ibus-gjs-3.4.1.20130115.tar.gz
fdde74794d8a1874f97294e0cd581d14 ibus-1.5.3.tar.gz