Bumped to ibus-gjs 3.3.90.20120308 to work with gnome-shell 3.3.90
This commit is contained in:
parent
5deefb26ef
commit
e429e123c3
1
.gitignore
vendored
1
.gitignore
vendored
@ -36,3 +36,4 @@ ibus-1.3.6.tar.gz
|
|||||||
/ibus-gjs-3.2.1.20111128.tar.gz
|
/ibus-gjs-3.2.1.20111128.tar.gz
|
||||||
/ibus-gjs-3.2.1.20111230.tar.gz
|
/ibus-gjs-3.2.1.20111230.tar.gz
|
||||||
/ibus-gjs-3.3.3.20120203.tar.gz
|
/ibus-gjs-3.3.3.20120203.tar.gz
|
||||||
|
/ibus-gjs-3.3.90.20120308.tar.gz
|
||||||
|
@ -50,3 +50,42 @@ index 6483aae..fb39d56 100644
|
|||||||
--
|
--
|
||||||
1.7.9.1
|
1.7.9.1
|
||||||
|
|
||||||
|
From 401f881314abce57a0979aa4ef08fc5462dfe3ca Mon Sep 17 00:00:00 2001
|
||||||
|
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||||
|
Date: Sat, 10 Mar 2012 09:45:07 +0900
|
||||||
|
Subject: [PATCH] Fix to ungrab ui/gtk3/switcher for GTK 3.3.18 and GLib
|
||||||
|
2.31.20
|
||||||
|
|
||||||
|
---
|
||||||
|
ui/gtk3/switcher.vala | 8 ++++++++
|
||||||
|
1 files changed, 8 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/ui/gtk3/switcher.vala b/ui/gtk3/switcher.vala
|
||||||
|
index 76c67ec..131cad5 100644
|
||||||
|
--- a/ui/gtk3/switcher.vala
|
||||||
|
+++ b/ui/gtk3/switcher.vala
|
||||||
|
@@ -127,6 +127,9 @@ class Switcher : Gtk.Window {
|
||||||
|
m_loop.run();
|
||||||
|
m_loop = null;
|
||||||
|
|
||||||
|
+ keyboard.ungrab(Gdk.CURRENT_TIME);
|
||||||
|
+ pointer.ungrab(Gdk.CURRENT_TIME);
|
||||||
|
+
|
||||||
|
hide();
|
||||||
|
// Make sure the switcher is hidden before returning from this function.
|
||||||
|
while (Gtk.events_pending())
|
||||||
|
@@ -239,6 +242,11 @@ class Switcher : Gtk.Window {
|
||||||
|
return true;
|
||||||
|
}
|
||||||
|
|
||||||
|
+ // if e.type == Gdk.EventType.KEY_RELEASE, m_loop is already null.
|
||||||
|
+ if (m_loop == null) {
|
||||||
|
+ return false;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
m_loop.quit();
|
||||||
|
m_result = (int)m_selected_engine;
|
||||||
|
return true;
|
||||||
|
--
|
||||||
|
1.7.9.1
|
||||||
|
|
||||||
|
8847
ibus-xx-vapi-build-failure.diff
Normal file
8847
ibus-xx-vapi-build-failure.diff
Normal file
File diff suppressed because it is too large
Load Diff
50
ibus.spec
50
ibus.spec
@ -8,8 +8,10 @@
|
|||||||
%define have_pygobject2 1
|
%define have_pygobject2 1
|
||||||
%define have_pygobject3 1
|
%define have_pygobject3 1
|
||||||
|
|
||||||
|
%define vala_build_failure 1
|
||||||
|
|
||||||
%if 0%{?fedora} > 16
|
%if 0%{?fedora} > 16
|
||||||
%define ibus_gjs_version 3.3.3.20120203
|
%define ibus_gjs_version 3.3.90.20120308
|
||||||
%define ibus_gjs_build_failure 1
|
%define ibus_gjs_build_failure 1
|
||||||
%else
|
%else
|
||||||
%define ibus_gjs_version 3.2.1.20111230
|
%define ibus_gjs_version 3.2.1.20111230
|
||||||
@ -25,7 +27,7 @@
|
|||||||
|
|
||||||
Name: ibus
|
Name: ibus
|
||||||
Version: 1.4.99.20120304
|
Version: 1.4.99.20120304
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Intelligent Input Bus for Linux OS
|
Summary: Intelligent Input Bus for Linux OS
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -43,11 +45,16 @@ Patch2: ibus-xx-setup-frequent-lang.patch
|
|||||||
|
|
||||||
# Workaround gnome-shell build failure
|
# Workaround gnome-shell build failure
|
||||||
# http://koji.fedoraproject.org/koji/getfile?taskID=3317917&name=root.log
|
# http://koji.fedoraproject.org/koji/getfile?taskID=3317917&name=root.log
|
||||||
Patch91: ibus-gjs-xx-gnome-shell-3.1.4-build-failure.patch
|
# Patch91: ibus-gjs-xx-gnome-shell-3.1.4-build-failure.patch
|
||||||
# Workaround to disable preedit on gnome-shell until bug 658420 is fixed.
|
# Workaround to disable preedit on gnome-shell until bug 658420 is fixed.
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=658420
|
# https://bugzilla.gnome.org/show_bug.cgi?id=658420
|
||||||
Patch92: ibus-xx-g-s-disable-preedit.patch
|
Patch92: ibus-xx-g-s-disable-preedit.patch
|
||||||
Patch93: ibus-771115-property-compatible.patch
|
Patch93: ibus-771115-property-compatible.patch
|
||||||
|
%if %vala_build_failure
|
||||||
|
# Xkl-1.0.gir cannot be converted to vapi.
|
||||||
|
# https://bugs.freedesktop.org/show_bug.cgi?id=47141
|
||||||
|
Patch94: ibus-xx-vapi-build-failure.diff
|
||||||
|
%endif
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -56,7 +63,6 @@ BuildRequires: cvs
|
|||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
BuildRequires: python
|
BuildRequires: python
|
||||||
BuildRequires: gobject-introspection-devel
|
|
||||||
BuildRequires: gtk2-devel
|
BuildRequires: gtk2-devel
|
||||||
BuildRequires: gtk3-devel
|
BuildRequires: gtk3-devel
|
||||||
BuildRequires: dbus-glib-devel
|
BuildRequires: dbus-glib-devel
|
||||||
@ -72,7 +78,7 @@ BuildRequires: vala-tools
|
|||||||
# for AM_GCONF_SOURCE_2 in configure.ac
|
# for AM_GCONF_SOURCE_2 in configure.ac
|
||||||
BuildRequires: GConf2-devel
|
BuildRequires: GConf2-devel
|
||||||
%if %have_pygobject3
|
%if %have_pygobject3
|
||||||
BuildRequires: pygobject3-devel
|
BuildRequires: gobject-introspection-devel
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: intltool
|
BuildRequires: intltool
|
||||||
BuildRequires: iso-codes-devel
|
BuildRequires: iso-codes-devel
|
||||||
@ -163,6 +169,7 @@ Requires(post): glib2 >= %{glib_ver}
|
|||||||
%description gtk3
|
%description gtk3
|
||||||
This package contains ibus im module for gtk3
|
This package contains ibus im module for gtk3
|
||||||
|
|
||||||
|
%ifnarch ppc ppc64 s390 s390x
|
||||||
%package gnome3
|
%package gnome3
|
||||||
Summary: IBus gnome-shell-extension for GNOME3
|
Summary: IBus gnome-shell-extension for GNOME3
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -174,6 +181,7 @@ Requires: gnome-shell
|
|||||||
This is a transitional package which allows users to try out new IBus
|
This is a transitional package which allows users to try out new IBus
|
||||||
GUI for GNOME3 in development. Note that this package will be marked
|
GUI for GNOME3 in development. Note that this package will be marked
|
||||||
as obsolete once the integration has completed in the GNOME3 upstream.
|
as obsolete once the integration has completed in the GNOME3 upstream.
|
||||||
|
%endif
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Development tools for ibus
|
Summary: Development tools for ibus
|
||||||
@ -198,20 +206,26 @@ The ibus-devel-docs package contains developer documentation for ibus
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%ifnarch ppc ppc64 s390 s390x
|
||||||
%if %have_gjsfile
|
%if %have_gjsfile
|
||||||
zcat %SOURCE2 | tar xf -
|
zcat %SOURCE2 | tar xf -
|
||||||
%if %ibus_gjs_build_failure
|
%if %ibus_gjs_build_failure
|
||||||
d=`basename %SOURCE2 .tar.gz`
|
d=`basename %SOURCE2 .tar.gz`
|
||||||
cd $d
|
cd $d
|
||||||
%patch91 -p1 -b .fail-g-s
|
#%patch91 -p1 -b .fail-g-s
|
||||||
cd ..
|
cd ..
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch92 -p1 -b .g-s-preedit
|
%patch92 -p1 -b .g-s-preedit
|
||||||
cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c ||
|
cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c ||
|
||||||
%if %have_libxkbfile
|
%if %have_libxkbfile
|
||||||
%patch1 -p1 -b .xkb
|
%patch1 -p1 -b .xkb
|
||||||
|
%if %vala_build_failure
|
||||||
|
%patch94 -p1 -b .vala-fail
|
||||||
|
%endif
|
||||||
rm -f bindings/vala/ibus-1.0.vapi
|
rm -f bindings/vala/ibus-1.0.vapi
|
||||||
%endif
|
%endif
|
||||||
%patch2 -p1 -b .setup-frequent-lang
|
%patch2 -p1 -b .setup-frequent-lang
|
||||||
@ -258,10 +272,18 @@ autoreconf -f -i
|
|||||||
%endif
|
%endif
|
||||||
--enable-introspection
|
--enable-introspection
|
||||||
|
|
||||||
|
%if %vala_build_failure
|
||||||
|
touch ui/gtk3/ibus_ui_gtk3_vala.stamp
|
||||||
|
touch ui/gtk3/*.c
|
||||||
|
cp ui/gtk3/gkbdlayout.c.true ui/gtk3/gkbdlayout.c
|
||||||
|
%endif
|
||||||
|
|
||||||
# make -C po update-gmo
|
# make -C po update-gmo
|
||||||
make %{?_smp_mflags} \
|
make %{?_smp_mflags} \
|
||||||
|
AM_DEFAULT_VERBOSITY=1 \
|
||||||
PKG_CONFIG_PATH=..:/usr/lib64/pkgconfig:/usr/lib/pkgconfig
|
PKG_CONFIG_PATH=..:/usr/lib64/pkgconfig:/usr/lib/pkgconfig
|
||||||
|
|
||||||
|
%ifnarch ppc ppc64 s390 s390x
|
||||||
%if %have_gjsfile
|
%if %have_gjsfile
|
||||||
d=`basename %SOURCE2 .tar.gz`
|
d=`basename %SOURCE2 .tar.gz`
|
||||||
cd $d
|
cd $d
|
||||||
@ -269,10 +291,13 @@ cd $d
|
|||||||
autoreconf
|
autoreconf
|
||||||
%endif
|
%endif
|
||||||
export PKG_CONFIG_PATH=..:/usr/lib64/pkgconfig:/usr/lib/pkgconfig
|
export PKG_CONFIG_PATH=..:/usr/lib64/pkgconfig:/usr/lib/pkgconfig
|
||||||
%configure
|
%configure \
|
||||||
|
--with-gnome-shell-version="3.3.90,3.3.5,3.3.4,3.3.3,3.2" \
|
||||||
|
--with-gjs-version="1.31.20,1.31.10,1.31.6,1.31.11,1.30"
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
cd ..
|
cd ..
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -303,6 +328,7 @@ desktop-file-install --delete-original \
|
|||||||
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
|
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
|
||||||
$RPM_BUILD_ROOT%{_datadir}/applications/*
|
$RPM_BUILD_ROOT%{_datadir}/applications/*
|
||||||
|
|
||||||
|
%ifnarch ppc ppc64 s390 s390x
|
||||||
%if %have_gjsfile
|
%if %have_gjsfile
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=657165
|
# https://bugzilla.redhat.com/show_bug.cgi?id=657165
|
||||||
d=`basename %SOURCE2 .tar.gz`
|
d=`basename %SOURCE2 .tar.gz`
|
||||||
@ -311,6 +337,7 @@ make DESTDIR=$RPM_BUILD_ROOT install
|
|||||||
rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/ibus-gjs.mo
|
rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/ibus-gjs.mo
|
||||||
cd ..
|
cd ..
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
# FIXME: no version number
|
# FIXME: no version number
|
||||||
%find_lang %{name}10
|
%find_lang %{name}10
|
||||||
@ -442,10 +469,12 @@ fi
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/gtk-3.0/%{gtk3_binary_version}/immodules/im-ibus.so
|
%{_libdir}/gtk-3.0/%{gtk3_binary_version}/immodules/im-ibus.so
|
||||||
|
|
||||||
|
%ifnarch ppc ppc64 s390 s390x
|
||||||
%files gnome3
|
%files gnome3
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_datadir}/gnome-shell/js/ui/status/ibus
|
%{_datadir}/gnome-shell/js/ui/status/ibus
|
||||||
%{_datadir}/gnome-shell/extensions/ibus-indicator@example.com
|
%{_datadir}/gnome-shell/extensions/ibus-indicator@example.com
|
||||||
|
%endif
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -461,11 +490,18 @@ fi
|
|||||||
%{_datadir}/gtk-doc/html/*
|
%{_datadir}/gtk-doc/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 08 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20120303-3
|
||||||
|
- Bumped to ibus-gjs 3.3.90.20120308 to work with gnome-shell 3.3.90
|
||||||
|
- Fixed Bug 786906 - Added ifnarch ppc ppc64 s390 s390x
|
||||||
|
- Updated ibus-HEAD.patch
|
||||||
|
Fixed Bug 800897 - After doing "ctrl+space", ibus tray icon freezes
|
||||||
|
|
||||||
* Mon Mar 05 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20120303-2
|
* Mon Mar 05 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20120303-2
|
||||||
- Added ibus-HEAD.patch to fix python library to load libibus.so.
|
- Added ibus-HEAD.patch to fix python library to load libibus.so.
|
||||||
|
|
||||||
* Sun Mar 04 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20120303-1
|
* Sun Mar 04 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20120303-1
|
||||||
- Bumped to 1.4.99.20120303
|
- Bumped to 1.4.99.20120303
|
||||||
|
Fixed Bug 796070 - ibus-setup without no ibus-daemon
|
||||||
|
|
||||||
* Wed Feb 08 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20120203-3
|
* Wed Feb 08 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20120203-3
|
||||||
- Fixed ibus-setup on C locale
|
- Fixed ibus-setup on C locale
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
28c77ed889dbe25525fde12e58f1402b ibus-1.4.99.20120304.tar.gz
|
28c77ed889dbe25525fde12e58f1402b ibus-1.4.99.20120304.tar.gz
|
||||||
8c713e47d403482cdd8b851dda3d0713 ibus-gjs-3.3.3.20120203.tar.gz
|
11274193093c9d729187bdcea6e85442 ibus-gjs-3.3.90.20120308.tar.gz
|
||||||
2d2ad58e3e41429dbd883ba7e501c9b2 ibus-gjs-3.2.1.20111230.tar.gz
|
2d2ad58e3e41429dbd883ba7e501c9b2 ibus-gjs-3.2.1.20111230.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user