Delete ibus-xinit dependency of ibus-panel
- Disable setxkbmap in RHEL10 - Build gnome-desktop-testing until the package is available
This commit is contained in:
parent
bc511ceda4
commit
d2dc7c64ea
20
ibus-xx-disable-setxkbmap.patch
Normal file
20
ibus-xx-disable-setxkbmap.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff --git a/src/tests/ibus-keypress.c b/src/tests/ibus-keypress.c
|
||||
index bab05398..41f16b98 100644
|
||||
--- a/src/tests/ibus-keypress.c
|
||||
+++ b/src/tests/ibus-keypress.c
|
||||
@@ -272,12 +272,15 @@ create_window ()
|
||||
static void
|
||||
test_keypress (void)
|
||||
{
|
||||
+#if 0
|
||||
int status = 0;
|
||||
GError *error = NULL;
|
||||
|
||||
+ /* setxkbmap is not available in RHEL10 */
|
||||
g_spawn_command_line_sync ("setxkbmap -layout us",
|
||||
NULL, NULL,
|
||||
&status, &error);
|
||||
+#endif
|
||||
g_assert (register_ibus_engine ());
|
||||
|
||||
create_window ();
|
14
ibus.spec
14
ibus.spec
@ -74,9 +74,11 @@ Source3: %{name}.conf.5
|
||||
Patch1: %{name}-2267615-wayland-init-keymap.patch
|
||||
# Under testing #1349148 #1385349 #1350291 #1406699 #1432252 #1601577
|
||||
Patch2: %{name}-1385349-segv-bus-proxy.patch
|
||||
%if 0%{?fedora:0}%{?rhel:1}
|
||||
%if %{without xinit}
|
||||
# Use mutter window manager in RHEL CI
|
||||
Patch100: %{name}-xx-desktop-testing-mutter.patch
|
||||
# Disable to run setxkbmap
|
||||
Patch101: %{name}-xx-disable-setxkbmap.patch
|
||||
%endif
|
||||
|
||||
# autoreconf requires autopoint but not po.m4
|
||||
@ -137,8 +139,8 @@ Requires: python3-gobject
|
||||
%if %{with xinit}
|
||||
# Owner of %%{_sysconfdir}/X11/xinit
|
||||
Requires: xorg-x11-xinit
|
||||
%endif
|
||||
Requires: setxkbmap
|
||||
%endif
|
||||
%if (0%{?fedora} > 29 || 0%{?rhel} > 8)
|
||||
%else
|
||||
Requires: dbus-x11
|
||||
@ -266,7 +268,7 @@ Summary: IBus Panel icon
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
%if %{without xinit}
|
||||
Requires: %{name}-xinit = %{version}-%{release}
|
||||
# ibus-xinit is not available in RHEL
|
||||
%endif
|
||||
BuildRequires: libdbusmenu-gtk3-devel
|
||||
|
||||
@ -405,6 +407,10 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{gtk3_binary_version}/immodules/im-ibus
|
||||
%if %{with gtk4}
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-4.0/%{gtk4_binary_version}/immodules/libim-ibus.la
|
||||
%endif
|
||||
%if %{without xinit}
|
||||
# setxkbmap is not available in RHEL10
|
||||
rm -f $RPM_BUILD_ROOT%{_datadir}/installed-tests/ibus/xkb-latin-layouts.test
|
||||
%endif
|
||||
|
||||
# install man page
|
||||
for S in %{SOURCE3}
|
||||
@ -620,7 +626,7 @@ dconf update || :
|
||||
%{_datadir}/installed-tests/ibus
|
||||
|
||||
%changelog
|
||||
* Thu May 02 2024 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.30
|
||||
* Thu May 02 2024 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.30-1
|
||||
- Bump to 1.5.30
|
||||
|
||||
* Fri Apr 12 2024 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.30~rc3-2
|
||||
|
@ -4,23 +4,8 @@
|
||||
stat:
|
||||
path: "/etc/fedora-release"
|
||||
|
||||
- name: Result1
|
||||
debug:
|
||||
msg: "{{ fedora_desktop }}"
|
||||
|
||||
- name: Check if GNOME installed-tests testing harness is installed
|
||||
register: gnome_desktop_testing_runner
|
||||
find:
|
||||
paths: "{{ ansible_env.PATH.split(':') }}"
|
||||
pattern: gnome-desktop-testing-runner
|
||||
|
||||
- name: Build and install GNOME installed-tests testing harness
|
||||
block:
|
||||
- name: Installing GNOME installed-tests testing harness
|
||||
when: gnome_desktop_testing_runner.matched == 0
|
||||
package:
|
||||
name:
|
||||
- gnome-desktop-testing
|
||||
- name: Installing common GNOME desktop components
|
||||
package:
|
||||
name:
|
||||
@ -125,6 +110,52 @@
|
||||
- simple-scan
|
||||
- sushi
|
||||
- totem
|
||||
- name: Installing GNOME installed-tests testing harness
|
||||
when: fedora_desktop.stat.exists == true
|
||||
package:
|
||||
name:
|
||||
- gnome-desktop-testing
|
||||
- name: Installing build environment
|
||||
when: fedora_desktop.stat.exists == false
|
||||
package:
|
||||
name:
|
||||
- autoconf
|
||||
- automake
|
||||
- make
|
||||
- gcc
|
||||
- git
|
||||
- libtool
|
||||
|
||||
- name: Fetching GNOME installed-tests testing harness source from remote repository
|
||||
when: fedora_desktop.stat.exists == false
|
||||
git:
|
||||
repo: 'https://gitlab.gnome.org/GNOME/gnome-desktop-testing.git'
|
||||
dest: gnome-desktop-testing
|
||||
force: yes
|
||||
|
||||
- name: Checkout v2021.1 tag in GNOME installed-tests testing harness
|
||||
when: fedora_desktop.stat.exists == false
|
||||
command: git checkout -b v2021.1 refs/tags/v2021.1
|
||||
args:
|
||||
chdir: gnome-desktop-testing
|
||||
|
||||
- name: Configure GNOME installed-tests testing harness build
|
||||
when: fedora_desktop.stat.exists == false
|
||||
command: ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
|
||||
args:
|
||||
chdir: gnome-desktop-testing
|
||||
|
||||
- name: Build GNOME installed-tests testing harness
|
||||
when: fedora_desktop.stat.exists == false
|
||||
command: make
|
||||
args:
|
||||
chdir: gnome-desktop-testing
|
||||
|
||||
- name: Install GNOME installed-tests testing harness
|
||||
when: fedora_desktop.stat.exists == false
|
||||
command: make install
|
||||
args:
|
||||
chdir: gnome-desktop-testing
|
||||
|
||||
- name: Start IBus installed-tests testing harness
|
||||
environment:
|
||||
|
Loading…
Reference in New Issue
Block a user