import ibus-1.5.19-14.el8_5
This commit is contained in:
parent
73a38625e7
commit
c7b7b4aa31
@ -1,14 +1,73 @@
|
||||
From cddde2dbcbb4d78a32c342c7416aef9a5c5eb7cd Mon Sep 17 00:00:00 2001
|
||||
From c38e925eba2b1f7af39696e2f64ec1eaea94b00b Mon Sep 17 00:00:00 2001
|
||||
From: Takao Fujiwara <fujiwara@redhat.com>
|
||||
Date: Thu, 8 Jul 2021 03:58:09 -0400
|
||||
Date: Thu, 30 Sep 2021 09:36:12 -0400
|
||||
Subject: [PATCH] Backport IBus Unicode feature
|
||||
|
||||
---
|
||||
ui/gtk3/emojier.vala | 37 ++++++++++++++--------
|
||||
ui/gtk3/emojierapp.vala | 66 +++++++++++++++++++++++++++------------
|
||||
configure.ac | 10 +++++++
|
||||
ui/gtk3/Makefile.am | 5 +++-
|
||||
ui/gtk3/emojier.vala | 37 +++++++++++++++--------
|
||||
ui/gtk3/emojierapp.vala | 63 ++++++++++++++++++++++++++++-----------
|
||||
ui/gtk3/panelbinding.vala | 13 ++++++--
|
||||
3 files changed, 80 insertions(+), 36 deletions(-)
|
||||
5 files changed, 93 insertions(+), 35 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 46ab7a9..26bb357 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -237,12 +237,21 @@ if test x"$enable_gtk3" = x"yes"; then
|
||||
PKG_CHECK_MODULES(GTK3, [
|
||||
gtk+-3.0
|
||||
])
|
||||
+ PKG_CHECK_EXISTS([gdk-wayland-3.0],
|
||||
+ [enable_gdk3_wayland=yes],
|
||||
+ [enable_gdk3_wayland=no]
|
||||
+ )
|
||||
|
||||
gtk3_binary_version=`$PKG_CONFIG --variable=gtk_binary_version gtk+-3.0`
|
||||
GTK3_IM_MODULEDIR="$libdir"/gtk-3.0/$gtk3_binary_version/immodules
|
||||
else
|
||||
enable_gtk3="no (disabled, use --enable-gtk3 to enable)"
|
||||
+ enable_gdk3_wayland=no
|
||||
+fi
|
||||
+if test x"$enable_gdk3_wayland" != x"yes"; then
|
||||
+ enable_gdk3_wayland="no (disabled, need to install gdk-wayland-3.0.pc)"
|
||||
fi
|
||||
+AM_CONDITIONAL([ENABLE_GDK3_WAYLAND], [test x"$enable_gdk3_wayland" = x"yes"])
|
||||
|
||||
if test x"$enable_xim" = x"yes"; then
|
||||
# Check for x11
|
||||
@@ -796,6 +805,7 @@ Build options:
|
||||
Build gtk3 immodule $enable_gtk3
|
||||
Build XIM agent server $enable_xim
|
||||
Build wayland support $enable_wayland
|
||||
+ Build gdk3 wayland support $enable_gdk3_wayland
|
||||
Build appindicator support $enable_appindicator
|
||||
Build appindicator engine icon $enable_appindicator_engine_icon
|
||||
Build python library $enable_python_library
|
||||
diff --git a/ui/gtk3/Makefile.am b/ui/gtk3/Makefile.am
|
||||
index aaba7a4..6ebc96c 100644
|
||||
--- a/ui/gtk3/Makefile.am
|
||||
+++ b/ui/gtk3/Makefile.am
|
||||
@@ -78,7 +78,6 @@ AM_VALAFLAGS = \
|
||||
--pkg=ibus-1.0 \
|
||||
--pkg=config \
|
||||
--pkg=xi \
|
||||
- --pkg=gdk-wayland \
|
||||
--target-glib="$(VALA_TARGET_GLIB_VERSION)" \
|
||||
$(NULL)
|
||||
|
||||
@@ -105,6 +104,10 @@ if ENABLE_APPINDICATOR_ENGINE_ICON
|
||||
AM_VALAFLAGS += --define=INDICATOR_ENGINE_ICON
|
||||
endif
|
||||
|
||||
+if ENABLE_GDK3_WAYLAND
|
||||
+AM_VALAFLAGS += --pkg=gdk-wayland --define=USE_GDK_WAYLAND
|
||||
+endif
|
||||
+
|
||||
libexec_PROGRAMS = ibus-ui-gtk3
|
||||
|
||||
ibus_ui_gtk3_SOURCES = \
|
||||
diff --git a/ui/gtk3/emojier.vala b/ui/gtk3/emojier.vala
|
||||
index 3eac2f2..9e6e926 100644
|
||||
--- a/ui/gtk3/emojier.vala
|
||||
@ -133,7 +192,7 @@ index 3eac2f2..9e6e926 100644
|
||||
if (start_index >= 0) {
|
||||
var attr = new IBus.Attribute(
|
||||
diff --git a/ui/gtk3/emojierapp.vala b/ui/gtk3/emojierapp.vala
|
||||
index fab99d9..783c611 100644
|
||||
index fab99d9..7bc7b42 100644
|
||||
--- a/ui/gtk3/emojierapp.vala
|
||||
+++ b/ui/gtk3/emojierapp.vala
|
||||
@@ -3,6 +3,7 @@
|
||||
@ -284,5 +343,5 @@ index cfedb2d..861255b 100644
|
||||
m_preedit.append_text(str);
|
||||
string annotation = m_preedit.get_text();
|
||||
--
|
||||
2.18.2
|
||||
2.27.0
|
||||
|
||||
|
@ -31,7 +31,7 @@
|
||||
|
||||
Name: ibus
|
||||
Version: 1.5.19
|
||||
Release: 13%{?dist}
|
||||
Release: 14%{?dist}
|
||||
Summary: Intelligent Input Bus for Linux OS
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
@ -501,6 +501,9 @@ dconf update || :
|
||||
%{_datadir}/installed-tests/ibus
|
||||
|
||||
%changelog
|
||||
* Mon Oct 18 2021 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.19-14
|
||||
- Resolves: #2014064 - Fix regression of Emoji typing in Wayland
|
||||
|
||||
* Tue Jul 06 2021 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.19-13
|
||||
- Resolves: #1897548 - Rebuild IBus emoji with unicode-emoji-13.0-4 and cldr-emoji-annotation-39-2
|
||||
- Rebuild ibusemojigen.h and ibusunicodegen.h
|
||||
|
Loading…
Reference in New Issue
Block a user