Bumped to 1.5.10
This commit is contained in:
parent
f7fc68e89b
commit
b157f27b35
@ -1,24 +0,0 @@
|
||||
--- ibus-1.5.8/client/gtk2/ibusimcontext.c.orig 2014-10-16 18:35:07.229056767 +0900
|
||||
+++ ibus-1.5.8/client/gtk2/ibusimcontext.c 2014-10-17 12:36:29.138998318 +0900
|
||||
@@ -857,12 +857,7 @@ ibus_im_context_focus_in (GtkIMContext *
|
||||
}
|
||||
}
|
||||
|
||||
- if (_focus_im_context != NULL) {
|
||||
- g_assert (_focus_im_context != context);
|
||||
- gtk_im_context_focus_out (_focus_im_context);
|
||||
- g_assert (_focus_im_context == NULL);
|
||||
- }
|
||||
- else {
|
||||
+ if (_focus_im_context == NULL) {
|
||||
/* focus out fake context */
|
||||
if (_fake_context != NULL) {
|
||||
ibus_input_context_focus_out (_fake_context);
|
||||
@@ -903,7 +898,6 @@ ibus_im_context_focus_out (GtkIMContext
|
||||
return;
|
||||
}
|
||||
|
||||
- g_assert (context == _focus_im_context);
|
||||
g_object_remove_weak_pointer ((GObject *) context,
|
||||
(gpointer *) &_focus_im_context);
|
||||
_focus_im_context = NULL;
|
1112
ibus-HEAD.patch
1112
ibus-HEAD.patch
File diff suppressed because it is too large
Load Diff
@ -1,84 +0,0 @@
|
||||
--- ibus-1.5.8/bus/global.c.orig 2014-10-24 11:39:02.992359855 +0900
|
||||
+++ ibus-1.5.8/bus/global.c 2014-12-01 19:11:11.311759112 +0900
|
||||
@@ -28,4 +28,4 @@ gchar *g_address = "unix:tmpdir=/tmp";
|
||||
gchar *g_cache = "auto";
|
||||
gboolean g_mempro = FALSE;
|
||||
gboolean g_verbose = FALSE;
|
||||
-gint g_gdbus_timeout = 5000;
|
||||
+gint g_gdbus_timeout = 15000;
|
||||
--- ibus-1.5.8/bus/ibusimpl.c.orig 2014-10-14 12:15:30.547369108 +0900
|
||||
+++ ibus-1.5.8/bus/ibusimpl.c 2014-10-14 12:16:23.182396247 +0900
|
||||
@@ -1390,11 +1390,12 @@ _ibus_set_global_engine_ready_cb (BusInp
|
||||
|
||||
GError *error = NULL;
|
||||
if (!bus_input_context_set_engine_by_desc_finish (context, res, &error)) {
|
||||
- g_error_free (error);
|
||||
g_dbus_method_invocation_return_error (data->invocation,
|
||||
G_DBUS_ERROR,
|
||||
G_DBUS_ERROR_FAILED,
|
||||
- "Set global engine failed.");
|
||||
+ "Set global engine failed: %s",
|
||||
+ error->message);
|
||||
+ g_error_free (error);
|
||||
}
|
||||
else {
|
||||
g_dbus_method_invocation_return_value (data->invocation, NULL);
|
||||
--- ibus-1.5.8/bus/main.c.orig 2014-10-24 11:41:32.579140912 +0900
|
||||
+++ ibus-1.5.8/bus/main.c 2014-12-01 19:12:17.235109849 +0900
|
||||
@@ -64,7 +64,7 @@ static const GOptionEntry entries[] =
|
||||
{ "address", 'a', 0, G_OPTION_ARG_STRING, &g_address, "specify the address of ibus daemon.", "address" },
|
||||
{ "replace", 'r', 0, G_OPTION_ARG_NONE, &replace, "if there is an old ibus-daemon is running, it will be replaced.", NULL },
|
||||
{ "cache", 't', 0, G_OPTION_ARG_STRING, &g_cache, "specify the cache mode. [auto/refresh/none]", NULL },
|
||||
- { "timeout", 'o', 0, G_OPTION_ARG_INT, &g_gdbus_timeout, "gdbus reply timeout in milliseconds. pass -1 to use the default timeout of gdbus.", "timeout [default is 5000]" },
|
||||
+ { "timeout", 'o', 0, G_OPTION_ARG_INT, &g_gdbus_timeout, "gdbus reply timeout in milliseconds. pass -1 to use the default timeout of gdbus.", "timeout [default is 15000]" },
|
||||
{ "mem-profile", 'm', 0, G_OPTION_ARG_NONE, &g_mempro, "enable memory profile, send SIGUSR2 to print out the memory profile.", NULL },
|
||||
{ "restart", 'R', 0, G_OPTION_ARG_NONE, &restart, "restart panel and config processes when they die.", NULL },
|
||||
{ "verbose", 'v', 0, G_OPTION_ARG_NONE, &g_verbose, "verbose.", NULL },
|
||||
--- ibus-1.5.8/src/ibusshare.c.orig 2014-10-22 11:49:55.386913376 +0900
|
||||
+++ ibus-1.5.8/src/ibusshare.c 2014-12-01 19:13:01.135009323 +0900
|
||||
@@ -158,8 +158,9 @@ ibus_get_socket_path (void)
|
||||
gint
|
||||
ibus_get_timeout (void)
|
||||
{
|
||||
- /* 6000 ms is the default timeout on the ibus-daemon side (5 sec) plus 1. */
|
||||
- static const gint default_timeout = 6000;
|
||||
+ /* 16000 ms is the default timeout on the ibus-daemon side
|
||||
+ * (15 sec) plus 1. */
|
||||
+ static const gint default_timeout = 16000;
|
||||
|
||||
static gint64 timeout = -2;
|
||||
if (timeout == -2) {
|
||||
--- ibus-1.5.8/ui/gtk3/panel.vala.orig 2014-10-22 12:00:37.017604825 +0900
|
||||
+++ ibus-1.5.8/ui/gtk3/panel.vala 2014-11-28 18:49:49.878234966 +0900
|
||||
@@ -65,6 +65,8 @@ class Panel : IBus.PanelService {
|
||||
red = 0.0, green = 0.0, blue = 0.0, alpha = 1.0 };
|
||||
private XKBLayout m_xkblayout = new XKBLayout();
|
||||
private bool inited_engines_order = true;
|
||||
+ private uint m_preload_engines_id;
|
||||
+ private const uint PRELOAD_ENGINES_DELAY_TIME = 30000;
|
||||
|
||||
private GLib.List<Keybinding> m_keybindings = new GLib.List<Keybinding>();
|
||||
|
||||
@@ -764,8 +766,21 @@ class Panel : IBus.PanelService {
|
||||
return;
|
||||
}
|
||||
|
||||
+ if (m_preload_engines_id != 0) {
|
||||
+ GLib.Source.remove(m_preload_engines_id);
|
||||
+ m_preload_engines_id = 0;
|
||||
+ }
|
||||
+
|
||||
names += engines[index].get_name();
|
||||
- m_bus.preload_engines_async.begin(names, -1, null);
|
||||
+ m_preload_engines_id =
|
||||
+ Timeout.add(
|
||||
+ PRELOAD_ENGINES_DELAY_TIME,
|
||||
+ () => {
|
||||
+ m_bus.preload_engines_async.begin(names,
|
||||
+ -1,
|
||||
+ null);
|
||||
+ return false;
|
||||
+ });
|
||||
}
|
||||
|
||||
private void update_engines(string[]? unowned_engine_names,
|
26
ibus.spec
26
ibus.spec
@ -9,6 +9,12 @@
|
||||
%global with_python2_override_pkg 0
|
||||
%endif
|
||||
|
||||
%if (0%{?fedora} > 21 || 0%{?rhel} > 7)
|
||||
%global with_kde5 1
|
||||
%else
|
||||
%global with_kde5 0
|
||||
%endif
|
||||
|
||||
%global ibus_api_version 1.0
|
||||
|
||||
# for bytecompile in %%{_datadir}/ibus/setup
|
||||
@ -27,8 +33,8 @@
|
||||
%global dbus_python_version 0.83.0
|
||||
|
||||
Name: ibus
|
||||
Version: 1.5.9
|
||||
Release: 11%{?dist}
|
||||
Version: 1.5.10
|
||||
Release: 1%{?dist}
|
||||
Summary: Intelligent Input Bus for Linux OS
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
@ -36,12 +42,8 @@ URL: http://code.google.com/p/ibus/
|
||||
Source0: https://github.com/ibus/ibus/releases/download/%{version}/%{name}-%{version}.tar.gz
|
||||
Source1: %{name}-xinput
|
||||
Source2: %{name}.conf.5
|
||||
Source3: https://fujiwara.fedorapeople.org/ibus/po/%{name}-po-%{version}-20141001.tar.gz
|
||||
# Upstreamed patches.
|
||||
# Patch0: %%{name}-HEAD.patch
|
||||
Patch0: %{name}-HEAD.patch
|
||||
Patch1: %{name}-xx-increase-timeout.patch
|
||||
Patch2: %{name}-1136623-lost-by-another-focus.patch
|
||||
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: libtool
|
||||
@ -222,17 +224,11 @@ The ibus-devel-docs package contains developer documentation for IBus
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
zcat %SOURCE3 | tar xfv -
|
||||
# %%patch0 -p1
|
||||
%patch0 -p1
|
||||
%patch1 -p1 -b .tmout
|
||||
%patch2 -p1 -b .fout
|
||||
# cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c ||
|
||||
cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c ||
|
||||
|
||||
%build
|
||||
#autoreconf -f -i -v
|
||||
autoreconf -f -i -v
|
||||
#make -C ui/gtk3 maintainer-clean-generic
|
||||
%configure \
|
||||
--disable-static \
|
||||
@ -247,6 +243,9 @@ autoreconf -f -i -v
|
||||
--enable-python-library \
|
||||
%endif
|
||||
--enable-wayland \
|
||||
%if ! %with_kde5
|
||||
--disable-appindicator \
|
||||
%endif
|
||||
--enable-introspection
|
||||
|
||||
make %{?_smp_mflags}
|
||||
@ -416,6 +415,9 @@ fi
|
||||
%{_datadir}/gtk-doc/html/*
|
||||
|
||||
%changelog
|
||||
* Wed Feb 25 2015 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.10-1
|
||||
- Bumped to 1.5.10
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1.5.9-11
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
Loading…
Reference in New Issue
Block a user