Fixed Bug 697471 - ibus-gconf zombie when restart ibus from ibus panel.
- Added ibus-HEAD.patch
This commit is contained in:
parent
48fb145b56
commit
aca4d37391
@ -1 +1,25 @@
|
|||||||
|
From 92246e8ffd4d1f4534ac7b487d599e3b2fa30fc0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||||
|
Date: Tue, 19 Apr 2011 14:22:04 +0900
|
||||||
|
Subject: [PATCH] Call waitpid when ibus-daemon restarts.
|
||||||
|
|
||||||
|
---
|
||||||
|
bus/ibusimpl.c | 2 ++
|
||||||
|
1 files changed, 2 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/bus/ibusimpl.c b/bus/ibusimpl.c
|
||||||
|
index a7ae52b..0b3e90e 100644
|
||||||
|
--- a/bus/ibusimpl.c
|
||||||
|
+++ b/bus/ibusimpl.c
|
||||||
|
@@ -1678,6 +1678,8 @@ _ibus_exit (BusIBusImpl *ibus,
|
||||||
|
|
||||||
|
g_dbus_method_invocation_return_value (invocation, NULL);
|
||||||
|
|
||||||
|
+ bus_ibus_impl_destroy (ibus);
|
||||||
|
+
|
||||||
|
/* Make sure the reply has been sent out before exit */
|
||||||
|
g_dbus_connection_flush_sync (g_dbus_method_invocation_get_connection (invocation),
|
||||||
|
NULL,
|
||||||
|
--
|
||||||
|
1.7.4.2
|
||||||
|
|
||||||
|
10
ibus.spec
10
ibus.spec
@ -13,7 +13,7 @@
|
|||||||
|
|
||||||
Name: ibus
|
Name: ibus
|
||||||
Version: 1.3.99.20110408
|
Version: 1.3.99.20110408
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Intelligent Input Bus for Linux OS
|
Summary: Intelligent Input Bus for Linux OS
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -24,7 +24,7 @@ Source1: xinput-ibus
|
|||||||
Source2: http://fujiwara.fedorapeople.org/ibus/gnome-shell/gnome-shell-ibus-plugins-20110317.tar.bz2
|
Source2: http://fujiwara.fedorapeople.org/ibus/gnome-shell/gnome-shell-ibus-plugins-20110317.tar.bz2
|
||||||
%endif
|
%endif
|
||||||
Source3: https://www.transifex.net/projects/p/ibus/resource/master/l/da/download/ibus_master_da.po
|
Source3: https://www.transifex.net/projects/p/ibus/resource/master/l/da/download/ibus_master_da.po
|
||||||
# Patch0: ibus-HEAD.patch
|
Patch0: ibus-HEAD.patch
|
||||||
Patch1: ibus-435880-surrounding-text.patch
|
Patch1: ibus-435880-surrounding-text.patch
|
||||||
Patch2: ibus-541492-xkb.patch
|
Patch2: ibus-541492-xkb.patch
|
||||||
Patch3: ibus-530711-preload-sys.patch
|
Patch3: ibus-530711-preload-sys.patch
|
||||||
@ -145,7 +145,7 @@ The ibus-devel-docs package contains developer documentation for ibus
|
|||||||
bzcat %SOURCE2 | tar xf -
|
bzcat %SOURCE2 | tar xf -
|
||||||
%endif
|
%endif
|
||||||
cp %SOURCE3 po/da.po
|
cp %SOURCE3 po/da.po
|
||||||
# %patch0 -p1
|
%patch0 -p1
|
||||||
# start surrounding patch
|
# start surrounding patch
|
||||||
%patch1 -p1 -b .surrounding
|
%patch1 -p1 -b .surrounding
|
||||||
cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c
|
cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c
|
||||||
@ -328,6 +328,10 @@ fi
|
|||||||
%{_datadir}/gtk-doc/html/*
|
%{_datadir}/gtk-doc/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 20 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20110408-2
|
||||||
|
- Added ibus-HEAD.patch
|
||||||
|
Fixed Bug 697471 - ibus-gconf zombie when restart ibus from ibus panel.
|
||||||
|
|
||||||
* Tue Apr 19 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20110408-1
|
* Tue Apr 19 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20110408-1
|
||||||
- Updated to 1.3.99.20110408
|
- Updated to 1.3.99.20110408
|
||||||
Fixed Bug 683484 - Timed out SetEngine when select an engine from panel.
|
Fixed Bug 683484 - Timed out SetEngine when select an engine from panel.
|
||||||
|
Loading…
Reference in New Issue
Block a user