Fix #628161 and update ibus-541492-xkb.patch

This commit is contained in:
Takao Fujiwara 2010-08-30 11:15:09 +09:00
parent cca15f3f91
commit 9b3b7484f1
2 changed files with 20 additions and 15 deletions

View File

@ -1,6 +1,6 @@
From a3819467deea74b82c55a4cfc8cecd6285f54e00 Mon Sep 17 00:00:00 2001 From 509ffdfc4b27f977f255f348c84743b4be40f25f Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com> From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Mon, 23 Aug 2010 11:31:55 +0900 Date: Mon, 30 Aug 2010 10:58:41 +0900
Subject: [PATCH] Add XKB layouts Subject: [PATCH] Add XKB layouts
--- ---
@ -11,7 +11,7 @@ Subject: [PATCH] Add XKB layouts
ibus/__init__.py | 2 + ibus/__init__.py | 2 +
ibus/bus.py | 3 + ibus/bus.py | 3 +
ibus/interface/iibus.py | 3 + ibus/interface/iibus.py | 3 +
ibus/xkblayout.py.in | 86 ++++++ ibus/xkblayout.py.in | 91 ++++++
ibus/xkbxml.py.in | 337 +++++++++++++++++++++ ibus/xkbxml.py.in | 337 +++++++++++++++++++++
setup/main.py | 228 ++++++++++++++- setup/main.py | 228 ++++++++++++++-
setup/setup.ui | 300 +++++++++++++++++++- setup/setup.ui | 300 +++++++++++++++++++-
@ -28,7 +28,7 @@ Subject: [PATCH] Add XKB layouts
xkb/xkblib.h | 36 +++ xkb/xkblib.h | 36 +++
xkb/xkbxml.c | 695 ++++++++++++++++++++++++++++++++++++++++++++ xkb/xkbxml.c | 695 ++++++++++++++++++++++++++++++++++++++++++++
xkb/xkbxml.h | 188 ++++++++++++ xkb/xkbxml.h | 188 ++++++++++++
24 files changed, 2941 insertions(+), 7 deletions(-) 24 files changed, 2946 insertions(+), 7 deletions(-)
create mode 100644 ibus/xkblayout.py.in create mode 100644 ibus/xkblayout.py.in
create mode 100644 ibus/xkbxml.py.in create mode 100644 ibus/xkbxml.py.in
create mode 100644 xkb/Makefile.am create mode 100644 xkb/Makefile.am
@ -264,10 +264,10 @@ index e63caa3..8b7b6f7 100644
diff --git a/ibus/xkblayout.py.in b/ibus/xkblayout.py.in diff --git a/ibus/xkblayout.py.in b/ibus/xkblayout.py.in
new file mode 100644 new file mode 100644
index 0000000..b5f1a06 index 0000000..75f925c
--- /dev/null --- /dev/null
+++ b/ibus/xkblayout.py.in +++ b/ibus/xkblayout.py.in
@@ -0,0 +1,87 @@ @@ -0,0 +1,91 @@
+# vim:set et sts=4 sw=4: +# vim:set et sts=4 sw=4:
+# +#
+# ibus - The Input Bus +# ibus - The Input Bus
@ -304,6 +304,8 @@ index 0000000..b5f1a06
+ self.__config = config + self.__config = config
+ self.__command = command + self.__command = command
+ self.__default_layout = self.get_layout() + self.__default_layout = self.get_layout()
+ self.__xkb_latin_layouts = []
+ if config != None:
+ self.__xkb_latin_layouts = list(self.__config.get_value("general", + self.__xkb_latin_layouts = list(self.__config.get_value("general",
+ "xkb_latin_layouts", + "xkb_latin_layouts",
+ [])) + []))
@ -324,10 +326,6 @@ index 0000000..b5f1a06
+ def set_layout(self, layout="default"): + def set_layout(self, layout="default"):
+ if self.__command == None: + if self.__command == None:
+ return + return
+ args = []
+ args.append(self.__command)
+ args.append(os.path.basename(self.__command))
+ args.append("--set")
+ layout = str(layout) + layout = str(layout)
+ if layout == "default": + if layout == "default":
+ layout = self.__default_layout + layout = self.__default_layout
@ -339,6 +337,12 @@ index 0000000..b5f1a06
+ break + break
+ if need_us_layout: + if need_us_layout:
+ layout = layout + ",us" + layout = layout + ",us"
+ if layout == self.get_layout():
+ return
+ args = []
+ args.append(self.__command)
+ args.append(os.path.basename(self.__command))
+ args.append("--set")
+ args.append(layout) + args.append(layout)
+ pid = os.spawnl(os.P_NOWAIT, *args) + pid = os.spawnl(os.P_NOWAIT, *args)
+ os.waitpid(pid, 0) + os.waitpid(pid, 0)

View File

@ -11,7 +11,7 @@
Name: ibus Name: ibus
Version: 1.3.7 Version: 1.3.7
Release: 2%{?dist} Release: 3%{?dist}
Summary: Intelligent Input Bus for Linux OS Summary: Intelligent Input Bus for Linux OS
License: LGPLv2+ License: LGPLv2+
Group: System Environment/Libraries Group: System Environment/Libraries
@ -269,8 +269,9 @@ fi
%{_datadir}/gtk-doc/html/* %{_datadir}/gtk-doc/html/*
%changelog %changelog
* Thu Aug 26 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.7-2 * Mon Aug 30 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.7-3
- Fix #627107 and update ibus-541492-xkb.patch - Fix #627107 and update ibus-541492-xkb.patch
- Fix #628161 and update ibus-541492-xkb.patch
* Mon Aug 23 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.7-1 * Mon Aug 23 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.7-1
- Update to 1.3.7 - Update to 1.3.7