Fixed to set the layouts with ibus xkb.
This commit is contained in:
parent
47affbc629
commit
88e8e76eb5
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@ ibus-1.3.6.tar.gz
|
||||
/gnome-shell-ibus-plugins-20110629.tar.bz2
|
||||
/ibus_master_da.po
|
||||
/ibus-indicator.tar.bz2
|
||||
/gnome-shell-ibus-plugins-20110630.tar.bz2
|
||||
|
@ -1,6 +1,6 @@
|
||||
From b58e9d7673d255f86f5224b527457c0132eea3c8 Mon Sep 17 00:00:00 2001
|
||||
From bbf124332b8ba43f369be86ba3a6411fe66556d1 Mon Sep 17 00:00:00 2001
|
||||
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||
Date: Wed, 29 Jun 2011 16:54:45 +0900
|
||||
Date: Thu, 30 Jun 2011 11:46:02 +0900
|
||||
Subject: [PATCH] Add a bridge hotkey which use prev-next engines instead
|
||||
of on-off.
|
||||
|
||||
@ -22,11 +22,11 @@ Subject: [PATCH] Add a bridge hotkey which use prev-next engines instead
|
||||
src/ibusenginedesc.c | 4 +
|
||||
src/ibushotkey.c | 11 ++
|
||||
src/ibushotkey.h | 11 ++
|
||||
ui/gtk/panel.py | 151 ++++++++++++++++++++---
|
||||
ui/gtk/panel.py | 157 +++++++++++++++++++++---
|
||||
xkb/Makefile.am | 2 +
|
||||
xkb/ibus-engine-xkb-main.c | 8 ++
|
||||
xkb/xkbxml.c | 8 +-
|
||||
21 files changed, 804 insertions(+), 387 deletions(-)
|
||||
21 files changed, 810 insertions(+), 387 deletions(-)
|
||||
delete mode 100644 data/ibus.schemas.in
|
||||
create mode 100644 data/ibus.schemas.in.in
|
||||
|
||||
@ -794,7 +794,7 @@ index 9a341f6..92ec6af 100644
|
||||
G_END_DECLS
|
||||
#endif
|
||||
diff --git a/ui/gtk/panel.py b/ui/gtk/panel.py
|
||||
index de64920..1dae2b1 100644
|
||||
index de64920..5839238 100644
|
||||
--- a/ui/gtk/panel.py
|
||||
+++ b/ui/gtk/panel.py
|
||||
@@ -133,6 +133,14 @@ class Panel(ibus.PanelBase):
|
||||
@ -1001,13 +1001,25 @@ index de64920..1dae2b1 100644
|
||||
self.__focus_ic.disable()
|
||||
|
||||
def __sys_menu_item_activate_cb(self, item, command):
|
||||
@@ -573,11 +671,28 @@ class Panel(ibus.PanelBase):
|
||||
@@ -573,11 +671,34 @@ class Panel(ibus.PanelBase):
|
||||
self.__setup_pid = pid
|
||||
glib.child_watch_add(self.__setup_pid, self.__child_watch_cb)
|
||||
|
||||
- def __engine_get_layout_wrapper(self, engine):
|
||||
+ def __engine_get_layout_wrapper(self, engine, changed_state):
|
||||
+ if ibus.use_bridge_hotkey() and \
|
||||
# This code is for the back compatibility.
|
||||
# Should we remove the codes after all IM engines are changed
|
||||
# to "default" layout?
|
||||
- if engine.name != None and engine.name.startswith("xkb:layout:"):
|
||||
+ if engine.name != None and engine.name.startswith("xkb:layout:") and \
|
||||
+ not ibus.use_bridge_hotkey():
|
||||
+ return engine.layout
|
||||
+ elif engine.name != None and \
|
||||
+ engine.name.startswith("xkb:layout:") and \
|
||||
+ ibus.use_bridge_hotkey() and \
|
||||
+ engine.name != ibus.DEFAULT_BRIDGE_ENGINE_NAME:
|
||||
return engine.layout
|
||||
+ elif ibus.use_bridge_hotkey() and \
|
||||
+ self.__disabled_engines_id >= 0 and \
|
||||
+ self.__disabled_engines != None and \
|
||||
+ self.__disabled_engines_id < len(self.__disabled_engines):
|
||||
@ -1024,12 +1036,6 @@ index de64920..1dae2b1 100644
|
||||
+ self.__disabled_engines_swapped = 1
|
||||
+ retval = self.__disabled_engines[self.__disabled_engines_id].layout
|
||||
+ return retval
|
||||
# This code is for the back compatibility.
|
||||
# Should we remove the codes after all IM engines are changed
|
||||
# to "default" layout?
|
||||
- if engine.name != None and engine.name.startswith("xkb:layout:"):
|
||||
+ elif engine.name != None and engine.name.startswith("xkb:layout:"):
|
||||
return engine.layout
|
||||
else:
|
||||
return "default"
|
||||
diff --git a/xkb/Makefile.am b/xkb/Makefile.am
|
||||
|
@ -13,7 +13,7 @@
|
||||
|
||||
Name: ibus
|
||||
Version: 1.3.99.20110419
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
Summary: Intelligent Input Bus for Linux OS
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
@ -21,7 +21,7 @@ URL: http://code.google.com/p/ibus/
|
||||
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||
Source1: xinput-ibus
|
||||
%if %have_gjsfile
|
||||
Source2: http://fujiwara.fedorapeople.org/ibus/gnome-shell/gnome-shell-ibus-plugins-20110629.tar.bz2
|
||||
Source2: http://fujiwara.fedorapeople.org/ibus/gnome-shell/gnome-shell-ibus-plugins-20110630.tar.bz2
|
||||
%endif
|
||||
Source3: https://www.transifex.net/projects/p/ibus/resource/master/l/da/download/ibus_master_da.po
|
||||
Source4: http://ueno.fedorapeople.org/ibus-indicator/ibus-indicator.tar.bz2
|
||||
@ -354,7 +354,7 @@ fi
|
||||
%{_datadir}/gtk-doc/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 20 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20110419-6
|
||||
* Mon Jun 20 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20110419-7
|
||||
- Updated ibus-HEAD.patch for upstream.
|
||||
- Removed ibus-435880-surrounding-text.patch as upstream.
|
||||
- Added ibus-711632-fedora-fallback-icon.patch
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
d4f2729fecb92ae6b41f26c770b1a772 ibus-1.3.99.20110419.tar.gz
|
||||
3d3ba1c988a81f483785c1eac4b00532 gnome-shell-ibus-plugins-20110629.tar.bz2
|
||||
1ba87ccf14bd54843f9a3c6940392ce0 gnome-shell-ibus-plugins-20110630.tar.bz2
|
||||
698c90edf0f037488e1aa969804e891f ibus_master_da.po
|
||||
23756d25109745bdc1c3a54db370d210 ibus-indicator.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user