Added ibus-xx-g-ir-compiler.patch to fix g-ir-compiler error.

This commit is contained in:
Takao Fujiwara 2010-09-29 16:33:14 +09:00
parent e36fdde2fb
commit 81a94b838d
2 changed files with 45 additions and 10 deletions

View File

@ -0,0 +1,32 @@
--- ibus-1.3.7/src/Makefile.am.orig 2010-09-29 15:46:18.941239947 +0900
+++ ibus-1.3.7/src/Makefile.am 2010-09-29 15:45:50.288225017 +0900
@@ -139,7 +139,7 @@ introspection_files = \
$(NULL)
IBus-1.0.gir: $(ibustargetlib) Makefile
IBus_1_0_gir_SCANNERFLAGS = --strip-prefix=IBus --pkg=dbus-1,glib-2.0
-IBus_1_0_gir_INCLUDES = GLib-2.0 GObject-2.0
+IBus_1_0_gir_INCLUDES = GLib-2.0 GObject-2.0 DBus-1.0
IBus_1_0_gir_LIBS = $(ibustargetlib)
IBus_1_0_gir_FILES = $(addprefix $(srcdir)/,$(introspection_files))
IBus_1_0_gir_CFLAGS = $(INCLUDES)
--- ibus-1.3.7/src/Makefile.in.orig 2010-09-29 15:46:30.076225797 +0900
+++ ibus-1.3.7/src/Makefile.in 2010-09-29 15:47:13.322226068 +0900
@@ -537,7 +537,7 @@ ibusincludedir = $(includedir)/ibus-1.0
@HAVE_INTROSPECTION_TRUE@ $(NULL)
@HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_SCANNERFLAGS = --strip-prefix=IBus --pkg=dbus-1,glib-2.0
-@HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_INCLUDES = GLib-2.0 GObject-2.0
+@HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_INCLUDES = GLib-2.0 GObject-2.0 DBus-1.0
@HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_LIBS = $(ibustargetlib)
@HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_FILES = $(addprefix $(srcdir)/,$(introspection_files))
@HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_CFLAGS = $(INCLUDES)
--- ibus-1.3.7/client/gtk3/ibusimcontext.c.orig 2010-09-29 16:05:47.435225305 +0900
+++ ibus-1.3.7/client/gtk3/ibusimcontext.c 2010-09-29 16:06:15.385224305 +0900
@@ -24,6 +24,7 @@
#endif
#include <gdk/gdkkeysyms.h>
+#include <gdk/gdkkeysyms-compat.h>
#include <gdk/gdkx.h>
#include <sys/types.h>
#include <sys/socket.h>

View File

@ -11,7 +11,7 @@
Name: ibus
Version: 1.3.7
Release: 7%{?dist}
Release: 8%{?dist}
Summary: Intelligent Input Bus for Linux OS
License: LGPLv2+
Group: System Environment/Libraries
@ -21,10 +21,11 @@ Source1: xinput-ibus
# Patch0: ibus-HEAD.patch
Patch1: ibus-621795-engineproxy-segv.patch
Patch2: ibus-626652-leak.patch
# Patch3: ibus-xx-va_list.patch
# Patch4: ibus-530711-preload-sys.patch
Patch5: ibus-541492-xkb.patch
Patch6: ibus-435880-surrounding-text.patch
Patch3: ibus-xx-g-ir-compiler.patch
# Patch4: ibus-xx-va_list.patch
# Patch5: ibus-530711-preload-sys.patch
Patch6: ibus-541492-xkb.patch
Patch7: ibus-435880-surrounding-text.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -131,12 +132,13 @@ The ibus-devel-docs package contains developer documentation for ibus
# %patch0 -p1
%patch1 -p1 -b .segv
%patch2 -p1 -b .leak
# %patch3 -p1 -b .valist
# %patch4 -p1 -b .preload-sys
%patch3 -p1 -b .gir
# %patch4 -p1 -b .valist
# %patch5 -p1 -b .preload-sys
%if %have_libxkbfile
%patch5 -p1 -b .xkb
%patch6 -p1 -b .xkb
%endif
%patch6 -p1 -b .surrounding
%patch7 -p1 -b .surrounding
%build
%if %have_libxkbfile
@ -279,7 +281,8 @@ fi
%{_datadir}/gtk-doc/html/*
%changelog
* Wed Sep 29 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.7-7
* Wed Sep 29 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.7-8
- Added ibus-xx-g-ir-compiler.patch to fix g-ir-compiler error.
- Updated ibus-435880-surrounding-text.patch
Fixes Bug 634829 - ibus_im_context_set_surrounding() to get strings.