Do not clear Unicode data when emoji annotation lang is changed
This commit is contained in:
parent
30bbd8c640
commit
7d5c2f40f5
1
.gitignore
vendored
1
.gitignore
vendored
@ -32,6 +32,7 @@
|
||||
/ibus-po-1.5.14-20160909.tar.gz
|
||||
/ibus-po-1.5.17-20180221.tar.gz
|
||||
/ibus-po-1.5.18-20180627.tar.gz
|
||||
/ibus-po-1.5.19-20180822.tar.gz
|
||||
ibus-1.3.6.tar.gz
|
||||
/ibus-1.3.7.tar.gz
|
||||
/ibus-1.3.8.tar.gz
|
||||
|
@ -0,0 +1,37 @@
|
||||
From 7edaefdc1d80aefdbbc2dc52526c20715759da83 Mon Sep 17 00:00:00 2001
|
||||
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||
Date: Wed, 22 Aug 2018 17:20:53 +0900
|
||||
Subject: [PATCH] ui/gtk3: Do not clear unicode data when emoji annotation lang
|
||||
is changed
|
||||
|
||||
---
|
||||
ui/gtk3/emojier.vala | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ui/gtk3/emojier.vala b/ui/gtk3/emojier.vala
|
||||
index 85dcdceb..637ae049 100644
|
||||
--- a/ui/gtk3/emojier.vala
|
||||
+++ b/ui/gtk3/emojier.vala
|
||||
@@ -440,13 +440,17 @@ public class IBusEmojier : Gtk.ApplicationWindow {
|
||||
m_emoji_to_emoji_variants_dict =
|
||||
new GLib.HashTable<string, GLib.SList<string>>(GLib.str_hash,
|
||||
GLib.str_equal);
|
||||
- m_unicode_to_data_dict =
|
||||
+ if (m_unicode_to_data_dict == null) {
|
||||
+ m_unicode_to_data_dict =
|
||||
new GLib.HashTable<unichar, IBus.UnicodeData>(
|
||||
GLib.direct_hash,
|
||||
GLib.direct_equal);
|
||||
- m_name_to_unicodes_dict =
|
||||
+ }
|
||||
+ if (m_name_to_unicodes_dict == null) {
|
||||
+ m_name_to_unicodes_dict =
|
||||
new GLib.HashTable<string, GLib.SList<unichar>>(GLib.str_hash,
|
||||
GLib.str_equal);
|
||||
+ }
|
||||
}
|
||||
|
||||
|
||||
--
|
||||
2.17.1
|
||||
|
11
ibus.spec
11
ibus.spec
@ -31,7 +31,7 @@
|
||||
|
||||
Name: ibus
|
||||
Version: 1.5.19
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Intelligent Input Bus for Linux OS
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
@ -39,9 +39,9 @@ URL: https://github.com/ibus/%name/wiki
|
||||
Source0: https://github.com/ibus/%name/releases/download/%{version}/%{name}-%{version}.tar.gz
|
||||
Source1: %{name}-xinput
|
||||
Source2: %{name}.conf.5
|
||||
# Will remove the annotation tarball once the rpm is available on Fedora
|
||||
# Upstreamed patches.
|
||||
Source3: https://fujiwara.fedorapeople.org/ibus/po/%{name}-po-1.5.19-20180822.tar.gz
|
||||
# Patch0: %%{name}-HEAD.patch
|
||||
Patch0: %{name}-HEAD.patch
|
||||
# Under testing #1349148 #1385349 #1350291 #1406699 #1432252 #1601577
|
||||
Patch1: %{name}-1385349-segv-bus-proxy.patch
|
||||
|
||||
@ -242,6 +242,8 @@ The ibus-devel-docs package contains developer documentation for IBus
|
||||
%autosetup -S git
|
||||
# cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c || :
|
||||
|
||||
zcat %SOURCE3 | tar xfv -
|
||||
|
||||
# prep test
|
||||
diff client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c
|
||||
if test $? -ne 0 ; then
|
||||
@ -424,6 +426,9 @@ dconf update || :
|
||||
%{_datadir}/gtk-doc/html/*
|
||||
|
||||
%changelog
|
||||
* Wed Aug 22 2018 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.19-2
|
||||
- Do not clear Unicode data when emoji annotation lang is changed
|
||||
|
||||
* Wed Aug 08 2018 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.19-1
|
||||
- Bumped to 1.5.19
|
||||
|
||||
|
1
sources
1
sources
@ -1 +1,2 @@
|
||||
SHA512 (ibus-1.5.19.tar.gz) = ddcd464c9afb6d081df1cfac65069506877eb4818c3ba5594bcf76f3c6795ef6c17177a778dc89b2ef69d10d87297aa12c8e04f156b750e500b51b32787bd9fc
|
||||
SHA512 (ibus-po-1.5.19-20180822.tar.gz) = 6a1a5164b6c5ddac4534b617b8f5fbd8134b4ce28731de8ba5712e3c4a816edd4a190591ae14ef90ec420b1038e7f3f5fbd761ecac821625c34ff93889eeed44
|
||||
|
Loading…
Reference in New Issue
Block a user