Fixed Bug 711632 SEGV with no icon in oxygen-gtk icon theme.
This commit is contained in:
parent
84d8da5428
commit
7c25acb4a8
23
ibus-711632-fedora-fallback-icon.patch
Normal file
23
ibus-711632-fedora-fallback-icon.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
--- ibus/ui/gtk/main.py.orig 2011-04-25 12:33:39.296999692 +0900
|
||||||
|
+++ ibus/ui/gtk/main.py 2011-06-08 11:53:44.027232075 +0900
|
||||||
|
@@ -86,6 +86,9 @@ class UIApplication:
|
||||||
|
pass
|
||||||
|
|
||||||
|
def launch_panel(replace):
|
||||||
|
+ settings = gtk.settings_get_default()
|
||||||
|
+ if settings.get_property('gtk-fallback-icon-theme') == None:
|
||||||
|
+ settings.set_property('gtk-fallback-icon-theme', 'gnome')
|
||||||
|
# gtk.settings_get_default().props.gtk_theme_name = "/home/phuang/.themes/aud-Default/gtk-2.0/gtkrc"
|
||||||
|
# gtk.rc_parse("./themes/default/gtkrc")
|
||||||
|
UIApplication(replace).run()
|
||||||
|
--- ibus/ui/gtk/panel.py.orig 2011-06-08 12:16:40.107577438 +0900
|
||||||
|
+++ ibus/ui/gtk/panel.py 2011-06-08 12:17:00.440460268 +0900
|
||||||
|
@@ -507,7 +507,7 @@ class Panel(ibus.PanelBase):
|
||||||
|
menu = gtk.Menu()
|
||||||
|
item = gtk.ImageMenuItem(_("No input window"))
|
||||||
|
size = gtk.icon_size_lookup(gtk.ICON_SIZE_MENU)
|
||||||
|
- item.set_image(_icon.IconWidget("gtk-info", size[0]))
|
||||||
|
+ item.set_image(_icon.IconWidget("gtk-dialog-info", size[0]))
|
||||||
|
menu.add(item)
|
||||||
|
menu.show_all()
|
||||||
|
else:
|
11
ibus.spec
11
ibus.spec
@ -13,7 +13,7 @@
|
|||||||
|
|
||||||
Name: ibus
|
Name: ibus
|
||||||
Version: 1.3.99.20110419
|
Version: 1.3.99.20110419
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Intelligent Input Bus for Linux OS
|
Summary: Intelligent Input Bus for Linux OS
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -30,6 +30,9 @@ Patch2: ibus-541492-xkb.patch
|
|||||||
Patch3: ibus-530711-preload-sys.patch
|
Patch3: ibus-530711-preload-sys.patch
|
||||||
Patch4: ibus-xx-setup-frequent-lang.patch
|
Patch4: ibus-xx-setup-frequent-lang.patch
|
||||||
|
|
||||||
|
# Workaround for oxygen-gtk icon theme until bug 699103 is fixed.
|
||||||
|
Patch91: ibus-711632-fedora-fallback-icon.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
|
||||||
@ -160,6 +163,8 @@ cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c
|
|||||||
%patch3 -p1 -b .preload-sys
|
%patch3 -p1 -b .preload-sys
|
||||||
%patch4 -p1 -b .setup-frequent-lang
|
%patch4 -p1 -b .setup-frequent-lang
|
||||||
|
|
||||||
|
%patch91 -p1 -b .fallback-icon
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %have_libxkbfile
|
%if %have_libxkbfile
|
||||||
aclocal -I m4
|
aclocal -I m4
|
||||||
@ -332,6 +337,10 @@ fi
|
|||||||
%{_datadir}/gtk-doc/html/*
|
%{_datadir}/gtk-doc/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 08 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20110419-2
|
||||||
|
- Added ibus-711632-fedora-fallback-icon.patch
|
||||||
|
Fixed SEGV with no icon in oxygen-gtk icon theme.
|
||||||
|
|
||||||
* Thu May 26 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20110419-1
|
* Thu May 26 2011 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20110419-1
|
||||||
- Updated to 1.3.99.20110419
|
- Updated to 1.3.99.20110419
|
||||||
- Added ibus-HEAD.patch
|
- Added ibus-HEAD.patch
|
||||||
|
Loading…
Reference in New Issue
Block a user