Bumped to 1.5.5

This commit is contained in:
Takao Fujiwara 2014-01-14 15:57:18 +09:00
parent 03baeb803a
commit 78aefa4312
7 changed files with 73 additions and 260 deletions

2
.gitignore vendored
View File

@ -25,6 +25,7 @@
/ibus-gjs-3.4.1.20120815.tar.gz
/ibus-gjs-3.4.1.20130115.tar.gz
/ibus-xkb-1.5.0.tar.gz
/ibus-xkb-1.5.0.20140114.tar.gz
ibus-1.3.6.tar.gz
/ibus-1.3.7.tar.gz
/ibus-1.3.8.tar.gz
@ -35,3 +36,4 @@ ibus-1.3.6.tar.gz
/ibus-1.5.2.tar.gz
/ibus-1.5.3.tar.gz
/ibus-1.5.4.tar.gz
/ibus-1.5.5.tar.gz

View File

@ -1,6 +1,6 @@
From d566bc83a4672b88a38fa5de25741b99ebaeae62 Mon Sep 17 00:00:00 2001
From a6d4b9ac9a22c5b88c362b659eaf6fd59a0cf5bd Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Fri, 20 Sep 2013 17:20:09 +0900
Date: Tue, 14 Jan 2014 15:30:24 +0900
Subject: [PATCH] Reload preload engines until users customize the list.
The idea is, if users don't customize the preload_engines with ibus-setup,
@ -25,7 +25,7 @@ IBUS_PRELOAD_ENGINE_MODE_USER and users can customize the value
5 files changed, 210 insertions(+), 9 deletions(-)
diff --git a/data/ibus.schemas.in b/data/ibus.schemas.in
index 88a287f..b6709fd 100644
index 8fd7e15..28d2219 100644
--- a/data/ibus.schemas.in
+++ b/data/ibus.schemas.in
@@ -2,6 +2,30 @@
@ -168,7 +168,7 @@ index d3f4414..235ef9c 100644
self.__bus = IBus.Bus()
if self.__bus.is_connected():
diff --git a/setup/setup.ui b/setup/setup.ui
index 1638abb..72a5d57 100644
index 65dcee4..a6a001b 100644
--- a/setup/setup.ui
+++ b/setup/setup.ui
@@ -669,7 +669,23 @@
@ -205,7 +205,7 @@ index 1638abb..72a5d57 100644
</packing>
</child>
<child>
@@ -905,7 +921,7 @@ You may use up/down buttons to change it.&lt;/i&gt;&lt;/small&gt;</property>
@@ -905,7 +921,7 @@
<packing>
<property name="expand">False</property>
<property name="fill">True</property>
@ -215,10 +215,10 @@ index 1638abb..72a5d57 100644
</child>
</object>
diff --git a/src/ibustypes.h b/src/ibustypes.h
index 6d30a86..dac7f8f 100644
index 86fc2cc..cb9eb22 100644
--- a/src/ibustypes.h
+++ b/src/ibustypes.h
@@ -204,6 +204,16 @@ typedef enum {
@@ -206,6 +206,16 @@ typedef enum {
} IBusError;
/**
@ -236,10 +236,10 @@ index 6d30a86..dac7f8f 100644
* @x: x coordinate.
* @y: y coordinate.
diff --git a/ui/gtk3/panel.vala b/ui/gtk3/panel.vala
index c08f6f4..9c1fef5 100644
index 1da7966..fc60fd4 100644
--- a/ui/gtk3/panel.vala
+++ b/ui/gtk3/panel.vala
@@ -130,6 +130,10 @@ class Panel : IBus.PanelService {
@@ -136,6 +136,10 @@ class Panel : IBus.PanelService {
null);
});
@ -250,7 +250,7 @@ index c08f6f4..9c1fef5 100644
m_settings_general.changed["switcher-delay-time"].connect((key) => {
set_switcher_delay_time();
});
@@ -476,7 +480,96 @@ class Panel : IBus.PanelService {
@@ -524,7 +528,96 @@ class Panel : IBus.PanelService {
init_gkbd();
}
@ -329,8 +329,8 @@ index c08f6f4..9c1fef5 100644
+ preload_engines += name;
+ }
+
+ if ("".joinv(",", orig_preload_engines) !=
+ "".joinv(",", preload_engines))
+ if (string.joinv(",", orig_preload_engines) !=
+ string.joinv(",", preload_engines))
+ m_settings_general.set_strv("preload-engines", preload_engines);
+
+ return true;

View File

@ -1,6 +1,6 @@
From 5c8ce9720f607512c2734f08d3e7141d8f5b9e99 Mon Sep 17 00:00:00 2001
From 8085ca38cb9c2ea370ebe64d80a4d7894a485960 Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Fri, 20 Sep 2013 17:16:56 +0900
Date: Tue, 14 Jan 2014 15:27:50 +0900
Subject: [PATCH] Add libgnomekbd and load preload engines.
---
@ -8,6 +8,7 @@ Subject: [PATCH] Add libgnomekbd and load preload engines.
bindings/vala/Makefile.am | 19 +-
bindings/vala/Xkl-1.0.metadata | 3 +
bindings/vala/gkbd.deps | 3 +
bus/ibusimpl.c | 12 +-
configure.ac | 40 ++++
data/ibus.schemas.in | 59 +++++
ibus-1.0.pc.in | 1 +
@ -21,7 +22,7 @@ Subject: [PATCH] Add libgnomekbd and load preload engines.
ui/gtk3/gkbdlayout.vala.true | 108 ++++++++++
ui/gtk3/panel.vala | 196 ++++++++++++++++-
ui/gtk3/xkblayout.vala | 429 ++++++++++++++++++++++++++++++++++++
17 files changed, 1623 insertions(+), 4 deletions(-)
18 files changed, 1634 insertions(+), 5 deletions(-)
create mode 100644 bindings/vala/Gkbd-3.0.metadata
create mode 100644 bindings/vala/Xkl-1.0.metadata
create mode 100644 bindings/vala/gkbd.deps
@ -39,7 +40,7 @@ index 0000000..661e6fd
@@ -0,0 +1 @@
+Configuration cheader_filename="libgnomekbd/gkbd-configuration.h"
diff --git a/bindings/vala/Makefile.am b/bindings/vala/Makefile.am
index 84aa1b4..4d8aae4 100644
index 29cc1eb..1d28501 100644
--- a/bindings/vala/Makefile.am
+++ b/bindings/vala/Makefile.am
@@ -28,8 +28,6 @@ vapi_deps = \
@ -51,7 +52,7 @@ index 84aa1b4..4d8aae4 100644
VAPIGEN_VAPIS = ibus-1.0.vapi
ibus_1_0_vapi_DEPS = gio-2.0
@@ -39,18 +37,33 @@ ibus_1_0_vapi_FILES = \
@@ -39,19 +37,34 @@ ibus_1_0_vapi_FILES = \
$(srcdir)/IBus-1.0-custom.vala \
$(NULL)
@ -80,6 +81,7 @@ index 84aa1b4..4d8aae4 100644
IBus-1.0.metadata \
IBus-1.0-custom.vala \
ibus-1.0.deps \
ibus-private.vapi \
config.vapi \
xi.vapi \
+ Xkl-1.0.metadata \
@ -104,8 +106,31 @@ index 0000000..172632c
+gtk+-3.0
+glib-2.0
+gmodule-2.0
diff --git a/bus/ibusimpl.c b/bus/ibusimpl.c
index eec6da3..f84c034 100644
--- a/bus/ibusimpl.c
+++ b/bus/ibusimpl.c
@@ -1135,7 +1135,17 @@ _ibus_get_engines_by_names (BusIBusImpl *ibus,
g_variant_builder_init (&builder, G_VARIANT_TYPE ("av"));
while (names[i] != NULL) {
IBusEngineDesc *desc = (IBusEngineDesc *) g_hash_table_lookup (
- ibus->engine_table, names[i++]);
+ ibus->engine_table, names[i]);
+
+ /* preload engines return user XKB so if the engine does not
+ * exist in simple.xml, fall back to 'us' layout. */
+ if (desc == NULL && g_str_has_prefix (names[i], "xkb:")) {
+ desc = (IBusEngineDesc *) g_hash_table_lookup (
+ ibus->engine_table, "xkb:us::eng");
+ }
+
+ i++;
+
if (desc == NULL)
continue;
g_variant_builder_add (
diff --git a/configure.ac b/configure.ac
index e8fde49..d084c8e 100644
index d71c415..779e29e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -261,6 +261,45 @@ else
@ -163,7 +188,7 @@ index e8fde49..d084c8e 100644
])
diff --git a/data/ibus.schemas.in b/data/ibus.schemas.in
index 2779139..88a287f 100644
index d256cbb..8fd7e15 100644
--- a/data/ibus.schemas.in
+++ b/data/ibus.schemas.in
@@ -56,6 +56,52 @@
@ -296,10 +321,10 @@ index 334f37e..2017af9 100644
# make -C po update-gmo
diff --git a/src/Makefile.am b/src/Makefile.am
index 811d097..912b75c 100644
index 404e1d2..f00fab7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -201,6 +201,9 @@ typelibs_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
@@ -202,6 +202,9 @@ typelibs_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
CLEANFILES += $(dist_gir_DATA) $(typelibs_DATA)
endif
@ -987,7 +1012,7 @@ index 0000000..5aa486d
+G_END_DECLS
+#endif
diff --git a/ui/gtk3/Makefile.am b/ui/gtk3/Makefile.am
index 547ef53..4b32d7e 100644
index 6012cfa..3dfa0df 100644
--- a/ui/gtk3/Makefile.am
+++ b/ui/gtk3/Makefile.am
@@ -44,6 +44,8 @@ AM_CPPFLAGS = \
@ -1049,15 +1074,15 @@ index 547ef53..4b32d7e 100644
handle.vala \
iconwidget.vala \
keybindingmanager.vala \
@@ -111,6 +143,7 @@ ibus_ui_gtk3_SOURCES = \
property.vala \
@@ -112,6 +144,7 @@ ibus_ui_gtk3_SOURCES = \
propertypanel.vala \
separator.vala \
switcher.vala \
+ xkblayout.vala \
$(NULL)
ibus_ui_gtk3_LDADD = \
@@ -119,9 +152,12 @@ ibus_ui_gtk3_LDADD = \
@@ -120,9 +153,12 @@ ibus_ui_gtk3_LDADD = \
CLEANFILES = \
gtkpanel.xml \
@ -1254,10 +1279,10 @@ index 0000000..a6e0f8d
+ */
+}
diff --git a/ui/gtk3/panel.vala b/ui/gtk3/panel.vala
index 82b9ee5..c08f6f4 100644
index a7a0c40..1da7966 100644
--- a/ui/gtk3/panel.vala
+++ b/ui/gtk3/panel.vala
@@ -57,6 +57,13 @@ class Panel : IBus.PanelService {
@@ -58,6 +58,13 @@ class Panel : IBus.PanelService {
private Gtk.CssProvider m_css_provider;
private int m_switcher_delay_time = 400;
private bool m_use_system_keyboard_layout = false;
@ -1271,7 +1296,7 @@ index 82b9ee5..c08f6f4 100644
private GLib.List<Keybinding> m_keybindings = new GLib.List<Keybinding>();
@@ -102,6 +109,14 @@ class Panel : IBus.PanelService {
@@ -108,6 +115,14 @@ class Panel : IBus.PanelService {
~Panel() {
unbind_switch_shortcut();
@ -1286,7 +1311,7 @@ index 82b9ee5..c08f6f4 100644
}
private void init_settings() {
@@ -399,6 +414,7 @@ class Panel : IBus.PanelService {
@@ -444,6 +459,7 @@ class Panel : IBus.PanelService {
}
public void load_settings() {
@ -1294,7 +1319,7 @@ index 82b9ee5..c08f6f4 100644
// Update m_use_system_keyboard_layout before update_engines()
// is called.
set_use_system_keyboard_layout();
@@ -415,6 +431,184 @@ class Panel : IBus.PanelService {
@@ -463,6 +479,184 @@ class Panel : IBus.PanelService {
set_version();
}
@ -1479,7 +1504,7 @@ index 82b9ee5..c08f6f4 100644
private void exec_setxkbmap(IBus.EngineDesc engine) {
string layout = engine.get_layout();
string variant = engine.get_layout_variant();
@@ -480,7 +674,7 @@ class Panel : IBus.PanelService {
@@ -528,7 +722,7 @@ class Panel : IBus.PanelService {
// set xkb layout
if (!m_use_system_keyboard_layout)

View File

@ -1,214 +1 @@
From a3f47e6509f19c6f11fca0328d63e973daec48ab Mon Sep 17 00:00:00 2001
From: Julien Humbert <julroy67@gmail.com>
Date: Wed, 2 Oct 2013 10:45:32 +0900
Subject: [PATCH] Add french layout variant oss to simple engine
Review URL: https://codereview.appspot.com/14115044
Patch from Julien Humbert <julroy67@gmail.com>.
---
engine/simple.xml.in | 82 ++++++++++++++++++++++++++++++----------------------
1 file changed, 47 insertions(+), 35 deletions(-)
diff --git a/engine/simple.xml.in b/engine/simple.xml.in
index fbca5ce..3b16820 100644
--- a/engine/simple.xml.in
+++ b/engine/simple.xml.in
@@ -236,41 +236,53 @@
<icon>ibus-keyboard</icon>
<rank>99</rank>
</engine>
- <engine>
- <name>xkb:fr::fra</name>
- <language>fra</language>
- <license>GPL</license>
- <author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
- <layout>fr</layout>
- <longname>French</longname>
- <description>French</description>
- <icon>ibus-keyboard</icon>
- <rank>99</rank>
- </engine>
- <engine>
- <name>xkb:fr:bepo:fra</name>
- <language>fra</language>
- <license>GPL</license>
- <author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
- <layout>fr</layout>
- <layout_variant>bepo</layout_variant>
- <longname>French (Bepo, ergonomic, Dvorak way)</longname>
- <description>French (Bepo, ergonomic, Dvorak way)</description>
- <icon>ibus-keyboard</icon>
- <rank>1</rank>
- </engine>
- <engine>
- <name>xkb:fr:dvorak:fra</name>
- <language>fra</language>
- <license>GPL</license>
- <author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
- <layout>fr</layout>
- <layout_variant>dvorak</layout_variant>
- <longname>French (Dvorak)</longname>
- <description>French (Dvorak)</description>
- <icon>ibus-keyboard</icon>
- <rank>99</rank>
- </engine>
+ <engine>
+ <name>xkb:fr::fra</name>
+ <language>fra</language>
+ <license>GPL</license>
+ <author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
+ <layout>fr</layout>
+ <longname>French</longname>
+ <description>French</description>
+ <icon>ibus-keyboard</icon>
+ <rank>99</rank>
+ </engine>
+ <engine>
+ <name>xkb:fr:oss:fra</name>
+ <language>fra</language>
+ <license>GPL</license>
+ <author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
+ <layout>fr</layout>
+ <layout_variant>oss</layout_variant>
+ <longname>French (alternative)</longname>
+ <description>French (alternative)</description>
+ <icon>ibus-keyboard</icon>
+ <rank>99</rank>
+ </engine>
+ <engine>
+ <name>xkb:fr:bepo:fra</name>
+ <language>fra</language>
+ <license>GPL</license>
+ <author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
+ <layout>fr</layout>
+ <layout_variant>bepo</layout_variant>
+ <longname>French (Bepo, ergonomic, Dvorak way)</longname>
+ <description>French (Bepo, ergonomic, Dvorak way)</description>
+ <icon>ibus-keyboard</icon>
+ <rank>99</rank>
+ </engine>
+ <engine>
+ <name>xkb:fr:dvorak:fra</name>
+ <language>fra</language>
+ <license>GPL</license>
+ <author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
+ <layout>fr</layout>
+ <layout_variant>dvorak</layout_variant>
+ <longname>French (Dvorak)</longname>
+ <description>French (Dvorak)</description>
+ <icon>ibus-keyboard</icon>
+ <rank>1</rank>
+ </engine>
<engine>
<name>xkb:de::ger</name>
<language>ger</language>
--
1.8.0
From b8f36164d9b405d95bdcb76e38daca6c531e7da5 Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Wed, 2 Oct 2013 10:55:09 +0900
Subject: [PATCH] Implement lookup-table-orientation in ibus-ui-gtk3.
BUG=RH#1012781
TEST=ui/gtk3/ibus-ui-gtk3
Review URL: https://codereview.appspot.com/14198043
---
ui/gtk3/panel.vala | 19 ++++++++++++++++++-
1 file changed, 18 insertions(+), 1 deletion(-)
diff --git a/ui/gtk3/panel.vala b/ui/gtk3/panel.vala
index 82b9ee5..5903e05 100644
--- a/ui/gtk3/panel.vala
+++ b/ui/gtk3/panel.vala
@@ -148,6 +148,10 @@ class Panel : IBus.PanelService {
m_settings_panel.changed["show-icon-on-systray"].connect((key) => {
set_show_icon_on_systray();
});
+
+ m_settings_panel.changed["lookup-table-orientation"].connect((key) => {
+ set_lookup_table_orientation();
+ });
}
private void keybinding_manager_bind(KeybindingManager keybinding_manager,
@@ -285,7 +289,7 @@ class Panel : IBus.PanelService {
m_switcher_delay_time =
m_settings_general.get_int("switcher-delay-time");
- if (m_switcher_delay_time >= 0) {
+ if (m_switcher != null && m_switcher_delay_time >= 0) {
m_switcher.set_popup_delay_time((uint) m_switcher_delay_time);
}
}
@@ -312,10 +316,22 @@ class Panel : IBus.PanelService {
}
private void set_show_icon_on_systray() {
+ if (m_status_icon == null)
+ return;
+
m_status_icon.set_visible(
m_settings_panel.get_boolean("show-icon-on-systray"));
}
+ private void set_lookup_table_orientation() {
+ if (m_candidate_panel == null)
+ return;
+
+ m_candidate_panel.set_vertical(
+ m_settings_panel.get_int("lookup-table-orientation")
+ == IBus.Orientation.VERTICAL);
+ }
+
private int compare_versions(string version1, string version2) {
string[] version1_list = version1.split(".");
string[] version2_list = version2.split(".");
@@ -411,6 +427,7 @@ class Panel : IBus.PanelService {
set_embed_preedit_text();
set_custom_font();
set_show_icon_on_systray();
+ set_lookup_table_orientation();
set_version();
}
--
1.8.0
From 9596aea2e2df4cd3ac9b795ad9f354723cf83317 Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Wed, 2 Oct 2013 10:58:36 +0900
Subject: [PATCH] Always save the content-type cache for gnome-shell
password.
GDBusProxy updates the cache immediatelly with the first call only
and has to save the next call in the cache by manual.
BUG=RH#1013948
TEST=password on gnome-shell 3.10.
Review URL: https://codereview.appspot.com/14196043
---
bus/engineproxy.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/bus/engineproxy.c b/bus/engineproxy.c
index 19c2861..efd9586 100644
--- a/bus/engineproxy.c
+++ b/bus/engineproxy.c
@@ -1159,6 +1159,11 @@ bus_engine_proxy_set_content_type (BusEngineProxy *engine,
NULL,
NULL,
NULL);
+
+ /* Need to update the cache by manual since there is a timing issue. */
+ g_dbus_proxy_set_cached_property ((GDBusProxy *) engine,
+ "ContentType",
+ content_type);
}
if (cached_content_type != NULL)
--
1.8.0

View File

@ -1,6 +1,6 @@
From 0e3608c614c2dee3c504a21cf5054ff621633585 Mon Sep 17 00:00:00 2001
From 6c5b4f197afde5185c23ed725eecb36da43507e6 Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Fri, 20 Sep 2013 17:20:23 +0900
Date: Tue, 14 Jan 2014 15:30:54 +0900
Subject: [PATCH] Enable ibus-setup to show the frequently used languages
only in IME list.
@ -10,10 +10,10 @@ Subject: [PATCH] Enable ibus-setup to show the frequently used languages
2 files changed, 292 insertions(+), 24 deletions(-)
diff --git a/data/ibus.schemas.in b/data/ibus.schemas.in
index b6709fd..e6cfaaa 100644
index 28d2219..0600133 100644
--- a/data/ibus.schemas.in
+++ b/data/ibus.schemas.in
@@ -339,6 +339,174 @@ se,si,sk,sy,sy(ku),th,tj,tr,ua,uz,vn
@@ -351,6 +351,174 @@ se,si,sk,sy,sy(ku),th,tj,tr,ua,uz,vn
</locale>
</schema>
<schema>

View File

@ -17,7 +17,7 @@
%endif
%global ibus_api_version 1.0
%global ibus_xkb_version 1.5.0
%global ibus_xkb_version 1.5.0.20140114
%if %with_pkg_config
%{!?gtk2_binary_version: %global gtk2_binary_version %(pkg-config --variable=gtk_binary_version gtk+-2.0)}
@ -32,8 +32,8 @@
%global dbus_python_version 0.83.0
Name: ibus
Version: 1.5.4
Release: 2%{?dist}
Version: 1.5.5
Release: 1%{?dist}
Summary: Intelligent Input Bus for Linux OS
License: LGPLv2+
Group: System Environment/Libraries
@ -46,7 +46,6 @@ Source2: %{name}.conf.5
Source3: https://github.com/ibus/ibus-xkb/archive/ibus-xkb-%{ibus_xkb_version}.tar.gz
# Upstreamed patches.
# Patch0: %%{name}-HEAD.patch
Patch0: %{name}-HEAD.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=810211
Patch1: %{name}-810211-no-switch-by-no-trigger.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=541492
@ -56,14 +55,12 @@ Patch3: %{name}-530711-preload-sys.patch
# Hide minor input method engines on ibus-setup by locale
Patch4: %{name}-xx-setup-frequent-lang.patch
%if (0%{?fedora} < 19 && 0%{?rhel} < 7)
# Removed the target.
# Even if fedpkg srpm's target is rhel, it can run on fedora box.
# Keep the default triggers for the back compatiblity.
Patch95: %{name}-xx-ctrl-space.patch
%endif
%if (0%{?fedora} < 20 && 0%{?rhel} < 8)
# Disable IME on gnome-shell password for the back compatiblity.
Patch96: %{name}-xx-f19-password.patch
%endif
BuildRequires: gettext-devel
@ -103,7 +100,6 @@ Requires: iso-codes
Requires: dbus-python >= %{dbus_python_version}
Requires: dbus-x11
Requires: dconf
Requires: notify-python
Requires: librsvg2
# for setxkbmap
Requires: xorg-x11-xkb-utils
@ -235,7 +231,6 @@ The ibus-devel-docs package contains developer documentation for ibus
%prep
%setup -q
# %%patch0 -p1
%patch0 -p1
%if (0%{?fedora} < 20 && 0%{?rhel} < 8)
%patch96 -p1 -b .passwd
%endif
@ -453,6 +448,10 @@ fi
%{_datadir}/gtk-doc/html/*
%changelog
* Tue Jan 14 2014 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.5-1
- Bumped to 1.5.5
- Deleted notify-python in Requires
* Fri Oct 04 2013 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.4-2
- Added ibus-HEAD.patch to sync upstream.

View File

@ -1,2 +1,2 @@
6ce27a692d2d4881e9898f3798dcf91c ibus-1.5.4.tar.gz
7d1eaa22dd374f453de4308bcad647c3 ibus-xkb-1.5.0.tar.gz
59b8d2fbed3ceb14edac130f882ccfd4 ibus-1.5.5.tar.gz
c0bc5be7f0c068bea1e4785c5b60694b ibus-xkb-1.5.0.20140114.tar.gz