Bumped to 1.4.99.20121006

This commit is contained in:
Takao Fujiwara 2012-10-06 20:53:32 +09:00
parent c0fd76cd79
commit 717e5a3b7d
9 changed files with 47 additions and 70 deletions

1
.gitignore vendored
View File

@ -22,6 +22,7 @@ ibus-1.3.6.tar.gz
/ibus-1.4.99.20120712.tar.gz
/ibus-1.4.99.20120822.tar.gz
/ibus-1.4.99.20120914.tar.gz
/ibus-1.4.99.20121006.tar.gz
/ibus-gjs-3.0.2.20110823.tar.gz
/ibus-gjs-3.1.4.20110823.tar.gz
/ibus-gjs-3.0.2.20110908.tar.gz

View File

@ -1,4 +1,4 @@
From d3ae9bc16830c4cca27eba953e4576ded588e1f3 Mon Sep 17 00:00:00 2001
From 2c4bbcc26f735d6c274483a79b4b27f730afa7b2 Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Fri, 14 Sep 2012 18:49:59 +0900
Subject: [PATCH] Reload preload engines until users customize the list.
@ -60,10 +60,10 @@ index 07169ae..4086f67 100644
<applyto>/desktop/ibus/general/preload_engines</applyto>
<owner>ibus</owner>
diff --git a/setup/main.py b/setup/main.py
index 141cdc2..0b6ce9c 100644
index 2a19c49..000a03b 100644
--- a/setup/main.py
+++ b/setup/main.py
@@ -189,6 +189,20 @@ class Setup(object):
@@ -196,6 +196,20 @@ class Setup(object):
self.__checkbutton_use_global_engine.connect("toggled",
self.__checkbutton_use_global_engine_toggled_cb)
@ -84,7 +84,7 @@ index 141cdc2..0b6ce9c 100644
# init engine page
self.__engines = self.__bus.list_engines()
value = self.__config.get_value("general", "load_xkb_layouts")
@@ -250,6 +264,7 @@ class Setup(object):
@@ -257,6 +271,7 @@ class Setup(object):
self.__checkbutton_auto_start_toggled_cb)
self.__config = self.__bus.get_config()
@ -92,7 +92,7 @@ index 141cdc2..0b6ce9c 100644
self.__init_hotkey()
self.__init_panel()
@@ -264,8 +279,8 @@ class Setup(object):
@@ -271,8 +286,8 @@ class Setup(object):
def __combobox_notify_active_engine_cb(self, combobox, property):
engine = self.__combobox.get_active_engine()
button = self.__builder.get_object("button_engine_add")
@ -103,7 +103,7 @@ index 141cdc2..0b6ce9c 100644
def __get_engine_setup_exec_args(self, engine):
args = []
@@ -344,6 +359,34 @@ class Setup(object):
@@ -351,6 +366,34 @@ class Setup(object):
del self.__engine_setup_exec_list[name]
self.__engine_setup_exec_list[name] = os.spawnl(os.P_NOWAIT, *args)
@ -138,7 +138,7 @@ index 141cdc2..0b6ce9c 100644
def __init_bus(self):
self.__bus = IBus.Bus()
if self.__bus.is_connected():
@@ -554,8 +597,18 @@ class Setup(object):
@@ -561,8 +604,18 @@ class Setup(object):
value = GLib.Variant.new_boolean(value)
self.__config.set_value("general", "use_global_engine", value)

View File

@ -1,6 +1,6 @@
From 39f4aa0d61f12ea1b46588fe23da639b293d76b0 Mon Sep 17 00:00:00 2001
From 168b9a502b24a15e037d6f517165b8e068e4b5a1 Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Fri, 14 Sep 2012 18:48:56 +0900
Date: Sat, 6 Oct 2012 18:05:16 +0900
Subject: [PATCH] Add ibus-xkb and libgnomekbd.
---
@ -19,7 +19,7 @@ Subject: [PATCH] Add ibus-xkb and libgnomekbd.
engine/simple.xml.in.in | 531 +--------------------------------------
ibus-1.0.pc.in | 4 +
ibus.spec.in | 12 +
setup/main.py | 39 ++-
setup/main.py | 38 ++-
src/Makefile.am | 5 +
src/ibus.h | 1 +
src/ibusxkbxml.c | 466 ++++++++++++++++++++++++++++++++++
@ -31,7 +31,7 @@ Subject: [PATCH] Add ibus-xkb and libgnomekbd.
ui/gtk3/panel.vala | 365 +++++++++++++++++++++++----
ui/gtk3/switcher.vala | 49 ++--
ui/gtk3/xkblayout.vala | 464 ++++++++++++++++++++++++++++++++++
27 files changed, 2560 insertions(+), 603 deletions(-)
27 files changed, 2559 insertions(+), 603 deletions(-)
create mode 100644 bindings/vala/Gkbd-3.0.metadata
create mode 100644 bindings/vala/Xkl-1.0.metadata
create mode 100644 engine/ibus-xkb/Makefile.am
@ -1610,14 +1610,13 @@ index 58cac38..4b6f869 100644
# make -C po update-gmo
diff --git a/setup/main.py b/setup/main.py
index 300f11b..141cdc2 100644
index 8a2391d..2a19c49 100644
--- a/setup/main.py
+++ b/setup/main.py
@@ -71,6 +71,14 @@ class Setup(object):
self.__builder.set_translation_domain(DOMAINNAME)
self.__builder.add_from_file(gtk_builder_file);
self.__bus = None
+
@@ -67,6 +67,13 @@ class Setup(object):
def __init__(self):
super(Setup, self).__init__()
+ # In the latest pygobject3 3.3.4 or later, g_variant_dup_strv
+ # returns the allocated strv but in the previous release,
+ # it returned the tuple of (strv, length)
@ -1625,10 +1624,10 @@ index 300f11b..141cdc2 100644
+ if type(GLib.Variant.new_strv([]).dup_strv()) == tuple:
+ self.__tuple_for_variant_strv = True
+
self.__init_bus()
self.__init_ui()
@@ -183,14 +191,22 @@ class Setup(object):
# IBus.Bus() calls ibus_bus_new().
# Gtk.Builder().add_from_file() also calls ibus_bus_new_async()
# via ibus_im_context_new().
@@ -191,14 +198,22 @@ class Setup(object):
# init engine page
self.__engines = self.__bus.list_engines()
@ -1656,7 +1655,7 @@ index 300f11b..141cdc2 100644
self.__treeview = self.__builder.get_object("treeview_engines")
self.__treeview.set_engines(engines)
@@ -239,6 +255,12 @@ class Setup(object):
@@ -247,6 +262,12 @@ class Setup(object):
self.__init_panel()
self.__init_general()
@ -1669,7 +1668,7 @@ index 300f11b..141cdc2 100644
def __combobox_notify_active_engine_cb(self, combobox, property):
engine = self.__combobox.get_active_engine()
button = self.__builder.get_object("button_engine_add")
@@ -263,6 +285,13 @@ class Setup(object):
@@ -271,6 +292,13 @@ class Setup(object):
args.append(path.basename(setup_path))
return args
@ -3172,7 +3171,7 @@ index 40079ec..8e6f756 100644
debug("switch cancelled");
} else {
diff --git a/ui/gtk3/switcher.vala b/ui/gtk3/switcher.vala
index 7b731c0..2fffcc3 100644
index ab2040b..dff5c96 100644
--- a/ui/gtk3/switcher.vala
+++ b/ui/gtk3/switcher.vala
@@ -63,13 +63,26 @@ class Switcher : Gtk.Window {
@ -3226,8 +3225,8 @@ index 7b731c0..2fffcc3 100644
+ event.key.state & KeybindingManager.MODIFIER_FILTER);
update_engines(engines);
m_result = 0;
@@ -302,23 +313,25 @@ class Switcher : Gtk.Window {
/* Let gtk recalculate the window size. */
@@ -305,23 +316,25 @@ class Switcher : Gtk.Window {
public override bool key_press_event(Gdk.EventKey e) {
bool retval = true;
Gdk.EventKey *pe = &e;

View File

@ -1,6 +1,6 @@
From fcfb99cfe6d83974c43bd41a1544d7a16460240f Mon Sep 17 00:00:00 2001
From c93407a1056a3dc062f1efb79104f0ae32352b0a Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Tue, 17 Jul 2012 14:35:17 +0900
Date: Sat, 6 Oct 2012 17:54:27 +0900
Subject: [PATCH] Fix not to switch engines by non-trigger keys.
---
@ -8,18 +8,18 @@ Subject: [PATCH] Fix not to switch engines by non-trigger keys.
1 file changed, 6 insertions(+)
diff --git a/ui/gtk3/switcher.vala b/ui/gtk3/switcher.vala
index b543a8f..ea56c07 100644
index 2587117..ab2040b 100644
--- a/ui/gtk3/switcher.vala
+++ b/ui/gtk3/switcher.vala
@@ -128,6 +128,7 @@ class Switcher : Gtk.Window {
state & KeybindingManager.MODIFIER_FILTER);
@@ -123,6 +123,7 @@ class Switcher : Gtk.Window {
/* Let gtk recalculate the window size. */
resize(1, 1);
update_engines(engines);
+ m_result = 0;
m_selected_engine = index;
m_label.set_text(m_buttons[index].longname);
m_buttons[index].grab_focus();
@@ -343,6 +344,11 @@ class Switcher : Gtk.Window {
@@ -338,6 +339,11 @@ class Switcher : Gtk.Window {
break;
default:
debug("0x%04x", pe->keyval);

View File

@ -1,11 +0,0 @@
--- ibus-1.4.99.20120822/ui/gtk3/panel.vala.orig
+++ ibus-1.4.99.20120822/ui/gtk3/panel.vala
@@ -125,7 +125,7 @@ class Panel : IBus.PanelService {
if ((switch_modifiers & VIRTUAL_MODIFIERS) != 0) {
// workaround a bug in gdk vapi vala > 0.18
// https://bugzilla.gnome.org/show_bug.cgi?id=677559
-#if VALA_0_18
+#if VALA_0_20
Gdk.Keymap.get_default().map_virtual_modifiers(
ref switch_modifiers);
#else

View File

@ -1,15 +0,0 @@
--- ibus-1.4.99.20120914/bus/ibusimpl.c.orig 2012-09-14 21:11:37.627075831 +0900
+++ ibus-1.4.99.20120914/bus/ibusimpl.c 2012-09-14 21:12:41.632072691 +0900
@@ -282,8 +282,10 @@ _dbus_name_owner_changed_cb (BusDBusImpl
if (engine != NULL) {
IBusPropList *prop_list =
bus_engine_proxy_get_properties (engine);
- bus_panel_proxy_register_properties (ibus->panel,
- prop_list);
+ if (prop_list) {
+ bus_panel_proxy_register_properties (ibus->panel,
+ prop_list);
+ }
}
}
}

View File

@ -1,4 +1,4 @@
From 294c84451647426d687988b60aa0b2719c6f27cc Mon Sep 17 00:00:00 2001
From 9fe1a6cf5d10d82c93bf2280a29ebf96e9813087 Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Fri, 14 Sep 2012 18:50:10 +0900
Subject: [PATCH] Enable ibus-setup to show the frequently used languages
@ -411,10 +411,10 @@ index f80b164..578098c 100644
return self.get_property("active-engine")
diff --git a/setup/main.py b/setup/main.py
index 0b6ce9c..7e1f8e7 100644
index 000a03b..ff1c0c6 100644
--- a/setup/main.py
+++ b/setup/main.py
@@ -217,6 +217,7 @@ class Setup(object):
@@ -224,6 +224,7 @@ class Setup(object):
engines.append(engine)
self.__combobox = self.__builder.get_object("combobox_engines")

View File

@ -29,8 +29,8 @@
%define gnome_icon_theme_legacy_version 2.91.6
Name: ibus
Version: 1.4.99.20120914
Release: 2%{?dist}
Version: 1.4.99.20121006
Release: 1%{?dist}
Summary: Intelligent Input Bus for Linux OS
License: LGPLv2+
Group: System Environment/Libraries
@ -39,20 +39,19 @@ Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
Source1: xinput-ibus
Source2: http://fujiwara.fedorapeople.org/ibus/gnome-shell/ibus-gjs-%{ibus_gjs_version}.tar.gz
# Patch0: ibus-HEAD.patch
Patch0: ibus-xx-segv-reg-prop.patch
Patch1: ibus-810211-no-switch-by-no-trigger.patch
Patch2: ibus-541492-xkb.patch
Patch3: ibus-530711-preload-sys.patch
Patch4: ibus-xx-setup-frequent-lang.patch
%if 0%{?fedora} <= 17
# Workaround to disable preedit on gnome-shell until bug 658420 is fixed.
# https://bugzilla.gnome.org/show_bug.cgi?id=658420
Patch92: ibus-xx-g-s-disable-preedit.patch
%endif
Patch93: ibus-771115-property-compatible.patch
# Hide no nused properties in f17.
Patch94: ibus-xx-no-use.diff
# Workaround since f18 vala is old.
Patch95: ibus-xx-f18-build.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -212,9 +211,10 @@ zcat %SOURCE2 | tar xf -
%endif
# patch0 -p1
%patch0 -p1
%if 0%{?fedora} <= 17
%patch92 -p1 -b .g-s-preedit
cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c ||
%endif
%patch1 -p1 -b .noswitch
%if %with_xkbfile
%patch2 -p1 -b .xkb
@ -229,7 +229,6 @@ rm -f data/dconf/00-upstream-settings
%endif
%patch94 -p1 -b .no-used
%patch95 -p1 -b .f18
%build
%if %with_xkbfile
@ -475,6 +474,10 @@ dconf update
%{_datadir}/gtk-doc/html/*
%changelog
* Sat Oct 06 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20121006-1
- Bumped to 1.4.99.20121006
- Removed ibus-xx-segv-reg-prop.patch
* Fri Sep 14 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20120914-2
- Added ibus-xx-segv-reg-prop.patch to avoid segv

View File

@ -1,3 +1,3 @@
3eba21398b1485d94aa4b587764ae6b1 ibus-1.4.99.20120914.tar.gz
28b26c84f021a0c15023d6326d4ad58e ibus-1.4.99.20121006.tar.gz
2d2ad58e3e41429dbd883ba7e501c9b2 ibus-gjs-3.2.1.20111230.tar.gz
8acf4ac4d1a7dfb9a0af9e755a8e7dba ibus-gjs-3.4.1.20120815.tar.gz