Fixed misc issues.
This commit is contained in:
parent
49a7b5cb83
commit
6bf9178ae9
@ -1,6 +1,6 @@
|
||||
From a2558c5d403bc150fae7fb1e07f0b541a7f90e8a Mon Sep 17 00:00:00 2001
|
||||
From 456ea33621814aa08ca62e31f7cb1e770ebb3670 Mon Sep 17 00:00:00 2001
|
||||
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||
Date: Wed, 14 Nov 2012 07:07:08 +0900
|
||||
Date: Tue, 27 Nov 2012 15:53:27 +0900
|
||||
Subject: [PATCH] Reload preload engines until users customize the list.
|
||||
|
||||
The idea is, if users don't customize the preload_engines with ibus-setup,
|
||||
|
@ -1,6 +1,6 @@
|
||||
From c53acc91c40753ec845a4a73035769d4e205be7c Mon Sep 17 00:00:00 2001
|
||||
From 8ca5d79b3f919621df691f8acbec58b206b15aa2 Mon Sep 17 00:00:00 2001
|
||||
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||
Date: Wed, 14 Nov 2012 07:06:58 +0900
|
||||
Date: Tue, 27 Nov 2012 15:53:14 +0900
|
||||
Subject: [PATCH] Add ibus-xkb and libgnomekbd.
|
||||
|
||||
---
|
||||
@ -23,14 +23,14 @@ Subject: [PATCH] Add ibus-xkb and libgnomekbd.
|
||||
src/ibus.h | 1 +
|
||||
src/ibusxkbxml.c | 466 +++++++++++++++++++++++++++++++
|
||||
src/ibusxkbxml.h | 187 +++++++++++++
|
||||
ui/gtk3/Makefile.am | 39 +++
|
||||
ui/gtk3/Makefile.am | 37 +++
|
||||
ui/gtk3/gkbdlayout.vala.false | 63 +++++
|
||||
ui/gtk3/gkbdlayout.vala.true | 108 +++++++
|
||||
ui/gtk3/keybindingmanager.vala | 14 +-
|
||||
ui/gtk3/panel.vala | 353 ++++++++++++++++++++---
|
||||
ui/gtk3/switcher.vala | 49 ++--
|
||||
ui/gtk3/xkblayout.vala | 464 ++++++++++++++++++++++++++++++
|
||||
26 files changed, 2628 insertions(+), 667 deletions(-)
|
||||
26 files changed, 2626 insertions(+), 667 deletions(-)
|
||||
create mode 100644 bindings/vala/Gkbd-3.0.metadata
|
||||
create mode 100644 bindings/vala/Xkl-1.0.metadata
|
||||
create mode 100644 engine/ibus-xkb/Makefile.am
|
||||
@ -2512,31 +2512,29 @@ index 0000000..6f5b7bd
|
||||
+G_END_DECLS
|
||||
+#endif
|
||||
diff --git a/ui/gtk3/Makefile.am b/ui/gtk3/Makefile.am
|
||||
index 5473027..cbd746c 100644
|
||||
index 5473027..6cb02a1 100644
|
||||
--- a/ui/gtk3/Makefile.am
|
||||
+++ b/ui/gtk3/Makefile.am
|
||||
@@ -47,6 +47,9 @@ USE_SYMBOL_ICON = FALSE
|
||||
@@ -47,6 +47,8 @@ USE_SYMBOL_ICON = FALSE
|
||||
# force include config.h before gi18n.h.
|
||||
AM_CPPFLAGS = -include $(CONFIG_HEADER)
|
||||
|
||||
+HAVE_IBUS_XKB_C = $(strip $(subst false, FALSE, $(subst true, TRUE, $(HAVE_IBUS_XKB))))
|
||||
+HAVE_IBUS_GKBD_C = $(strip $(subst false, FALSE, $(subst true, TRUE, $(HAVE_IBUS_GKBD))))
|
||||
+
|
||||
AM_CFLAGS = \
|
||||
@GLIB2_CFLAGS@ \
|
||||
@GIO2_CFLAGS@ \
|
||||
@@ -58,6 +61,10 @@ AM_CFLAGS = \
|
||||
@@ -58,6 +60,9 @@ AM_CFLAGS = \
|
||||
-DBINDIR=\"$(bindir)\" \
|
||||
-DIBUS_DISABLE_DEPRECATED \
|
||||
-DSWITCHER_USE_SYMBOL_ICON=$(USE_SYMBOL_ICON) \
|
||||
+ -DHAVE_IBUS_XKB=$(HAVE_IBUS_XKB_C) \
|
||||
+ -DHAVE_IBUS_GKBD=$(HAVE_IBUS_GKBD_C) \
|
||||
+ -DIBUS_XKB_COMMAND=\"$(libexecdir)/ibus-xkb\" \
|
||||
+ -DXKB_LAYOUTS_MAX_LENGTH=4 \
|
||||
-Wno-unused-variable \
|
||||
-Wno-unused-but-set-variable \
|
||||
-Wno-unused-function \
|
||||
@@ -91,6 +98,7 @@ ibus_ui_gtk3_SOURCES = \
|
||||
@@ -91,6 +96,7 @@ ibus_ui_gtk3_SOURCES = \
|
||||
application.vala \
|
||||
candidatearea.vala \
|
||||
candidatepanel.vala \
|
||||
@ -2544,7 +2542,7 @@ index 5473027..cbd746c 100644
|
||||
handle.vala \
|
||||
iconwidget.vala \
|
||||
keybindingmanager.vala \
|
||||
@@ -99,17 +107,48 @@ ibus_ui_gtk3_SOURCES = \
|
||||
@@ -99,17 +105,48 @@ ibus_ui_gtk3_SOURCES = \
|
||||
property.vala \
|
||||
separator.vala \
|
||||
switcher.vala \
|
||||
|
@ -1,6 +1,6 @@
|
||||
From cdfad7a4f7026c6db0e570b4d9b2c14d1c7ca2b2 Mon Sep 17 00:00:00 2001
|
||||
From d3ce0467bb7825cc97da9646254bc09f58119fda Mon Sep 17 00:00:00 2001
|
||||
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||
Date: Wed, 14 Nov 2012 07:07:17 +0900
|
||||
Date: Tue, 27 Nov 2012 15:53:34 +0900
|
||||
Subject: [PATCH] Enable ibus-setup to show the frequently used languages
|
||||
only in IME list.
|
||||
|
||||
|
60
ibus.spec
60
ibus.spec
@ -1,31 +1,30 @@
|
||||
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||
%{!?gtk2_binary_version: %define gtk2_binary_version %(pkg-config --variable=gtk_binary_version gtk+-2.0)}
|
||||
%{!?gtk3_binary_version: %define gtk3_binary_version %(pkg-config --variable=gtk_binary_version gtk+-3.0)}
|
||||
%{!?gtk2_binary_version: %global gtk2_binary_version %(pkg-config --variable=gtk_binary_version gtk+-2.0)}
|
||||
%{!?gtk3_binary_version: %global gtk3_binary_version %(pkg-config --variable=gtk_binary_version gtk+-3.0)}
|
||||
|
||||
%define with_xkbfile 1
|
||||
%define with_pygobject2 1
|
||||
%define with_pygobject3 1
|
||||
%global with_xkbfile 1
|
||||
%global with_pygobject2 1
|
||||
%global with_pygobject3 1
|
||||
|
||||
%if (0%{?fedora} > 17 || 0%{?rhel} > 6)
|
||||
#ifarch ppc ppc64 s390 s390x
|
||||
%define with_gjs 0
|
||||
%global with_gjs 0
|
||||
%else
|
||||
%define with_gjs 1
|
||||
%global with_gjs 1
|
||||
%endif
|
||||
|
||||
%define ibus_gjs_version 3.4.1.20120815
|
||||
%define ibus_gjs_build_failure 1
|
||||
%global ibus_gjs_version 3.4.1.20120815
|
||||
%global ibus_gjs_build_failure 1
|
||||
|
||||
%define ibus_api_version 1.0
|
||||
%global ibus_api_version 1.0
|
||||
|
||||
%define glib_ver %([ -a %{_libdir}/pkgconfig/glib-2.0.pc ] && pkg-config --modversion glib-2.0 | cut -d. -f 1,2 || echo -n "999")
|
||||
%define dbus_python_version 0.83.0
|
||||
%global glib_ver %([ -a %{_libdir}/pkgconfig/glib-2.0.pc ] && pkg-config --modversion glib-2.0 | cut -d. -f 1,2 || echo -n "999")
|
||||
%global dbus_python_version 0.83.0
|
||||
# FIXME: It's better to use the new icon names
|
||||
%define gnome_icon_theme_legacy_version 2.91.6
|
||||
%global gnome_icon_theme_legacy_version 2.91.6
|
||||
|
||||
Name: ibus
|
||||
Version: 1.4.99.20121109
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Intelligent Input Bus for Linux OS
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
@ -54,7 +53,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: libtool
|
||||
BuildRequires: python
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: gtk2-devel
|
||||
BuildRequires: gtk3-devel
|
||||
BuildRequires: dbus-glib-devel
|
||||
@ -110,6 +109,7 @@ Requires: gnome-icon-theme-legacy >= %{gnome_icon_theme_legacy_version}
|
||||
Requires: gnome-icon-theme-symbolic
|
||||
%endif
|
||||
%if (0%{?fedora} > 17 || 0%{?rhel} > 6)
|
||||
# The feature in ibus-gnome3 is provided by gnome-shell.
|
||||
Obsoletes: ibus-gnome3 < %{version}-%{release}
|
||||
%endif
|
||||
|
||||
@ -121,7 +121,7 @@ Requires(posttrans): dconf
|
||||
Requires(post): %{_sbindir}/alternatives
|
||||
Requires(postun): %{_sbindir}/alternatives
|
||||
|
||||
%define _xinputconf %{_sysconfdir}/X11/xinit/xinput.d/ibus.conf
|
||||
%global _xinputconf %{_sysconfdir}/X11/xinit/xinput.d/ibus.conf
|
||||
|
||||
%description
|
||||
IBus means Intelligent Input Bus. It is an input framework for Linux OS.
|
||||
@ -142,9 +142,6 @@ Group: System Environment/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires(post): glib2 >= %{glib_ver}
|
||||
# Added for F14: need to keep bumping for backports
|
||||
Obsoletes: ibus-gtk < %{version}-%{release}
|
||||
Provides: ibus-gtk = %{version}-%{release}
|
||||
|
||||
%description gtk2
|
||||
This package contains ibus im module for gtk2
|
||||
@ -284,6 +281,7 @@ echo "NoDisplay=true" >> $RPM_BUILD_ROOT%{_datadir}/applications/ibus-setup.desk
|
||||
echo "X-GNOME-Autostart-enabled=false" >> $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/ibus.desktop
|
||||
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/ibus.desktop
|
||||
rm -rf $RPM_BUILD_ROOT%{_datadir}/applications/ibus.desktop
|
||||
|
||||
# workaround for desktop-file-install
|
||||
sed -i -e 's|Comment\[ja\]=IBus |& |' \
|
||||
$RPM_BUILD_ROOT%{_datadir}/applications/ibus-setup.desktop
|
||||
@ -295,7 +293,7 @@ desktop-file-install --delete-original \
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=657165
|
||||
d=`basename %SOURCE2 .tar.gz`
|
||||
cd $d
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
|
||||
rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/ibus-gjs.mo
|
||||
cd ..
|
||||
%endif
|
||||
@ -337,23 +335,30 @@ dconf update
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%post gtk2
|
||||
%{_bindir}/update-gtk-immodules %{_host} || :
|
||||
if [ $1 -eq 1 ] ; then
|
||||
# For upgrades, the cache will be regenerated by the new package's %%postun
|
||||
%{_bindir}/update-gtk-immodules %{_host} || :
|
||||
fi
|
||||
|
||||
%postun gtk2
|
||||
%{_bindir}/update-gtk-immodules %{_host} || :
|
||||
|
||||
%post gtk3
|
||||
%{_bindir}/gtk-query-immodules-3.0-%{__isa_bits} --update-cache || :
|
||||
if [ $1 -eq 1 ] ; then
|
||||
# For upgrades, the cache will be regenerated by the new package's %%postun
|
||||
/usr/bin/gtk-query-immodules-3.0-%{__isa_bits} --update-cache &> /dev/null || :
|
||||
fi
|
||||
|
||||
%postun gtk3
|
||||
%{_bindir}/gtk-query-immodules-3.0-%{__isa_bits} --update-cache || :
|
||||
/usr/bin/gtk-query-immodules-3.0-%{__isa_bits} --update-cache &> /dev/null || :
|
||||
|
||||
|
||||
# FIXME: no version number
|
||||
%files -f %{name}10.lang
|
||||
%doc AUTHORS COPYING README
|
||||
%if %with_pygobject2
|
||||
%dir %{python_sitelib}/ibus
|
||||
%{python_sitelib}/ibus/*
|
||||
%dir %{python2_sitelib}/ibus
|
||||
%{python2_sitelib}/ibus/*
|
||||
%endif
|
||||
%dir %{_datadir}/ibus/
|
||||
%{_bindir}/ibus
|
||||
@ -409,6 +414,9 @@ dconf update
|
||||
%{_datadir}/gtk-doc/html/*
|
||||
|
||||
%changelog
|
||||
* Tue Nov 27 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20121109-3
|
||||
- Fixed misc issues.
|
||||
|
||||
* Thu Oct 11 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20121109-2
|
||||
- Obsoleted ibus-gnome3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user