Moved input focus on Emojier to engines' preedit

- Removed ibus-xx-emoji-harfbuzz.patch not to change session emoji font
This commit is contained in:
Takao Fujiwara 2018-06-20 19:07:39 +09:00
parent 30023155fc
commit 6784864abc
3 changed files with 7789 additions and 34 deletions

View File

@ -1,6 +1,6 @@
From 4ad2f160e2af0b71148b3f7726e71f26a107ff1c Mon Sep 17 00:00:00 2001
From 8c5ccd2c990080e581f6cf5c71d8f5603a87bf15 Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Wed, 21 Feb 2018 15:05:18 +0900
Date: Wed, 20 Jun 2018 17:40:15 +0900
Subject: [PATCH] bus: Fix SEGV in bus_panel_proxy_focus_in()
BUG=rhbz#1349148
@ -124,12 +124,12 @@ index b54ef817..e4dd8683 100644
if (incoming) {
/* is incoming message */
diff --git a/bus/ibusimpl.c b/bus/ibusimpl.c
index 58d205cf..34f6c909 100644
index ec1caea8..9ae3751b 100644
--- a/bus/ibusimpl.c
+++ b/bus/ibusimpl.c
@@ -357,13 +357,16 @@ _dbus_name_owner_changed_cb (BusDBusImpl *dbus,
else if (!g_strcmp0 (name, IBUS_SERVICE_PANEL_EXTENSION))
panel_type = PANEL_TYPE_EXTENSION;
@@ -484,13 +484,16 @@ _dbus_name_owner_changed_cb (BusDBusImpl *dbus,
else if (!g_strcmp0 (name, IBUS_SERVICE_PANEL_EXTENSION_EMOJI))
panel_type = PANEL_TYPE_EXTENSION_EMOJI;
- if (panel_type != PANEL_TYPE_NONE) {
+ do {
@ -140,12 +140,12 @@ index 58d205cf..34f6c909 100644
BusConnection *connection;
BusInputContext *context = NULL;
BusPanelProxy **panel = (panel_type == PANEL_TYPE_PANEL) ?
&ibus->panel : &ibus->extension;
&ibus->panel : &ibus->emoji_extension;
+ GDBusConnection *dbus_connection = NULL;
if (*panel != NULL) {
ibus_proxy_destroy ((IBusProxy *)(*panel));
@@ -372,9 +375,21 @@ _dbus_name_owner_changed_cb (BusDBusImpl *dbus,
@@ -499,9 +502,21 @@ _dbus_name_owner_changed_cb (BusDBusImpl *dbus,
g_assert (*panel == NULL);
}
@ -166,9 +166,9 @@ index 58d205cf..34f6c909 100644
+ }
+
*panel = bus_panel_proxy_new (connection, panel_type);
g_signal_connect (*panel,
@@ -406,7 +421,7 @@ _dbus_name_owner_changed_cb (BusDBusImpl *dbus,
if (panel_type == PANEL_TYPE_EXTENSION_EMOJI)
ibus->enable_emoji_extension = FALSE;
@@ -555,7 +570,7 @@ _dbus_name_owner_changed_cb (BusDBusImpl *dbus,
}
}
}

File diff suppressed because it is too large Load Diff

View File

@ -20,8 +20,6 @@
%global with_kde5 0
%endif
%global with_emoji_harfbuzz 1
%global ibus_api_version 1.0
# for bytecompile in %%{_datadir}/ibus/setup
@ -41,7 +39,7 @@
Name: ibus
Version: 1.5.18
Release: 6%{?dist}
Release: 7%{?dist}
Summary: Intelligent Input Bus for Linux OS
License: LGPLv2+
Group: System Environment/Libraries
@ -53,12 +51,8 @@ Source2: %{name}.conf.5
# Upstreamed patches.
# Patch0: %%{name}-HEAD.patch
Patch0: %{name}-HEAD.patch
%if %with_emoji_harfbuzz
# Under testing self rendering until Pango, Fontconfig, Cairo are stable
Patch1: %{name}-xx-emoji-harfbuzz.patch
%endif
# Under testing #1349148 #1385349 #1350291 #1406699 #1432252
Patch2: %{name}-1385349-segv-bus-proxy.patch
Patch1: %{name}-1385349-segv-bus-proxy.patch
BuildRequires: gettext-devel
BuildRequires: libtool
@ -82,6 +76,7 @@ BuildRequires: vala-devel
BuildRequires: vala-tools
# for AM_GCONF_SOURCE_2 in configure.ac
BuildRequires: GConf2-devel
BuildRequires: git
BuildRequires: intltool
BuildRequires: iso-codes-devel
BuildRequires: libnotify-devel
@ -92,11 +87,6 @@ BuildRequires: qt5-qtbase-devel
BuildRequires: cldr-emoji-annotation
BuildRequires: unicode-emoji
BuildRequires: unicode-ucd
%if %with_emoji_harfbuzz
BuildRequires: cairo-devel
BuildRequires: fontconfig-devel
BuildRequires: harfbuzz-devel
%endif
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Requires: %{name}-gtk2%{?_isa} = %{version}-%{release}
@ -260,14 +250,8 @@ The ibus-devel-docs package contains developer documentation for IBus
%prep
%setup -q
# %%patch0 -p1
%patch0 -p1
%autosetup -S git
# cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c ||
%if %with_emoji_harfbuzz
%patch1 -p1 -z .hb
%endif
%patch2 -p1 -z .segv
# prep test
diff client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c
@ -298,9 +282,6 @@ autoreconf -f -i -v
--enable-wayland \
%if ! %with_kde5
--disable-appindicator \
%endif
%if %with_emoji_harfbuzz
--enable-harfbuzz-for-emoji \
%endif
--enable-introspection \
%{nil}
@ -452,6 +433,10 @@ dconf update || :
%{_datadir}/gtk-doc/html/*
%changelog
* Wed Jun 20 2018 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.18-7
- Moved input focus on Emojier to engines' preedit
- Removed ibus-xx-emoji-harfbuzz.patch not to change session emoji font
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.5.18-6
- Rebuilt for Python 3.7