Update to 1.3.7
This commit is contained in:
parent
11fef93360
commit
60148ca4f1
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
ibus-1.3.6.tar.gz
|
||||
/ibus-1.3.7.tar.gz
|
||||
|
3360
ibus-541492-xkb.patch
Normal file
3360
ibus-541492-xkb.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,52 +1 @@
|
||||
commit 674bc53c30c8ac40e021da660f2af533ab015587
|
||||
Author: Daiki Ueno <ueno@unixuser.org>
|
||||
Date: Wed Jun 30 12:05:32 2010 +0900
|
||||
|
||||
Fix "Show language panel: Embedded in menu" behavior.
|
||||
|
||||
Signed-off-by: Daiki Ueno <ueno@unixuser.org>
|
||||
|
||||
diff --git a/ui/gtk/languagebar.py b/ui/gtk/languagebar.py
|
||||
index f22080f..2fc1cb7 100644
|
||||
--- a/ui/gtk/languagebar.py
|
||||
+++ b/ui/gtk/languagebar.py
|
||||
@@ -29,6 +29,7 @@ from handle import Handle
|
||||
from menu import menu_position,\
|
||||
ImageMenuItem,\
|
||||
Menu,\
|
||||
+ CheckMenuItem,\
|
||||
RadioMenuItem,\
|
||||
SeparatorMenuItem
|
||||
from engineabout import EngineAbout
|
||||
@@ -378,6 +379,8 @@ class LanguageBar(gtk.Toolbar):
|
||||
item = ImageMenuItem(prop = prop)
|
||||
self.__set_item_icon(item, prop)
|
||||
elif prop.type == ibus.PROP_TYPE_TOGGLE:
|
||||
+ item = CheckMenuItem(prop = prop)
|
||||
+ elif prop.type == ibus.PROP_TYPE_RADIO:
|
||||
item = RadioMenuItem(radio_group, prop = prop)
|
||||
radio_group = item
|
||||
elif prop.type == ibus.PROP_TYPE_SEPARATOR:
|
||||
diff --git a/ui/gtk/menu.py b/ui/gtk/menu.py
|
||||
index b9a6b44..53fa39f 100644
|
||||
--- a/ui/gtk/menu.py
|
||||
+++ b/ui/gtk/menu.py
|
||||
@@ -59,7 +59,7 @@ class Menu(gtk.Menu, PropItem):
|
||||
item = SeparatorMenuItem()
|
||||
radio_group = None
|
||||
elif prop.type == ibus.PROP_TYPE_MENU:
|
||||
- item = gtk.ImageMenuItem()
|
||||
+ item = ImageMenuItem(prop)
|
||||
if prop.icon:
|
||||
size = gtk.icon_size_lookup(gtk.ICON_SIZE_MENU)
|
||||
item.set_image(icon.IconWidget(prop.icon, size[0]))
|
||||
@@ -238,6 +238,9 @@ class SeparatorMenuItem(gtk.SeparatorMenuItem, PropItem):
|
||||
(gobject.TYPE_STRING, gobject.TYPE_INT)),
|
||||
}
|
||||
|
||||
+ def __init__(self):
|
||||
+ gtk.SeparatorMenuItem.__init__(self)
|
||||
+ PropItem.__init__(self, None)
|
||||
|
||||
|
||||
def menu_position(menu, button):
|
||||
|
30
ibus.spec
30
ibus.spec
@ -2,21 +2,24 @@
|
||||
%{!?gtk2_binary_version: %define gtk2_binary_version %(pkg-config --variable=gtk_binary_version gtk+-2.0)}
|
||||
%{!?gtk3_binary_version: %define gtk3_binary_version %(pkg-config --variable=gtk_binary_version gtk+-3.0)}
|
||||
|
||||
%define have_libxkbfile 1
|
||||
|
||||
%define glib_ver %([ -a %{_libdir}/pkgconfig/glib-2.0.pc ] && pkg-config --modversion glib-2.0 | cut -d. -f 1,2 || echo -n "999")
|
||||
%define gconf2_version 2.12.0
|
||||
%define dbus_python_version 0.83.0
|
||||
%define im_chooser_version 1.2.5
|
||||
|
||||
Name: ibus
|
||||
Version: 1.3.6
|
||||
Release: 5%{?dist}
|
||||
Version: 1.3.7
|
||||
Release: 1%{?dist}
|
||||
Summary: Intelligent Input Bus for Linux OS
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://code.google.com/p/ibus/
|
||||
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||
Source1: xinput-ibus
|
||||
Patch0: ibus-HEAD.patch
|
||||
# Patch0: ibus-HEAD.patch
|
||||
Patch1: ibus-541492-xkb.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -35,6 +38,9 @@ BuildRequires: GConf2-devel
|
||||
BuildRequires: pygobject2-devel
|
||||
BuildRequires: intltool
|
||||
BuildRequires: iso-codes-devel
|
||||
%if %have_libxkbfile
|
||||
BuildRequires: libxkbfile-devel
|
||||
%endif
|
||||
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: %{name}-gtk2 = %{version}-%{release}
|
||||
@ -117,9 +123,18 @@ The ibus-devel-docs package contains developer documentation for ibus
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
# %patch0 -p1
|
||||
%if %have_libxkbfile
|
||||
%patch1 -p1 -b .xkb
|
||||
%endif
|
||||
|
||||
%build
|
||||
%if %have_libxkbfile
|
||||
aclocal -I m4
|
||||
autoheader
|
||||
autoconf -f
|
||||
automake -a -c -f
|
||||
%endif
|
||||
%configure \
|
||||
--disable-static \
|
||||
--enable-gtk2 \
|
||||
@ -223,6 +238,10 @@ fi
|
||||
# %{_sysconfdir}/xdg/autostart/ibus.desktop
|
||||
%{_sysconfdir}/gconf/schemas/ibus.schemas
|
||||
%config %{_xinputconf}
|
||||
%if %have_libxkbfile
|
||||
%{_libexecdir}/ibus-engine-xkb
|
||||
%{_libexecdir}/ibus-xkb
|
||||
%endif
|
||||
|
||||
%files libs
|
||||
%defattr(-,root,root,-)
|
||||
@ -250,6 +269,9 @@ fi
|
||||
%{_datadir}/gtk-doc/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Aug 23 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.7-1
|
||||
- Update to 1.3.7
|
||||
|
||||
* Wed Jul 28 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.3.6-5
|
||||
- Rebuild against python 2.7
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user