git checkout gnome-desktop-testing until the package is available
disable setxkbmap
This commit is contained in:
parent
9263b028de
commit
3771817e30
20
ibus-xx-el10n.patch
Normal file
20
ibus-xx-el10n.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff --git a/src/tests/ibus-keypress.c b/src/tests/ibus-keypress.c
|
||||||
|
index bab05398..41f16b98 100644
|
||||||
|
--- a/src/tests/ibus-keypress.c
|
||||||
|
+++ b/src/tests/ibus-keypress.c
|
||||||
|
@@ -272,12 +272,15 @@ create_window ()
|
||||||
|
static void
|
||||||
|
test_keypress (void)
|
||||||
|
{
|
||||||
|
+#if 0
|
||||||
|
int status = 0;
|
||||||
|
GError *error = NULL;
|
||||||
|
|
||||||
|
+ /* setxkbmap is not available in RHEL10 */
|
||||||
|
g_spawn_command_line_sync ("setxkbmap -layout us",
|
||||||
|
NULL, NULL,
|
||||||
|
&status, &error);
|
||||||
|
+#endif
|
||||||
|
g_assert (register_ibus_engine ());
|
||||||
|
|
||||||
|
create_window ();
|
16
ibus.spec
16
ibus.spec
@ -61,7 +61,7 @@
|
|||||||
Name: ibus
|
Name: ibus
|
||||||
Version: 1.5.30
|
Version: 1.5.30
|
||||||
# https://github.com/fedora-infra/rpmautospec/issues/101
|
# https://github.com/fedora-infra/rpmautospec/issues/101
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Intelligent Input Bus for Linux OS
|
Summary: Intelligent Input Bus for Linux OS
|
||||||
License: LGPL-2.1-or-later
|
License: LGPL-2.1-or-later
|
||||||
URL: https://github.com/ibus/%name/wiki
|
URL: https://github.com/ibus/%name/wiki
|
||||||
@ -77,6 +77,8 @@ Patch2: %{name}-1385349-segv-bus-proxy.patch
|
|||||||
%if 0%{?fedora:0}%{?rhel:1}
|
%if 0%{?fedora:0}%{?rhel:1}
|
||||||
# Use mutter window manager in RHEL CI
|
# Use mutter window manager in RHEL CI
|
||||||
Patch100: %{name}-xx-desktop-testing-mutter.patch
|
Patch100: %{name}-xx-desktop-testing-mutter.patch
|
||||||
|
# Disable to run setxkbmap
|
||||||
|
Patch101: %{name}-xx-el10n.patch
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# autoreconf requires autopoint but not po.m4
|
# autoreconf requires autopoint but not po.m4
|
||||||
@ -138,7 +140,9 @@ Requires: python3-gobject
|
|||||||
# Owner of %%{_sysconfdir}/X11/xinit
|
# Owner of %%{_sysconfdir}/X11/xinit
|
||||||
Requires: xorg-x11-xinit
|
Requires: xorg-x11-xinit
|
||||||
%endif
|
%endif
|
||||||
|
%if 0%{?fedora:1}%{?rhel:0}
|
||||||
Requires: setxkbmap
|
Requires: setxkbmap
|
||||||
|
%endif
|
||||||
%if (0%{?fedora} > 29 || 0%{?rhel} > 8)
|
%if (0%{?fedora} > 29 || 0%{?rhel} > 8)
|
||||||
%else
|
%else
|
||||||
Requires: dbus-x11
|
Requires: dbus-x11
|
||||||
@ -405,6 +409,10 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-3.0/%{gtk3_binary_version}/immodules/im-ibus
|
|||||||
%if %{with gtk4}
|
%if %{with gtk4}
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-4.0/%{gtk4_binary_version}/immodules/libim-ibus.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-4.0/%{gtk4_binary_version}/immodules/libim-ibus.la
|
||||||
%endif
|
%endif
|
||||||
|
%if 0%{?fedora:0}%{?rhel:1}
|
||||||
|
# setxkbmap is not available in RHEL10
|
||||||
|
rm -f $RPM_BUILD_ROOT%{_datadir}/installed-tests/ibus/xkb-latin-layouts.test
|
||||||
|
%endif
|
||||||
|
|
||||||
# install man page
|
# install man page
|
||||||
for S in %{SOURCE3}
|
for S in %{SOURCE3}
|
||||||
@ -620,7 +628,11 @@ dconf update || :
|
|||||||
%{_datadir}/installed-tests/ibus
|
%{_datadir}/installed-tests/ibus
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu May 02 2024 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.30
|
* Tue May 14 2024 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.30-2
|
||||||
|
- git checkout gnome-desktop-testing until the package is available
|
||||||
|
- disable setxkbmap
|
||||||
|
|
||||||
|
* Thu May 02 2024 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.30-1
|
||||||
- Bump to 1.5.30
|
- Bump to 1.5.30
|
||||||
|
|
||||||
* Fri Apr 12 2024 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.30~rc3-2
|
* Fri Apr 12 2024 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.30~rc3-2
|
||||||
|
@ -16,11 +16,11 @@
|
|||||||
|
|
||||||
- name: Build and install GNOME installed-tests testing harness
|
- name: Build and install GNOME installed-tests testing harness
|
||||||
block:
|
block:
|
||||||
- name: Installing GNOME installed-tests testing harness
|
#- name: Installing GNOME installed-tests testing harness
|
||||||
when: gnome_desktop_testing_runner.matched == 0
|
# when: gnome_desktop_testing_runner.matched == 0
|
||||||
package:
|
# package:
|
||||||
name:
|
# name:
|
||||||
- gnome-desktop-testing
|
# - gnome-desktop-testing
|
||||||
- name: Installing common GNOME desktop components
|
- name: Installing common GNOME desktop components
|
||||||
package:
|
package:
|
||||||
name:
|
name:
|
||||||
@ -126,6 +126,32 @@
|
|||||||
- sushi
|
- sushi
|
||||||
- totem
|
- totem
|
||||||
|
|
||||||
|
- name: Fetching GNOME installed-tests testing harness source from remote repository
|
||||||
|
git:
|
||||||
|
repo: 'https://gitlab.gnome.org/GNOME/gnome-desktop-testing.git'
|
||||||
|
dest: gnome-desktop-testing
|
||||||
|
force: yes
|
||||||
|
|
||||||
|
- name: Checkout v2021.1 tag in GNOME installed-tests testing harness
|
||||||
|
command: git checkout -b v2021.1 refs/tags/v2021.1
|
||||||
|
args:
|
||||||
|
chdir: gnome-desktop-testing
|
||||||
|
|
||||||
|
- name: Configure GNOME installed-tests testing harness build
|
||||||
|
command: ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
|
||||||
|
args:
|
||||||
|
chdir: gnome-desktop-testing
|
||||||
|
|
||||||
|
- name: Build GNOME installed-tests testing harness
|
||||||
|
command: make
|
||||||
|
args:
|
||||||
|
chdir: gnome-desktop-testing
|
||||||
|
|
||||||
|
- name: Install GNOME installed-tests testing harness
|
||||||
|
command: make install
|
||||||
|
args:
|
||||||
|
chdir: gnome-desktop-testing
|
||||||
|
|
||||||
- name: Start IBus installed-tests testing harness
|
- name: Start IBus installed-tests testing harness
|
||||||
environment:
|
environment:
|
||||||
ANSIBLE: 1
|
ANSIBLE: 1
|
||||||
|
Loading…
Reference in New Issue
Block a user