Updated ibus-HEAD.patch to fix typo in data/dconf/profile/ibus
This commit is contained in:
parent
717e5a3b7d
commit
28f7f62c93
@ -1,11 +1,11 @@
|
|||||||
From 168b9a502b24a15e037d6f517165b8e068e4b5a1 Mon Sep 17 00:00:00 2001
|
From 15a9eb2a8f9a278b5e357d7dd7ffebedd05d0c5e Mon Sep 17 00:00:00 2001
|
||||||
From: fujiwarat <takao.fujiwara1@gmail.com>
|
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||||
Date: Sat, 6 Oct 2012 18:05:16 +0900
|
Date: Tue, 9 Oct 2012 17:21:01 +0900
|
||||||
Subject: [PATCH] Add ibus-xkb and libgnomekbd.
|
Subject: [PATCH] Add ibus-xkb and libgnomekbd.
|
||||||
|
|
||||||
---
|
---
|
||||||
bindings/vala/Gkbd-3.0.metadata | 1 +
|
bindings/vala/Gkbd-3.0.metadata | 1 +
|
||||||
bindings/vala/Makefile.am | 20 ++
|
bindings/vala/Makefile.am | 23 ++
|
||||||
bindings/vala/Xkl-1.0.metadata | 3 +
|
bindings/vala/Xkl-1.0.metadata | 3 +
|
||||||
client/x11/gdk-private.c | 3 +-
|
client/x11/gdk-private.c | 3 +-
|
||||||
configure.ac | 60 +++++
|
configure.ac | 60 +++++
|
||||||
@ -31,7 +31,7 @@ Subject: [PATCH] Add ibus-xkb and libgnomekbd.
|
|||||||
ui/gtk3/panel.vala | 365 +++++++++++++++++++++++----
|
ui/gtk3/panel.vala | 365 +++++++++++++++++++++++----
|
||||||
ui/gtk3/switcher.vala | 49 ++--
|
ui/gtk3/switcher.vala | 49 ++--
|
||||||
ui/gtk3/xkblayout.vala | 464 ++++++++++++++++++++++++++++++++++
|
ui/gtk3/xkblayout.vala | 464 ++++++++++++++++++++++++++++++++++
|
||||||
27 files changed, 2559 insertions(+), 603 deletions(-)
|
27 files changed, 2562 insertions(+), 603 deletions(-)
|
||||||
create mode 100644 bindings/vala/Gkbd-3.0.metadata
|
create mode 100644 bindings/vala/Gkbd-3.0.metadata
|
||||||
create mode 100644 bindings/vala/Xkl-1.0.metadata
|
create mode 100644 bindings/vala/Xkl-1.0.metadata
|
||||||
create mode 100644 engine/ibus-xkb/Makefile.am
|
create mode 100644 engine/ibus-xkb/Makefile.am
|
||||||
@ -52,7 +52,7 @@ index 0000000..661e6fd
|
|||||||
@@ -0,0 +1 @@
|
@@ -0,0 +1 @@
|
||||||
+Configuration cheader_filename="libgnomekbd/gkbd-configuration.h"
|
+Configuration cheader_filename="libgnomekbd/gkbd-configuration.h"
|
||||||
diff --git a/bindings/vala/Makefile.am b/bindings/vala/Makefile.am
|
diff --git a/bindings/vala/Makefile.am b/bindings/vala/Makefile.am
|
||||||
index abcc543..ed132e0 100644
|
index abcc543..307a161 100644
|
||||||
--- a/bindings/vala/Makefile.am
|
--- a/bindings/vala/Makefile.am
|
||||||
+++ b/bindings/vala/Makefile.am
|
+++ b/bindings/vala/Makefile.am
|
||||||
@@ -27,12 +27,22 @@ dist_vapi_DATA = \
|
@@ -27,12 +27,22 @@ dist_vapi_DATA = \
|
||||||
@ -78,13 +78,14 @@ index abcc543..ed132e0 100644
|
|||||||
|
|
||||||
ibus-@IBUS_API_VERSION@.vapi: $(vapi_deps)
|
ibus-@IBUS_API_VERSION@.vapi: $(vapi_deps)
|
||||||
$(AM_V_GEN) $(VAPIGEN) --library ibus-@IBUS_API_VERSION@ \
|
$(AM_V_GEN) $(VAPIGEN) --library ibus-@IBUS_API_VERSION@ \
|
||||||
@@ -41,11 +51,21 @@ ibus-@IBUS_API_VERSION@.vapi: $(vapi_deps)
|
@@ -41,13 +51,26 @@ ibus-@IBUS_API_VERSION@.vapi: $(vapi_deps)
|
||||||
$(top_srcdir)/src/IBus-@IBUS_API_VERSION@.gir \
|
$(top_srcdir)/src/IBus-@IBUS_API_VERSION@.gir \
|
||||||
$(srcdir)/IBus-1.0-custom.vala
|
$(srcdir)/IBus-1.0-custom.vala
|
||||||
|
|
||||||
+if ENABLE_LIBGNOMEKBD
|
+if ENABLE_LIBGNOMEKBD
|
||||||
+$(builddir)/gkbd.vapi:
|
+$(builddir)/gkbd.vapi:
|
||||||
+ $(VAPIGEN) --metadatadir . --library gkbd \
|
+ $(AM_V_GEN) $(VAPIGEN) --library gkbd \
|
||||||
|
+ --metadatadir $(srcdir) \
|
||||||
+ --pkg gtk+-3.0 --pkg glib-2.0 --pkg gmodule-2.0 \
|
+ --pkg gtk+-3.0 --pkg glib-2.0 --pkg gmodule-2.0 \
|
||||||
+ /usr/share/gir-1.0/Gkbd-3.0.gir
|
+ /usr/share/gir-1.0/Gkbd-3.0.gir
|
||||||
+ $(NULL)
|
+ $(NULL)
|
||||||
@ -99,7 +100,11 @@ index abcc543..ed132e0 100644
|
|||||||
+ Xkl-1.0.metadata \
|
+ Xkl-1.0.metadata \
|
||||||
$(NULL)
|
$(NULL)
|
||||||
|
|
||||||
|
+CLEANFILES = gkbd.vapi
|
||||||
|
+
|
||||||
MAINTAINERCLEANFILES = ibus-@IBUS_API_VERSION@.vapi
|
MAINTAINERCLEANFILES = ibus-@IBUS_API_VERSION@.vapi
|
||||||
|
|
||||||
|
-include $(top_srcdir)/git.mk
|
||||||
diff --git a/bindings/vala/Xkl-1.0.metadata b/bindings/vala/Xkl-1.0.metadata
|
diff --git a/bindings/vala/Xkl-1.0.metadata b/bindings/vala/Xkl-1.0.metadata
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..4961d0c
|
index 0000000..4961d0c
|
||||||
|
@ -1 +1,53 @@
|
|||||||
|
From f0fa7254fb1326489daa88ffed6af6d48cad49d0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||||
|
Date: Thu, 11 Oct 2012 16:04:38 +0900
|
||||||
|
Subject: [PATCH] Fix typo in data/dconf/profile/ibus
|
||||||
|
|
||||||
|
http://git.gnome.org/browse/gdm/commit/?id=aa25b559c6e907485cc9e
|
||||||
|
I copied the typo by mitake. dconf_engine_source_new() supports
|
||||||
|
"user-db" or "system-db".
|
||||||
|
http://git.gnome.org/browse/dconf/tree/engine/dconf-engine-source.c#n75
|
||||||
|
---
|
||||||
|
data/dconf/profile/ibus | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/data/dconf/profile/ibus b/data/dconf/profile/ibus
|
||||||
|
index 1d3fc5f..aa8fe5f 100644
|
||||||
|
--- a/data/dconf/profile/ibus
|
||||||
|
+++ b/data/dconf/profile/ibus
|
||||||
|
@@ -1,2 +1,2 @@
|
||||||
|
user-db:user
|
||||||
|
-systemd-db:ibus
|
||||||
|
+system-db:ibus
|
||||||
|
--
|
||||||
|
1.7.10.4
|
||||||
|
|
||||||
|
From 065ad6c44a665526796dffe91ac7c2ebd83ecd71 Mon Sep 17 00:00:00 2001
|
||||||
|
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||||
|
Date: Thu, 11 Oct 2012 16:43:06 +0900
|
||||||
|
Subject: [PATCH] Fix fallback 'C' locale in ibus-setup.
|
||||||
|
|
||||||
|
---
|
||||||
|
setup/main.py | 6 +++++-
|
||||||
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/setup/main.py b/setup/main.py
|
||||||
|
index 8a2391d..81e4301 100644
|
||||||
|
--- a/setup/main.py
|
||||||
|
+++ b/setup/main.py
|
||||||
|
@@ -548,7 +548,11 @@ class Setup(object):
|
||||||
|
Gtk.main()
|
||||||
|
|
||||||
|
if __name__ == "__main__":
|
||||||
|
- locale.setlocale(locale.LC_ALL, '')
|
||||||
|
+ try:
|
||||||
|
+ locale.setlocale(locale.LC_ALL, '')
|
||||||
|
+ except locale.Error:
|
||||||
|
+ print >> sys.stderr, "IBUS-WARNING **: Using the fallback 'C' locale"
|
||||||
|
+ locale.setlocale(locale.LC_ALL, 'C')
|
||||||
|
i18n_init()
|
||||||
|
setup = Setup()
|
||||||
|
setup.run()
|
||||||
|
--
|
||||||
|
1.7.10.4
|
||||||
|
|
||||||
|
@ -30,7 +30,7 @@
|
|||||||
|
|
||||||
Name: ibus
|
Name: ibus
|
||||||
Version: 1.4.99.20121006
|
Version: 1.4.99.20121006
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Intelligent Input Bus for Linux OS
|
Summary: Intelligent Input Bus for Linux OS
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -38,7 +38,7 @@ URL: http://code.google.com/p/ibus/
|
|||||||
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||||
Source1: xinput-ibus
|
Source1: xinput-ibus
|
||||||
Source2: http://fujiwara.fedorapeople.org/ibus/gnome-shell/ibus-gjs-%{ibus_gjs_version}.tar.gz
|
Source2: http://fujiwara.fedorapeople.org/ibus/gnome-shell/ibus-gjs-%{ibus_gjs_version}.tar.gz
|
||||||
# Patch0: ibus-HEAD.patch
|
Patch0: ibus-HEAD.patch
|
||||||
Patch1: ibus-810211-no-switch-by-no-trigger.patch
|
Patch1: ibus-810211-no-switch-by-no-trigger.patch
|
||||||
Patch2: ibus-541492-xkb.patch
|
Patch2: ibus-541492-xkb.patch
|
||||||
Patch3: ibus-530711-preload-sys.patch
|
Patch3: ibus-530711-preload-sys.patch
|
||||||
@ -211,6 +211,7 @@ zcat %SOURCE2 | tar xf -
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# patch0 -p1
|
# patch0 -p1
|
||||||
|
%patch0 -p1
|
||||||
%if 0%{?fedora} <= 17
|
%if 0%{?fedora} <= 17
|
||||||
%patch92 -p1 -b .g-s-preedit
|
%patch92 -p1 -b .g-s-preedit
|
||||||
cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c ||
|
cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c ||
|
||||||
@ -474,6 +475,9 @@ dconf update
|
|||||||
%{_datadir}/gtk-doc/html/*
|
%{_datadir}/gtk-doc/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 11 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20121006-2
|
||||||
|
- Updated ibus-HEAD.patch to fix typo in data/dconf/profile/ibus
|
||||||
|
|
||||||
* Sat Oct 06 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20121006-1
|
* Sat Oct 06 2012 Takao Fujiwara <tfujiwar@redhat.com> - 1.4.99.20121006-1
|
||||||
- Bumped to 1.4.99.20121006
|
- Bumped to 1.4.99.20121006
|
||||||
- Removed ibus-xx-segv-reg-prop.patch
|
- Removed ibus-xx-segv-reg-prop.patch
|
||||||
|
Loading…
Reference in New Issue
Block a user