Fixed Bug 640038 - unresolved reference to symbol gdk_drawable_get_size
This commit is contained in:
parent
793508187e
commit
20eb2be968
@ -1 +1,32 @@
|
|||||||
|
From 843c9e13f3363cf7f4ee131b13270e55cb9a2778 Mon Sep 17 00:00:00 2001
|
||||||
|
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||||
|
Date: Tue, 2 Nov 2010 11:21:24 +0900
|
||||||
|
Subject: [PATCH] Replace s/gdk_drawable_get_size/gdk_window_get_height/ for GTK3.
|
||||||
|
|
||||||
|
---
|
||||||
|
client/gtk2/ibusimcontext.c | 5 +++++
|
||||||
|
1 files changed, 5 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/client/gtk3/ibusimcontext.c b/client/gtk3/ibusimcontext.c
|
||||||
|
index 0bb71b5..c06faaa 100644
|
||||||
|
--- a/client/gtk3/ibusimcontext.c
|
||||||
|
+++ b/client/gtk3/ibusimcontext.c
|
||||||
|
@@ -669,10 +669,15 @@ _set_cursor_location_internal (GtkIMContext *context)
|
||||||
|
|
||||||
|
area = ibusimcontext->cursor_area;
|
||||||
|
if (area.x == -1 && area.y == -1 && area.width == 0 && area.height == 0) {
|
||||||
|
+#if GTK_CHECK_VERSION (2, 91, 0)
|
||||||
|
+ area.x = 0;
|
||||||
|
+ area.y += gdk_window_get_height (ibusimcontext->client_window);
|
||||||
|
+#else
|
||||||
|
gint w, h;
|
||||||
|
gdk_drawable_get_size (ibusimcontext->client_window, &w, &h);
|
||||||
|
area.y += h;
|
||||||
|
area.x = 0;
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
gdk_window_get_origin (ibusimcontext->client_window, &x, &y);
|
||||||
|
--
|
||||||
|
1.7.2.1
|
||||||
|
|
||||||
|
10
ibus.spec
10
ibus.spec
@ -11,14 +11,14 @@
|
|||||||
|
|
||||||
Name: ibus
|
Name: ibus
|
||||||
Version: 1.3.8
|
Version: 1.3.8
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Intelligent Input Bus for Linux OS
|
Summary: Intelligent Input Bus for Linux OS
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://code.google.com/p/ibus/
|
URL: http://code.google.com/p/ibus/
|
||||||
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
Source0: http://ibus.googlecode.com/files/%{name}-%{version}.tar.gz
|
||||||
Source1: xinput-ibus
|
Source1: xinput-ibus
|
||||||
# Patch0: ibus-HEAD.patch
|
Patch0: ibus-HEAD.patch
|
||||||
# Patch1: ibus-xx-va_list.patch
|
# Patch1: ibus-xx-va_list.patch
|
||||||
# Patch2: ibus-530711-preload-sys.patch
|
# Patch2: ibus-530711-preload-sys.patch
|
||||||
Patch3: ibus-541492-xkb.patch
|
Patch3: ibus-541492-xkb.patch
|
||||||
@ -130,7 +130,7 @@ The ibus-devel-docs package contains developer documentation for ibus
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
# %patch0 -p1
|
%patch0 -p1
|
||||||
# %patch1 -p1 -b .valist
|
# %patch1 -p1 -b .valist
|
||||||
# %patch2 -p1 -b .preload-sys
|
# %patch2 -p1 -b .preload-sys
|
||||||
%if %have_libxkbfile
|
%if %have_libxkbfile
|
||||||
@ -295,6 +295,10 @@ fi
|
|||||||
%{_datadir}/gtk-doc/html/*
|
%{_datadir}/gtk-doc/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 02 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.8-2
|
||||||
|
- Added ibus-HEAD.patch.
|
||||||
|
Fix Bug 640038 - unresolved reference to symbol gdk_drawable_get_size
|
||||||
|
|
||||||
* Fri Oct 22 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.8-1
|
* Fri Oct 22 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.8-1
|
||||||
- Updated to 1.3.8
|
- Updated to 1.3.8
|
||||||
- Added ibus-541492-xkb.patch
|
- Added ibus-541492-xkb.patch
|
||||||
|
Loading…
Reference in New Issue
Block a user