Bumped to 1.5.18

This commit is contained in:
Takao Fujiwara 2018-03-02 18:05:41 +09:00
parent d6bf0e42b2
commit 18b43f85bb
5 changed files with 18 additions and 18 deletions

3
.gitignore vendored
View File

@ -1,3 +1,4 @@
/cldr-emoji-annotation-30.0.3_2.tar.gz
/ibus-gjs-3.0.2.20110823.tar.gz /ibus-gjs-3.0.2.20110823.tar.gz
/ibus-gjs-3.1.4.20110823.tar.gz /ibus-gjs-3.1.4.20110823.tar.gz
/ibus-gjs-3.0.2.20110908.tar.gz /ibus-gjs-3.0.2.20110908.tar.gz
@ -51,6 +52,6 @@ ibus-1.3.6.tar.gz
/ibus-1.5.13.tar.gz /ibus-1.5.13.tar.gz
/ibus-1.5.14.tar.gz /ibus-1.5.14.tar.gz
/ibus-1.5.15.tar.gz /ibus-1.5.15.tar.gz
/cldr-emoji-annotation-30.0.3_2.tar.gz
/ibus-1.5.16.tar.gz /ibus-1.5.16.tar.gz
/ibus-1.5.17.tar.gz /ibus-1.5.17.tar.gz
/ibus-1.5.18.tar.gz

0
ibus-HEAD.patch Normal file
View File

View File

@ -1,6 +1,6 @@
From 158e06a10726a10393f1f6dd7237457b0b601f84 Mon Sep 17 00:00:00 2001 From 631ef573ebdd4f3fad8f036fcb33929e04372ab2 Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com> From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Wed, 21 Feb 2018 15:39:49 +0900 Date: Thu, 1 Mar 2018 16:05:04 +0900
Subject: [PATCH] Integrate custom rendering to use HarfBuzz glyph info Subject: [PATCH] Integrate custom rendering to use HarfBuzz glyph info
IBusFontSet offers FcFontSet, glyph info with HarfBuzz and rendering IBusFontSet offers FcFontSet, glyph info with HarfBuzz and rendering
@ -202,7 +202,7 @@ index bd41069b..243396ff 100644
]) ])
diff --git a/ui/gtk3/Makefile.am b/ui/gtk3/Makefile.am diff --git a/ui/gtk3/Makefile.am b/ui/gtk3/Makefile.am
index 0a8f4200..8bb2345d 100644 index bf9f98d7..388f80f9 100644
--- a/ui/gtk3/Makefile.am --- a/ui/gtk3/Makefile.am
+++ b/ui/gtk3/Makefile.am +++ b/ui/gtk3/Makefile.am
@@ -159,6 +159,8 @@ EXTRA_DIST = \ @@ -159,6 +159,8 @@ EXTRA_DIST = \
@ -213,8 +213,8 @@ index 0a8f4200..8bb2345d 100644
+ ibusfontset.h \ + ibusfontset.h \
notification-item.xml \ notification-item.xml \
notification-watcher.xml \ notification-watcher.xml \
panelbinding.vala \ ibus-ui-emojier.desktop.in.in \
@@ -247,6 +249,40 @@ panelbinding.o: $(srcdir)/panelbinding.c @@ -249,6 +251,40 @@ panelbinding.o: $(srcdir)/panelbinding.c
$(AM_V_CC_no)$(COMPILE) -c -o $@ $< $(AM_V_CC_no)$(COMPILE) -c -o $@ $<
$(NULL) $(NULL)
@ -256,7 +256,7 @@ index 0a8f4200..8bb2345d 100644
man_seven_DATA =$(man_seven_files:.7=.7.gz) man_seven_DATA =$(man_seven_files:.7=.7.gz)
man_sevendir = $(mandir)/man7 man_sevendir = $(mandir)/man7
diff --git a/ui/gtk3/emojier.vala b/ui/gtk3/emojier.vala diff --git a/ui/gtk3/emojier.vala b/ui/gtk3/emojier.vala
index c85dfa86..86482543 100644 index 8707e432..49619d1c 100644
--- a/ui/gtk3/emojier.vala --- a/ui/gtk3/emojier.vala
+++ b/ui/gtk3/emojier.vala +++ b/ui/gtk3/emojier.vala
@@ -99,16 +99,103 @@ public class IBusEmojier : Gtk.ApplicationWindow { @@ -99,16 +99,103 @@ public class IBusEmojier : Gtk.ApplicationWindow {
@ -381,7 +381,7 @@ index c85dfa86..86482543 100644
private ThemedRGBA m_rgba; private ThemedRGBA m_rgba;
private Gtk.Box m_vbox; private Gtk.Box m_vbox;
@@ -2070,6 +2161,22 @@ public class IBusEmojier : Gtk.ApplicationWindow { @@ -2116,6 +2207,22 @@ public class IBusEmojier : Gtk.ApplicationWindow {
} }
@ -404,7 +404,7 @@ index c85dfa86..86482543 100644
public static bool has_loaded_emoji_dict() { public static bool has_loaded_emoji_dict() {
if (m_emoji_to_data_dict == null) if (m_emoji_to_data_dict == null)
return false; return false;
@@ -2100,6 +2207,10 @@ public class IBusEmojier : Gtk.ApplicationWindow { @@ -2146,6 +2253,10 @@ public class IBusEmojier : Gtk.ApplicationWindow {
int font_size = font_desc.get_size() / Pango.SCALE; int font_size = font_desc.get_size() / Pango.SCALE;
if (font_size != 0) if (font_size != 0)
m_emoji_font_size = font_size; m_emoji_font_size = font_size;

View File

@ -29,8 +29,8 @@
%global dbus_python_version 0.83.0 %global dbus_python_version 0.83.0
Name: ibus Name: ibus
Version: 1.5.17 Version: 1.5.18
Release: 11%{?dist} Release: 1%{?dist}
Summary: Intelligent Input Bus for Linux OS Summary: Intelligent Input Bus for Linux OS
License: LGPLv2+ License: LGPLv2+
Group: System Environment/Libraries Group: System Environment/Libraries
@ -38,11 +38,9 @@ URL: https://github.com/ibus/%name/wiki
Source0: https://github.com/ibus/%name/releases/download/%{version}/%{name}-%{version}.tar.gz Source0: https://github.com/ibus/%name/releases/download/%{version}/%{name}-%{version}.tar.gz
Source1: %{name}-xinput Source1: %{name}-xinput
Source2: %{name}.conf.5 Source2: %{name}.conf.5
Source3: https://fujiwara.fedorapeople.org/ibus/po/%{name}-po-1.5.17-20180221.tar.gz
# Will remove the annotation tarball once the rpm is available on Fedora # Will remove the annotation tarball once the rpm is available on Fedora
# Upstreamed patches. # Upstreamed patches.
# Patch0: %%{name}-HEAD.patch # Patch0: %%{name}-HEAD.patch
Patch0: %{name}-HEAD.patch
%if %with_emoji_harfbuzz %if %with_emoji_harfbuzz
# Under testing self rendering until Pango, Fontconfig, Cairo are stable # Under testing self rendering until Pango, Fontconfig, Cairo are stable
Patch1: %{name}-xx-emoji-harfbuzz.patch Patch1: %{name}-xx-emoji-harfbuzz.patch
@ -250,15 +248,12 @@ The ibus-devel-docs package contains developer documentation for IBus
%prep %prep
%setup -q %setup -q
# %%patch0 -p1 # %%patch0 -p1
%patch0 -p1
# cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c || # cp client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c ||
%if %with_emoji_harfbuzz %if %with_emoji_harfbuzz
%patch1 -p1 -z .hb %patch1 -p1 -z .hb
%endif %endif
%patch2 -p1 -z .segv %patch2 -p1 -z .segv
zcat %SOURCE3 | tar xfvp -
# prep test # prep test
diff client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c diff client/gtk2/ibusimcontext.c client/gtk3/ibusimcontext.c
if test $? -ne 0 ; then if test $? -ne 0 ; then
@ -355,6 +350,8 @@ dconf update || :
%dir %{_datadir}/ibus/ %dir %{_datadir}/ibus/
%{_bindir}/ibus %{_bindir}/ibus
%{_bindir}/ibus-daemon %{_bindir}/ibus-daemon
%{_datadir}/applications/org.freedesktop.IBus.Panel.Emojier.desktop
%{_datadir}/applications/org.freedesktop.IBus.Panel.Extension.Gtk3.desktop
%{_datadir}/bash-completion/completions/ibus.bash %{_datadir}/bash-completion/completions/ibus.bash
%{_datadir}/dbus-1/services/*.service %{_datadir}/dbus-1/services/*.service
%{_datadir}/GConf/gsettings/* %{_datadir}/GConf/gsettings/*
@ -432,6 +429,9 @@ dconf update || :
%{_datadir}/gtk-doc/html/* %{_datadir}/gtk-doc/html/*
%changelog %changelog
* Fri Mar 02 2018 Takao Fujiwara <tfujiwar@redhat.com> - 1.5.18-1
- Bumped to 1.5.18
* Wed Feb 28 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.5.17-11 * Wed Feb 28 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.5.17-11
- Update Python 2 dependency declarations to new packaging standards - Update Python 2 dependency declarations to new packaging standards
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3) (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)

View File

@ -1,2 +1 @@
SHA512 (ibus-1.5.17.tar.gz) = 8a7e4fabbcb2096e647b1fb7487c92882bd320a4d777f2765817378abec2e60cafd63364c881fefc2805ff2baa6b28b15ee0710587662a3e65eeb60ead19496c SHA512 (ibus-1.5.18.tar.gz) = 34519c3464eaf2cac3320e1568fc76f4edb281afa70f335c015b828ff4e86b3224d77b95cdc0b2e76e42459c54b1044264ff226963fe739dd553ac7326d2f2d3
SHA512 (ibus-po-1.5.17-20180221.tar.gz) = db4c388cba66c669ea4c594dbf0fc66410d9c093347f9ec168696dfd68b546fb452a715a699b8589f39492c082daf1e578411011c5725eac43ed8b7409d533b3