Fixed Bug 654260 - NULL of focused input context
This commit is contained in:
parent
8a795bf3bf
commit
08b90e8e95
@ -376,3 +376,29 @@ index 978b467..98fa1d1 100644
|
|||||||
self.__builder.add_from_file(gtk_builder_file);
|
self.__builder.add_from_file(gtk_builder_file);
|
||||||
self.__bus = None
|
self.__bus = None
|
||||||
self.__init_bus()
|
self.__init_bus()
|
||||||
|
diff --git a/ui/gtk/engineabout.py b/ui/gtk/engineabout.py
|
||||||
|
index 3ac853a..a34e930 100644
|
||||||
|
--- a/ui/gtk/engineabout.py
|
||||||
|
+++ b/ui/gtk/engineabout.py
|
||||||
|
@@ -25,7 +25,7 @@ from gtk import gdk
|
||||||
|
import pango
|
||||||
|
import ibus
|
||||||
|
|
||||||
|
-from i18n import *
|
||||||
|
+from i18n import _, N_
|
||||||
|
|
||||||
|
class EngineAbout(gtk.Dialog):
|
||||||
|
def __init__(self, enginedesc):
|
||||||
|
diff --git a/bus/inputcontext.c b/bus/inputcontext.c
|
||||||
|
index ec72dd1..8af3ccb 100644
|
||||||
|
--- a/bus/inputcontext.c
|
||||||
|
+++ b/bus/inputcontext.c
|
||||||
|
@@ -699,7 +699,7 @@ _ic_process_key_event (BusInputContext *context,
|
||||||
|
/* workaround: set focus if context does not have focus */
|
||||||
|
BusInputContext *focused_context = bus_ibus_impl_get_focused_input_context (BUS_DEFAULT_IBUS);
|
||||||
|
if (context == NULL ||
|
||||||
|
- focused_context->fake == TRUE ||
|
||||||
|
+ (focused_context != NULL && focused_context->fake == TRUE) ||
|
||||||
|
context->fake == FALSE) {
|
||||||
|
/* grab focus, if context is a real IC or current focused IC is fake */
|
||||||
|
bus_input_context_focus_in (context);
|
||||||
|
12
ibus.spec
12
ibus.spec
@ -12,7 +12,7 @@
|
|||||||
|
|
||||||
Name: ibus
|
Name: ibus
|
||||||
Version: 1.3.99.20101028
|
Version: 1.3.99.20101028
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Intelligent Input Bus for Linux OS
|
Summary: Intelligent Input Bus for Linux OS
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -310,13 +310,15 @@ fi
|
|||||||
%{_datadir}/gtk-doc/html/*
|
%{_datadir}/gtk-doc/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Fri Oct 29 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20101028-2
|
* Thu Nov 18 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20101028-3
|
||||||
- Added ibus-652157-x11-ppc64.patch
|
- Added ibus-652157-x11-ppc64.patch
|
||||||
Fixes Bug 652157 - Window position of ibus-x11 in ppc64
|
Fixed Bug 652157 - Window position of ibus-x11 in ppc64
|
||||||
- Added ibus-530711-preload-sys.patch
|
- Added ibus-530711-preload-sys.patch
|
||||||
Fixes Bug 530711 - Reload preloaded engines by login
|
Fixed Bug 530711 - Reload preloaded engines by login
|
||||||
- Updated ibus-HEAD.patch
|
- Updated ibus-HEAD.patch
|
||||||
Fixes ibus.get_version & gettext domain for gtkbuilder
|
Fixed ibus.get_version & gettext domain for gtkbuilder
|
||||||
|
Fixed undefined '_' in EngineAbout
|
||||||
|
Fixed Bug 654260 - NULL of focused input context
|
||||||
- Applied no-snooper for 'gnome-do,Do.*,firefox.*,.*chrome.*,.*chromium.*'
|
- Applied no-snooper for 'gnome-do,Do.*,firefox.*,.*chrome.*,.*chromium.*'
|
||||||
|
|
||||||
* Fri Oct 29 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20101028-1
|
* Fri Oct 29 2010 Takao Fujiwara <tfujiwar@redhat.com> - 1.3.99.20101028-1
|
||||||
|
Loading…
Reference in New Issue
Block a user