Merge branch 'f18' into f19
This commit is contained in:
commit
f3f0e69c91
1
.gitignore
vendored
1
.gitignore
vendored
@ -54,3 +54,4 @@ hplip-3.10.6.tar.gz
|
|||||||
/hplip-3.13.2.tar.gz
|
/hplip-3.13.2.tar.gz
|
||||||
/hplip-3.13.3.tar.gz
|
/hplip-3.13.3.tar.gz
|
||||||
/hplip-3.13.4.tar.gz
|
/hplip-3.13.4.tar.gz
|
||||||
|
/hplip-3.13.5.tar.gz
|
||||||
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v1.4.11 (GNU/Linux)
|
|
||||||
|
|
||||||
iEYEABECAAYFAlFilg8ACgkQc9dwzaWQR7mjyQCeOrk6FE3i3zZXxPbL2MrxcbOq
|
|
||||||
MR4AniFyO5jFPdrtC05y9zMnIbM5nxH/
|
|
||||||
=qCIl
|
|
||||||
-----END PGP SIGNATURE-----
|
|
7
hplip-3.13.5.tar.gz.asc
Normal file
7
hplip-3.13.5.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v1.4.11 (GNU/Linux)
|
||||||
|
|
||||||
|
iEYEABECAAYFAlGMyHEACgkQc9dwzaWQR7mbhQCg6toDozQF4AOYtjUKU2oEdKDx
|
||||||
|
DYIAn0vw4HPVVDL+u95ug5xW8B+vgE+e
|
||||||
|
=Fbzl
|
||||||
|
-----END PGP SIGNATURE-----
|
@ -1,7 +1,7 @@
|
|||||||
diff -up hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp
|
diff -up hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp
|
||||||
--- hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2013-04-09 12:26:18.750566175 +0200
|
--- hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2013-05-14 15:01:34.288431852 +0200
|
||||||
+++ hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp 2013-04-09 12:27:07.525884647 +0200
|
+++ hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp 2013-05-14 15:03:08.103139571 +0200
|
||||||
@@ -452,7 +452,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
@@ -471,7 +471,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||||
m_DBusComm.sendEvent(EVENT_PRINT_FAILED_MISSING_PLUGIN, "Plugin missing", m_JA.job_id, m_JA.user_name);
|
m_DBusComm.sendEvent(EVENT_PRINT_FAILED_MISSING_PLUGIN, "Plugin missing", m_JA.job_id, m_JA.user_name);
|
||||||
|
|
||||||
}
|
}
|
||||||
@ -10,25 +10,25 @@ diff -up hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.13.4/p
|
|||||||
ppdClose(m_ppd);
|
ppdClose(m_ppd);
|
||||||
m_ppd = NULL;
|
m_ppd = NULL;
|
||||||
return err;
|
return err;
|
||||||
@@ -545,7 +545,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
@@ -564,7 +564,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||||
close(fd);
|
|
||||||
}
|
}
|
||||||
|
|
||||||
if (m_iLogLevel & BASIC_LOG)
|
if (m_iLogLevel & BASIC_LOG)
|
||||||
- dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()", err);
|
- dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()", err);
|
||||||
+ dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()\n", err);
|
+ dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()\n", err);
|
||||||
|
|
||||||
closeFilter();
|
closeFilter();
|
||||||
cupsRasterClose(cups_raster);
|
cupsRasterClose(cups_raster);
|
||||||
return 1;
|
@@ -576,7 +576,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||||
@@ -555,7 +555,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
|
||||||
close(fd);
|
|
||||||
}
|
}
|
||||||
|
|
||||||
if (m_iLogLevel & BASIC_LOG)
|
if (m_iLogLevel & BASIC_LOG)
|
||||||
- dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()");
|
- dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()");
|
||||||
+ dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()\n");
|
+ dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()\n");
|
||||||
|
|
||||||
closeFilter();
|
closeFilter();
|
||||||
cupsRasterClose(cups_raster);
|
cupsRasterClose(cups_raster);
|
||||||
return 0;
|
@@ -728,7 +728,7 @@ int HPCupsFilter::processRasterData(cups
|
||||||
@@ -705,7 +705,7 @@ int HPCupsFilter::processRasterData(cups
|
|
||||||
//Need to revisit to crosscheck if it is a firmware issue.
|
//Need to revisit to crosscheck if it is a firmware issue.
|
||||||
|
|
||||||
*m_pPrinterBuffer = 0x01;
|
*m_pPrinterBuffer = 0x01;
|
||||||
@ -37,9 +37,9 @@ diff -up hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.13.4/p
|
|||||||
}
|
}
|
||||||
|
|
||||||
if (this->isBlankRaster((BYTE *) m_pPrinterBuffer, &cups_header)) {
|
if (this->isBlankRaster((BYTE *) m_pPrinterBuffer, &cups_header)) {
|
||||||
diff -up hplip-3.13.4/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.13.4/prnt/hpcups/Lidil.cpp
|
diff -up hplip-3.13.5/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.13.5/prnt/hpcups/Lidil.cpp
|
||||||
--- hplip-3.13.4/prnt/hpcups/Lidil.cpp.dbglog-newline 2013-04-08 11:52:06.000000000 +0200
|
--- hplip-3.13.5/prnt/hpcups/Lidil.cpp.dbglog-newline 2013-05-10 12:03:36.000000000 +0200
|
||||||
+++ hplip-3.13.4/prnt/hpcups/Lidil.cpp 2013-04-09 12:26:19.400557093 +0200
|
+++ hplip-3.13.5/prnt/hpcups/Lidil.cpp 2013-05-14 15:01:34.985422251 +0200
|
||||||
@@ -103,7 +103,7 @@ DRIVER_ERROR Lidil::Configure(Pipeline *
|
@@ -103,7 +103,7 @@ DRIVER_ERROR Lidil::Configure(Pipeline *
|
||||||
if (m_pPM->BaseResX != m_pQA->horizontal_resolution ||
|
if (m_pPM->BaseResX != m_pQA->horizontal_resolution ||
|
||||||
m_pPM->BaseResY != m_pQA->vertical_resolution)
|
m_pPM->BaseResY != m_pQA->vertical_resolution)
|
||||||
@ -94,9 +94,9 @@ diff -up hplip-3.13.4/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.13.4/prnt/hpc
|
|||||||
return false;
|
return false;
|
||||||
}
|
}
|
||||||
|
|
||||||
diff -up hplip-3.13.4/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.13.4/prnt/hpcups/Pcl3.cpp
|
diff -up hplip-3.13.5/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.13.5/prnt/hpcups/Pcl3.cpp
|
||||||
--- hplip-3.13.4/prnt/hpcups/Pcl3.cpp.dbglog-newline 2013-04-08 11:52:06.000000000 +0200
|
--- hplip-3.13.5/prnt/hpcups/Pcl3.cpp.dbglog-newline 2013-05-10 12:03:36.000000000 +0200
|
||||||
+++ hplip-3.13.4/prnt/hpcups/Pcl3.cpp 2013-04-09 12:26:19.400557093 +0200
|
+++ hplip-3.13.5/prnt/hpcups/Pcl3.cpp 2013-05-14 15:01:34.985422251 +0200
|
||||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3::Configure(Pipeline **
|
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3::Configure(Pipeline **
|
||||||
|
|
||||||
if (!selectPrintMode())
|
if (!selectPrintMode())
|
||||||
@ -140,9 +140,9 @@ diff -up hplip-3.13.4/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.13.4/prnt/hpcu
|
|||||||
return false;
|
return false;
|
||||||
}
|
}
|
||||||
|
|
||||||
diff -up hplip-3.13.4/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.13.4/prnt/hpcups/Pcl3Gui.cpp
|
diff -up hplip-3.13.5/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.13.5/prnt/hpcups/Pcl3Gui.cpp
|
||||||
--- hplip-3.13.4/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2013-04-08 11:52:06.000000000 +0200
|
--- hplip-3.13.5/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2013-05-10 12:03:36.000000000 +0200
|
||||||
+++ hplip-3.13.4/prnt/hpcups/Pcl3Gui.cpp 2013-04-09 12:26:19.400557093 +0200
|
+++ hplip-3.13.5/prnt/hpcups/Pcl3Gui.cpp 2013-05-14 15:01:34.986422237 +0200
|
||||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3Gui::Configure(Pipeline
|
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3Gui::Configure(Pipeline
|
||||||
|
|
||||||
if (!selectPrintMode())
|
if (!selectPrintMode())
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up hplip-3.13.4/fax/backend/hpfax.py.logdir hplip-3.13.4/fax/backend/hpfax.py
|
diff -up hplip-3.13.5/fax/backend/hpfax.py.logdir hplip-3.13.5/fax/backend/hpfax.py
|
||||||
--- hplip-3.13.4/fax/backend/hpfax.py.logdir 2013-04-08 11:58:34.000000000 +0200
|
--- hplip-3.13.5/fax/backend/hpfax.py.logdir 2013-05-10 12:09:22.000000000 +0200
|
||||||
+++ hplip-3.13.4/fax/backend/hpfax.py 2013-04-09 12:12:18.485307795 +0200
|
+++ hplip-3.13.5/fax/backend/hpfax.py 2013-05-14 14:57:19.458942171 +0200
|
||||||
@@ -244,7 +244,7 @@ else:
|
@@ -244,7 +244,7 @@ else:
|
||||||
input_fd = 0
|
input_fd = 0
|
||||||
|
|
||||||
@ -10,9 +10,9 @@ diff -up hplip-3.13.4/fax/backend/hpfax.py.logdir hplip-3.13.4/fax/backend/hpfax
|
|||||||
|
|
||||||
|
|
||||||
pipe_name = os.path.join(tmp_dir, "hpfax-pipe-%d" % job_id)
|
pipe_name = os.path.join(tmp_dir, "hpfax-pipe-%d" % job_id)
|
||||||
diff -up hplip-3.13.4/logcapture.py.logdir hplip-3.13.4/logcapture.py
|
diff -up hplip-3.13.5/logcapture.py.logdir hplip-3.13.5/logcapture.py
|
||||||
--- hplip-3.13.4/logcapture.py.logdir 2013-04-08 11:58:45.000000000 +0200
|
--- hplip-3.13.5/logcapture.py.logdir 2013-05-10 12:09:32.000000000 +0200
|
||||||
+++ hplip-3.13.4/logcapture.py 2013-04-09 12:12:18.485307795 +0200
|
+++ hplip-3.13.5/logcapture.py 2013-05-14 14:57:19.458942171 +0200
|
||||||
@@ -39,7 +39,7 @@ CUPS_BACKUP_FILE='/etc/cups/cupsd.conf_o
|
@@ -39,7 +39,7 @@ CUPS_BACKUP_FILE='/etc/cups/cupsd.conf_o
|
||||||
LOG_FOLDER_PATH='./'
|
LOG_FOLDER_PATH='./'
|
||||||
LOG_FOLDER_NAME='hplip_troubleshoot_logs'
|
LOG_FOLDER_NAME='hplip_troubleshoot_logs'
|
||||||
@ -31,9 +31,9 @@ diff -up hplip-3.13.4/logcapture.py.logdir hplip-3.13.4/logcapture.py
|
|||||||
if File_list:
|
if File_list:
|
||||||
sts,out = utils.run('cp -f %s %s'%(File_list_str, LOG_FILES))
|
sts,out = utils.run('cp -f %s %s'%(File_list_str, LOG_FILES))
|
||||||
if sts != 0:
|
if sts != 0:
|
||||||
diff -up hplip-3.13.4/prnt/filters/hplipjs.c.logdir hplip-3.13.4/prnt/filters/hplipjs.c
|
diff -up hplip-3.13.5/prnt/filters/hplipjs.c.logdir hplip-3.13.5/prnt/filters/hplipjs.c
|
||||||
--- hplip-3.13.4/prnt/filters/hplipjs.c.logdir 2013-04-08 11:53:27.000000000 +0200
|
--- hplip-3.13.5/prnt/filters/hplipjs.c.logdir 2013-05-10 12:04:50.000000000 +0200
|
||||||
+++ hplip-3.13.4/prnt/filters/hplipjs.c 2013-04-09 12:12:18.486307781 +0200
|
+++ hplip-3.13.5/prnt/filters/hplipjs.c 2013-05-14 14:57:19.459942157 +0200
|
||||||
@@ -275,7 +275,8 @@ int main (int argc, char **argv)
|
@@ -275,7 +275,8 @@ int main (int argc, char **argv)
|
||||||
{
|
{
|
||||||
fprintf (stderr, "DEBUG: HPLIPJS: argv[%d] = %s\n", i, argv[i]);
|
fprintf (stderr, "DEBUG: HPLIPJS: argv[%d] = %s\n", i, argv[i]);
|
||||||
@ -44,9 +44,9 @@ diff -up hplip-3.13.4/prnt/filters/hplipjs.c.logdir hplip-3.13.4/prnt/filters/hp
|
|||||||
|
|
||||||
HPFp = fopen (szPSFile, "w");
|
HPFp = fopen (szPSFile, "w");
|
||||||
#endif
|
#endif
|
||||||
diff -up hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp
|
diff -up hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp
|
||||||
--- hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.logdir 2013-04-09 12:12:18.478307892 +0200
|
--- hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp.logdir 2013-05-14 14:57:19.450942281 +0200
|
||||||
+++ hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp 2013-04-09 12:15:34.838563875 +0200
|
+++ hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp 2013-05-14 14:59:45.745927028 +0200
|
||||||
@@ -31,7 +31,9 @@
|
@@ -31,7 +31,9 @@
|
||||||
\*****************************************************************************/
|
\*****************************************************************************/
|
||||||
|
|
||||||
@ -57,13 +57,13 @@ diff -up hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.13.4/prnt/hpcu
|
|||||||
#include <sys/wait.h>
|
#include <sys/wait.h>
|
||||||
#include <sys/utsname.h>
|
#include <sys/utsname.h>
|
||||||
#include <time.h>
|
#include <time.h>
|
||||||
@@ -39,9 +41,15 @@
|
@@ -39,10 +41,15 @@
|
||||||
|
|
||||||
#define HP_FILE_VERSION_STR "03.09.08.0"
|
#define HP_FILE_VERSION_STR "03.09.08.0"
|
||||||
|
|
||||||
+char *env_tmpdir = NULL;
|
+char *env_tmpdir = NULL;
|
||||||
+
|
|
||||||
static HPCupsFilter filter;
|
static HPCupsFilter filter;
|
||||||
|
|
||||||
int main (int argc, char *argv[])
|
int main (int argc, char *argv[])
|
||||||
{
|
{
|
||||||
+ env_tmpdir = getenv ("TMPDIR");
|
+ env_tmpdir = getenv ("TMPDIR");
|
||||||
@ -73,7 +73,7 @@ diff -up hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.13.4/prnt/hpcu
|
|||||||
openlog("hpcups", LOG_PID, LOG_DAEMON);
|
openlog("hpcups", LOG_PID, LOG_DAEMON);
|
||||||
|
|
||||||
if (argc < 6 || argc > 7) {
|
if (argc < 6 || argc > 7) {
|
||||||
@@ -587,9 +595,10 @@ int HPCupsFilter::processRasterData(cups
|
@@ -610,9 +617,10 @@ int HPCupsFilter::processRasterData(cups
|
||||||
DRIVER_ERROR err;
|
DRIVER_ERROR err;
|
||||||
int ret_status = 0;
|
int ret_status = 0;
|
||||||
|
|
||||||
@ -86,8 +86,8 @@ diff -up hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.13.4/prnt/hpcu
|
|||||||
|
|
||||||
|
|
||||||
while (cupsRasterReadHeader2(cups_raster, &cups_header))
|
while (cupsRasterReadHeader2(cups_raster, &cups_header))
|
||||||
@@ -651,14 +660,15 @@ int HPCupsFilter::processRasterData(cups
|
@@ -675,14 +683,15 @@ int HPCupsFilter::processRasterData(cups
|
||||||
|
// Save Raster file for Debugging
|
||||||
if (m_iLogLevel & SAVE_INPUT_RASTERS)
|
if (m_iLogLevel & SAVE_INPUT_RASTERS)
|
||||||
{
|
{
|
||||||
- char szFileName[64];
|
- char szFileName[64];
|
||||||
@ -104,7 +104,7 @@ diff -up hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.13.4/prnt/hpcu
|
|||||||
createTempFile(szFileName, &cfp);
|
createTempFile(szFileName, &cfp);
|
||||||
if (cfp)
|
if (cfp)
|
||||||
{
|
{
|
||||||
@@ -669,7 +679,7 @@ int HPCupsFilter::processRasterData(cups
|
@@ -693,7 +702,7 @@ int HPCupsFilter::processRasterData(cups
|
||||||
if (cups_header.cupsColorSpace == CUPS_CSPACE_RGBW ||
|
if (cups_header.cupsColorSpace == CUPS_CSPACE_RGBW ||
|
||||||
cups_header.cupsColorSpace == CUPS_CSPACE_K)
|
cups_header.cupsColorSpace == CUPS_CSPACE_K)
|
||||||
{
|
{
|
||||||
@ -113,9 +113,9 @@ diff -up hplip-3.13.4/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.13.4/prnt/hpcu
|
|||||||
createTempFile(szFileName, &kfp);
|
createTempFile(szFileName, &kfp);
|
||||||
if (kfp)
|
if (kfp)
|
||||||
{
|
{
|
||||||
diff -up hplip-3.13.4/prnt/hpcups/LJZjStream.cpp.logdir hplip-3.13.4/prnt/hpcups/LJZjStream.cpp
|
diff -up hplip-3.13.5/prnt/hpcups/LJZjStream.cpp.logdir hplip-3.13.5/prnt/hpcups/LJZjStream.cpp
|
||||||
--- hplip-3.13.4/prnt/hpcups/LJZjStream.cpp.logdir 2013-04-08 11:52:06.000000000 +0200
|
--- hplip-3.13.5/prnt/hpcups/LJZjStream.cpp.logdir 2013-05-10 12:03:36.000000000 +0200
|
||||||
+++ hplip-3.13.4/prnt/hpcups/LJZjStream.cpp 2013-04-09 12:12:18.487307767 +0200
|
+++ hplip-3.13.5/prnt/hpcups/LJZjStream.cpp 2013-05-14 14:57:19.460942143 +0200
|
||||||
@@ -42,9 +42,12 @@
|
@@ -42,9 +42,12 @@
|
||||||
#include "LJZjStream.h"
|
#include "LJZjStream.h"
|
||||||
#include "Utils.h"
|
#include "Utils.h"
|
||||||
@ -144,9 +144,9 @@ diff -up hplip-3.13.4/prnt/hpcups/LJZjStream.cpp.logdir hplip-3.13.4/prnt/hpcups
|
|||||||
|
|
||||||
if (1 != m_pJA->pre_process_raster || !firstpage_cups_header->Duplex){
|
if (1 != m_pJA->pre_process_raster || !firstpage_cups_header->Duplex){
|
||||||
return NO_ERROR;
|
return NO_ERROR;
|
||||||
diff -up hplip-3.13.4/prnt/hpcups/SystemServices.cpp.logdir hplip-3.13.4/prnt/hpcups/SystemServices.cpp
|
diff -up hplip-3.13.5/prnt/hpcups/SystemServices.cpp.logdir hplip-3.13.5/prnt/hpcups/SystemServices.cpp
|
||||||
--- hplip-3.13.4/prnt/hpcups/SystemServices.cpp.logdir 2013-04-08 11:52:06.000000000 +0200
|
--- hplip-3.13.5/prnt/hpcups/SystemServices.cpp.logdir 2013-05-10 12:03:36.000000000 +0200
|
||||||
+++ hplip-3.13.4/prnt/hpcups/SystemServices.cpp 2013-04-09 12:12:18.488307753 +0200
|
+++ hplip-3.13.5/prnt/hpcups/SystemServices.cpp 2013-05-14 14:57:19.460942143 +0200
|
||||||
@@ -31,14 +31,17 @@
|
@@ -31,14 +31,17 @@
|
||||||
#include "CommonDefinitions.h"
|
#include "CommonDefinitions.h"
|
||||||
#include "SystemServices.h"
|
#include "SystemServices.h"
|
||||||
@ -167,9 +167,9 @@ diff -up hplip-3.13.4/prnt/hpcups/SystemServices.cpp.logdir hplip-3.13.4/prnt/hp
|
|||||||
|
|
||||||
createTempFile(fname, &m_fp);
|
createTempFile(fname, &m_fp);
|
||||||
if (m_fp)
|
if (m_fp)
|
||||||
diff -up hplip-3.13.4/prnt/hpijs/hpcupsfax.cpp.logdir hplip-3.13.4/prnt/hpijs/hpcupsfax.cpp
|
diff -up hplip-3.13.5/prnt/hpijs/hpcupsfax.cpp.logdir hplip-3.13.5/prnt/hpijs/hpcupsfax.cpp
|
||||||
--- hplip-3.13.4/prnt/hpijs/hpcupsfax.cpp.logdir 2013-04-08 11:53:31.000000000 +0200
|
--- hplip-3.13.5/prnt/hpijs/hpcupsfax.cpp.logdir 2013-05-10 12:04:54.000000000 +0200
|
||||||
+++ hplip-3.13.4/prnt/hpijs/hpcupsfax.cpp 2013-04-09 12:12:18.488307753 +0200
|
+++ hplip-3.13.5/prnt/hpijs/hpcupsfax.cpp 2013-05-14 14:57:19.461942130 +0200
|
||||||
@@ -29,6 +29,7 @@
|
@@ -29,6 +29,7 @@
|
||||||
POSSIBILITY OF SUCH DAMAGE.
|
POSSIBILITY OF SUCH DAMAGE.
|
||||||
\*****************************************************************************/
|
\*****************************************************************************/
|
||||||
@ -219,9 +219,9 @@ diff -up hplip-3.13.4/prnt/hpijs/hpcupsfax.cpp.logdir hplip-3.13.4/prnt/hpijs/hp
|
|||||||
|
|
||||||
// fdFax = mkstemp (hpFileName);
|
// fdFax = mkstemp (hpFileName);
|
||||||
fdFax = createTempFile(hpFileName, &pFilePtrFax);
|
fdFax = createTempFile(hpFileName, &pFilePtrFax);
|
||||||
diff -up hplip-3.13.4/prnt/hpijs/hpijs.cpp.logdir hplip-3.13.4/prnt/hpijs/hpijs.cpp
|
diff -up hplip-3.13.5/prnt/hpijs/hpijs.cpp.logdir hplip-3.13.5/prnt/hpijs/hpijs.cpp
|
||||||
--- hplip-3.13.4/prnt/hpijs/hpijs.cpp.logdir 2013-04-09 12:12:18.475307934 +0200
|
--- hplip-3.13.5/prnt/hpijs/hpijs.cpp.logdir 2013-05-14 14:57:19.448942309 +0200
|
||||||
+++ hplip-3.13.4/prnt/hpijs/hpijs.cpp 2013-04-09 12:12:18.489307739 +0200
|
+++ hplip-3.13.5/prnt/hpijs/hpijs.cpp 2013-05-14 14:57:19.461942130 +0200
|
||||||
@@ -29,6 +29,7 @@
|
@@ -29,6 +29,7 @@
|
||||||
POSSIBILITY OF SUCH DAMAGE.
|
POSSIBILITY OF SUCH DAMAGE.
|
||||||
\*****************************************************************************/
|
\*****************************************************************************/
|
||||||
@ -273,9 +273,9 @@ diff -up hplip-3.13.4/prnt/hpijs/hpijs.cpp.logdir hplip-3.13.4/prnt/hpijs/hpijs.
|
|||||||
if ((pSS->InitScript(szCapOutFile, TRUE)) != NO_ERROR)
|
if ((pSS->InitScript(szCapOutFile, TRUE)) != NO_ERROR)
|
||||||
BUG("unable to init capture");
|
BUG("unable to init capture");
|
||||||
#endif
|
#endif
|
||||||
diff -up hplip-3.13.4/prnt/hpijs/hpijsfax.cpp.logdir hplip-3.13.4/prnt/hpijs/hpijsfax.cpp
|
diff -up hplip-3.13.5/prnt/hpijs/hpijsfax.cpp.logdir hplip-3.13.5/prnt/hpijs/hpijsfax.cpp
|
||||||
--- hplip-3.13.4/prnt/hpijs/hpijsfax.cpp.logdir 2013-04-08 11:53:31.000000000 +0200
|
--- hplip-3.13.5/prnt/hpijs/hpijsfax.cpp.logdir 2013-05-10 12:04:54.000000000 +0200
|
||||||
+++ hplip-3.13.4/prnt/hpijs/hpijsfax.cpp 2013-04-09 12:12:18.489307739 +0200
|
+++ hplip-3.13.5/prnt/hpijs/hpijsfax.cpp 2013-05-14 14:57:19.462942116 +0200
|
||||||
@@ -31,6 +31,7 @@
|
@@ -31,6 +31,7 @@
|
||||||
|
|
||||||
#ifdef HAVE_LIBHPIP
|
#ifdef HAVE_LIBHPIP
|
||||||
|
@ -1,23 +1,26 @@
|
|||||||
diff -up hplip-3.12.11/data/rules/56-hpmud_support.rules.udev-rules hplip-3.12.11/data/rules/56-hpmud_support.rules
|
diff -up hplip-3.13.5/data/rules/56-hpmud.rules.udev-rules hplip-3.13.5/data/rules/56-hpmud.rules
|
||||||
--- hplip-3.12.11/data/rules/56-hpmud_support.rules.udev-rules 2012-11-20 10:53:51.000000000 +0100
|
--- hplip-3.13.5/data/rules/56-hpmud.rules.udev-rules 2013-05-10 12:08:05.000000000 +0200
|
||||||
+++ hplip-3.12.11/data/rules/56-hpmud_support.rules 2012-11-27 10:07:00.377519016 +0100
|
+++ hplip-3.13.5/data/rules/56-hpmud.rules 2013-05-14 19:03:18.003846301 +0200
|
||||||
@@ -6,6 +6,7 @@ SUBSYSTEM!="usb_device", GOTO="hpmud_rul
|
@@ -11,8 +11,8 @@ LABEL="hpmud_usb_rules"
|
||||||
|
ATTR{idVendor}=="03f0", ATTR{idProduct}=="????", OWNER="root", GROUP="lp", MODE="0660", ENV{sane_hpaio}="yes", ENV{libsane_matched}="yes", ENV{hp_test}="yes", ENV{ID_HPLIP}="1"
|
||||||
|
|
||||||
LABEL="pid_test"
|
|
||||||
|
|
||||||
+ENV{ID_USB_INTERFACES}=="", IMPORT{program}="usb_id --export %p"
|
-# This rule will add the printer and install plugin
|
||||||
# Check for LaserJet products (0x03f0xx17).
|
-ENV{hp_test}=="yes", PROGRAM="/bin/sh -c 'logger -p user.info loading HP Device $env{BUSNUM} $env{DEVNUM}'", RUN+="/bin/sh -c 'if [ -f /usr/bin/systemctl ]; then /usr/bin/systemctl --no-block start hplip-printer@$env{BUSNUM}:$env{DEVNUM}.service; else /usr/bin/hp-config_usb_printer $env{BUSNUM}:$env{DEVNUM}; fi'"
|
||||||
ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??17", ENV{hp_model}="$attrs{product}", ENV{hp_test}="yes"
|
+# This rule will install plugin
|
||||||
# Check for LaserJet products (0x03f0xx2a).
|
+ENV{hp_test}=="yes", PROGRAM="/bin/sh -c 'logger -p user.info loading HP Device $env{BUSNUM} $env{DEVNUM}'", RUN+="/bin/sh -c '/usr/bin/python /usr/share/hplip/check-plugin.py -m $env{BUSNUM}:$env{DEVNUM} &'"
|
||||||
diff -up hplip-3.12.11/Makefile.in.udev-rules hplip-3.12.11/Makefile.in
|
|
||||||
--- hplip-3.12.11/Makefile.in.udev-rules 2012-11-20 10:55:50.000000000 +0100
|
# If sane-bankends is installed add hpaio backend support to dll.conf if needed.
|
||||||
+++ hplip-3.12.11/Makefile.in 2012-11-27 10:07:00.380518971 +0100
|
ENV{sane_hpaio}=="yes", RUN+="/bin/sh -c 'grep -q ^#hpaio /etc/sane.d/dll.conf;if [ $$? -eq 0 ];then sed -i -e s/^#hpaio/hpaio/ /etc/sane.d/dll.conf;else grep -q ^hpaio /etc/sane.d/dll.conf;if [ $$? -ne 0 ];then echo hpaio >>/etc/sane.d/dll.conf;fi;fi'"
|
||||||
@@ -4353,7 +4353,7 @@ cups_drv = prnt/drv/hpcups.drv
|
diff -up hplip-3.13.5/Makefile.in.udev-rules hplip-3.13.5/Makefile.in
|
||||||
|
--- hplip-3.13.5/Makefile.in.udev-rules 2013-05-14 12:45:14.670392763 +0200
|
||||||
|
+++ hplip-3.13.5/Makefile.in 2013-05-14 12:47:24.779623958 +0200
|
||||||
|
@@ -4369,7 +4369,7 @@ cups_drv = prnt/drv/hpcups.drv
|
||||||
@HPLIP_BUILD_TRUE@dist_cron_DATA = data/rules/hplip_cron
|
@HPLIP_BUILD_TRUE@dist_cron_DATA = data/rules/hplip_cron
|
||||||
|
|
||||||
# hpmud.rules
|
# hpmud.rules
|
||||||
-@HPLIP_BUILD_TRUE@rulesdir = /etc/udev/rules.d
|
-@HPLIP_BUILD_TRUE@rulesdir = /etc/udev/rules.d
|
||||||
+@HPLIP_BUILD_TRUE@rulesdir = /usr/lib/udev/rules.d
|
+@HPLIP_BUILD_TRUE@rulesdir = /usr/lib/udev/rules.d
|
||||||
@HPLIP_BUILD_TRUE@@UDEV_SYSFS_RULES_FALSE@dist_rules_DATA = data/rules/56-hpmud_support.rules \
|
@HPLIP_BUILD_TRUE@@UDEV_SYSFS_RULES_FALSE@dist_rules_DATA = data/rules/56-hpmud.rules
|
||||||
@HPLIP_BUILD_TRUE@@UDEV_SYSFS_RULES_FALSE@ data/rules/86-hpmud_plugin.rules \
|
@HPLIP_BUILD_TRUE@@UDEV_SYSFS_RULES_TRUE@dist_rules_DATA = data/rules/56-hpmud_sysfs.rules
|
||||||
@HPLIP_BUILD_TRUE@@UDEV_SYSFS_RULES_FALSE@ data/rules/56-hpmud_add_printer.rules \
|
@HPLIP_BUILD_TRUE@halpredir = /usr/share/hal/fdi/preprobe/10osvendor
|
||||||
|
13
hplip.spec
13
hplip.spec
@ -6,8 +6,8 @@
|
|||||||
|
|
||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.13.4
|
Version: 3.13.5
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ and MIT
|
License: GPLv2+ and MIT
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
|
|
||||||
@ -185,8 +185,8 @@ mv prnt/drv/hpijs.drv.in{,.deviceIDs-drv-hpijs}
|
|||||||
# directly (bug #552572).
|
# directly (bug #552572).
|
||||||
%patch6 -p1 -b .mucks-with-spooldir
|
%patch6 -p1 -b .mucks-with-spooldir
|
||||||
|
|
||||||
# Removed SYSFS use in udev rules and actually made them work (bug #560754).
|
# Don't add printer queue, just check plugin.
|
||||||
# Move udev rules to /lib/udev/rules.d (bug #748208).
|
# Move udev rules from /etc/ to /usr/lib/ (bug #748208).
|
||||||
%patch7 -p1 -b .udev-rules
|
%patch7 -p1 -b .udev-rules
|
||||||
|
|
||||||
# Retry when connecting to device fails (bug #532112).
|
# Retry when connecting to device fails (bug #532112).
|
||||||
@ -376,6 +376,7 @@ rm -f %{buildroot}%{_bindir}/hp-uninstall
|
|||||||
rm -f %{buildroot}%{_datadir}/hplip/upgrade.*
|
rm -f %{buildroot}%{_datadir}/hplip/upgrade.*
|
||||||
rm -f %{buildroot}%{_bindir}/hp-upgrade
|
rm -f %{buildroot}%{_bindir}/hp-upgrade
|
||||||
rm -f %{buildroot}%{_bindir}/hp-config_usb_printer
|
rm -f %{buildroot}%{_bindir}/hp-config_usb_printer
|
||||||
|
rm -f %{buildroot}%{_unitdir}/hplip-printer@.service
|
||||||
rm -f %{buildroot}%{_datadir}/hplip/config_usb_printer.*
|
rm -f %{buildroot}%{_datadir}/hplip/config_usb_printer.*
|
||||||
rm -f %{buildroot}%{_datadir}/hplip/hpijs.drv.in.template
|
rm -f %{buildroot}%{_datadir}/hplip/hpijs.drv.in.template
|
||||||
rm -f %{buildroot}%{_datadir}/cups/mime/pstotiff.types
|
rm -f %{buildroot}%{_datadir}/cups/mime/pstotiff.types
|
||||||
@ -526,6 +527,10 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
|||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 14 2013 Jiri Popelka <jpopelka@redhat.com> - 3.13.5-1
|
||||||
|
- 3.13.5
|
||||||
|
- change udev rule to not add printer queue, just check plugin.
|
||||||
|
|
||||||
* Fri May 10 2013 Jiri Popelka <jpopelka@redhat.com> - 3.13.4-3
|
* Fri May 10 2013 Jiri Popelka <jpopelka@redhat.com> - 3.13.4-3
|
||||||
- Device ID for HP LaserJet 2200 (bug #873123#c8).
|
- Device ID for HP LaserJet 2200 (bug #873123#c8).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user