27 lines
2.1 KiB
Diff
27 lines
2.1 KiB
Diff
diff -up hplip-3.13.5/data/rules/56-hpmud.rules.udev-rules hplip-3.13.5/data/rules/56-hpmud.rules
|
|
--- hplip-3.13.5/data/rules/56-hpmud.rules.udev-rules 2013-05-10 12:08:05.000000000 +0200
|
|
+++ hplip-3.13.5/data/rules/56-hpmud.rules 2013-05-14 19:03:18.003846301 +0200
|
|
@@ -11,8 +11,8 @@ LABEL="hpmud_usb_rules"
|
|
ATTR{idVendor}=="03f0", ATTR{idProduct}=="????", OWNER="root", GROUP="lp", MODE="0660", ENV{sane_hpaio}="yes", ENV{libsane_matched}="yes", ENV{hp_test}="yes", ENV{ID_HPLIP}="1"
|
|
|
|
|
|
-# This rule will add the printer and install plugin
|
|
-ENV{hp_test}=="yes", PROGRAM="/bin/sh -c 'logger -p user.info loading HP Device $env{BUSNUM} $env{DEVNUM}'", RUN+="/bin/sh -c 'if [ -f /usr/bin/systemctl ]; then /usr/bin/systemctl --no-block start hplip-printer@$env{BUSNUM}:$env{DEVNUM}.service; else /usr/bin/hp-config_usb_printer $env{BUSNUM}:$env{DEVNUM}; fi'"
|
|
+# This rule will install plugin
|
|
+ENV{hp_test}=="yes", PROGRAM="/bin/sh -c 'logger -p user.info loading HP Device $env{BUSNUM} $env{DEVNUM}'", RUN+="/bin/sh -c '/usr/bin/python /usr/share/hplip/check-plugin.py -m $env{BUSNUM}:$env{DEVNUM} &'"
|
|
|
|
# If sane-bankends is installed add hpaio backend support to dll.conf if needed.
|
|
ENV{sane_hpaio}=="yes", RUN+="/bin/sh -c 'grep -q ^#hpaio /etc/sane.d/dll.conf;if [ $$? -eq 0 ];then sed -i -e s/^#hpaio/hpaio/ /etc/sane.d/dll.conf;else grep -q ^hpaio /etc/sane.d/dll.conf;if [ $$? -ne 0 ];then echo hpaio >>/etc/sane.d/dll.conf;fi;fi'"
|
|
diff -up hplip-3.13.5/Makefile.in.udev-rules hplip-3.13.5/Makefile.in
|
|
--- hplip-3.13.5/Makefile.in.udev-rules 2013-05-14 12:45:14.670392763 +0200
|
|
+++ hplip-3.13.5/Makefile.in 2013-05-14 12:47:24.779623958 +0200
|
|
@@ -4369,7 +4369,7 @@ cups_drv = prnt/drv/hpcups.drv
|
|
@HPLIP_BUILD_TRUE@dist_cron_DATA = data/rules/hplip_cron
|
|
|
|
# hpmud.rules
|
|
-@HPLIP_BUILD_TRUE@rulesdir = /etc/udev/rules.d
|
|
+@HPLIP_BUILD_TRUE@rulesdir = /usr/lib/udev/rules.d
|
|
@HPLIP_BUILD_TRUE@@UDEV_SYSFS_RULES_FALSE@dist_rules_DATA = data/rules/56-hpmud.rules
|
|
@HPLIP_BUILD_TRUE@@UDEV_SYSFS_RULES_TRUE@dist_rules_DATA = data/rules/56-hpmud_sysfs.rules
|
|
@HPLIP_BUILD_TRUE@halpredir = /usr/share/hal/fdi/preprobe/10osvendor
|