- Ship installer directory (bug #428246).
- Avoid multilib conflict (bug #341531). - The hpijs sub-package requires net-snmp (bug #376641).
This commit is contained in:
parent
395efcdf6a
commit
d9e8e71ce7
24
hplip-gzip-n.patch
Normal file
24
hplip-gzip-n.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -up hplip-2.7.12/Makefile.am.gzip-n hplip-2.7.12/Makefile.am
|
||||||
|
--- hplip-2.7.12/Makefile.am.gzip-n 2008-01-18 15:42:03.000000000 +0000
|
||||||
|
+++ hplip-2.7.12/Makefile.am 2008-01-18 15:42:38.000000000 +0000
|
||||||
|
@@ -420,7 +420,7 @@ if HPLIP_BUILD
|
||||||
|
# Install fax support.
|
||||||
|
if [ "$(fax_build)" = "yes" ]; then \
|
||||||
|
mv $(DESTDIR)$(hpfaxdir)/hpfax.py $(DESTDIR)$(hpfaxdir)/hpfax; \
|
||||||
|
- gzip -f $(DESTDIR)$(faxppddir)/HP-Fax-hplip.ppd; \
|
||||||
|
+ gzip -n -f $(DESTDIR)$(faxppddir)/HP-Fax-hplip.ppd; \
|
||||||
|
fi
|
||||||
|
endif # if HPLIP_BUILD
|
||||||
|
|
||||||
|
diff -up hplip-2.7.12/Makefile.in.gzip-n hplip-2.7.12/Makefile.in
|
||||||
|
--- hplip-2.7.12/Makefile.in.gzip-n 2008-01-18 15:42:44.000000000 +0000
|
||||||
|
+++ hplip-2.7.12/Makefile.in 2008-01-18 15:43:08.000000000 +0000
|
||||||
|
@@ -7345,7 +7345,7 @@ install-data-hook: install-foo
|
||||||
|
# Install fax support.
|
||||||
|
@HPLIP_BUILD_TRUE@ if [ "$(fax_build)" = "yes" ]; then \
|
||||||
|
@HPLIP_BUILD_TRUE@ mv $(DESTDIR)$(hpfaxdir)/hpfax.py $(DESTDIR)$(hpfaxdir)/hpfax; \
|
||||||
|
-@HPLIP_BUILD_TRUE@ gzip -f $(DESTDIR)$(faxppddir)/HP-Fax-hplip.ppd; \
|
||||||
|
+@HPLIP_BUILD_TRUE@ gzip -n -f $(DESTDIR)$(faxppddir)/HP-Fax-hplip.ppd; \
|
||||||
|
@HPLIP_BUILD_TRUE@ fi
|
||||||
|
|
||||||
|
install-foo:
|
15
hplip.spec
15
hplip.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 2.7.12
|
Version: 2.7.12
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+ and MIT
|
License: GPLv2+ and MIT
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Conflicts: system-config-printer < 0.6.132
|
Conflicts: system-config-printer < 0.6.132
|
||||||
@ -15,6 +15,7 @@ Url: http://hplip.sourceforge.net/
|
|||||||
Source0: http://kent.dl.sourceforge.net/sourceforge/hplip/%{name}-%{version}.tar.gz
|
Source0: http://kent.dl.sourceforge.net/sourceforge/hplip/%{name}-%{version}.tar.gz
|
||||||
Source1: hplip.fdi
|
Source1: hplip.fdi
|
||||||
Patch1: hplip-desktop.patch
|
Patch1: hplip-desktop.patch
|
||||||
|
Patch2: hplip-gzip-n.patch
|
||||||
Patch3: hplip-quiet.patch
|
Patch3: hplip-quiet.patch
|
||||||
Patch4: hplip-marker-supply.patch
|
Patch4: hplip-marker-supply.patch
|
||||||
Patch5: hplip-libm.patch
|
Patch5: hplip-libm.patch
|
||||||
@ -68,6 +69,7 @@ Group: Applications/Publishing
|
|||||||
License: BSD
|
License: BSD
|
||||||
Epoch: %{hpijs_epoch}
|
Epoch: %{hpijs_epoch}
|
||||||
Requires: python-reportlab
|
Requires: python-reportlab
|
||||||
|
Requires: net-snmp
|
||||||
|
|
||||||
%description -n hpijs
|
%description -n hpijs
|
||||||
hpijs is a collection of optimized drivers for HP printers.
|
hpijs is a collection of optimized drivers for HP printers.
|
||||||
@ -94,6 +96,9 @@ rm -rf $RPM_BUILD_DIR/%{name}-%{version}
|
|||||||
# Fix desktop file.
|
# Fix desktop file.
|
||||||
%patch1 -p1 -b .desktop
|
%patch1 -p1 -b .desktop
|
||||||
|
|
||||||
|
# Avoid multilib conflict (bug #341531).
|
||||||
|
%patch2 -p1 -b .gzip-n
|
||||||
|
|
||||||
# Quieten hpssd on startup.
|
# Quieten hpssd on startup.
|
||||||
%patch3 -p1 -b .quiet
|
%patch3 -p1 -b .quiet
|
||||||
|
|
||||||
@ -160,7 +165,7 @@ install -p -m644 %{SOURCE1} %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor/10
|
|||||||
# Remove files we don't want to package.
|
# Remove files we don't want to package.
|
||||||
rm -f %{buildroot}%{_datadir}/hplip/hpaio.desc
|
rm -f %{buildroot}%{_datadir}/hplip/hpaio.desc
|
||||||
rm -f %{buildroot}%{_datadir}/hplip/hplip-install
|
rm -f %{buildroot}%{_datadir}/hplip/hplip-install
|
||||||
rm -rf %{buildroot}%{_datadir}/hplip/install*
|
rm -rf %{buildroot}%{_datadir}/hplip/install.*
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
@ -238,6 +243,7 @@ rm -rf %{buildroot}
|
|||||||
%{_datadir}/hplip/toolbox.py*
|
%{_datadir}/hplip/toolbox.py*
|
||||||
# Directories
|
# Directories
|
||||||
%{_datadir}/hplip/data/images
|
%{_datadir}/hplip/data/images
|
||||||
|
%{_datadir}/hplip/installer
|
||||||
%{_datadir}/hplip/plugins
|
%{_datadir}/hplip/plugins
|
||||||
%{_datadir}/hplip/ui
|
%{_datadir}/hplip/ui
|
||||||
|
|
||||||
@ -274,6 +280,11 @@ fi
|
|||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 18 2008 Tim Waugh <twaugh@redhat.com> 2.7.12-2
|
||||||
|
- Ship installer directory (bug #428246).
|
||||||
|
- Avoid multilib conflict (bug #341531).
|
||||||
|
- The hpijs sub-package requires net-snmp (bug #376641).
|
||||||
|
|
||||||
* Fri Jan 18 2008 Tim Waugh <twaugh@redhat.com> 2.7.12-1
|
* Fri Jan 18 2008 Tim Waugh <twaugh@redhat.com> 2.7.12-1
|
||||||
- 2.7.12. No longer need ljdot4 patch.
|
- 2.7.12. No longer need ljdot4 patch.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user