- 2.7.12. No longer need ljdot4 patch.
This commit is contained in:
parent
743ee7d38a
commit
395efcdf6a
@ -19,3 +19,4 @@ hplip-2.7.6.tar.gz
|
||||
hplip-2.7.7.tar.gz
|
||||
hplip-2.7.9.tar.gz
|
||||
hplip-2.7.10.tar.gz
|
||||
hplip-2.7.12.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up hplip-2.7.7/data/models/models.dat.ljdot4 hplip-2.7.7/data/models/models.dat
|
||||
--- hplip-2.7.7/data/models/models.dat.ljdot4 2007-10-09 17:30:18.000000000 +0100
|
||||
+++ hplip-2.7.7/data/models/models.dat 2007-10-09 17:30:37.000000000 +0100
|
||||
@@ -12316,7 +12316,7 @@ fax-type=0
|
||||
fw-download=0
|
||||
icon=HP_LaserJet_4000.png
|
||||
io-mfp-mode=6
|
||||
-io-mode=3
|
||||
+io-mode=1
|
||||
io-support=1
|
||||
linefeed-cal-type=0
|
||||
model1=LaserJet 4000
|
@ -1,28 +1,50 @@
|
||||
--- hplip-2.7.6/prnt/backend/hp.c.media-empty 2007-05-11 22:55:52.000000000 +0100
|
||||
+++ hplip-2.7.6/prnt/backend/hp.c 2007-06-29 15:34:02.000000000 +0100
|
||||
@@ -326,7 +326,7 @@
|
||||
int len, vstatus, cnt;
|
||||
char buf[HPMUD_BUFFER_SIZE];
|
||||
struct hpmud_model_attributes ma;
|
||||
- int paperout=0, offline=0;
|
||||
+ int paperout=-1, offline=-1;
|
||||
HPMUD_DEVICE hd=-1;
|
||||
HPMUD_CHANNEL cd=-1;
|
||||
int n, total, retry=0, size;
|
||||
@@ -440,14 +440,14 @@
|
||||
switch (vstatus)
|
||||
{
|
||||
case VSTATUS_OOPA:
|
||||
- if (!paperout)
|
||||
+ if (paperout != 1)
|
||||
{
|
||||
fputs("STATE: +media-empty-error\n", stderr);
|
||||
paperout=1;
|
||||
}
|
||||
break;
|
||||
default:
|
||||
- if (!offline)
|
||||
+ if (offline != 1)
|
||||
{
|
||||
fputs("STATE: +other\n", stderr);
|
||||
offline=1;
|
||||
diff -up hplip-2.7.12/prnt/backend/hp.c.media-empty hplip-2.7.12/prnt/backend/hp.c
|
||||
--- hplip-2.7.12/prnt/backend/hp.c.media-empty 2007-11-29 00:17:27.000000000 +0000
|
||||
+++ hplip-2.7.12/prnt/backend/hp.c 2008-01-18 14:37:11.000000000 +0000
|
||||
@@ -517,10 +517,12 @@ bugout:
|
||||
}
|
||||
|
||||
/* Check printer status, if in an error state, loop until error condition is cleared. */
|
||||
+/* XXX What if it is immediately replaced by a different error condition? XXX */
|
||||
static int loop_test(HPMUD_DEVICE dd, HPMUD_CHANNEL cd, struct pjl_attributes *pa, const char *uri, const char *job)
|
||||
{
|
||||
- int retry=0, status;
|
||||
+ int status;
|
||||
const char *pstate;
|
||||
+ const char *emitted_state_reason = NULL;
|
||||
|
||||
while (1)
|
||||
{
|
||||
@@ -529,27 +531,26 @@ static int loop_test(HPMUD_DEVICE dd, HP
|
||||
|
||||
if (strcmp(pstate, "none")==0)
|
||||
{
|
||||
- if (retry)
|
||||
+ if (emitted_state_reason)
|
||||
{
|
||||
/* Clear error. */
|
||||
device_event(uri, job, VSTATUS_PRNT, "event", 0);
|
||||
fputs("INFO: Printing...\n", stderr);
|
||||
- fprintf(stderr, "STATE: -%s\n", pstate);
|
||||
- retry=0;
|
||||
+ fprintf(stderr, "STATE: -%s\n", emitted_state_reason);
|
||||
}
|
||||
break; /* no error, done */
|
||||
}
|
||||
|
||||
- if (!retry)
|
||||
+ if (!emitted_state_reason)
|
||||
{
|
||||
/* Display error. */
|
||||
device_event(uri, job, status, "error", RETRY_TIMEOUT);
|
||||
- fprintf(stderr, "STATE: +%s\n", pstate);
|
||||
+ emitted_state_reason = pstate;
|
||||
+ fprintf(stderr, "STATE: +%s\n", emitted_state_reason);
|
||||
}
|
||||
|
||||
BUG("ERROR: %d %s; will retry in %d seconds...\n", status, pstate, RETRY_TIMEOUT);
|
||||
sleep(RETRY_TIMEOUT);
|
||||
- retry = 1;
|
||||
}
|
||||
|
||||
return 0;
|
||||
|
11
hplip.spec
11
hplip.spec
@ -1,7 +1,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 2.7.10
|
||||
Release: 3%{?dist}
|
||||
Version: 2.7.12
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT
|
||||
Group: System Environment/Daemons
|
||||
Conflicts: system-config-printer < 0.6.132
|
||||
@ -15,7 +15,6 @@ Url: http://hplip.sourceforge.net/
|
||||
Source0: http://kent.dl.sourceforge.net/sourceforge/hplip/%{name}-%{version}.tar.gz
|
||||
Source1: hplip.fdi
|
||||
Patch1: hplip-desktop.patch
|
||||
Patch2: hplip-ljdot4.patch
|
||||
Patch3: hplip-quiet.patch
|
||||
Patch4: hplip-marker-supply.patch
|
||||
Patch5: hplip-libm.patch
|
||||
@ -95,9 +94,6 @@ rm -rf $RPM_BUILD_DIR/%{name}-%{version}
|
||||
# Fix desktop file.
|
||||
%patch1 -p1 -b .desktop
|
||||
|
||||
# Use raw instead of 1284.4 communication for LJ4000 series (bug #249191).
|
||||
%patch2 -p1 -b .ljdot4
|
||||
|
||||
# Quieten hpssd on startup.
|
||||
%patch3 -p1 -b .quiet
|
||||
|
||||
@ -278,6 +274,9 @@ fi
|
||||
exit 0
|
||||
|
||||
%changelog
|
||||
* Fri Jan 18 2008 Tim Waugh <twaugh@redhat.com> 2.7.12-1
|
||||
- 2.7.12. No longer need ljdot4 patch.
|
||||
|
||||
* Fri Jan 4 2008 Tim Waugh <twaugh@redhat.com> 2.7.10-2
|
||||
- Don't ship udev rules; instead, grant an ACL for group lp (bug #424331).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user