This commit is contained in:
Jiri Popelka 2012-09-07 15:48:12 +02:00
parent 90fce7b6d2
commit b906ef154d
10 changed files with 48 additions and 65 deletions

1
.gitignore vendored
View File

@ -47,3 +47,4 @@ hplip-3.10.6.tar.gz
/hplip-3.12.2.tar.gz
/hplip-3.12.4.tar.gz
/hplip-3.12.6.tar.gz
/hplip-3.12.9.tar.gz

View File

@ -1,7 +0,0 @@
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
iEYEABECAAYFAk/fBzsACgkQc9dwzaWQR7n/hgCeLWOa+DwaRaS7AOKrxyPbLxJ8
7ZsAoNhcYLg6Sx3u360POOnKw1tiN0qh
=YfNt
-----END PGP SIGNATURE-----

7
hplip-3.12.9.tar.gz.asc Normal file
View File

@ -0,0 +1,7 @@
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
iEYEABECAAYFAlBF9lcACgkQc9dwzaWQR7l6bACgwhUMGbH/uitt9s62sYGpiq4A
bGkAoMJcec/MsWx+lKsVr4NsuBxa/uwn
=QoO5
-----END PGP SIGNATURE-----

View File

@ -1,11 +1,11 @@
diff -up hplip-3.11.1/prnt/cupsext/cupsext.c.addprinter hplip-3.11.1/prnt/cupsext/cupsext.c
--- hplip-3.11.1/prnt/cupsext/cupsext.c.addprinter 2011-01-19 06:15:27.000000000 +0100
+++ hplip-3.11.1/prnt/cupsext/cupsext.c 2011-01-24 12:24:01.000000000 +0100
@@ -510,6 +510,7 @@ PyObject * addPrinter( PyObject * self,
strcpy( info, name );
/* Connect to the HTTP server */
+ cupsSetUser ("root");
if ( ( http = httpConnectEncrypt( cupsServer(), ippPort(), cupsEncryption() ) ) == NULL )
{
r = 0;
diff -up hplip-3.12.9/prnt/cupsext/cupsext.c.addprinter hplip-3.12.9/prnt/cupsext/cupsext.c
--- hplip-3.12.9/prnt/cupsext/cupsext.c.addprinter 2012-09-04 14:31:10.000000000 +0200
+++ hplip-3.12.9/prnt/cupsext/cupsext.c 2012-09-07 14:20:24.626193617 +0200
@@ -511,6 +511,7 @@ PyObject * addPrinter( PyObject * self,
strcpy( info, name );
/* Connect to the HTTP server */
+ cupsSetUser ("root");
if ( ( http = httpConnectEncrypt( cupsServer(), ippPort(), cupsEncryption() ) ) == NULL )
{
r = 0;

View File

@ -621,15 +621,6 @@ diff -up hplip-3.12.2/prnt/drv/hpcups.drv.in.deviceIDs-drv hplip-3.12.2/prnt/drv
PCFileName "hp-laserjet_m1522nf_mfp-pcl3.ppd"
Attribute "Product" "" "(HP LaserJet m1522nf Multifunction Printer)"
}
@@ -11050,7 +11051,7 @@ Group "RLT/HP Real Life Technologies"
ModelName "HP LaserJet m1536dnf MFP"
Attribute "NickName" "" "HP LaserJet m1536dnf MFP pcl3, $Version"
Attribute "ShortNickName" "" "HP LaserJet m1536dnf MFP"
- Attribute "1284DeviceID" "" "MFG:HP;MDL:hp laserjet m1536dnf mfp;DES:hp laserjet m1536dnf mfp;"
+ Attribute "1284DeviceID" "" "MFG:Hewlett-Packard;MDL:hp laserjet m1536dnf mfp;DES:hp laserjet m1536dnf mfp;"
PCFileName "hp-laserjet_m1536dnf_mfp-pcl3.ppd"
Attribute "Product" "" "(HP LaserJet m1536dnf MFP)"
}
@@ -11122,7 +11123,7 @@ Group "RLT/HP Real Life Technologies"
ModelName "HP LaserJet p2015 Series"
Attribute "NickName" "" "HP LaserJet p2015 Series pcl3, $Version"

View File

@ -1,24 +0,0 @@
diff -up hplip-3.11.1/ui/setupform.py.fax-ppd hplip-3.11.1/ui/setupform.py
--- hplip-3.11.1/ui/setupform.py.fax-ppd 2011-01-19 06:18:26.000000000 +0100
+++ hplip-3.11.1/ui/setupform.py 2011-01-24 12:00:48.000000000 +0100
@@ -886,16 +886,16 @@ class SetupForm(SetupForm_base):
QApplication.setOverrideCursor(QApplication.waitCursor)
if self.mq.get('fax-type', FAX_TYPE_NONE) == FAX_TYPE_MARVELL:
- fax_ppd_name = "HP-Fax3-hplip" # Fixed width (2528 pixels) and 300dpi rendering
+ fax_ppd_name = "HP-Fax3-hpcups" # Fixed width (2528 pixels) and 300dpi rendering
nick = "HP Fax 3"
if self.mq.get('fax-type', FAX_TYPE_NONE) == FAX_TYPE_SOAP or self.mq.get('fax-type', FAX_TYPE_NONE) == FAX_TYPE_LEDMSOAP:
- fax_ppd_name = "HP-Fax2-hplip" # Fixed width (2528 pixels) and 300dpi rendering
+ fax_ppd_name = "HP-Fax2-hpcups" # Fixed width (2528 pixels) and 300dpi rendering
nick = "HP Fax 2"
if self.mq.get('fax-type', FAX_TYPE_NONE) == FAX_TYPE_LEDM:
- fax_ppd_name = "HP-Fax4-hplip" # Fixed width (1728 pixels) and 200dpi rendering
+ fax_ppd_name = "HP-Fax4-hpcups" # Fixed width (1728 pixels) and 200dpi rendering
nick = "HP Fax 4"
else:
- fax_ppd_name = "HP-Fax-hplip" # Standard
+ fax_ppd_name = "HP-Fax-hpcups" # Standard
nick = "HP Fax"
ppds = []

View File

@ -1,7 +1,7 @@
diff -up hplip-3.11.12/Makefile.in.chgrp hplip-3.11.12/Makefile.in
--- hplip-3.11.12/Makefile.in.chgrp 2011-12-09 12:23:55.000000000 +0100
+++ hplip-3.11.12/Makefile.in 2011-12-19 15:16:53.907090155 +0100
@@ -8582,10 +8582,10 @@ uninstall-am: uninstall-binPROGRAMS unin
diff -up hplip-3.12.9/Makefile.in.chgrp hplip-3.12.9/Makefile.in
--- hplip-3.12.9/Makefile.in.chgrp 2012-09-07 14:35:14.334691556 +0200
+++ hplip-3.12.9/Makefile.in 2012-09-07 14:36:02.974988844 +0200
@@ -8841,18 +8841,18 @@ uninstall-am: uninstall-binPROGRAMS unin
install-dist_hplip_LogDATA:
@FULL_BUILD_TRUE@ test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
@ -13,4 +13,14 @@ diff -up hplip-3.11.12/Makefile.in.chgrp hplip-3.11.12/Makefile.in
+#@HPLIP_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
@HPLIP_BUILD_TRUE@ chmod 774 $(DESTDIR)$(hplip_Logdir)
install-data-hook:
install-dist_hplip_tmpDATA:
@FULL_BUILD_TRUE@ test -z "$(DESTDIR)$(hplip_tmpdir)" || mkdir -p $(DESTDIR)$(hplip_tmpdir)
-@FULL_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
+#@FULL_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
@FULL_BUILD_TRUE@ chmod 1774 $(DESTDIR)$(hplip_tmpdir)
@HPLIP_BUILD_TRUE@ test -z "$(DESTDIR)$(hplip_tmpdir)" || mkdir -p $(DESTDIR)$(hplip_tmpdir)
-@HPLIP_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
+#@HPLIP_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
@HPLIP_BUILD_TRUE@ chmod 1774 $(DESTDIR)$(hplip_tmpdir)
install-dist_cronDATA:$(dist_cron_DATA)

View File

@ -13,7 +13,7 @@ diff -up hplip-3.12.6/Makefile.in.udev-rules hplip-3.12.6/Makefile.in
--- hplip-3.12.6/Makefile.in.udev-rules 2012-06-18 12:44:46.000000000 +0200
+++ hplip-3.12.6/Makefile.in 2012-06-19 10:57:37.812828378 +0200
@@ -4274,7 +4274,7 @@ cups_drv = prnt/drv/hpcups.drv
@HPLIP_BUILD_TRUE@hp_mkuri_CFLAGS = -DCONFDIR=\"$(hplip_confdir)\"
@HPLIP_BUILD_TRUE@dist_cron_DATA = data/rules/hplip_cron
# hpmud.rules
-@HPLIP_BUILD_TRUE@rulesdir = /etc/udev/rules.d

View File

@ -1,6 +1,6 @@
Summary: HP Linux Imaging and Printing Project
Name: hplip
Version: 3.12.6
Version: 3.12.9
Release: 1%{?dist}
License: GPLv2+ and MIT
Group: System Environment/Daemons
@ -28,7 +28,6 @@ Patch11: hplip-hpijs-marker-supply.patch
Patch12: hplip-clear-old-state-reasons.patch
Patch13: hplip-systray-dbus-exception.patch
Patch14: hplip-hpcups-sigpipe.patch
Patch15: hplip-fax-ppd.patch
Patch16: hplip-bad-low-ink-warning.patch
Patch17: hplip-deviceIDs-ppd.patch
Patch18: hplip-skip-blank-lines.patch
@ -50,13 +49,15 @@ Requires(post): /sbin/chkconfig
Requires(preun): /sbin/service
Requires(preun): /sbin/chkconfig
%define hpijs_epoch 1
%global hpijs_epoch 1
Requires: hpijs = %{hpijs_epoch}:%{version}-%{release}
Requires: %{name}-libs = %{version}-%{release}
Requires: python-imaging
Requires: cups
Requires: wget
Requires: dbus-python
# for /etc/cron.daily/hplip_cron
Requires: crontabs
BuildRequires: net-snmp-devel
BuildRequires: cups-devel
@ -213,9 +214,6 @@ mv prnt/drv/hpijs.drv.in{,.deviceIDs-drv-hpijs}
# Avoid busy loop in hpcups when backend has exited (bug #525944).
%patch14 -p1 -b .hpcups-sigpipe
# Use correct fax PPD name for Qt3 UI.
%patch15 -p1 -b .fax-ppd
# Fixed Device ID parsing code in hpijs's dj9xxvip.c (bug #510926).
%patch16 -p1 -b .bad-low-ink-warning
@ -288,7 +286,7 @@ done
# Avoid KeyError in ui4/wifisetupdialog.py (bug #680939).
%patch28 -p1 -b .wifisetup
# Don't run 'chgrp lp /var/log/hp' in makefile
# Don't run 'chgrp lp /var/log/hp' and 'chgrp lp /var/log/hp/tmp' in makefile
%patch29 -p1 -b .chgrp
# Pay attention to the SANE localOnly flag in hpaio (bug #743593).
@ -395,6 +393,7 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
%{_bindir}/hp-info
%{_bindir}/hp-levels
%{_bindir}/hp-linefeedcal
%{_bindir}/hp-logcapture
%{_bindir}/hp-makecopies
%{_bindir}/hp-makeuri
%{_bindir}/hp-mkuri
@ -433,6 +432,7 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
%{_datadir}/hplip/__init__.py*
%{_datadir}/hplip/levels.py*
%{_datadir}/hplip/linefeedcal.py*
%{_datadir}/hplip/logcapture.py*
%{_datadir}/hplip/makecopies.py*
%{_datadir}/hplip/makeuri.py*
%{_datadir}/hplip/plugin.py*
@ -461,6 +461,7 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
%{_datadir}/hplip/scan
%{_localstatedir}/lib/hp
%dir %attr(0774,root,lp) %{_localstatedir}/log/hp
%{_sysconfdir}/cron.daily/hplip_cron
%files common
%doc COPYING
@ -528,6 +529,10 @@ fi
%postun libs -p /sbin/ldconfig
%changelog
* Fri Sep 07 2012 Jiri Popelka <jpopelka@redhat.com> 3.12.9-1
- 3.12.9
-- no longer needed: fax-ppd.patch
* Tue Jun 19 2012 Jiri Popelka <jpopelka@redhat.com> 3.12.6-1
- 3.12.6

View File

@ -1 +1 @@
5303938e8630775ea6fb383af85775e5 hplip-3.12.6.tar.gz
843a089fb4f113e6a65312094aeab8aa hplip-3.12.9.tar.gz